Subject: [ntpwg] draft-odonoghue-ntpv4-control-02.txt: "Read Variables" on page 14

From: "Ulrich Windl" <[email-masked]>
Date: Tue, 27 Oct 2015 13:31:40 +0100

Hi!

I just came across the description of "Read Variables" on draft-odonoghue-ntpv4-control-02.txt:
There is some confusing part (copied from RFC 1305) saying: "If a peer has been selected as the synchronization source (...)"
I think this part is confusing, because it's not clear whether "selected" refers to NTP's selection of a peer, or to the user's selection of an association ID. To me it seems the text describes the latter.

The text in question is:
   Read Variables (2): The command data field is empty or contains a
   list of identifiers separated by commas.  If the association
   identifier is nonzero, the response includes the requested peer
   identifier and status word, while the data field contains a list of
   peer variables and values as described above.  If the association
   identifier is zero, the data field contains a list of system
   variables and values.  If a peer has been selected as the
   synchronization source, the response includes the peer identifier and
   status word; otherwise, the response includes the system identifier
   (0) and status word.

In addition it's not clear _where_ the peer identifier (and status) would be included; in "Association ID" (and "Status") of the response?

Regards,
Ulrich

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Greg Dowd <[email-masked]>
Date: Tue, 27 Oct 2015 15:05:04 +0000

When I read rv (implicit assoc id 0), I see a field peer where the sys_peer association id is displayed.  Not quite sure about status though.

-----Original Message-----
From: ntpwg [mailto:ntpwg-bounces+greg.dowd=[email-masked]] On Behalf Of Ulrich Windl
Sent: Tuesday, October 27, 2015 5:32 AM
To: [email-masked]
Subject: [ntpwg] draft-odonoghue-ntpv4-control-02.txt: "Read Variables" on page 14

EXTERNAL EMAIL

Hi!

The text in question is:

Regards,
Ulrich