Subject: Re: [ntpwg] Jari Arkko's Discuss on draft-ietf-ntp-extension-field-06: (with DISCUSS)

From: Danny Mayer <[email-masked]>
Date: Tue, 2 Feb 2016 23:13:59 -0500

On 2/2/2016 4:40 PM, Jari Arkko wrote:
> Jari Arkko has entered the following ballot position for
> draft-ietf-ntp-extension-field-06: Discuss
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-ntp-extension-field/
> 
> 
> 
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
> 
> Thank you for writing this much clarifying document!
> 
> I want to recommend its approval with a 'Yes' position shortly, but
> before that I had one question which I believe would benefit from some
> discussion:
> 
> Section 7.5.1.2 says:
> 
>    If an NTP packet is received with two or more extension fields that
>    require a MAC with different algorithms, the packet MUST be
>    discarded.
> 
> However, Section 7.5 already said earlier:
> 
>    If a host receives an
>    extension field with an unknown Field Type, the host SHOULD ignore
>    the extension field and MAY drop the packet altogether if policy
>    requires it.
> 
> This leaves me wondering how the
> MUST-drop-packet-with-fields-with-different-algs can be implemented. Did
> you perhaps mean:
> 
>    If an NTP packet is received with two or more extension fields that
>    this receiver recognises and those fields require a MAC with
>    different algorithms, the packet MUST be discarded.
> 
> Or maybe something else? Can you clarify?

Let me try and clarify. There can only be one MAC in an NTP packet. If
extension field A requires that the MAC use algorithm X and extension
field B requires that the MAC use algorithm Y then the packet cannot
have both extension field A AND extension field B at the same time since
there are conflicting requirements for the MAC. So I guess your above
text is correct.

Does this help?

Danny

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Danny Mayer <[email-masked]>
Date: Tue, 2 Feb 2016 23:14:31 -0500

Does this help?

Danny

---

From: "Jari Arkko" <[email-masked]>
Date: Tue, 02 Feb 2016 13:40:26 -0800

Section 7.5.1.2 says:

   If a host receives an

---

From: Jari Arkko <[email-masked]>
Date: Wed, 3 Feb 2016 14:27:09 +0200

Thanks, and your explanation is reasonable. Could something be added to the document so that the next reader will not ask the same question?

I plan to clear the Discuss and leave the editing to you, under Brian’s guidance.

Jari