Subject: Re: [Ntp] Publication has been requested for draft-ietf-ntp-bcp-06

From: Steven Sommars <[email-masked]>
Date: Sat, 16 Jun 2018 20:47:44 -0500

[Hopefully this goes to the correct email threads.]

There are many NTP implementations, some historically linked, others are
unrelated.  There are also several versions of the NTP RFC. This draft does
not adequately distinguish between these.  For example:
   "After fetching the leap seconds file onto the server, add this line to
   ntpd.conf to apply and use the file:
   leapfile "/path/to your/leap-file""
and
   "As of ntp-4.2.6"
Refers to one particular family of implementations.

This document should minimize implementation-specifics.  Where they are
essential use a qualifier, such as "Reference ntpd"

On Wed, May 30, 2018 at 11:23 PM, Karen O'Donoghue <[email-masked]>
wrote:

> Karen O&#39;Donoghue has requested publication of draft-ietf-ntp-bcp-06 as
> Best Current Practice on behalf of the NTP working group.
>
> Please verify the document's state at https://datatracker.ietf.org/
> doc/draft-ietf-ntp-bcp/
>
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
>

---

From: Denis Reilly <[email-masked]>
Date: Tue, 19 Jun 2018 18:29:54 +0000

Steven:

You're not the only one to bring this up recently. Most of the contributions were very focused on ntpd, so we had to tread a line of conveying these contributions properly while not being too implementation specific. I am going to try and identify parts of the draft that can be rewritten with this feedback in mind soon, so it can be considered in Montreal.

As always, if anyone has comments please continue to comment on the list, send them to me directly, or you can access the git repo at https://github.com/denisreilly/ntp-bcp .

Best Regards,

--
Denis Reilly  |  Lead Engineer  |  [email-masked]<mailto:[email-masked]>  (585)321-5837<tel:(585)%20321-5837>

From: ntp [mailto:[email-masked]] On Behalf Of Steven Sommars
Sent: Saturday, June 16, 2018 9:48 PM
To: Karen O'Donoghue <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Karen O'Donoghue <[email-masked]>
Subject: Re: [Ntp] Publication has been requested for draft-ietf-ntp-bcp-06

There are many NTP implementations, some historically linked, others are unrelated.  There are also several versions of the NTP RFC. This draft does not adequately distinguish between these.  For example:

This document should minimize implementation-specifics.  Where they are essential use a qualifier, such as "Reference ntpd"

On Wed, May 30, 2018 at 11:23 PM, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
Karen O&#39;Donoghue has requested publication of draft-ietf-ntp-bcp-06 as Best Current Practice on behalf of the NTP working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-ntp-bcp/

_______________________________________________
ntp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ntp