Subject: Re: [Ntp] Servers stepping back their clocks

From: Heiko Gerstung <[email-masked]>
Date: Wed, 13 Feb 2019 14:08:53 +0100

..... and I would like to add that every source of time that applies a leap smearing technology is most probably not usable in applications where a requirement to use legal time exists and a maximum offset to legal time is defined that is exceeded during the leap smearing period. If you need to stay within a couple of microseconds of UTC, you might have to step your clock backwards if you want to be compliant ...

Heiko

On 13.02.19, 10:20 "ntp im Auftrag von Martin Burnicki" <[email-masked] im Auftrag von [email-masked]> wrote:

    Danny Mayer wrote:
    > I'd just like to reiterate what I said in the virtual interim meeting
    > during the roughtime discussion that any server that steps their clock
    > backwards is fundamentally broken and breaks the NTP protocol. It does
    > not matter where it's broken, if Posix, the O/S, or elsewhere.
    > 
    > Any such server should not be used as a source of NTP packets and should
    > be avoided at all costs.
    
    If this is taken strictly then most Unix operating systems must not be
    used as NTP servers since they simply *do* step the time back whenever a
    leap second is inserted. :-(
    
    Martin
    -- 
    Martin Burnicki
    
    Senior Software Engineer
    
    MEINBERG Funkuhren GmbH & Co. KG
    Email: [email-masked]
    Phone: +49 5281 9309-414
    Linkedin: https://www.linkedin.com/in/martinburnicki/
    
    Lange Wand 9, 31812 Bad Pyrmont, Germany
    Amtsgericht Hannover 17HRA 100322
    Geschäftsführer/Managing Directors: Günter Meinberg, Werner Meinberg,
    Andre Hartmann, Heiko Gerstung
    Websites: https://www.meinberg.de  https://www.meinbergglobal.com
    Training: https://www.meinberg.academy
    
    _______________________________________________
    ntp mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/ntp

-- 
Heiko Gerstung 
Managing Director

MEINBERG® Funkuhren GmbH & Co. KG
Lange Wand 9
D-31812 Bad Pyrmont, Germany
Phone:    +49 (0)5281 9309-404
Fax:        +49 (0)5281 9309-9404

Amtsgericht Hannover 17HRA 100322
Geschäftsführer/Management: Günter Meinberg, Werner Meinberg, Andre Hartmann, Heiko Gerstung

Email:
 [email-masked] 
Web:
 Deutsch   https://www.meinberg.de
 English    https://www.meinbergglobal.com

Do not miss our Time Synchronization Blog:
 https://blog.meinbergglobal.com 

Connect via LinkedIn: 
https://www.linkedin.com/in/heikogerstung

---

From: Harlan Stenn <[email-masked]>
Date: Wed, 13 Feb 2019 14:06:04 -0800

> ..... and I would like to add that every source of time that applies a leap smearing technology is most probably not usable in applications where a requirement to use legal time exists and a maximu…

As long as one can calculate the expected difference between smeared
time and UTC I'm not sure what the problem is, other than POSIX.

This may not require a backwards step - there are some tests I want to
do to be sure.

H
--

-- 
Harlan Stenn, Network Time Foundation
http://nwtime.org - be a Member!