Subject: Re: [Ntp] NTS Hackathon coordination

From: Martin Langer <[email-masked]>
Date: Thu, 04 Jul 2019 10:17:30 +0200

Hello everybody.

I just wanted to say that I will participate the next hackathon (remote).
We should note somewhere which IPs, port numbers, NTP-EF IDs and 
features (like IPv6 support, separated NTS-KE server, ...) each 
implementation expect.

I can provide 3 time servers with different settings.

best regards,
Martin

Am 22.03.2019 um 23:32 schrieb Hal Murray:
> [email-masked] said:
>>     For those participating, Iâ€™ll see you physically or virtually tomorrow.
>>     The room will open at 9:00 am CET. It will take us a little while to get
>>     started and get through the opening portions, so for the remote folks,
>>     please be patient with us.
> I assume somebody will find bugs/quirks in our code.  I'll be available via
> email.  I'm in California.  I think that means you are starting at my
> midnight.  I'm a night owl, so we'll get some overlap.
>
> 2 more servers:
>    ntp1.glypnod.com - San Francisco
>    ntp2.glypnod.com - London
>
> The NTS-LE server is listening on port 123, both IPv4 and IPv6.
>
> I've seen cases where some NTP packets don't make it to London.  I assume it's
> filtering leftover from the DDoS mess of a few years ago.  Normal NTP
> request/responses get through.  Longer requests with NTS extensions don't get
> in to London if the source port is 123.
>
>
>

-- 
Martin Langer, M.Eng.
Ostfalia Hochschule für angewandte Wissenschaften
- Hochschule Braunschweig/Wolfenbüttel
University of Applied Sciences

Labor Datentechnik, Labor Design Digitaler Systeme
Fakultät Elektrotechnik
Salzdahlumer Straße 46/48
38302 Wolfenbüttel
Germany

Tel. : +49 5331 939 43370
Web  : https://www.ostfalia.de/cms/de/pws/bermbach/mitarbeiter/martin-langer

---

From: Christer Weinigel <[email-masked]>
Date: Sat, 20 Jul 2019 13:51:08 +0200

Hi all,

I just got back from vacation, but I will participate too.

I've set up my Python server on the same machine as before:

ntske: zoo.weinigel.se 4446

There's nothing really new though, I've fixed a crash bug in my server 
(an exception that would stop the server if the client closed the TLS 
socket before I could read from it).

When I was at the AIS hackathon in Uganda a few weeks ago we used slack 
to communicate within the group and I think that worked out rather well. 
  I'd suggest that we set up a slack channel for the NTP/NTS/time group 
for this hackathon too.  Does anybody know how to do that?  Otherwise I 
could give it a try.

   /Christer

---

From: Christer Weinigel <[email-masked]>
Date: Sat, 20 Jul 2019 15:55:35 +0200

Hi everyone,

I've created a Slack channel for IETF-105 hackathon time-related stuff.

You ought to be able to join the channel using this link:

https://join.slack.com/t/ietf-105-time/shared_invite/enQtNjg5NDAyNDE0MTE1LTVhZDE3YzEzMTk1ZWYyNDAxZGFjZmM1OTE1ZTFiYmY4MGJlZGYyZDYyMThjNmQzOTk0MGE4N2FkZmU5MmFjNDM

   /Christer