Subject: Re: [Ntp] Call for adoption: draft-gont-ntp-port-randomization

From: Loganaden Velvindron <[email-masked]>
Date: Mon, 2 Sep 2019 16:16:42 +0400

On Wed, Aug 28, 2019 at 9:31 AM Karen O'Donoghue <[email-masked]> wrote:
>
> Folks,
>
> This is the official call for adoption for the following document:
>
> Port Randomization in the Network Time Protocol Version 4
> https://datatracker.ietf.org/doc/draft-gont-ntp-port-randomization/
>
> Please reply with your opinion on whether or not the working group should adopt this document including your willingness to review and contribute.
>

I support adoption of the document.

I can contribute on my end.

> Regards,
> Karen
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp

---

From: Harlan Stenn <[email-masked]>
Date: Mon, 9 Sep 2019 21:36:35 -0700

I am opposed to the adoption of this document as currently written.

It should not be on the Standards track.

A partial list of my objections and concerns follow.

Its recommendations are already allowed by RFC5905.

It focuses on client mode, and is written in a way where that's the only
mode worth considering.

It is written only from the POV of "internet traffic" and its
recommendations, if followed or prescribed, will negatively impact
behavior and analysis of internal NTP traffic.

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!

---

From: Miroslav Lichvar <[email-masked]>
Date: Tue, 10 Sep 2019 09:17:36 +0200

> Please reply with your opinion on whether or not the working group should adopt this document including your willingness to review and contribute. 

I support adoption of this draft. I'd like to continue my work on it
as a co-author.

-- 
Miroslav Lichvar

---

From: Fernando Gont <[email-masked]>
Date: Wed, 11 Sep 2019 14:35:20 +0300

Harlan,

> Its recommendations are already allowed by RFC5905.

The goal of the document is to *recommend* port randomization. So I
don't know why "this is allowed by RFC5905" can be an objection.

> It focuses on client mode, and is written in a way where that's the only

Again: how can this be an objection?  It focuses in client mode because
this is the mode in which you should be randomizing the source port.

> behavior and analysis of internal NTP traffic.

Could you please elaborate on this one?

(aside: it would seem to me that ntp.org's implementation is the only
one that does not randomize the source port. Are folks running any of
the other implementations having a terrible life?)

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492