Subject: Re: [Ntp] The NTP WG has placed draft-schiff-ntp-chronos in state "Call For Adoption By WG Issued"

From: Hal Murray <[email-masked]>
Date: Tue, 10 Sep 2019 03:10:17 -0700

[email-masked] said:
> *Threat model: *Chronos considers a powerful form of man-in-the-middle (MitM)
> Byzantine attacker, capable of determining precisely the values of the time
> samples gathered by the Chronos client from a subset of the NTP servers in
> its server pool (up to one-third of the pool). 

I consider that "up to one-third" to be a serious problem.  It doesn't cover 
the case where the bad guy has taken over your ISP (or is your ISP) and thus 
controls all the traffic to the servers you try to use.  I think that's going 
to be a common case.

[Disclaimer: I work on NTS so I'm probably biased.]

Why should we work on this rather than getting NTS deployed?

There is an additional complication.  You are inventing a new method of 
processing the data from packets that get past your filters.

-- 
These are my opinions.  I hate spam.

---

From: Neta R S <[email-masked]>
Date: Tue, 10 Sep 2019 13:33:22 +0300

Hi,

Please see my responses inline.

> controls all the traffic to the servers you try to use.  I think that's

In this scenario the attacker can drop all the packets from the servers.
I am not sure there is a good solution for this case.
However, we are currently working on extending the threat model.

> Why should we work on this rather than getting NTS deployed?
I think NTS is important extension for NTP.
We suggest Chronos as a watchdog (for example for cases where the MitM
drops packets).

> processing the data from packets that get past your filters.
We suggest to run Chronos side by side with NTP (as a watchdog).

> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
>

---

From: Marcus Dansarie <[email-masked]>
Date: Tue, 10 Sep 2019 22:24:48 +0200

As one of the co-authors on the NTS draft, I can only agree with Neta
here. Chronos and NTS are not mutually exclusive and Chronos can detect
attacks that NTS does not protect against. Section 9.4 in the NTS draft
mentions one example of this.

Kind regards,
Marcus Dansarie

On 2019-09-10 12:33, Neta R S wrote:
> On Tue, Sep 10, 2019 at 1:10 PM Hal Murray <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> 
>     [email-masked] <mailto:[email-masked]> said:
>     [email-masked] <mailto:[email-masked]>