Subject: Re: [Ntp] Call for adoption: draft-schiff-ntp-chronos

From: Miroslav Lichvar <[email-masked]>
Date: Mon, 2 Sep 2019 13:59:15 +0200

On Wed, Aug 28, 2019 at 05:37:10AM +0000, Karen O'Donoghue wrote:
> A Secure Selection and Filtering Mechanism for the Network Time Protocol Version 4
> https://datatracker.ietf.org/doc/draft-schiff-ntp-chronos/
> 
> Please reply with your opinion on whether or not the working group should adopt this document including your willingness to review and contribute. 

I support adoption of this draft. I would like the group to consider
using a slightly different title and more careful use of the word
"secure" in the document. The algorithms improve resiliency against
some MITM attacks, but in the worst case security doesn't change.

-- 
Miroslav Lichvar

---

From: Neta R S <[email-masked]>
Date: Mon, 2 Sep 2019 15:49:19 +0300

Hi,

Chronos has a provable security guarantees compared to the current NTPv4,
even when facing MitM attacker.
Thus, we suggested Chronos as NTPv4 watchdog and named the draft
accordingly.
We'll consider your comment regarding the draft's name, but in the worse
case (where the MitM controls the client's gateway) I am not sure there is
a solution.

Regarding Daniel's and Kristof's comments, we agree that experimental might
be a more appropriate intended status.

Best,
Neta

On Mon, Sep 2, 2019 at 2:59 PM Miroslav Lichvar <[email-masked]> wrote:

> > Please reply with your opinion on whether or not the working group
> should adopt this document including your willingness to review and
> contribute.
>
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
>

---

From: Harlan Stenn <[email-masked]>
Date: Mon, 2 Sep 2019 05:55:32 -0700

I am opposed to the adoption of this draft as anything other than an
experimental proposal.

On 9/2/2019 5:49 AM, Neta R S wrote:
> Hi,
> 
> Chronos has a provable security guarantees compared to the current
> NTPv4, even when facing MitM attacker.

What *exactly* are these provable security guarantees?

I suspect people are drawing incorrect inferences from "provable
security guarantees".

H
--
> case (where the MitM controls the client's gateway) I am not sure there
> is a solution. 
> 
> Regarding Daniel's and Kristof's comments, we agree that experimental
> might be a more appropriate intended status.
> 
> Best, 
> Neta
> 
> On Mon, Sep 2, 2019 at 2:59 PM Miroslav Lichvar <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     contribute..
>     [email-masked] <mailto:[email-masked]>

-- 
Harlan Stenn, Network Time Foundation
http://nwtime.org - be a Member!

---

From: Neta R S <[email-masked]>
Date: Mon, 2 Sep 2019 16:03:17 +0300

Hi,

Chronos' security guarantees were analysed in the following paper:
https://www.ndss-symposium.org/wp-content/uploads/2018/02/ndss2018_02A-2_Deutsch_paper.pdf

(which is also referred in the draft).

Best,
Neta

---

From: Harlan Stenn <[email-masked]>
Date: Mon, 2 Sep 2019 06:06:03 -0700

Am I the only person who would want to see the security guarantees at
least summarized in the draft?

I'm talking about a summary, not a pointer to some other document.

I care less about this if the draft switches to the Experimental track.

H

On 9/2/2019 6:03 AM, Neta R S wrote:
> On Mon, Sep 2, 2019 at 3:55 PM Harlan Stenn <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     > On Mon, Sep 2, 2019 at 2:59 PM Miroslav Lichvar
>     <[email-masked] <mailto:[email-masked]>
>     > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >     > A Secure Selection and Filtering Mechanism for the Network Time
>     >     Protocol Version 4
>     >     > https://datatracker.ietf.org/doc/draft-schiff-ntp-chronos/
>     >     >
>     >     > Please reply with your opinion on whether or not the working
>     group
>     >     [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>

---

From: Marcus Dansarie <[email-masked]>
Date: Mon, 2 Sep 2019 20:39:56 +0200

I support adoption of this draft. I am willing to help in reviewing the
draft.

Kind regards,
Marcus Dansarie

On 2019-08-28 07:37, Karen O'Donoghue wrote:
> Folks,
> 
> This is the official call for adoption for the following document: 
> 
> Regards,
> Karen

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 3 Sep 2019 10:34:29 +0300

Hi Harlan,

Thanks for the feedback.

>I am opposed to the adoption of this draft as anything other than an

The difference between Informational and Experimental is a bit subtle,
e.g., "Experimental" is usually defined for a limited period of time.
However, Informational and Experimental are 'on the same level' in terms of
importance.

It is important to emphasize that the intended status of the current draft
is not "Standards Track", and it is not intended to "update" RFC 5905.
Chronos is defined as a client algorithm that does not affect NTP servers
or non-Chronos clients, so there is no interoperability issues with
existing implementations of NTP. That is why we see it as "Informational",
as it does not change the protocol, and an implementation may choose to
implement Chronos or not to implement it, without affecting other
implementations.

Anyway, I believe this is not a big issue, and can probably be resolved
with the WG chairs.

Thanks,
Tal.

---

From: "Ulrich Windl" <[email-masked]>
Date: Tue, 03 Sep 2019 10:15:05 +0200

>>> Tal Mizrahi <[email-masked]> schrieb am 03.09.2019 um 09:34 in
Nachricht
> However, Informational and Experimental are 'on the same level' in terms of

Hi!

I don't know the IETF criteria, but I'd say "experimental" is "something ongoing, not finished with uncertain end" while "informational" is "something completed, not defining any standard or proposal of a standard".

Regards,
Ulrich