Subject: [Ntp] 16 bit extension numbers

From: Watson Ladd <[email-masked]>
Date: Wed, 19 Feb 2020 17:08:19 -0800

Dear all,

The value of having all 16 bits available, and reserving 1/2 the space
(or maybe a bit less) as experimental is tremendous: it means we don't
have to worry about coordinating values and can let IANA assign them
from the bottom to the top of the space.

Grouping related extensions by having a code and a type as Harlan is
proposing wastes space: a type with no codes consumes 256 possible
extension values, and the greatest number of codes ever used is 10.
Each flag bit cuts the number of extensions in half: one has to be
really sure that bit is valuable, and they aren't: one of them is
depreciated and reserved for a protocol you shouldn't use.

I don't see any reason to be so profligate.

Sincerely,
Watson

---

From: Harlan Stenn <[email-masked]>
Date: Wed, 19 Feb 2020 17:17:39 -0800

Do I need to repeat why this is a bad idea?

H

On 2/19/2020 5:08 PM, Watson Ladd wrote:
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
> 

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!

---

From: Watson Ladd <[email-masked]>
Date: Wed, 19 Feb 2020 17:27:01 -0800

> Do I need to repeat why this is a bad idea?

What is a bad idea? TLS does just fine with a flat extension space.

---

From: Harlan Stenn <[email-masked]>
Date: Wed, 19 Feb 2020 17:40:45 -0800

I will hold my response until either/both of the Chairs responds.

H

On 2/19/2020 5:27 PM, Watson Ladd wrote:
> 
> 
> On Wed, Feb 19, 2020, 5:17 PM Harlan Stenn <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     > [email-masked] <mailto:[email-masked]>
>     Harlan Stenn <[email-masked] <mailto:[email-masked]>>
>     [email-masked] <mailto:[email-masked]>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Feb 2020 02:16:30 +0000

>   Do I need to repeat why this is a bad idea?
  
Yes, please.  Ideally post a link to previous email.

---

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 20 Feb 2020 02:38:43 +0000

Yes please... repeat your responses so that we have the points to consider in the context of the current conversation. 

And please, remember that time has moved on and any agreements made for early versions of NTS are no longer binding. 

Karen

On 2/19/20, 8:41 PM, "ntp on behalf of Harlan Stenn" <[email-masked] on behalf of [email-masked]> wrote:

    H