Subject: [Ntp] I-D Action: draft-ietf-ntp-using-nts-for-ntp-24.txt

From: [email-masked]
Date: Wed, 18 Mar 2020 14:09:13 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Time Protocol WG of the IETF.

        Title           : Network Time Security for the Network Time Protocol
        Authors         : Daniel Fox Franke
                          Dieter Sibold
                          Kristof Teichel
                          Marcus Dansarie
                          Ragnar Sundblad
	Filename        : draft-ietf-ntp-using-nts-for-ntp-24.txt
	Pages           : 44
	Date            : 2020-03-18

Abstract:
   This memo specifies Network Time Security (NTS), a mechanism for
   using Transport Layer Security (TLS) and Authenticated Encryption
   with Associated Data (AEAD) to provide cryptographic security for the
   client-server mode of the Network Time Protocol (NTP).

   NTS is structured as a suite of two loosely coupled sub-protocols.
   The first (NTS-KE) handles initial authentication and key
   establishment over TLS.  The second handles encryption and
   authentication during NTP time synchronization via extension fields
   in the NTP packets, and holds all required state only on the client
   via opaque cookies.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ntp-using-nts-for-ntp/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ntp-using-nts-for-ntp-24
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-using-nts-for-ntp-24

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ntp-using-nts-for-ntp-24

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Marcus Dansarie <[email-masked]>
Date: Wed, 18 Mar 2020 22:24:19 +0100

All,

On behalf of all the authors, I would like to thank the reviewers for
the overwhelming response. In all, we have received over 140 individual
comments on the draft since the IETF Last Call. As you can probably
understand, it has taken us some time to go through and address the
comments one by one. This version of the draft will hopefully resolve
most of your concerns. We will get back to you shortly with individual
replies to each of the comments.

Thank you for your patience so far.

Kind regards,
Marcus Dansarie

On 2020-03-18 22:09, [email-masked] wrote:
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
>

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 19 Mar 2020 13:33:48 +0000

Hi Sandy,
  Thanks again for the review and for going through the issue resolutions.

> On Mar 19, 2020, at 7:10 AM, Sandra Murphy <[email-masked]> wrote:
> 
> Thanks for this message!
> 
> My bad, my very very bad, I only yesterday saw the message sent to me about the gitlab repo where the 3-4 of you discussed each issue.  (Each issue!  Impressive!) I spent a lot of time yesterday afternoon reviewing the resolution of each of my comments.  In some cases, I would like to respond further.

Will you be able to do this in the next couple of days? 

> 
> I’m glad this is being sent to the list.
> 
> The draft is still listed on today’s IESG agenda.  Will it be discussed?

Yes. We do plan to discuss this on the telechat today. The telechat is open to observers if you would like to call in.

Regards
Suresh

---

From: Sandra Murphy <[email-masked]>
Date: Thu, 19 Mar 2020 07:10:16 -0400

Thanks for this message!

(IMHO, there’s no reason to apologize for getting comments addressed in just two weeks after the end of the IETF Last Call is incredibly quick.  I think it is phenomenal.)

—Sandy

> On Mar 18, 2020, at 5:24 PM, Marcus Dansarie <[email-masked]> wrote:
> 
> Signed PGP part
> All,
>

---

From: Sandra Murphy <[email-masked]>
Date: Thu, 19 Mar 2020 09:59:18 -0400

In the next few days, but not today.

—Sandy

> On Mar 19, 2020, at 9:33 AM, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi Sandy,

---

From: Marcus Dansarie <[email-masked]>
Date: Thu, 19 Mar 2020 19:25:16 +0100

Hi Sandra!

> My bad, my very very bad, I only yesterday saw the message sent to me about the gitlab repo where the 3-4 of you discussed each issue.  (Each issue!  Impressive!) I spent a lot of time yesterday af…

No problem, we're glad you found it! Are you ok with reading the
resolutions on Github or would you like us to reply on-list with a
digest message?

> (IMHO, there’s no reason to apologize for getting comments addressed in just two weeks after the end of the IETF Last Call is incredibly quick.  I think it is phenomenal.)

Thank you!

Kind regards,
Marcus Dansarie