Subject: [Ntp] Minutes from the last NTP Interim Meeting (2020-02-27)

From: [email-masked]
Date: Tue, 3 Mar 2020 19:38:54 +0100

Dear all,
below, please find the minutes from the last NTP Interim meeting. 

https://datatracker.ietf.org/meeting/interim-2020-ntp-02/materials/minutes-interim-2020-ntp-02-202002271600.txt

Dieter

===============================
NTP Virtual Interim
February 27th, 2020
16:00 UCT
Meeting Minutes
===============================

Chairs: Karen O'Donoghue, Dieter Sibold
Minutes: Tal Mizrahi

Participants:
=============
Karen O'Donoghue
Dieter Sibold
Tal Mizrahi
Denis Reilly
Danny Mayer
Fireball Steve
Marcus Dansarie
Martin Langer
Ragnar Sunblad
Watson Ladd
Rich Salz

Introduction
============
- Karen: we are going to record the meeting. Any comments?
- No comments.
- Karen: the IETF note well applies.
- The agenda was presented.

Packet Timestamp Draft Status
=============================
Tal: the IETF last call is over. There were a few comments from the 
Gen-ART reviewer, and we updated the draft based on theses comments. 
Nothing major. The draft is currently under IESG evaluation, and is 
scheduled to be discussed in the telechat on the 12th of March.
Karen: there was some discussion in the last few days.
Tal: right, there were two comments, both related to the control field 
section. We can address them with minor changes to the control field 
section.
Karen: is it going to be a technical change that require to notify the 
IESG?
Tal: I believe they are minor changes.
Karen: is there still a plan to pursue the additional document about the 
control fields?
Tal: yes, Joachim is leading this effort, and we have recently discussed 
it, and it looks like there is motivation to pursue this draft in the near 
future.
Karen: did Doug ask a question on the mailing list?
Tal: yes, it was one of the two comments I mentioned. Doug noted that it 
would be worthwhile to mention the PTP correctionField. We can add a 
comment to the control field section, since the correctionField is not a 
timestamp, it is an additional field that is sent along with the 
timestamp.

NTS Draft Status
================
Karen: IETF last call on NTS - do any of the authors want to summarize the 
status?
Dieter: there were a couple of comments that we already implemented in the 
Github repository, and will be in the next version of the draft. A couple 
of comments from the Gen-ART reviewere have not been resolved yet.
Marcus: the only additional issue is the issue from the Gen-ART reviewer. 
There was a comment that we were not leaving values for future versions, 
but we do not agree with that.
Watson: I believe the question was about values for experimental use.
Marcus: there are enough values for experimental use.
Dieter: Marcus - can you please send a reply to the Gen-ART reviewer?
Marcus: yes, I will do that.
Karen: regarding the IANA values - the suggested text was posted, but I 
have not seen any comments from implementers.
Dieter: it was added.
Karen: I am not sure we will complete this before the IESG transition.
Karen: any other discussion about NTS?
Karen: once the IESG starts balloting it is much easier if all the issues 
are addressed before the telechat. Be proactive to respond to any comments 
- no need to ask the working group, unless it is a controversial issue.

Roughtime Draft Status
======================
Karen: an update was published about a month ago.
Watson: a number of suggestions will be implemented. Not sure when the 
Roughtime deployment will implement these changes. Just ignore the 
optional fields if they are not familiar.
Karen: any other comments or questions?

Chronos Draft Status
====================
Tal: the authors have been working on an updated version that will be 
posted in the next few days. The new version addresses the main comment 
that was received about the draft, which is that Chronos may compromise 
the precision compared to NTP. The updated version of the draft suggests a 
solution that improves the security without compromising the precision.

Status of other drafts:
=======================
Karen: Interleaved mode needs to go to the IESG.
Karen: the YANG model draft still has some issues that need to be 
discussed.
Karen: port randomization - the authors are not available to give an 
update.

NTS Discussion
==============
Watson: some concerns have been raised about NTS. Some middleboxes are 
filtering NTP packets based on length. Do we need another NTP port?
Rich: a new NTP port will not help, since unknown UDP ports are denied by 
default.
Watson: maybe we can ask NANOG.
Danny: the same problem was when we started deploying EDNS0. There is no 
easy way to start deploying a new protocol.
Karen: do you have any suggestions to a successful strategy?
Danny: need to ask the people who were involved.
Karen: NTP has been widely used, so this is a problem.
Danny: the problem is that middleboxes will need to do deep packet 
inspection.
Watson: some boxes do not go beyond the headers.
Danny: legacy routers and devices will have a problem.
Karen: I am interested to find the right way to help deploy NTS, find the 
right organizations and resources. People from ISPs and operators may be 
able to help.
Danny: regardless of the port number, you still have a problem.
Watson: you can get an organization to change the firewall.
Danny: people try not to touch firewalls.
Karen: I am not sure what will happen in the IETF in Vancouver, and what 
tools we can have to try to promote NTS.
Dieter: can we pass the question to the OPS area?
Karen: the question about the ports?
Dieter: yes.
Karen: yes, we can ask. Running it by the NANOG mailing list may be 
interesting.
Rich: the IETF has good connection with an ISP (Jason Livingood). We can 
ask where we can talk about this.
Karen: it is a real problem. I was talking to Judah Levine, and he is 
concerned about scaling in this context. Two potential NTS topcis for 
Vancouver: measurement and deployment.
Watson: we are not seeing a lot of uptake for NTS so far.
Karen: encouraging deployment is a general problem.
Marcus: if any major OS vendor would adopt NTS that would go a long way.
Steve: a lot of Linux distributions use NTP pool. Will not necessarily 
work with NTS.
Danny: nothing in the pool prevents NTS. Just need changes to specify that 
NTS is needed.
Karen: the way that NTP pool is used, it will not exactly work with NTS.
Marcus: it would be possible for the NTP pool to use NTS, by assigning a 
specific member of the pool.
Karen: we talked about this, but we haven't done the work to get it 
incorporated.
Watson: I have some ideas I can send to the list.
Karen: that would be great.
Steve: maybe we can take it to the list.
Karen: good idea. I do not see a major issue in the IESG process. It is 
timely to talk about deployment.

AOB
===
Karen: any other business?
Karen: there is a possibility that the IETF will hold a fully virtual 
meeting. It is currently not clear.
Karen: thanks everyone for the hard work that got us to this point.

Adjourned at 16:40 UTC.

---

From: Harlan Stenn <[email-masked]>
Date: Tue, 3 Mar 2020 14:24:40 -0800

Did an agenda get sent before the meeting?  I didn't see one.

H

On 3/3/2020 10:38 AM, [email-masked] wrote:
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
> 

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!

---

From: "Dieter Sibold" <[email-masked]>
Date: Tue, 03 Mar 2020 23:49:04 +0100

Hi Harlan,
yes, Karen has send it at the February, 13th to the NTP mailing list.
Dieter