Subject: Re: [Ntp] Leap smearing

From: Hal Murray <[email-masked]>
Date: Wed, 09 Dec 2020 17:00:30 -0800

[email-masked] said:
> The leap smear function co uld be a cosine function, to match the frequency
> at the start and end of the lea p smear interval.

We could do lots of things, but in this case, the guys who want leap smearing 
have already decided on those details and we should copy whatever they do.

I think it's linear over 24 hours.  Does anybody have a good reference?

-- 
These are my opinions.  I hate spam.

---

From: Steve Allen <[email-masked]>
Date: Wed, 9 Dec 2020 17:16:21 -0800

> I think it's linear over 24 hours.  Does anybody have a good reference?

full day linear smear
updated last week to list other known methods

https://developers.google.com/time/smear

--
Steve Allen                    <[email-masked]>              WGS-84 (GPS)
UCO/Lick Observatory--ISB 260  Natural Sciences II, Room 165  Lat  +36.99855
1156 High Street               Voice: +1 831 459 3046         Lng -122.06015
Santa Cruz, CA 95064           https://www.ucolick.org/~sla/  Hgt +250 m

---

From: Hal Murray <[email-masked]>
Date: Wed, 09 Dec 2020 17:51:41 -0800

> full day linear smear 

Just in case somebody doesn't read the fine print....

That "day" is 24 hours.
The smear is noon to noon, not the day before/after the leap.

---

From: Martin Burnicki <[email-masked]>
Date: Thu, 10 Dec 2020 14:42:42 +0100

> I think it's linear over 24 hours.  Does anybody have a good reference?

The Google page at

also lists some other smearing approaches at the bottom of the page.

Martin
-- 
Martin Burnicki

Senior Software Engineer

MEINBERG Funkuhren GmbH & Co. KG
Email: [email-masked]
Phone: +49 5281 9309-414
Linkedin: https://www.linkedin.com/in/martinburnicki/

Lange Wand 9, 31812 Bad Pyrmont, Germany
Amtsgericht Hannover 17HRA 100322
Geschäftsführer/Managing Directors: Günter Meinberg, Werner Meinberg,
Andre Hartmann, Heiko Gerstung
Websites: https://www.meinberg.de  https://www.meinbergglobal.com
Training: https://www.meinberg.academy