Subject: [Ntp] FW: [lamps] RFC 6019

From: "Salz, Rich" <[email-masked]>
Date: Tue, 12 Jan 2021 16:25:39 +0000

Forwarded.  Any comments, please post to spasm@ and/or Russ.

On 1/12/21, 11:14 AM, "Russ Housley" <[email-masked]> wrote:

    RFC 6019 is:

         BinaryTime: An Alternate Format for Representing Date and Time in
         ASN.1. R. Housley. September 2010. (Format: TXT, HTML) (Obsoletes
         RFC4049) (Status: PROPOSED STANDARD) (DOI: 10.17487/RFC6019) 

    Is appears that several people are finding this useful:

        https://datatracker.ietf.org/doc/rfc6019/referencedby 

    I would like to know if people have implemented it.  If so, should we progress the document to Internet Standard?

    Russ

---

From: "Ulrich Windl" <[email-masked]>
Date: Wed, 13 Jan 2021 08:09:01 +0100

Hi!

I wonder: What sense does it make to specify a new time format in 2010 that
can represent dates only up to 2038? Despite of that the method just uses UTC
("... based on coordinated universal time (UTC), which is also called Greenwich
Mean Time (GMT) and ZULU clock time."), so what's the actual benefit in this
context?
I'm surprised: Wouldn't BER (Basic Encoding Rules) allow arbitrarily large
integers? And when talking about "civil" time, woiuldn'a "broken down" format
like year, month, day, hoer, miniute, second, fractional-second,
timezone(-offset) be a preferrable representation?

I think this is a "standard" nobody actually needs.

Regards,
Ulrich

>>> "Salz, Rich" <rsalz=[email-masked]> schrieb am 12.01.2021 um
17:25
in Nachricht <[email-masked]>:
>     I would like to know if people have implemented it.  If so, should we 
> progress the document to Internet Standard?
> 
>     Russ
>  
> 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp

---

From: "Ulrich Windl" <[email-masked]>
Date: Wed, 13 Jan 2021 08:34:26 +0100

Sorry for the many spellign errors, but I hope you could understand still:
"woiuldn'a" is "wouldn't"
"hoer" is "hour"
"miniute" is "minute"
"preferrable" probably has too many "r"s
...

>>> "Ulrich Windl" <[email-masked]> schrieb am 13.01.2021
um

---

From: Russ Housley <[email-masked]>
Date: Wed, 13 Jan 2021 10:44:45 -0500

I am confused by your response because the RFC says:

   BinaryTime ::= INTEGER (0..MAX)

You seem to think that it is limited to four-byte integers, but it is not.

Russ

> On Jan 13, 2021, at 2:09 AM, Ulrich Windl <[email-masked]> wrote:
> 
> Hi!
>

---

From: "Ulrich Windl" <[email-masked]>
Date: Thu, 14 Jan 2021 08:41:38 +0100

>>> Russ Housley <[email-masked]> schrieb am 13.01.2021 um 16:44 in
Nachricht
> You seem to think that it is limited to four-byte integers, but it is not.

OK, I was confused by:
...
   represent time values prior to January 1, 1970.  The latest UTC time
   value that can be represented by a four-octet integer value is
   03:14:07 on January 19, 2038, which is represented by the hexadecimal
   value 7FFFFFFF."

Regards,
Ulrich

> 
> Russ
> 
>> On Jan 13, 2021, at 2:09 AM, Ulrich Windl
<[email-masked]> 
> wrote: