Subject: Re: [Ntp] Circular dependencies

From: Philip Prindeville <[email-masked]>
Date: Sat, 16 Jan 2021 19:19:31 -0700

> On Nov 11, 2020, at 5:02 PM, Hal Murray <[email-masked]> wrote:
> 
> 2) Systems like the Raspberry Pi that have a real file system but no battery 
> backed clock.  We can store the time in the file system.  This works as long 
> as the systems are powered up often enough to keep the time in the file system 
> close enough.

I had to do this... ran a cron job to save the time every 5 minutes.

The issue isn't how often you're booted.  It's how long you've been shut down (i.e. how old is your last snapshot of the time).

---

From: Warner Losh <[email-masked]>
Date: Sat, 16 Jan 2021 19:39:27 -0700

On Sat, Jan 16, 2021, 7:19 PM Philip Prindeville <
[email-masked]> wrote:

> The issue isn't how often you're booted.  It's how long you've been shut
> down (i.e. how old is your last snapshot of the time).
>

Sure makes cold spares hard to implement..

_______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
>