Subject: [Ntp] [Technical Errata Reported] RFC5906 (6402)

From: RFC Errata System <[email-masked]>
Date: Wed, 20 Jan 2021 14:54:21 -0800 (PST)

The following errata report has been submitted for RFC5906,
"Network Time Protocol Version 4: Autokey Specification".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6402

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: Appendix J

Original Text
-------------
   CertificateSerialNumber
   SET { ::= INTEGER
           Validity ::= SEQUENCE {
                   notBefore              UTCTime,
                   notAfter               UTCTime
           }
   }

Corrected Text
--------------
   CertificateSerialNumber ::= INTEGER

   Validity ::= SEQUENCE {
                   notBefore              UTCTime,
                   notAfter               UTCTime
   }

Notes
-----
The original ASN.1 will not compile.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5906 (draft-ietf-ntp-autokey-08)
--------------------------------------
Title               : Network Time Protocol Version 4: Autokey Specification
Publication Date    : June 2010
Author(s)           : B. Haberman, Ed., D. Mills
Category            : INFORMATIONAL
Source              : Network Time Protocol
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Brian Haberman <[email-masked]>
Date: Thu, 21 Jan 2021 07:27:15 -0500

I agree with Russ' correction.

Brian