Subject: [Ntp] draft-ietf-ntp-roughtime-05: GREASE-type tags?

From: JP Sugarbroad <[email-masked]>
Date: Mon, 20 Sep 2021 21:09:29 -0700

I notice there is a requirement to ignore unknown tags. However, with the
existence of a defined padding tag, I worry that implementations will not
necessarily abide by this requirement, making future extensions difficult
to deploy.

Perhaps a GREASE-type tag space would be beneficial?

-- 
JP Sugarbroad <[email-masked]>
"Please let me know if there's any further trouble I can give you."
    -- Unknown

---

From: Watson Ladd <[email-masked]>
Date: Mon, 20 Sep 2021 21:14:37 -0700

On Mon, Sep 20, 2021 at 9:09 PM JP Sugarbroad <[email-masked]> wrote:
>
> I notice there is a requirement to ignore unknown tags. However, with the existence of a defined padding tag, I worry that implementations will not necessarily abide by this requirement, making future extensions difficult to deploy.
>

This is a good idea that we dropped from the original description. We
shall add it back in.

Sincerely,
Watson
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp

--
Astra mortemque praestare gradatim