Subject: [Ntp] NTS and validation

From: "Salz, Rich" <[email-masked]>
Date: Mon, 13 Sep 2021 13:04:53 +0000

Question for NTS implementors: do you validate the server certificate?

I’m the primary author updating RFC 6125. QUIC uses TLS to set up its key material, like NTS, and it does the certificate validation the way TLS does.  NTS the same?

---

From: "Langer, Martin" <[email-masked]>
Date: Mon, 13 Sep 2021 13:11:39 +0000

Yes, NTS uses TLS for key establishment. An NTP client also checks the certificate of the TLS server (= NTS-KE server).

greetings,

Martin

-------------------
Martin Langer, M.Eng.
Ostfalia Hochschule für angewandte Wissenschaften
- Hochschule Braunschweig/Wolfenbüttel
University of Applied Sciences

Labor Datentechnik, Labor Design Digitaler Systeme
Fakultät Elektrotechnik
Salzdahlumer Straße 46/48
38302 Wolfenbüttel
Germany

Tel.: +49 5331 939 43370
Web: https://www.ostfalia.de/cms/de/pws/bermbach/mitarbeiter/martin-langer

________________________________
Von: ntp <[email-masked]> im Auftrag von Salz, Rich <rsalz=[email-masked]>
Gesendet: Montag, 13. September 2021 15:04:53
An: [email-masked]
Betreff: [Ntp] NTS and validation

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 13 Sep 2021 13:26:18 +0000

*   Yes, NTS uses TLS for key establishment. An NTP client also checks the certificate of the TLS server (= NTS-KE server).

Thanks!  https://github.com/richsalz/draft-ietf-uta-rfc6125bis/issues/22