Subject: [Ntp] draft-ietf-ntp-roughtime-05: mixed time units

From: JP Sugarbroad <[email-masked]>
Date: Mon, 20 Sep 2021 21:26:51 -0700

I notice that DTAI and DUT1 are in milliseconds, while everything else is
in microseconds. Is the extra range of a millisecond value needed?

-- 
JP Sugarbroad <[email-masked]>
"Please let me know if there's any further trouble I can give you."
    -- Unknown

---

From: Watson Ladd <[email-masked]>
Date: Mon, 20 Sep 2021 21:47:54 -0700

On Mon, Sep 20, 2021 at 9:27 PM JP Sugarbroad <[email-masked]> wrote:
>
> I notice that DTAI and DUT1 are in milliseconds, while everything else is in microseconds. Is the extra range of a millisecond value needed?

DUT1 is only available in 10^-1s precision. DTAI is always whole
seconds. We could probably fix that to be seconds.

The extra range isn't needed, but having more decimals isn't either.

Sincerely,
Watson

> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp

--
Astra mortemque praestare gradatim

---

From: JP Sugarbroad <[email-masked]>
Date: Mon, 20 Sep 2021 22:09:56 -0700

> The extra range isn't needed, but having more decimals isn't either.

My experience is that mixed units is a source of errors when people forget
to rescale them before combining. If the extra range isn't needed, I
suggest using microseconds everywhere.

- JP