Subject: [Ntp] draft-ietf-ntp-alternative-port-02

From: Doug Arnold <[email-masked]>
Date: Wed, 10 Nov 2021 21:54:01 +0000

Miroslav,

You write with a style that is consice and straight forward, which makes your drafts easy to read.  Definitely a good thing.

However, there are two statements on page 4 of draft-ietf-ntp-alternative-port-02<https://datatracker.ietf.org/doc/draft-ietf-ntp-alternative-port/> that could use some elaboration.
“Only modes 1 (active), 2 (passive), 3 (client), 4 (server), and 5(broadcast) are generally usable on this port.”

The word “generally” makes this statement vague.  How about:
“Only modes 1 (active), 2 (passive), 3 (client), 4 (server), and 5(broadcast) SHOULD be used on this port.”

“The client MAY send a limited number of requests to both ports …”

A limit without further elaboration is not a limit at all. How about recommending a specific maximum number of requests/unit time on each port?
Doug

---

From: Miroslav Lichvar <[email-masked]>
Date: Fri, 12 Nov 2021 15:17:20 +0100

> “Only modes 1 (active), 2 (passive), 3 (client), 4 (server), and 5(broadcast) SHOULD be used on this port.”

Ok, makes sense to me.
> A limit without further elaboration is not a limit at all.

It's not unlimited :).

> How about recommending a specific maximum number of requests/unit time on each port?

Ok, say 8?

Thanks,

-- 
Miroslav Lichvar

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 15 Nov 2021 08:32:51 +0100

>>> Miroslav Lichvar <[email-masked]> schrieb am 12.11.2021 um 15:17 in
Nachricht <YY53cMl+SlxUu21H@localhost>:
>> “Only modes 1 (active), 2 (passive), 3 (client), 4 (server), and 
> 5(broadcast) SHOULD be used on this port.”
> 
> Ok, makes sense to me.
>> 
>> 

Well, maybe add some reasoning, just no make it look non-arbitrary.

> 
> Thanks,
> 
> -- 
> Miroslav Lichvar
> 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp

---

From: Miroslav Lichvar <[email-masked]>
Date: Mon, 15 Nov 2021 10:03:05 +0100

> Well, maybe add some reasoning, just no make it look non-arbitrary.

It is arbitrary. The idea behind it is to avoid clients wasting
network capacity if the server doesn't support the alternative port.

-- 
Miroslav Lichvar