Subject: [Ntp] draft-gruessing-ntp-ntpv5-requirements-04

From: Doug Arnold <[email-masked]>
Date: Wed, 1 Dec 2021 22:50:36 +0000

This draft of the ntpv5 requirements includes a number of minor changes that bring it in line with the consensus in the email discussions.

Regarding the signaling of pending leap seconds, the document states:

The specification SHOULD also be capable of transmitting upcoming leap seconds greater than 1 calendar day in advance.

We could consider a stronger requirement, such as:

The specification MUST require that servers transmit upcoming leap seconds greater than 1 calendar day in advance if that information is known by the server. If the server learns of a leap second less than 1 calendar day before a leap second event, it will start transmitting the information immediately.

Doug

---

From: James G <[email-masked]>
Date: Thu, 2 Dec 2021 15:55:50 +0100

Thanks for the feedback Doug. I agree with this and made an issue for it [1] which I'll incorporate later.

- J

1: https://github.com/fiestajetsam/draft-gruessing-ntp-ntpv5-requirements/issues/7

> On 1 Dec 2021, at 23:50, Doug Arnold <doug.arnold=[email-masked]> wrote:
> 
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp