Subject: Re: [Ntp] Francesca Palombini's Discuss on draft-ietf-ntp-yang-data-model-15: (with DISCUSS and COMMENT)

From: Dhruv Dhody <[email-masked]>
Date: Thu, 9 Dec 2021 22:28:59 +0530

Hi Francesca,

Firstly let me apologize for this very late reply. Secondly thanks for your
review. I was finally able to make all the changes.

On Wed, Jun 30, 2021 at 9:45 PM Francesca Palombini via Datatracker <
[email-masked]> wrote:

> Francesca Palombini has entered the following ballot position for
> draft-ietf-ntp-yang-data-model-15: Discuss
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-ntp-yang-data-model/
>
>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> Thank you for the work on this document.
>
> I have a simple-to-solve DISCUSS point, and some non blocking comments.
>
> Francesca
>
>
> 1. -----
>
>         leaf clock-precision {
>           type int8;
>           units "Hz";
>
> FP: I believe the units should be seconds here.
>
>
Dhruv: The Hz was incorrect. BTW I am using a new typedef log2seconds now
(as per Ben's DISCUSS).

>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> 2. -----
>
>   typedef ntp-date-and-time {
>     type union {
>       type yang:date-and-time;
>       type uint8;
>     }
>     description
>       "Follows the normal date-and-time format when valid value
>        exist, otherwise allows for setting special value such as
>        zero.";
>
> FP: I'd rather the document avoided the term "normal", which could be just
> removed. Also, could a 'reference' be added, pointing to RFC 6991?
>
>
Dhruv: Agreed and updated.

> 3. -----
>
>         "The association was configured or dynamic
>          which result in clock synchronization.";
>
> FP: This sentence doesn't parse correctly for me. Is there any text
> missing? Or
> maybe a wrong copy paste?
>
>
Dhruv: Updated to - "Indicates if the association (that resulted in the
clock synchronization) is explicitly configured."

> 4. -----
>
>       description
>         "Configuration to control access to NTP service
>          by using NTP access-group feature.
>          The access-mode identifies how the acl is
>          applied with NTP.";
>
> FP: (here and other places) please make sure the capitalization of ACL is
> consistent in the descriptions and in the text of the doc.
>
>
> Dhruv: Ack.

Thanks!
Dhruv

Diff:
https://www.ietf.org/rfcdiff?url1=draft-ietf-ntp-yang-data-model-15&url2=https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt
Working Copy:
https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt

Consolidated Review Status:
https://notes.ietf.org/draft-ietf-ntp-yang-data-model

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 9 Dec 2021 17:11:29 +0000

Hi Dhruv,

Thanks for the update! It all looks good to me, I will remove my DISCUSS as soon as the new version is uploaded.

Thanks,
Francesca

From: Dhruv Dhody <[email-masked]>
Date: Thursday, 9 December 2021 at 17:59
To: Francesca Palombini <[email-masked]>
Cc: The IESG <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, NTP WG <[email-masked]>, Dieter Sibold <[email-masked]>
Subject: Re: Francesca Palombini's Discuss on draft-ietf-ntp-yang-data-model-15: (with DISCUSS and COMMENT)
Hi Francesca,

Firstly let me apologize for this very late reply. Secondly thanks for your review. I was finally able to make all the changes.

On Wed, Jun 30, 2021 at 9:45 PM Francesca Palombini via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Francesca Palombini has entered the following ballot position for
draft-ietf-ntp-yang-data-model-15: Discuss

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-bb14cec5df0b3a0e&q=1&e=0-dbf36cfba4fb1321942c93a8f7c87d31&u=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html>
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ntp-yang-data-model/<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-08e23231aefba629&q=1&e=0-dbf36cfba4fb1321942c93a8f7c87d31&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-ntp-yang-data-model%2F>

Francesca

1. -----

        leaf clock-precision {
          type int8;
          units "Hz";

Dhruv: The Hz was incorrect. BTW I am using a new typedef log2seconds now (as per Ben's DISCUSS).

2. -----

3. -----

FP: This sentence doesn't parse correctly for me. Is there any text missing? Or
maybe a wrong copy paste?

Dhruv: Updated to - "Indicates if the association (that resulted in the clock synchronization) is explicitly configured."

4. -----

      description

Dhruv: Ack.

Thanks!
Dhruv

Diff: https://www.ietf.org/rfcdiff?url1=draft-ietf-ntp-yang-data-model-15&url2=https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-a13f81f1d2c92697&q=1&e=0-dbf36cfba4fb1321942c93a8f7c87d31&u=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl1%3Ddraft-ietf-ntp-yang-data-model-15%26url2%3Dhttps%3A%2F%2Fraw.githubusercontent.com%2Fdhruvdhody%2Fietf%2Fmaster%2Fdraft-ietf-ntp-yang-data-model-16.txt>
Working Copy: https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-b1568e82014e9cd1&q=1&e=0-dbf36cfba4fb1321942c93a8f7c87d31&u=https%3A%2F%2Fraw.githubusercontent.com%2Fdhruvdhody%2Fietf%2Fmaster%2Fdraft-ietf-ntp-yang-data-model-16.txt>
Consolidated Review Status: https://notes.ietf.org/draft-ietf-ntp-yang-data-model<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-1a425099e82ddf55&q=1&e=0-dbf36cfba4fb1321942c93a8f7c87d31&u=https%3A%2F%2Fnotes.ietf.org%2Fdraft-ietf-ntp-yang-data-model>