Subject: Re: [Ntp] Zaheduzzaman Sarker's No Objection on draft-ietf-ntp-yang-data-model-15: (with COMMENT)

From: Dhruv Dhody <[email-masked]>
Date: Thu, 9 Dec 2021 22:30:47 +0530

Hi Zaheduzzaman,

Firstly let me apologize for this very late reply. Secondly thanks for your
review. I was finally able to make all the changes.

On Wed, Jun 30, 2021 at 8:53 PM Zaheduzzaman Sarker via Datatracker <
[email-masked]> wrote:

> Zaheduzzaman Sarker has entered the following ballot position for
> draft-ietf-ntp-yang-data-model-15: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-ntp-yang-data-model/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> Thanks for the efforts on this document.
>
> I support Éric Vyncke's discuss.
>
> I also think adding reference to RFC 1305 in section 5 and section 6
> creates a
> bit of confusion when this document says it defines YANG model for RFC
> 5905.
> Also it is a fact that RFC 1305 is obsoleted by RFC 5905. So is this yang
> model
> also applicable to NTPv3? if not please mention, if so please mention and
> consider removing references to RFC 1305.
>
>
>
>
Dhruv: Since the YANG model allows the version to be set to 3, it can be
used to configure NTPv3. I have added text to make this clearer.

Thanks!
Dhruv

Diff:
https://www.ietf.org/rfcdiff?url1=draft-ietf-ntp-yang-data-model-15&url2=https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt
Working Copy:
https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt

Consolidated Review Status:
https://notes.ietf.org/draft-ietf-ntp-yang-data-model

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 9 Dec 2021 17:06:50 +0000

I agree this is much clearer now. Thanks.

BR
Zahed

On 2021-12-09, 18:01, "Dhruv Dhody" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Zaheduzzaman,

Firstly let me apologize for this very late reply. Secondly thanks for your review. I was finally able to make all the changes.

On Wed, Jun 30, 2021 at 8:53 PM Zaheduzzaman Sarker via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Zaheduzzaman Sarker has entered the following ballot position for
draft-ietf-ntp-yang-data-model-15: No Objection

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-bb14cec5df0b3a0e&q=1&e=0-e1a070539e91f9c818cabaf130e2392b&u=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html>
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ntp-yang-data-model/<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-08e23231aefba629&q=1&e=0-e1a070539e91f9c818cabaf130e2392b&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-ntp-yang-data-model%2F>

I also think adding reference to RFC 1305 in section 5 and section 6 creates a
bit of confusion when this document says it defines YANG model for RFC 5905.
Also it is a fact that RFC 1305 is obsoleted by RFC 5905. So is this yang model
also applicable to NTPv3? if not please mention, if so please mention and
consider removing references to RFC 1305.

Dhruv: Since the YANG model allows the version to be set to 3, it can be used to configure NTPv3. I have added text to make this clearer.

Thanks!
Dhruv

Diff: https://www.ietf.org/rfcdiff?url1=draft-ietf-ntp-yang-data-model-15&url2=https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-a13f81f1d2c92697&q=1&e=0-e1a070539e91f9c818cabaf130e2392b&u=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl1%3Ddraft-ietf-ntp-yang-data-model-15%26url2%3Dhttps%3A%2F%2Fraw.githubusercontent.com%2Fdhruvdhody%2Fietf%2Fmaster%2Fdraft-ietf-ntp-yang-data-model-16.txt>
Working Copy: https://raw.githubusercontent.com/dhruvdhody/ietf/master/draft-ietf-ntp-yang-data-model-16.txt<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-b1568e82014e9cd1&q=1&e=0-e1a070539e91f9c818cabaf130e2392b&u=https%3A%2F%2Fraw.githubusercontent.com%2Fdhruvdhody%2Fietf%2Fmaster%2Fdraft-ietf-ntp-yang-data-model-16.txt>
Consolidated Review Status: https://notes.ietf.org/draft-ietf-ntp-yang-data-model<https://protect2.fireeye.com/v1/url?k=31323334-501d5122-fe22d327-454445555731-1a425099e82ddf55&q=1&e=0-e1a070539e91f9c818cabaf130e2392b&u=https%3A%2F%2Fnotes.ietf.org%2Fdraft-ietf-ntp-yang-data-model>