Subject: Re: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync

From: Sami Boutros <[email-masked]>
Date: Sun, 5 Feb 2017 01:44:35 +0000

I am resending the draft I sent on Thursday,

Hopefully, it will get through this time.

Thanks,

Sami
From: nvo3-dt-encap <[email-masked]<mailto:[email-masked]>> on behalf of Sami Boutros <[email-masked]<mailto:[email-masked]>>
Date: Monday, January 30, 2017 at 5:28 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync

Hey Folks,

I don’t see much updates going to the doc?

Are we still meeting tomorrow?

The only comment was from David a suggestion to increase the MAX size of a single TLV to be 256 bytes.

Thanks,

Sami
From: [email-masked]<mailto:[email-masked]>
When: 8:00 AM - 10:00 AM January 31, 2017
Subject: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync
Location: Skype Meeting

Sorry for being late on this. I have been struggling on the home front with both my kids and wife down with flu.
I am setting up the regular 2 hour sync, based on preferred time in doodle. If an alternative method like WebEx is preferred for the online call, then please set it up as I only have access to Skype.
Thanks
Pankaj
.........................................................................................................................................
-->Join Skype Meeting<https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=UmXWKhsr5ftLGNUPrRC5rAXvE6Lt2T-cs3ad-iQ_HEQ&e=>
Trouble Joining? Try Skype Web App<https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.com_microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=2YOfmxoNQri7YQrWRUL-lrl44Xruly4NFUIaPGXdyeg&e=>
Join by phone
+1 (425) 706-3470<tel:+1%20(425)%20706-3470,28245940%23> (Redmond) English (United States)
+1 (425) 707-0048<tel:+1%20(425)%20707-0048,28245940%23> (Redmond) English (United States)
+1 (425) 538-0005<tel:+1%20(425)%20538-0005,28245940%23> (Redmond) English (United States)
+1 (425) 538-0006<tel:+1%20(425)%20538-0006,28245940%23> (Redmond) English (United States)
+1 (866) 256-4036<tel:+1%20(866)%20256-4036,28245940%23> (Redmond) English (United Kingdom)
Find a local number<https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.com_microsoft.com-3Fid-3D28245940&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=e-WpXQTneFetp3czkAmWKYxQYE0_MVBGSeeSWys8S1I&e=>
Conference ID: 28245940
Forgot your dial-in PIN?<https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.com_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=PRReskp_6UTaQDZvlmyunr41Cjv3MQb0iOE8QI00En4&e=> |Help<https://urldefense.proofpoint.com/v2/url?u=http-3A__go.microsoft.com_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=tVJ-dyXc7Dam55U6WsU98Ji7qx9i6KQqxrJpOSq57jc&e=>
Welcome to Skype for Business Online Meetings. Participants using the Join by Phone option must dial the full number for call access.
[!OC([1033])!]
.........................................................................................................................................

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 6 Feb 2017 10:48:10 -0800

Sam,

I have some minor issues; have others read the document and is it ready 
to submit as an I-D?
Once we submit it as a I-D we can follow-up with a message to the NVO3 
list asking whether there are things folks want to see clarified so we 
can add any clarifications before Chicago.

The things I saw are:
1. I don't seem to be listed as an author at the end

2. The section on Group Base Policy has '[reference]'.  Michael, do you 
have a reference we can add?

3. It isn't clear whether we are recommending some change with respect 
to the 'C' bit. Section 7 item 6 says it is useful. Do we mean its 
definition is unchanged?

4. Item 7 in section 7 can be generalized by saying that there are 
already some extensions that are being discussed (see section 6.2) of 
varying sizes. (Is that the main point? We can enumerate them as 
"extensions for Telemetry, Security/Integrity, and Group Based Policy" 
if that makes it more clear.

5. Last sentence in section 7 might have a typo. It says "The control 
planes defined today need to add the ability to describe the different 
encapsulations." but the text above talks about the different 
TLVs/options, and we've talked about having the control plane describe 
the supported TLVs and their order. Thus should the text say "The 
control planes defined today need to add the ability to describe the 
supported TLVs and their order."?

If we fix the above I think the draft is good enough to submit.

Thanks,
    Erik

On 2/4/17 5:44 PM, Sami Boutros wrote:
> From: nvo3-dt-encap <[email-masked] 
> <mailto:[email-masked]>> on behalf of Sami Boutros 
> <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>
> From: [email-masked] <mailto:[email-masked]>
> Sorry for being late on this. I have been struggling on the home front 
> with both my kids and wife down with flu.
>
> I am setting up the regular 2 hour sync, based on preferred time in 
> doodle. If an alternative method like WebEx is preferred for the 
> online call, then please set it up as I only have access to Skype.
>
> Thanks
>
> Pankaj
>
> .........................................................................................................................................**
>
> àJoin Skype 
> Meeting<https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=UmXWKhsr5ftLGNUPrRC5rAXvE6Lt2T-cs3ad-iQ_HEQ&e=>
>
> Trouble Joining? _Try Skype Web App 
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.com_microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=2YOfmxoNQri7YQrWRUL-lrl44Xruly4NFUIaPGXdyeg&e=> 
> _
>
> Join by phone
>
> +1 (425) 706-3470 <tel:+1%20%28425%29%20706-3470,28245940%23> 
> (Redmond) English (United States)
>
> +1 (425) 707-0048 <tel:+1%20%28425%29%20707-0048,28245940%23> 
> (Redmond) English (United States)
>
> +1 (425) 538-0005 <tel:+1%20%28425%29%20538-0005,28245940%23> 
> (Redmond) English (United States)
>
> +1 (425) 538-0006 <tel:+1%20%28425%29%20538-0006,28245940%23> 
> (Redmond) English (United States)
>
> +1 (866) 256-4036 <tel:+1%20%28866%29%20256-4036,28245940%23> 
> (Redmond) English (United Kingdom)
>
> _Find a local number 
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.com_microsoft.com-3Fid-3D28245940&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=e-WpXQTneFetp3czkAmWKYxQYE0_MVBGSeeSWys8S1I&e=>_
>
> Conference ID: 28245940
>
> Forgot your dial-in PIN? 
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.com_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=PRReskp_6UTaQDZvlmyunr41Cjv3MQb0iOE8QI00En4&e=>|Help 
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__go.microsoft.com_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=tVJ-dyXc7Dam55U6WsU98Ji7qx9i6KQqxrJpOSq57jc&e=>
>
> Welcome to Skype for Business Online Meetings. Participants using the 
> Join by Phone option must dial the full number for call access.
>
> _[!OC([1033])!]
>
> _______________________________________________
> nvo3-dt-encap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3-dt-encap

---

From: Sami Boutros <[email-masked]>
Date: Mon, 6 Feb 2017 19:16:48 +0000

Hi Erik,

There was some issues with sending the draft to the list, please let me know if you don’t get the attachment.

One more comment to add, to be consistent should we change extension to option in the draft to be consistent with the language in Geneve? If we are ok with that, I can do this change in the next rev before submitting.

>1. I don't seem to be listed as an author at the end

Sorry, about that, I added your name in the attached draft.

>to the 'C' bit. Section 7 item 6 says it is useful. Do we mean its 

This is my assumption.

>if that makes it more clear.

I updated this item a bit in the attached draft, please have a look.

>supported TLVs and their order."?

Done.

Thanks,

Sami
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwID-g&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=POJQPmhf4KRfbnXI4rRk6kNiAMpKuPuD6jIE2qGWkF0&s=KBn4fq-_zk9mq-lnDFrg5uLnoErEkPgr3_1-CroDKkM&e= 
>
>

---

From: Rajeev Manur <[email-masked]>
Date: Mon, 6 Feb 2017 11:27:17 -0800

Hi Team,

In the current GENEVE proposal, when parsing multiple options hdrs, we have
to keep track of the total OpeLen field in the base hdr to know which is
the last options hdr. It would be much easier if we could just add a 1 bit
flag to the options hdr to indicate it is the last option hdr. If you guys
see value in this, we could add this to the recommendations.

Has it been already submitted to the WG list? If not could we could we hold
off till EOB today?

Thanks!
--Rajeev

On Mon, Feb 6, 2017 at 11:16 AM, Sami Boutros <[email-masked]> wrote:

> One more comment to add, to be consistent should we change extension to
> option in the draft to be consistent with the language in Geneve? If we are
> ok with that, I can do this change in the next rev before submitting.
>
> >> ............................................................
> ............................................................
> .................**
> >>
> >> àJoin Skype
> >> Meeting<https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__meet.lync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=
> uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=
> 3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=
> UmXWKhsr5ftLGNUPrRC5rAXvE6Lt2T-cs3ad-iQ_HEQ&e=>
> >>
> >> <https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__meet.lync.com_microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=
> uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=
> 3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=2YOfmxoNQri7YQrWRUL-
> lrl44Xruly4NFUIaPGXdyeg&e=>
> >> _
> >>
> >> Join by phone
> >>
> >> <https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__dialin.lync.com_microsoft.com-3Fid-3D28245940&d=DgMFAw&
> c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=
> 3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=e-WpXQTneFetp3czkAmWKYxQYE0_
> MVBGSeeSWys8S1I&e=>_
> >>
> >> Conference ID: 28245940
> >>
> >> Forgot your dial-in PIN?
> >> <https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__dialin.lync.com_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=
> IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_
> fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=PRReskp_
> 6UTaQDZvlmyunr41Cjv3MQb0iOE8QI00En4&e=>|Help
> >> <https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__go.microsoft.com_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=
> uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=
> 3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=tVJ-
> dyXc7Dam55U6WsU98Ji7qx9i6KQqxrJpOSq57jc&e=>
> >>
> >> ............................................................
> ............................................................
> .................
> >>
> >>
> >>
> >> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwID-g&c=
> uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=
> POJQPmhf4KRfbnXI4rRk6kNiAMpKuPuD6jIE2qGWkF0&s=KBn4fq-_zk9mq-
> lnDFrg5uLnoErEkPgr3_1-CroDKkM&e=
> >
> >
>

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 6 Feb 2017 12:01:21 -0800

> There was some issues with sending the draft to the list, please let me know if you don’t get the attachment.
I got this one, and the earlier one, but not your original one.
> One more comment to add, to be consistent should we change extension to option in the draft to be consistent with the language in Geneve? If we are ok with that, I can do this change in the next re…

I think it is fine to have "extension" about the general concept, and 
"option" as the implementation of that concept in Geneve.
However, looking at the the current use of those words I'd suggest
OLD
6.1 Current Encapsulations Options
NEW
6.1 Current Encapsulations

I think some other text can have option changed to extension, but I'd 
leave the draft the way it is for now.

>> to the 'C' bit. Section 7 item 6 says it is useful. Do we mean its

Then I think it makes sense to add a sentence to the end of item 6 
saying "Thus the C-bit remains as defined in Geneve."
> I updated this item a bit in the attached draft, please have a look.
Looks OK.

Thanks,
     Erik

---

From: "Michael Smith (michsmit)" <[email-masked]>
Date: Mon, 6 Feb 2017 20:09:01 +0000

>have a reference we can add?

https://www.ietf.org/id/draft-smith-vxlan-group-policy-03.txt

---

From: Sami Boutros <[email-masked]>
Date: Tue, 7 Feb 2017 04:40:40 +0000

Draft updated.

Thanks,

Sami

---

From: "Ganga, Ilango S" <[email-masked]>
Date: Tue, 7 Feb 2017 14:59:29 +0000

Hi Sami,

Regarding Section 6.4 Extension size. Currently 6.4 states first paragraph states, The Extension header length, min recommended size is 64B and later in the second paragraph it states, The recommended max option length value is 256 bytes. Does both the statements refer to the total extension header length? I remember we had a discussion last week about the max individual option size and we did not arrive at a consensus on the max size. Please clarify.

Thanks,
Ilango

-----Original Message-----
From: nvo3-dt-encap [mailto:[email-masked]] On Behalf Of Sami Boutros
Sent: Monday, February 6, 2017 8:41 PM
To: Erik Nordmark <[email-masked]>; Michael Smith (michsmit) <[email-masked]>
Cc: [email-masked]
Subject: Re: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync

Draft updated.

Thanks,

Sami

On 2/6/17, 12:01 PM, "Erik Nordmark" <[email-masked]> wrote:

>However, looking at the the current use of those words I'd suggest OLD
>>> I have some minor issues; have others read the document and is it 
>>> ready to submit as an I-D?
>>> Once we submit it as a I-D we can follow-up with a message to the 
>>> NVO3 list asking whether there are things folks want to see 
>>> clarified so we can add any clarifications before Chicago.
>>>
>>>
>>> The things I saw are:
>>> 2. The section on Group Base Policy has '[reference]'.  Michael, do 
>>> you have a reference we can add?
>>>
>>> 3. It isn't clear whether we are recommending some change with 
>>> respect to the 'C' bit. Section 7 item 6 says it is useful. Do we 
>>> mean its definition is unchanged?
>> This is my assumption.
>
>>> already some extensions that are being discussed (see section 6.2) 
>>> of varying sizes. (Is that the main point? We can enumerate them as 
>>> 5. Last sentence in section 7 might have a typo. It says "The 
>>> different encapsulations." but the text above talks about the 
>>> different TLVs/options, and we've talked about having the control 
>>> plane describe the supported TLVs and their order. Thus should the 
>>> text say "The control planes defined today need to add the ability 
>>> to describe the supported TLVs and their order."?
>> Done.
>
>Thanks,
>     Erik
>
>>
>>
>> Thanks,
>>
>> Sami
>>>> Sorry for being late on this. I have been struggling on the home 
>>>> front with both my kids and wife down with flu.
>>>>
>>>> ...................................................................
>>>> ...................................................................
>>>> ...**
>>>>
>>>> àJoin Skype
>>>> Meeting<https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.l
>>>> ync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=uilaK90D4TOVoH58JNXRg
>>>> Q&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0H
>>>> pgY2dkZrDHuUOszSOrBjA8FbNY&s=UmXWKhsr5ftLGNUPrRC5rAXvE6Lt2T-cs3ad-i
>>>> Q_HEQ&e=>
>>>>
>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.com
>>>> _microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=uilaK90D4TOVoH58JNX
>>>> RgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY
>>>> 0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=2YOfmxoNQri7YQrWRUL-lrl44Xruly4NFUIa
>>>> PGXdyeg&e=>
>>>> _
>>>>
>>>> Join by phone
>>>>
>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.c
>>>> om_microsoft.com-3Fid-3D28245940&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&
>>>> r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0Hpg
>>>> Y2dkZrDHuUOszSOrBjA8FbNY&s=e-WpXQTneFetp3czkAmWKYxQYE0_MVBGSeeSWys8
>>>> S1I&e=>_
>>>>
>>>> Conference ID: 28245940
>>>>
>>>> Forgot your dial-in PIN?
>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.c
>>>> om_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08
>>>> L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOr
>>>> BjA8FbNY&s=PRReskp_6UTaQDZvlmyunr41Cjv3MQb0iOE8QI00En4&e=>|Help
>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__go.microsoft.c
>>>> om_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IV
>>>> zcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dk
>>>> ZrDHuUOszSOrBjA8FbNY&s=tVJ-dyXc7Dam55U6WsU98Ji7qx9i6KQqxrJpOSq57jc&
>>>> e=>
>>>>
>>>> Welcome to Skype for Business Online Meetings. Participants using 
>>>> the Join by Phone option must dial the full number for call access.
>>>>
>>>> _[!OC([1033])!]
>>>>
>>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_m
>>>> ailman_listinfo_nvo3-2Ddt-2Dencap&d=DwID-g&c=uilaK90D4TOVoH58JNXRgQ
>>>> &r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=POJQPmhf4KRfbnXI4r
>>>> Rk6kNiAMpKuPuD6jIE2qGWkF0&s=KBn4fq-_zk9mq-lnDFrg5uLnoErEkPgr3_1-Cro
>>>> DKkM&e=
>>>
>

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 7 Feb 2017 08:06:08 -0800

Are we having a call now? I waiting in the virtual lobby.

I don't know if we need a call. I saw Pankaj had a comment but other 
than that I think it is good enough to submit as an I-D.

    Erik

---

From: "Ganga, Ilango S" <[email-masked]>
Date: Tue, 7 Feb 2017 16:11:43 +0000

I am also waiting in the virtual lobby. Do we have a meeting now?

Regards,
Ilango

-----Original Message-----
From: nvo3-dt-encap [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: Tuesday, February 7, 2017 8:06 AM
To: Sami Boutros <[email-masked]>; Michael Smith (michsmit) <[email-masked]>
Cc: [email-masked]
Subject: Re: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync

I don't know if we need a call. I saw Pankaj had a comment but other than that I think it is good enough to submit as an I-D.

    Erik

On 2/6/17 8:40 PM, Sami Boutros wrote:
>>>> control planes defined today need to add the ability to describe 
>>>> the different encapsulations." but the text above talks about the 
>>>>> I am setting up the regular 2 hour sync, based on preferred time 
>>>>> in doodle. If an alternative method like WebEx is preferred for 
>>>>> the online call, then please set it up as I only have access to Skype.
>>>>>
>>>>> Thanks
>>>>>
>>>>> Pankaj
>>>>>
>>>>> ..................................................................
>>>>> ..................................................................
>>>>> .....**
>>>>>
>>>>> àJoin Skype
>>>>> Meeting<https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.
>>>>> lync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=uilaK90D4TOVoH58JNX
>>>>> RgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHm
>>>>> Y0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=UmXWKhsr5ftLGNUPrRC5rAXvE6Lt2T-cs3
>>>>> ad-iQ_HEQ&e=>
>>>>>
>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.co
>>>>> m_microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=uilaK90D4TOVoH58J
>>>>> NXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMg
>>>>> HmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=2YOfmxoNQri7YQrWRUL-lrl44Xruly4N
>>>>> FUIaPGXdyeg&e=>
>>>>> _
>>>>>
>>>>> Join by phone
>>>>>
>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.
>>>>> com_microsoft.com-3Fid-3D28245940&d=DgMFAw&c=uilaK90D4TOVoH58JNXRg
>>>>> Q&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0
>>>>> HpgY2dkZrDHuUOszSOrBjA8FbNY&s=e-WpXQTneFetp3czkAmWKYxQYE0_MVBGSeeS
>>>>> Wys8S1I&e=>_
>>>>>
>>>>> Conference ID: 28245940
>>>>>
>>>>> Forgot your dial-in PIN?
>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.
>>>>> com_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta
>>>>> 08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOsz
>>>>> SOrBjA8FbNY&s=PRReskp_6UTaQDZvlmyunr41Cjv3MQb0iOE8QI00En4&e=>|Help
>>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__go.microsoft.
>>>>> com_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=
>>>>> IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY
>>>>> 2dkZrDHuUOszSOrBjA8FbNY&s=tVJ-dyXc7Dam55U6WsU98Ji7qx9i6KQqxrJpOSq5
>>>>> 7jc&e=>
>>>>>
>>>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_
>>>>> mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwID-g&c=uilaK90D4TOVoH58JNXR
>>>>> gQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=POJQPmhf4KRfbnX
>>>>> I4rRk6kNiAMpKuPuD6jIE2qGWkF0&s=KBn4fq-_zk9mq-lnDFrg5uLnoErEkPgr3_1
>>>>> -CroDKkM&e=

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 7 Feb 2017 08:15:46 -0800

Pankaj can't attend hence we can't use the meeting he set up.

    Erik

---

From: Sami Boutros <[email-masked]>
Date: Tue, 7 Feb 2017 16:20:20 +0000

I am having trouble connecting.

Thanks,

Sami

On 2/7/17, 8:06 AM, "nvo3-dt-encap on behalf of Erik Nordmark" <[email-masked] on behalf of [email-masked]> wrote:

>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwIGaQ&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=8qrOK8bjrV5TOruzGsGf0EW0-6INKyMtc3jtKM5FDz0&s=DIYTebCIz6497CgysPfm-CxDD0O0uy2rx-gLwaSU1Fs&e=

---

From: Sami Boutros <[email-masked]>
Date: Tue, 7 Feb 2017 16:20:21 +0000

Hi Ilango,

On 2/7/17, 6:59 AM, "Ganga, Ilango S" <[email-masked]> wrote:

>Hi Sami,
>
>Regarding Section 6.4 Extension size. Currently 6.4 states first paragraph states, The Extension header length, min recommended size is 64B and later in the second paragraph it states, The recommended max option length value is 256 bytes. Does both the statements refer to the total extension header length?

No, the later statement refer to the max single option length, I changed the text from "max option length” -> “max single option length”

Thanks,

Sami 
> I remember we had a discussion last week about the max individual option size and we did not arrive at a consensus on the max size. Please clarify.
>
>Thanks,
>Ilango
>
>

---

From: Sami Boutros <[email-masked]>
Date: Tue, 7 Feb 2017 16:22:15 +0000

Let’s cancel it then, 

BTW, I don’t see Pankaj comment.

If we are all good with the draft I can submit today.

Please let me know if there is any objection to this.

Thanks,

Sami

On 2/7/17, 8:15 AM, "Erik Nordmark" <[email-masked]> wrote:

>>>>>>> Meeting<https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.>>>>>> lync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=uilaK90D4TOVoH58JNX
>>>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.lync.co>>>>>> m_microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=uilaK90D4TOVoH58J
>>>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.>>>>>> com_microsoft.com-3Fid-3D28245940&d=DgMFAw&c=uilaK90D4TOVoH58JNXRg
>>>>>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dialin.lync.>>>>>> com_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta
>>>>>>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__go.microsoft.>>>>>> com_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=uilaK90D4TOVoH58JNXRgQ&r=
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwIDaQ&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=AJLwxgxuP6zC27J0FveAdyY5jk_gi6p5UnVmfmdklvc&s=6K2AY0Zstk4I-c-SugykdJBRJO8Ol8_Mt_a0DNc4QO4&e= 
>>
>

---

From: "Ganga, Ilango S" <[email-masked]>
Date: Tue, 7 Feb 2017 16:24:19 +0000

Hi Sami,

If it is a "max single option length" that is stated as 256 bytes, then this is the point we discussed last week and as per my understanding there is no consensus to make this to 256 bytes.

Thanks,
Ilango

-----Original Message-----
From: Sami Boutros [mailto:[email-masked]] 
Sent: Tuesday, February 7, 2017 8:20 AM
To: Ganga, Ilango S <[email-masked]>
Cc: [email-masked]
Subject: Re: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync

Hi Ilango,

Thanks,

Sami 
>>>>> l 
>>>>> H 
>>>>> m 
>>>>> Y 
>>>>> c 
>>>>> c
>>>>> L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSO
>>>>> r BjA8FbNY&s=PRReskp_6UTaQDZvlmyunr41Cjv3MQb0iOE8QI00En4&e=>|Help
>>>>> c 
>>>>> m

---

From: Sami Boutros <[email-masked]>
Date: Tue, 7 Feb 2017 16:30:31 +0000

I see Ilango, I remember now

I will remove the sentence then.

Thanks,

Sami

---

From: Sam Aldrin <[email-masked]>
Date: Tue, 7 Feb 2017 09:56:02 -0800

I could have setup a hangout session, but couldn't as I was driving.

Regd the draft, I am ok with its submission in its current form. We could address any comments at later point of time.

Sam

Sent from my iPhone

> On Feb 7, 2017, at 8:30 AM, Sami Boutros <[email-masked]> wrote:
>

---

From: Rajeev Manur <[email-masked]>
Date: Tue, 7 Feb 2017 10:13:59 -0800

Hi,

i would want to suggest we bring down the minimum option length the middle
boxes should support to "up to 32B". Vendors always have the option to
support anything above this if they choose to. Also, any comments on the
earlier point I brought up?

Thanks!
--Rajeev

On Mon, Feb 6, 2017 at 11:27 AM, Rajeev Manur <[email-masked]>
wrote:

> Hi Team,
>
> In the current GENEVE proposal, when parsing multiple options hdrs, we
> have to keep track of the total OpeLen field in the base hdr to know which
> is the last options hdr. It would be much easier if we could just add a 1
> bit flag to the options hdr to indicate it is the last option hdr. If you
> guys see value in this, we could add this to the recommendations.
>
> Has it been already submitted to the WG list? If not could we could we
> hold off till EOB today?
>
> Thanks!
> --Rajeev
>
>
>
>
>> >> Meeting<https://urldefense.proofpoint.com/v2/url?u=https-3A_
>> _meet.lync.com_microsoft_pankajg_GV7DS8RK&d=DgMFAw&c=uilaK90
>> D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-
>> LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=UmXWKhs
>> r5ftLGNUPrRC5rAXvE6Lt2T-cs3ad-iQ_HEQ&e=>
>> >>
>> >> <https://urldefense.proofpoint.com/v2/url?u=https-3A__meet.
>> lync.com_microsoft_pankajg_GV7DS8RK-3Fsl-3D1&d=DgMFAw&c=u
>> ilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-
>> 2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=
>> 2YOfmxoNQri7YQrWRUL-lrl44Xruly4NFUIaPGXdyeg&e=>
>> >> _
>> >>
>> >> Join by phone
>> >>
>> >> +1 (425) 538-0005 <(425)%20538-0005> <tel:+1%20%28425%29%20538-0005
>> ,28245940%23>
>> >> +1 (425) 538-0006 <(425)%20538-0006> <tel:+1%20%28425%29%20538-0006
>> ,28245940%23>
>> >> +1 (866) 256-4036 <(866)%20256-4036> <tel:+1%20%28866%29%20256-4036
>> ,28245940%23>
>> >> <https://urldefense.proofpoint.com/v2/url?u=https-3A__
>> dialin.lync.com_microsoft.com-3Fid-3D28245940&d=DgMFAw&c=
>> uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX
>> -2K-LV98&m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=e-W
>> pXQTneFetp3czkAmWKYxQYE0_MVBGSeeSWys8S1I&e=>_
>> >>
>> >> Conference ID: 28245940
>> >>
>> >> Forgot your dial-in PIN?
>> >> <https://urldefense.proofpoint.com/v2/url?u=https-3A__
>> dialin.lync.com_microsoft.com&d=DgMFAw&c=uilaK90D4TOVoH58JNX
>> RgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=3Pr77Dew
>> _fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=PRReskp_6UTaQDZvlmyunr
>> 41Cjv3MQb0iOE8QI00En4&e=>|Help
>> >> <https://urldefense.proofpoint.com/v2/url?u=http-3A__go.
>> microsoft.com_fwlink_-3FLinkId-3D389737&d=DgMFAw&c=uilaK90D4
>> TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&
>> m=3Pr77Dew_fMgHmY0HpgY2dkZrDHuUOszSOrBjA8FbNY&s=tVJ-dyXc7Dam
>> 55U6WsU98Ji7qx9i6KQqxrJpOSq57jc&e=>
>> >>
>> >> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>> f.org_mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwID-g&c=uilaK9
>> 0D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-
>> LV98&m=POJQPmhf4KRfbnXI4rRk6kNiAMpKuPuD6jIE2qGWkF0&s=KBn4fq-
>> _zk9mq-lnDFrg5uLnoErEkPgr3_1-CroDKkM&e=
>> >
>> >
>>

---

From: Sami Boutros <[email-masked]>
Date: Tue, 7 Feb 2017 18:55:43 +0000

Hi Rajeev,

I think we should wait to get consensus from the group on your 2 comments below before including them.

I will submit what I have, and we can address those in the next rev.

Thanks,

Sami
From: Rajeev Manur <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 7, 2017 at 10:13 AM
To: Sami Boutros <[email-masked]<mailto:[email-masked]>>
Cc: Erik Nordmark <[email-masked]<mailto:[email-masked]>>, "Michael Smith (michsmit)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3-dt-encap] NVO3 Encap Design Team Weekly Sync

Hi,

i would want to suggest we bring down the minimum option length the middle boxes should support to "up to 32B". Vendors always have the option to support anything above this if they choose to. Also, any comments on the earlier point I brought up?

Thanks!
--Rajeev

On Mon, Feb 6, 2017 at 11:27 AM, Rajeev Manur <[email-masked]<mailto:[email-masked]>> wrote:
Hi Team,

In the current GENEVE proposal, when parsing multiple options hdrs, we have to keep track of the total OpeLen field in the base hdr to know which is the last options hdr. It would be much easier if we could just add a 1 bit flag to the options hdr to indicate it is the last option hdr. If you guys see value in this, we could add this to the recommendations.

Has it been already submitted to the WG list? If not could we could we hold off till EOB today?

Thanks!
--Rajeev

On Mon, Feb 6, 2017 at 11:16 AM, Sami Boutros <[email-masked]<mailto:[email-masked]>> wrote:
Hi Erik,

This is my assumption.

Done.

Thanks,

Sami
>> From: nvo3-dt-encap <[email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>> on behalf of Sami Boutros
>> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>> To: "[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>"
>> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>,
>> "[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>"
>> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>> From: [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>> +1 (425) 706-3470<tel:%2B1%20%28425%29%20706-3470> <tel:+1%20%28425%29%20706-3470,28245940%23>
>> +1 (425) 707-0048<tel:%2B1%20%28425%29%20707-0048> <tel:+1%20%28425%29%20707-0048,28245940%23>
>> +1 (425) 538-0005<tel:(425)%20538-0005> <tel:+1%20%28425%29%20538-0005,28245940%23>
>> +1 (425) 538-0006<tel:(425)%20538-0006> <tel:+1%20%28425%29%20538-0006,28245940%23>
>> +1 (866) 256-4036<tel:(866)%20256-4036> <tel:+1%20%28866%29%20256-4036,28245940%23>
>> [email-masked]<mailto:[email-masked]>

_______________________________________________
nvo3-dt-encap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3-dt-encap<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_nvo3-2Ddt-2Dencap&d=DwMFaQ&c=uilaK90D4TOVoH58JNXRgQ&r=IVzcTRLQdpta08L0b_y2zDkqvwJhRKMCAbX-2K-LV98&m=otykFBqsOOGDBBIzPQ4w7mlEigrtpCzN82IGRAPEaf8&s=GsHkRijM691HTmc_mpVVPaQkc1mjFRYACnuxnUydk5Y&e=>