Subject: [nvo3] comment on draft-bl-nvo3-dataplane-requirements-01.txt

From: Lucy yong <[email-masked]>
Date: Wed, 27 Jun 2012 19:42:06 +0000

Hi Marc,

Text:
When a frame is received by an ingress NVE from a Tenant End System
        over a local VAP, it needs to be parsed in order to identify which
        virtual network instance it belongs to. The parsing function can
        examine various fields in the data frame (e.g., VLANID) and/or
        associated interface/port the frame came from.

Comment: Should this parsing function relate to the type of VNI instance? If a VNI is L3 VNI, the parsing should be on IP address field; if an VNI is L2 VNI, the parsing should be on Ethernet field; or the parsing field is configured regardless of VNI type?

Section 3.4.1. should belong to the framework draft? It is more about structure than data plane requirement.

Section 3.6  Hierarchical NVE. This only applies to L2 VN. should mention it.

Section 3.7 NVE Multi-homing requirement. When supporting a multi-homing with active-active, L2VNI no longer provide an emulated LAN as described in section 3.2.1.

The doc. should describe VM mobility support and requirement.

Cheers,
Lucy

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Thu, 28 Jun 2012 17:46:36 +0200

Lucy,

See my comments below.

Tnanks,
Marc

________________________________
From: Lucy yong [mailto:[email-masked]]
Sent: Wednesday, June 27, 2012 9:42 PM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: comment on draft-bl-nvo3-dataplane-requirements-01.txt

Hi Marc,

Text:

Comment: Should this parsing function relate to the type of VNI instance? If a VNI is L3 VNI, the parsing should be on IP address field; if an VNI is L2 VNI, the parsing should be on Ethernet field; or the parsing field is configured regardless of VNI type?
 Typically, parsing is based on the VNI type (L2 and/or L3) and hence corresponding fields are examined.
Section 3.4.1. should belong to the framework draft? It is more about structure than data plane requirement.
Translation of encaps is a dataplane function

Ok.

The doc. should describe VM mobility support and requirement.
Dataplane-related aspects of VM moves will be described in a future revision.

Cheers,
Lucy