Subject: Re: [nvo3] call for adoption: draft-lasserre-nvo3-framework-02

From: Lizhong Jin <[email-masked]>
Date: Thu, 21 Jun 2012 00:05:14 +0800

Hi Benson, Matthew,
I support the work of this document, but there is indeed much to improve
the draft.
Please consider the following points which have been sent privately before,
and hope to see the comments from the list.
1. I think it is very important to have a generic protocol layer model for
a framework document, which maybe like below and also mentioned in
http://tools.ietf.org/html/draft-kj-nvo3-pion-architecture-00.txt. And
protocol stack reference model is also missing.
       +-------------------------------------------+
       |         L2/L3 Customer Payload            |
       |                      ~~~                  |
       +-------------------------------------------+
       |        Tenant Network Identifier          |
       +-------------------------------------------+
       |                IP/MPLS Layer              |
       +-------------------------------------------+
       |                  Data-Link                |
       +-------------------------------------------+
       |                Physical Layer             |
       +-------------------------------------------+
2. The centralized control plane is not mentioned in the framework, which
would be an important option for NVO3.
3. Load balancing or ECMP is not mentioned in the draft, which is also
important for datacenter. Maybe I missed in the draft.

Regards
Lizhong

> ---------- Forwarded message ----------
> From: Benson Schliesser <[email-masked]>
> To: [email-masked]
> Cc: "Matthew \(Matthew\) Bocci" <[email-masked]>,
> [email-masked]
> Date: Mon, 18 Jun 2012 16:51:20 -0500
> Subject: [nvo3] call for adoption: draft-lasserre-nvo3-framework-02
> Dear NVO3 Participants -
>
> This message begins a two week Call for Adoption of
> http://tools.ietf.org/html/draft-lasserre-nvo3-framework-02 by the NVO3
> working group, ending on 02-July-2012.
>
> Please respond to the NVO3 mailing list with any statements of approval or
> disapproval, along with any additional comments that might explain your
> position. Also, if any NVO3 participant is aware of IPR associated with
> this draft, please inform the mailing list and/or the NVO3 chairs.
>
> Thanks,
> -Benson & Matthew
>
>

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Wed, 20 Jun 2012 18:30:45 +0200

Hi Lizhong,

Thanks for your support. A few comments about the points you raised:

1. If a stack is to be added, the field that you have called "Tenant Network Identifier" should be replaced with "Overlay Header (includes a VN context)"
2. We will add some text about the use of a "centralized" approach in a future revision
3. This section is covered in details in the nvo3-dataplane-requirements draft. A small section could be added to the framework draft if deemed useful

Marc
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Wednesday, June 20, 2012 6:05 PM
To: [email-masked]
Cc: Bocci, Matthew (Matthew); [email-masked]; Benson Schliesser
Subject: Re: [nvo3] call for adoption: draft-lasserre-nvo3-framework-02

Hi Benson, Matthew,
I support the work of this document, but there is indeed much to improve the draft.
Please consider the following points which have been sent privately before, and hope to see the comments from the list.
1. I think it is very important to have a generic protocol layer model for a framework document, which maybe like below and also mentioned in http://tools.ietf.org/html/draft-kj-nvo3-pion-architecture-00.txt. And protocol stack reference model is also missing.
       +-------------------------------------------+
       |         L2/L3 Customer Payload            |
       |                      ~~~                  |
       +-------------------------------------------+
       |        Tenant Network Identifier          |
       +-------------------------------------------+
       |                IP/MPLS Layer              |
       +-------------------------------------------+
       |                  Data-Link                |
       +-------------------------------------------+
       |                Physical Layer             |
       +-------------------------------------------+
2. The centralized control plane is not mentioned in the framework, which would be an important option for NVO3.
3. Load balancing or ECMP is not mentioned in the draft, which is also important for datacenter. Maybe I missed in the draft.

Regards
Lizhong

---------- Forwarded message ----------
From: Benson Schliesser <[email-masked]<mailto:[email-masked]>>
To: [email-masked]<mailto:[email-masked]>
Cc: "Matthew \(Matthew\) Bocci" <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Date: Mon, 18 Jun 2012 16:51:20 -0500
Subject: [nvo3] call for adoption: draft-lasserre-nvo3-framework-02
Dear NVO3 Participants -

This message begins a two week Call for Adoption of http://tools.ietf.org/html/draft-lasserre-nvo3-framework-02 by the NVO3 working group, ending on 02-July-2012.

Please respond to the NVO3 mailing list with any statements of approval or disapproval, along with any additional comments that might explain your position. Also, if any NVO3 participant is aware of IPR associated with this draft, please inform the mailing list and/or the NVO3 chairs.

Thanks,
-Benson & Matthew

---

From: Lizhong Jin <[email-masked]>
Date: Thu, 21 Jun 2012 20:22:37 +0800

On Thu, Jun 21, 2012 at 12:30 AM, LASSERRE, MARC (MARC) <
[email-masked]> wrote:

> **
> 1. If a stack is to be added, the field that you have called "Tenant
> Network Identifier" should be replaced with "Overlay Header (includes a VN
> context)"
>
[Lizhong] yes, should be an encapsulation header include "tenant network
identifier".

Thanks
Lizhong

>  2. We will add some text about the use of a "centralized" approach in a
 3. This section is covered in details in the nvo3-dataplane-requirements
> draft. A small section could be added to the framework draft if deemed
> useful
>

> Marc
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Lizhong Jin
> *Sent:* Wednesday, June 20, 2012 6:05 PM
> *To:* [email-masked]
> *Cc:* Bocci, Matthew (Matthew);
> [email-masked]; Benson Schliesser
> *Subject:* Re: [nvo3] call for adoption: draft-lasserre-nvo3-framework-02
>
>    Hi Benson, Matthew,
> Please consider the following points which have been sent privately
> before, and hope to see the comments from the list.
>> Please respond to the NVO3 mailing list with any statements of approval
>> or disapproval, along with any additional comments that might explain your