Subject: Re: [nvo3] FW: New Version Notification fordraft-fang-vpn4dc-problem-statement-01.txt

From: Lizhong Jin<[email-masked]>
Date: Mon, 25 Jun 2012 17:07:57 +0800

Hi Luyuan,
I review the draft, and it describes the virtualized network with routed 
function, and the corresponding control plane, data plane and VM migration 
considerations. draft-narten-nvo3-overlay-problem-statement describes the 
virtualized network with switched or routed function, but mainly focus on 
virtualized switched network. The two draft seem to be complementary for 
me.

Since this is a Problem Statement and Requirements, it would be better if 
it did not have many contents of solution specific, e.g, BGP, MPLS label. 

Thanks
Lizhong

> 
> -----From "Luyuan Fang (lufang)" <[email-masked]> on Wed, 20
> Jun 2012 10:50:53 -0500 -----
> 
> To:
> 
> <[email-masked]>
> 
> CC:
> 
> Pedro Marques <[email-masked]>, [email-masked], 
> "Dennis Cai \(dcai\)" <[email-masked]>
> 
> Subject:
> 
> [nvo3] FW: New Version Notification fordraft-fang-vpn4dc-problem-
> statement-01.txt
> 
> Dear colleagues,
> 
> We have uploaded a new updated version of draft-fang-vpn4dc-problem-
> statement-01.txt (on 6/12), by Maria Napierala, Dennis Cai, and myself.
> Appreciate your review and comments.
> 
> Thanks,
> Luyuan
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, June 12, 2012 10:48 PM
> To: Luyuan Fang (lufang)
> Cc: [email-masked]; Dennis Cai (dcai)
> Subject: New Version Notification fordraft-fang-vpn4dc-problem-
> statement-01.txt
> 
> 
> A new version of I-D, draft-fang-vpn4dc-problem-statement-01.txt
> has been successfully submitted by Luyuan Fang and posted to the
> IETF repository.
> 
> Filename:    draft-fang-vpn4dc-problem-statement
> Revision:    01
> Title:       IP-VPN Data Center Problem Statement and Requirements
> Creation date:    2012-06-12
> WG ID:       Individual Submission
> Number of pages: 18
> URL:             http://www.ietf.org/internet-drafts/draft-fang-
> vpn4dc-problem-statement-01.txt
> Status:          http://datatracker.ietf.org/doc/draft-fang-vpn4dc-
> problem-statement
> Htmlized:        http://tools.ietf.org/html/submission.filename }}-01
> Diff:            http://tools.ietf.org/rfcdiff?url2=draft-fang-
> vpn4dc-problem-statement-01
> 
> Abstract:
>    Network Service Providers commonly use BGP/MPLS VPNs [RFC 4364] as
>    the control plane for virtual networks. This technology has proven
>    to scale to a large number of VPNs and attachment points, and it is
>    well suited for Data Center connectivity, especially when
>    supporting all IP applications.
> 
>    The Data Center environment presents new challenges and imposes
>    additional requirements to IP VPN technologies, including multi-
>    tenancy support, high scalability, VM mobility, security, and
>    orchestration. This document describes the problems and defines the
>    new requirements.
> 
> 
>  
> 
> 
> The IETF Secretariat

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Wed, 27 Jun 2012 14:33:04 -0500

Hi Lizhong,

Thanks for your review and comments.

Yes, our draft is focused on L3 solutions for its scalability and all IP application support.

Ø  Since this is a Problem Statement and Requirements, it would be better if it did not have many contents of solution specific, e.g, BGP, MPLS label. 

Since we are talking L3 VPN, therefore IP, VPN, GRE, BGP, MPLS come into the discussion. 

Wouldn't this be the same nature as TRILL, VLAN, etc. being discussed in draft-natern-nvo3-overlay-problem-statement?  

May be we should look into how to resolve this, one option could be that the problem statement do not mention any protocols? E.g. TRILL, VLAN, and any other protocols  should be removed from draft-natern-nvo3-overlay-problem-statement. Protocols discussions could split into separate protocol gap analysis, requirements...? We could do the same for L3 if this is the preferred way by WG.

Thanks,

Luyuan

From: Lizhong Jin [mailto:[email-masked]] 
Sent: Monday, June 25, 2012 5:08 AM
To: [email-masked]
Cc: Luyuan Fang (lufang)
Subject: Re: [nvo3] FW: New Version Notification fordraft-fang-vpn4dc-problem-statement-01.txt

Hi Luyuan, 
I review the draft, and it describes the virtualized network with routed function, and the corresponding control plane, data plane and VM migration considerations. draft-narten-nvo3-overlay-problem-statement describes the virtualized network with switched or routed function, but mainly focus on virtualized switched network. The two draft seem to be complementary for me. 

Since this is a Problem Statement and Requirements, it would be better if it did not have many contents of solution specific, e.g, BGP, MPLS label. 

Thanks 
Lizhong

---

From: <[email-masked]>
Date: Wed, 27 Jun 2012 15:42:10 -0400

This isn't just a "mention" - Section 10 of the VPN4DC problem statement draft (and to a lesser extent Section 12) of the VPV4DC draft are entirely about BGP/MPLS L3VPNs.  If those sections are to remain in the draft, then I suggest that the draft needs some clear scope language up front to say that it's only about BGP/MPLS L3VPNs, and it could also use a new title that is consistent with that scope, as BGP/MPLS is not the only IP VPN technology.

Thanks,
--David

From: [email-masked] [mailto:[email-masked]] On Behalf Of Luyuan Fang (lufang)
Sent: Wednesday, June 27, 2012 3:33 PM
To: Lizhong Jin; [email-masked]
Subject: Re: [nvo3] FW: New Version Notification fordraft-fang-vpn4dc-problem-statement-01.txt

Hi Lizhong,

Thanks,
Luyuan

Hi Luyuan,

Thanks
Lizhong

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Wed, 27 Jun 2012 16:02:45 -0500

David,

Thanks for your comments.

Adding some clear scoping language is a good idea. Modification of title later is not an issue, just answered Lucy's title change question too.

Luyuan

From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 27, 2012 3:42 PM
To: Luyuan Fang (lufang); [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [nvo3] FW: New Version Notificationfordraft-fang-vpn4dc-problem-statement-01.txt

Thanks,
--David

Hi Lizhong,

Thanks,

Luyuan

Hi Luyuan, 

Thanks 
Lizhong