Subject: [nvo3] Support for multi-homed NVEs

From: Somesh Gupta <[email-masked]>
Date: Thu, 30 Aug 2012 21:58:13 -0700

I did not see any mention of multi-homed NVEs in
draft-lasserre-nvo3-framework-03.txt. NVEs are connected
together by an L3 network - does that mean only one?
Can it be multi-homes to two L3 networks?

Somesh

---

From: "Ivan Pepelnjak" <[email-masked]>
Date: Fri, 31 Aug 2012 09:23:26 +0200

This is definitely an interesting can of worms ;)

While I don't think we should go down the path of IP-A/IP-B networks similar to some other DC technology, we will face the reality of some NVE elements (hypervisor soft switches) not being underlay IP routers.

We could either:

(A) ignore the issue and expect the network designer to solve it using any one of the existing NIC teaming/MLAG kludges while retaining a single encapsulation IP address per NVE;

(B) provide support for multiple encapsulation addresses per NVE so a multi-homed NVE could have one IP address per physical interface and send and receive nvo3-encapsulated frames using more than one address.

Option (A) is the easy way out similar to existing MPLS/VPN behavior and would fit well with existing DC deployments. It would also retain all the server-to-ToR multihoming complexity.

Option (B) would reduce the complexity of the underlay DC network (which would become a simple L3 network with single-homed IP addresses), but we'd have to deal with a bunch of additional problems (peer IP address liveliness check).

Just speculating ...
Ivan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Somesh Gupta
> Sent: Friday, August 31, 2012 6:58 AM
> To: [email-masked]
> Subject: [nvo3] Support for multi-homed NVEs
> 
> I did not see any mention of multi-homed NVEs in draft-lasserre-nvo3-
> framework-03.txt. NVEs are connected together by an L3 network - does that
> mean only one?
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3