Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 14 Aug 2012 17:48:09 +0200

All,

At the Vancouver IETF, there was considerable support for adopting
draft-narten-nvo3-overlay-problem-statement-03 as an NVO3 working group
document. However, there was also some support for
draft-fang-vpn4dc-problem-statement-01.

Therefore, the chairs asked authors from both drafts, with help from Eric
Gray, to work together on a common problem statement draft, the result of
which is the subject of this adoption poll.

If you support adoption of draft-narten-nvo3-overlay-problem-statement-04,
please reply to this thread with 'support'.

If you do not support adoption, please reply to this thread with 'do not
support', and state your reasons.

This poll will close on Tuesday 28th August 2012.

Note that we will be polling for adoption of the NVO3 framework draft
separately. We will start that poll in a separate thread, shortly.

Regards

Matthew & Benson

---

From: Randy Bush <[email-masked]>
Date: Wed, 15 Aug 2012 00:54:10 +0900

> please reply to this thread with 'support'.

support

---

From: "Mcdysan, David E" <[email-masked]>
Date: Tue, 14 Aug 2012 11:56:38 -0400

support

On 8/14/12 11:48 AM, "Bocci, Matthew (Matthew)"
<[email-masked]> wrote:

>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3

---

From: Melinda Shore <[email-masked]>
Date: Tue, 14 Aug 2012 07:59:20 -0800

> please reply to this thread with 'support'.

Support!

Melinda

---

From: David Allan I <[email-masked]>
Date: Tue, 14 Aug 2012 13:53:29 -0400

> please reply to this thread with 'support'.

Support.

Dave

---

From: Selvam Ramanathan <[email-masked]>
Date: Tue, 14 Aug 2012 13:58:47 -0400

Support

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 14 Aug 2012 20:19:38 +0200

support

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: dinsdag 14 augustus 2012 17:48
To: [email-masked]
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

---

From: AshwoodsmithPeter <[email-masked]>
Date: Tue, 14 Aug 2012 18:21:39 +0000

support

Peter

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 14 Aug 2012 14:55:59 -0400

Support.

---

From: Sam Aldrin <[email-masked]>
Date: Tue, 14 Aug 2012 12:09:31 -0700

Support.

-sam

---

From: Ning So <[email-masked]>
Date: Tue, 14 Aug 2012 13:21:10 -0700 (PDT)

Support.

Ning

________________________________
 From: "Bocci, Matthew (Matthew)" <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Tuesday, August 14, 2012 10:48 AM
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04
 
All,

Regards

Matthew & Benson

---

From: "Guyingjie (Yingjie)" <[email-masked]>
Date: Wed, 15 Aug 2012 00:35:39 +0000

Support

Best Regards
Gu Yingjie

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Bocci, Matthew (Matthew)
发送时间: 2012年8月14日 乐乐23:48
收件人: [email-masked]
主题: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

---

From: Chris Wright <[email-masked]>
Date: Tue, 14 Aug 2012 17:41:33 -0700

support

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Wed, 15 Aug 2012 00:52:42 +0000

Support

Joe Pelissier
________________________________
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, August 14, 2012 10:48 AM
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 15 Aug 2012 00:55:04 +0000

Support.

Xiaohu

> 发送时间: 2012年8月14日 23:48
> 主题: [nvo3] Poll for WG adoption:
> draft-narten-nvo3-overlay-problem-statement-04
> 
> All,
>

---

From: [email-masked]
Date: Wed, 15 Aug 2012 09:02:31 +0800

Support!

"Bocci, Matthew (Matthew)" <[email-masked]> 
发件人:  [email-masked]
2012/08/14 23:48

收件人
"[email-masked]" <[email-masked]>
抄送

主题
[nvo3] Poll for WG adoption: 
draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

---

From: Lucy yong <[email-masked]>
Date: Wed, 15 Aug 2012 01:03:38 +0000

Support!
Cheers,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Tuesday, August 14, 2012 10:48 AM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 15 Aug 2012 01:05:34 +0000

Support.

> Sent: Tuesday, August 14, 2012 11:48 PM
> To: [email-masked]
> Subject: [nvo3] Poll for WG adoption:

---

From: "Senad.palislamovic" <[email-masked]>
Date: Tue, 14 Aug 2012 22:02:53 -0400

'support'

Senad

Sent from my iPhone

On Aug 14, 2012, at 11:48 AM, "Bocci, Matthew (Matthew)" <[email-masked]> wrote:

> 'support'.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 15 Aug 2012 07:16:05 -0400

Support
/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Tuesday, August 14, 2012 11:48 AM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

At the Vancouver IETF, there was considerable support for adopting
draft-narten-nvo3-overlay-problem-statement-03 as an NVO3 working group document. However, there was also some support for draft-fang-vpn4dc-problem-statement-01.

Therefore, the chairs asked authors from both drafts, with help from Eric Gray, to work together on a common problem statement draft, the result of which is the subject of this adoption poll.

If you do not support adoption, please reply to this thread with 'do not support', and state your reasons.

Note that we will be polling for adoption of the NVO3 framework draft separately. We will start that poll in a separate thread, shortly.

Regards

Matthew & Benson

---

From: Eric Gray <[email-masked]>
Date: Wed, 15 Aug 2012 07:56:46 -0400

Support.

Note: Several of the authors/co-authors of this draft are on
vacation at least this week and possibly next.  I think it's
fair to assume that they also support making this draft a WG
draft, given that the request to do so came jointly from the
draft authors/co-authors... 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Tuesday, August 14, 2012 11:48 AM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

---

From: John E Drake <[email-masked]>
Date: Wed, 15 Aug 2012 05:22:35 -0700

Support.  However, it would be a graceful gesture for the document to be renamed to something other than 'draft-narten'.  Also, there are other requirements drafts.  What is their disposition?

Sent from my iPhone

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Eric Gray
> Sent: Wednesday, August 15, 2012 4:57 AM
> To: Bocci, Matthew (Matthew); [email-masked]
> Subject: Re: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-
> problem-statement-04
> 
> Support.
> 
> Note: Several of the authors/co-authors of this draft are on vacation
> at least this week and possibly next.  I think it's fair to assume that
> they also support making this draft a WG draft, given that the request
> to do so came jointly from the draft authors/co-authors...
> 
> document. However, there was also some support for draft-fang-vpn4dc-
> problem-statement-01.
> 
> Therefore, the chairs asked authors from both drafts, with help from
> Eric Gray, to work together on a common problem statement draft, the
> result of which is the subject of this adoption poll.
>

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 15 Aug 2012 08:45:36 -0400

If adopted, the draft will be renamed draft-ietf-nvo3-...

At this time we are just talking about adoption of a Problem
Statement. We will focus on Requirements separately, per our
milestones.

FYI, other text related to the Problem Statement can be contributed
(and incorporated) after adoption, if that text has WG consensus.

Cheers,
-Benson

On Aug 15, 2012, at 8:33, John E Drake <[email-masked]> wrote:

>> Bocci, Matthew (Matthew)

---

From: John E Drake <[email-masked]>
Date: Wed, 15 Aug 2012 06:08:47 -0700

Comments inline

Sent from my iPhone

> From: Benson Schliesser [mailto:[email-masked]]
> Sent: Wednesday, August 15, 2012 5:46 AM
> To: John E Drake
> Cc: Eric Gray; Bocci, Matthew (Matthew); [email-masked]

JD:  And prior to its adoption, its name would be?

> 
> At this time we are just talking about adoption of a Problem Statement.
> We will focus on Requirements separately, per our milestones.

JD:  The distinction between a problem statement and a set of requirements seems, in retrospect, to be artificial.

> > Support.  However, it would be a graceful gesture for the document to
> be renamed to something other than 'draft-narten'.  Also, there are
> other requirements drafts.  What is their disposition?
> >
> > Sent from my iPhone
> >
> >> From: [email-masked] [mailto:[email-masked]] On Behalf
> >> Of Eric Gray
> vacation
> >> at least this week and possibly next.  I think it's fair to assume
> >> that they also support making this draft a WG draft, given that the
> >> request to do so came jointly from the draft authors/co-authors...
> >>
> >> draft-narten-nvo3-overlay-problem-statement-03 as an NVO3 working
> >> group document. However, there was also some support for
> >> draft-fang-vpn4dc- problem-statement-01.
> >>
> >> If you support adoption of
> >> draft-narten-nvo3-overlay-problem-statement-
> >> 04,

---

From: Fabio Maino <[email-masked]>
Date: Wed, 15 Aug 2012 10:37:13 -0700

support.

Fabio

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Aug 2012 05:48:35 +0900

> JD:  And prior to its adoption, its name would be?

what it is, draft-narten-nvo3-overlay-problem-statement

we've been doing it this way we for a while.  you'll survive.

> The distinction between a problem statement and a set of requirements
> seems, in retrospect, to be artificial.

perhaps some technical examples would help us understand where you think
we have gone wrong.

and could we focus on engineering not process?

randy

---

From: Eric Gray <[email-masked]>
Date: Wed, 15 Aug 2012 16:55:47 -0400

John,

	The distinction could be artificial, however, in working
on the problem statement draft the authors very deliberately
made this distinction.  They were very careful to avoid use of
"requirements" language, and a few items were considered for 
removal as potential "requirements."

	On a case-by-case basis, it is often true that it is hard
to distinguish portions of a problem from possible requirements
of a solution.  In general, though, it is somewhat easier to
decide whether you want specific documents to describe problems
or requirements.

	With the problem statement draft, the intent was to focus
on describing the problem, hoping to make the task of defining
requirements of a solution as easy as possible - but without 
attempting to do the task outright.

	Baby-steps...

--
Eric

-----Original Message-----
From: John E Drake [mailto:[email-masked]] 
Sent: Wednesday, August 15, 2012 9:09 AM
To: Benson Schliesser
Cc: Eric Gray; Bocci, Matthew (Matthew); [email-masked]
Subject: RE: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

Comments inline

Sent from my iPhone

> >> Of Bocci, Matthew (Matthew)

---

From: Lucy yong <[email-masked]>
Date: Wed, 15 Aug 2012 20:58:20 +0000

Hi Randy,

There is a use case draft. Draft-mity-nvo3-use-case-01. Three sets of use cases are described in the draft. We got some good feedbacks in Vancouver and will revise the draft and upload soon. 

Here are three sets of use cases.
1) Virtual network in one data center
2) Interconnect between DC virtual network and external users
3) DC applications using virtual networks

Please review the draft. Your feedback and suggestion are highly appreciated.

Regards,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Bush
Sent: Wednesday, August 15, 2012 3:49 PM
To: John E Drake
Cc: nvo3
Subject: Re: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

randy

---

From: Luay Jalil <[email-masked]>
Date: Thu, 16 Aug 2012 00:29:54 +0300

Support

Luay
On Aug 14, 2012 10:48 AM, "Bocci, Matthew (Matthew)" <

---

From: John E Drake <[email-masked]>
Date: Wed, 15 Aug 2012 14:34:37 -0700

Andy,

Thanks for your email, below, it was extremely helpful.  Will you also be making some engineering comments?

John

Sent from my iPhone

> From: Randy Bush [mailto:[email-masked]]
> Sent: Wednesday, August 15, 2012 1:49 PM
> To: John E Drake
> Cc: nvo3
> perhaps some technical examples would help us understand where you
> think we have gone wrong.
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Aug 2012 06:36:51 +0900

> Thanks for your email, below, it was extremely helpful.  Will you also be making some engineering comments?

ong,

i have done so quietly to actual author(s) for some time.

randy

---

From: Lucy yong <[email-masked]>
Date: Wed, 15 Aug 2012 21:41:22 +0000

Randy,

Would you mind sharing your thought on the mailing list?

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Bush
Sent: Wednesday, August 15, 2012 4:37 PM
To: John E Drake
Cc: nvo3
Subject: Re: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

ong,

randy

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Aug 2012 06:51:02 +0900

ong,

>> Thanks for your email, below, it was extremely helpful.  Will you
>> also be making some engineering comments?

btw, (aside from beinga researcher) i am an op with a bit of data in a
bunch of datacenters.  as i warned way back when, much of what large
deployments do today is considered competitive secret sauce.  and almost
no one talks.

so what was predicted has come true, a bunch of vendors throwing their
favorite spaghetti at the wall hoping some of it will stick [0].  this
is not a pretty sight.

randy

[0] - Randy Bush, "Editorial zone: Into the Future with the Internet
      Vendor Task Force: a very curmudgeonly view, or testing
      spaghetti," ACM SIGCOMM Computer Communication Review Volume 35
      Issue 5, October 2005.
      <http://archive.psg.com/051000.ccr-ivtf.html>

---

From: John E Drake <[email-masked]>
Date: Wed, 15 Aug 2012 15:02:43 -0700

Wow!

Sent from my iPhone

> Sent: Wednesday, August 15, 2012 2:51 PM
> To: John E Drake
> Cc: nvo3
> deployments do today is considered competitive secret sauce.  and
> almost no one talks.
>

---

From: Sunny Rajagopalan <[email-masked]>
Date: Wed, 15 Aug 2012 15:39:31 -0700

Support !

From:   "Bocci, Matthew (Matthew)" <[email-masked]>
To:     "[email-masked]" <[email-masked]>
Date:   08/14/2012 08:49 AM
Subject:        [nvo3] Poll for WG adoption: 
draft-narten-nvo3-overlay-problem-statement-04
Sent by:        [email-masked]

All,

Regards

Matthew & Benson

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 16 Aug 2012 09:19:26 +0530

Support! 

****************************************************************************
***
Dhruv Dhody, System Architect, Huawei Technologies, Bangalore, India, Ph.
+91-9845062422

This e-mail and attachments contain confidential information from HUAWEI,
which is intended only for the person or entity whose address is listed
above. Any use of the information contained herein in any way (including,
but not limited to, total or partial disclosure, reproduction, or
dissemination) by persons other than the intended recipient's) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

> Sent: Tuesday, August 14, 2012 9:18 PM
> To: [email-masked]

---

From: "Ayandeh, Siamack" <[email-masked]>
Date: Fri, 17 Aug 2012 19:09:36 +0000

Support (with comments).

Best Regards

Siamack Ayandeh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Tuesday, August 14, 2012 11:48 AM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption: draft-narten-nvo3-overlay-problem-statement-04

All,

Regards

Matthew & Benson

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 17 Aug 2012 20:14:20 +0000

Support... as an author (in case it wasn't clear).

 - Larry

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 18 Aug 2012 18:15:08 +0000

Support!

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Michael Richardson <[email-masked]>
Date: Sun, 19 Aug 2012 18:49:27 -0400

I agree with adopting draft-narten-nvo3-overlay-problem-statement-04 as
a problem statement.  

I have three comments:

1) I am surprised that there is a view that bridges/virtual-switches
   located in hypervisors will be among those most constrained.
   I think that things located in the hypervisor are not constrained
   in terms of code space or code update latency.
   (By "code update latency", I mean, how quickly a patch can be
   deployed.  No silicon is involved, no firmware needs to be updated,
   a simple patch and reboot of a server is enough. Perhaps there is
   another term for this)

   It could be that hypervisors, having hundreds of instances of
   virtual switches maybe constrained as to amount of memory used
   by each instance, but comparing that to ToR switches, I think
   that they have huge amounts of memory available.

2) I did not get a clear idea that we are looking at only solutions
   that provide layer-2 services.  I think that this is the case,
   but it felt to me that some layer-3 solutions (ones that did
   not require renumbering) might be still in the running.
   For instance, creative use of proxy-arp (or layer-3 meshes
   like OLSRV) might be admissible. These have limitations for
   multicast and broadcast traffic which are both features
   and hindrances.

3) I would like some guidance as to why the problem that NVO3
   is dealing with was out of scope for, for instance, TRILL.
   Not just a statement that TRILL has a GAP, but a clear 
   indication why that GAP isn't something that TRILL should
   solve.... also why this problem is an IETF problem, and
   not an IEEE problem.

-- 
Michael Richardson
-at the cottage-

---

From: <[email-masked]>
Date: Mon, 27 Aug 2012 13:12:35 +0000

Hi all,

*Support*, pending removal of this paritcular piece (end of the second 
paragraph of "3.5 Overlay Networking Work Areas"):
 >
> For example, routing protocols  (e.g., IS-IS, BGP) may have scaling
 > difficulties if implemented directly in all NVEs, based on both
 > flooding and convergence time concerns. An alternative approach
 > would be to use a standard query protocol between NVEs and the set of
 > network nodes that maintain address mappings used across the data
 > center for the entire overlay system.

The above, beyond the fact that it is very debatable, would belong to a 
discussion on solutions.

Thanks,

-Thomas

Matthew Bocci, 2012-08-14 :
 > draft-narten-nvo3-overlay-problem-statement-04, please reply to this
 > thread with 'support'.
 >
 > Note that we will be polling for adoption of the NVO3 framework
 > draft separately. We will start that poll in a separate thread,
 > shortly.
 >
 > Regards
 >
 > Matthew & Benson
 >
 >
 >
 > _______________________________________________ nvo3 mailing list
 > [email-masked] https://www.ietf.org/mailman/listinfo/nvo3

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 27 Aug 2012 06:22:36 -0700

Thomas,

> The above, beyond the fact that it is very debatable, would belong to a 

I agree with you that the above is highly debatable, and should be
removed from the document prior to its adoption.

Yakov.

> _____________________________________________________________________________
____________________________________________
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu c
e message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages elec
troniques etant susceptibles d'alteration,
> As emails may be altered, France Telecom - Orange is not liable for messages 
that have been modified, changed or falsified.

---

From: Somesh Gupta <[email-masked]>
Date: Mon, 27 Aug 2012 09:37:16 -0700

I agree that the statement does not have proof behind it.

Perhaps the question is whether a distributed control plane
makes sense in this environment. It seems that there will be
a central management entity that will do all of the provisioning
and setup/teardown etc. And it may be better to have a protocol
to query/distribute the information from this entity to all
NVEs (that need to have this information) than to update one or
two NVEs and for the NVEs to distribute the information among
themselves - just seems redundant.

The preferred answer may depend on whether you think NVE will
be primarily in the hypervisor or the TOR.

> Yakov Rekhter
> Sent: Monday, August 27, 2012 6:23 AM
> To: [email-masked]
> Cc: [email-masked]
> >  > If you do not support adoption, please reply to this thread with
> 'do
> >  > not support', and state your reasons.
> >  >
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidenti
> elles ou privilegiees et ne doivent donc
> > France Telecom - Orange decline toute responsabilite si ce message a
> ete alte
> re, deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> privileged infor
> mation that may be protected by law;
> > If you have received this email in error, please notify the sender
> and delete
>  this message and its attachments.

---

From: Thomas Narten <[email-masked]>
Date: Mon, 27 Aug 2012 13:02:53 -0400

Hi Thomas.

I will remove the text at issue. The WG will need to have the
discussion about this, but doing that in  a separate document is fine.

Background. I am assuming that the vast majority of NVEs in a network
will be on Hypervisors. That is what industry is doing today, for
lot's of compelling reasons. :-)

If you take a link-state routing protocol that floods link state and
associated information to *all* nodes in the network, those protocols
will impose scaling limitations that will limit the number of nodes
that can participate and the overall size of the overlay.

If we assume that all NVEs (on hypervisors) have to participate, the
size of your network is fundamentally limited by how well the protocol
scales and how much information each participant needs to process. The
charter itself says:

    An NVO3 solution (known here as a Data Center Virtual Private
    Network (DCVPN)) is a VPN that is viable across a scaling
    range of a few thousand VMs to several million VMs running on
    greater than one hundred thousand physical servers.

I don't see how running IS-IS (or anything that floods information to
all participants) on 100K hypervisors is a viable starting
point. YMMV.

Thomas

---

From: <[email-masked]>
Date: Tue, 28 Aug 2012 07:24:01 +0000

Hi Thomas,

> discussion about this, but doing that in  a separate document is fine.

Agreed.
Thanks.

> all participants) on 100K hypervisors is a viable starting

I certainly agree with the above, the statement about IS-IS is not the 
part I was finding debatable (but nevertheless does not belong to a 
problem statement document).

-Thomas

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Wed, 29 Aug 2012 17:48:34 +0200

This email closes this call for WG adoption.

There is consensus to adopt this draft.

Please could the authors republish the draft, renaming it as
draft-ietf-nvo3-overlay-problem-statement-00, and incorporating the
comment from Thomas Morin.

There were also some other comments on the list that probably need further
consideration.

Best regards

Matthew & Benson