Subject: Re: [nvo3] Let's refocus on real world

From: <[email-masked]>
Date: Wed, 29 Aug 2012 12:25:37 -0500

"Host machine" was meant to describe a machine hosting VMs, which in this context can also be referred to as a "hypervisor".

When a "hypervisor" has an FCoE CNA installed, if that hardware is exposed to the VM, it would be presented to the VM as an FC adapter, not as an FCoE CNA. Hence FC frames would still be encalculated by the hypervisor, not the VM. And therefore FCoE would still operate on the underlay, not the overlay.

The only situation under which a VM would encapsulate FC frames into FCoE, and transmit those frames to the hypervisor virtual switch, is when the VM has an FCoE software stack installed, such as the one available from Intel. In that case, FCoE frames would be delivered to and carried by the overlay virtual network.

If and when software FCoE on a VM moves from being experimental and niche to production deployments (not likely anytime soon), that is when NVO3 should consider FCoE and DCB -- in my humble opinion.

Cheers,
Brad

-----Original Message-----
From: Ayandeh, Siamack [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, August 29, 2012 10:47 AM Central Standard Time
To: Hedlund, Brad; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nvo3] Let's refocus on real world

Not sure what you mean by “host machine”. FCoE can be used by both the hypervisor and the VMs using the N_Port virtualization capability. And when do you think would be the “right” time?

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, August 29, 2012 11:38 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nvo3] Let's refocus on real world

VLAN space exhaustion is not an issue with FCoE. Generally you have (1) FCoE VLAN per (1) FC VSAN. And many host machines can access storage on the same VSAN.

I agree with previous comments that FCoE is used by the host machine, not the VMs. Hence FCoE operates on the underlay, not the overlay, and therefore should be out of scope for NVO3 (for now).

Cheers,
Brad

-----Original Message-----
From: Lizhong Jin [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, August 29, 2012 10:05 AM Central Standard Time
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nvo3] Let's refocus on real world
Hi,
If FCoE does not transport with overlay, then do you infer that FCoE will not meet similar problem as NVO3 currently defined, e.g, VLAN space limitation?

Thanks
Lizhong

---------- Forwarded message ----------
From: Aldrin Isaac <[email-masked]<mailto:[email-masked]>>
To: Somesh Gupta <[email-masked]<mailto:[email-masked]>>
Cc: Ivan Pepelnjak <[email-masked]<mailto:[email-masked]>>, "Black, David" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Stiliadis, Dimitrios \(Dimitri\)" <[email-masked]<mailto:[email-masked]>>, Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Tue, 28 Aug 2012 12:40:37 -0400
Subject: Re: [nvo3] Let's refocus on real world (was: Comments on Live Migration and VLAN-IDs)
The question regarding FCoE is whether overlay solutions need to transport it.  I think the answer is no.  If something operates at the underlay level than it isn't in scope for NVo3, including DCB.

---

From: Somesh Gupta <[email-masked]>
Date: Wed, 29 Aug 2012 12:30:43 -0700

While FCoE access from VMs may remain marginal, the ability to have
numerous very small networks that can span any distance could make
overlays interesting for FCoE from hypervisor as well (not that
I am encouraging addressing this use case right now).

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 29, 2012 10:26 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Somesh Gupta; [email-masked]
Subject: RE: [nvo3] Let's refocus on real world

Cheers,
Brad

-----Original Message-----
From: Ayandeh, Siamack [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, August 29, 2012 10:47 AM Central Standard Time
To: Hedlund, Brad; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nvo3] Let's refocus on real world

Cheers,
Brad

-----Original Message-----
From: Lizhong Jin [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, August 29, 2012 10:05 AM Central Standard Time
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nvo3] Let's refocus on real world
Hi,

Thanks
Lizhong