Subject: [nvo3] Control plane interface between NVE and Oracle

From: Qin Wu <[email-masked]>
Date: Wed, 27 Feb 2013 18:49:59 +0800

Hi, folks:
We have submitted the new versions of draft-fw-nvo3-server2vcenter-01 and Draft-wu-nvo3-nve2nve-01 
http://tools.ietf.org/html/draft-fw-nvo3-server2vcenter-01
http://tools.ietf.org/html/draft-wu-nvo3-nve2nve-01
http://tools.ietf.org/html/draft-wu-nvo3-mac-learning-arp-01
which target NVO3 architecture and go into details to discuss centralized approach
and distributed approach for End to End Auto Provision and forwarding plane setup.

draft-wu-nvo3-server2vcenter is restructed recently and more focuses on control plance 
interfacce between NVE and Oracle backend system. In addtion, management plane interface are discussed 
as well by introducing managment system like vCenter.

Draft-wu-nvo3-nve2nve-01 more focuses on mapping table creation,distribution, update between NVEs and how tenant system
and NVE join and leave VN together with NVEs from general perspective.

Draft-wu-nvo3-mac-learning-arp focuses discussing several possible ways for MAC address learning between NVEs by constrict ARP flooding
in the local subnet behind NVE and use control plane and/or mapping table distribution to learn MAC address sinceARP flooding
in the whole VN is not desirable.

Your comments and suggestions are welcome!

Regards!
-Qin

---

From: "Cao,Zhen (cz)" <[email-masked]>
Date: Wed, 27 Feb 2013 20:15:02 +0800

Hi Qin,

The drafts look interesting, I have the following questions for
discussion, could you help clarify?

Does your draft rely on management plane function (VCenter) and or
control plane function (Oracle/nDirector) to manage VM and VM
migration? If you rely on management plane function, VMware manage
them differently, Microsoft’s SysCenter manage them differently.

And how is the draft draft-wu-nvo3-nve2nve-01 related to
draft-kreeger-nvo3-overlay-cp?

Thanks,
zhen
On Wed, Feb 27, 2013 at 6:49 PM, Qin Wu <[email-masked]> wrote:
> Draft-wu-nvo3-nve2nve-01 more focuses on mapping table
> creation,distribution, update between NVEs and how tenant system
> Draft-wu-nvo3-mac-learning-arp focuses discussing several possible ways for
> MAC address learning between NVEs by constrict ARP flooding
> in the local subnet behind NVE and use control plane and/or mapping table
> distribution to learn MAC address sinceARP flooding
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 28 Feb 2013 10:05:48 +0800

Hi,Zhen:
Thank for your quick review, please see my reply inline below.
----- Original Message ----- 
From: "Cao,Zhen (cz)" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, February 27, 2013 8:15 PM
Subject: Re: [nvo3] Control plane interface between NVE and Oracle

Hi Qin,

[Qin]: Good question, the draft draft-wu-nvo3-server2vcenter  did rely on management plane function, i.e.,vCenter which 
can VMware vPhere manager or Miscrosoft's SysCenter to perform VM management,e.g.,VM creation, VM termination.
However this is not focus of this draft after we restructured it in this version. 

This draft now focus on going into details to discuss the control plance interface between NVE and Oracle, 
using interaction between NVE and Oracle to perform three things:
a. Populate forwarding table in the path from tenant system to NVE
b. Distribute mapping table from local NVE to remote NVEs that belong to the same VN.
c. Enforce network policy in the switched network from tenant system to NVE.

Maybe somebody may argue VM management using management plane function part is not scope of this WG.
But I think the purpose to add this part  is intending to give a whole picture of what NVO3 archicture looks like.
In some case, we may need interaction between management plane function and control plane function, one possible way
is management plane function (e.g.,vCenter) help establish the mapping tables which can be accessed by control plane function
 (e.g., BGP Gateway or Controller).

[Qin]: Good catch, this draft also tagets control plane protocol related to building and distributing mapping table and covering both control plane
between tenant system and NVE and control plane between NVE and Oracle. The difference is
we go into details to discuss how tenant system joins/leavs to VN togehter with NVE, mapping table establishment and distribution,how mapping 
table is updated when VM moves or something fail, which are complementary to what draft-kreeger-nvo3-overlay-cp is currently describing.

Thanks,
zhen