Subject: [nvo3] New version of draft-kompella-nvo3-server2nve posted

From: "Black, David" <[email-masked]>
Date: Mon, 29 Apr 2013 18:24:00 -0400

A -02 version of this draft can be found at:

http://datatracker.ietf.org/doc/draft-kompella-nvo3-server2nve/

This is the draft version that I should've completed and posted before
the Orlando meetings.  The primary purpose of this -02 version is to
serve as a useful source of text for other drafts; the authors do not
plan to update this draft any further.

FYI,
--David

---

From: "Reith, Lothar" <[email-masked]>
Date: Tue, 30 Apr 2013 09:24:29 +0000

Hi David, dear authors,

could you explain why the draft contains the following definitions, but does not use them?

      VM: Virtual Machine (same as Virtual Station)
      VSI: Virtual Station Interface

My recommendation would be, to enhance the definition as follows:

      VM: Virtual Machine (same as Virtual Station, but viewed with a compute centric view where attachment means attaching a network to the VM)
	VS: Virtual Station (same as Virtual Machine, but viewed with a network centric view where attachment means attaching a VM to the network)

      VMI: Virtual Machine interface (is a network side facing interface from a higher layer to a lower layer in the stack)
	VSI: Virtual Station Interface (is a compute side facing interface from a lower layer to a higher layer in the stack)

Check the occurances of "VM interface" and "port" and replace them accordingly by either VMI or VSI

Regards, Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Black, David
Gesendet: Dienstag, 30. April 2013 00:24
An: [email-masked]
Betreff: [nvo3] New version of draft-kompella-nvo3-server2nve posted

FYI,
--David

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Black, David" <[email-masked]>
Date: Tue, 30 Apr 2013 11:00:55 -0400

Hi Lothar,

Thank you for your comments.

The VM acronym is used in the draft title and the table of contents ;-).

The VSI acronym is of limited use in this draft, as this version was
(re)written primarily in terms of NVE management of addresses (e.g., MACs)
rather than interfaces.  The text involved in that is probably too specific
to live on in a requirements draft as (IMHO) address vs. interface management
is probably a solution-specific/solution-dependent design decision.

For the use case orientation of this draft, I don't think the use of VS, VSI
or VMI adds clarity, but those terms would be candidates for a revision of
draft-kreeger-nvo3-hypervisor-nve-cp on requirements for server/hypervisor
to NVE communication.  So, while there are no plans to revise
draft-kompella-nvo3-server2nve, as a co-author of that that requirements draft,
I'll keep those terms in mind.

Thanks,
--David

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith,
> Lothar
> Sent: Tuesday, April 30, 2013 5:24 AM
> To: Black, David; [email-masked]
> Subject: Re: [nvo3] New version of draft-kompella-nvo3-server2nve posted
> 
> Hi David, dear authors,
> 
>       VM: Virtual Machine (same as Virtual Station, but viewed with a compute
> centric view where attachment means attaching a network to the VM)
> 	VS: Virtual Station (same as Virtual Machine, but viewed with a network
> centric view where attachment means attaching a VM to the network)
> 
>       VMI: Virtual Machine interface (is a network side facing interface from
> a higher layer to a lower layer in the stack)
> 	VSI: Virtual Station Interface (is a compute side facing interface from
 > a lower layer to a higher layer in the stack)
>