Subject: [nvo3] suggestions on data plane requirements draft

From: ramki Krishnan <[email-masked]>
Date: Wed, 17 Apr 2013 08:25:02 -0700

Dear Authors,

In section 3.3.2.1 (LAG/ECMP), the change suggested below articulates the inference of entropy in a much better way.

>>The entropy information MAY be inferred from the NVO3 overlay header or underlay header.

The entropy information should be ideally present in the overlay header e.g. Entropy Label for MPLS [RFC 6790], VXLAN - UDP source port. In case the overlay protocol does not support the necessary entropy information or the switches/routers in the underlay do not support parsing of the additional entropy information in the overlay header, the following support is needed in the underlay switches/routers. The underlay switches and routers should be programmable, i.e. select the appropriate fields in the underlay header for hash calculation based on the type of overlay header - the point to note is even the location of the underlay header in the packet will vary based on the type of overlay header.

Thanks,
Ramki

---

From: Jon Hudson <[email-masked]>
Date: Wed, 17 Apr 2013 17:40:44 +0200

+1

On Apr 17, 2013, at 5:25 PM, ramki Krishnan <[email-masked]> wrote:

> The entropy information should be ideally present in the overlay header e.g. Entropy Label for MPLS [RFC 6790], VXLAN – UDP source port. In case the overlay protocol does not support the necessary entropy information or the switches/routers in the underlay do not support parsing of the additional entropy information in the overlay header, the following support is needed in the underlay switches/routers. The underlay switches and routers should be programmable, i.e. select the appropriate fields in the underlay header for hash calculation based on the type of overlay header – the point to note is even the location of the underlay header in the packet will vary based on the type of overlay header.
>  
> Thanks,
> Ramki
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3