Subject: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

From: Thomas Narten <[email-masked]>
Date: Fri, 19 Apr 2013 10:06:50 -0400

Qin Wu <[email-masked]> writes:

> [Qin]: I agree with one tenant system may have one pNIC and one ore
>        multiple vNICs,

Let me zero on in this because I don't quite understand this model,
and I suspect this point is leading to the back-and-forth on the
terminology thread.  The two terms are also used in
draft-wu-nvo3-nve2nve-04.tx, which says:

>    o Each tenant system is corresponding to one virtual machine.
>       Each tenant system has only one pNIC and one or more vNIC
>       adapters that it uses to communicate with both the virtual and
>       physical networks.The pNIC and vNIC adapters each virtual
>       machine has belong to a single tenant.

To me, a Tenant System (TS) doesn't have pNICS and vNICs. It has
NICs. By definition, a TS is connected to one or more virtual networks
(VNs). If it has a native connection to the DC network, that is
out-of-scope for NVO3. Plus, I don't know why it would do that, or
what implication it would have for NVO3.

To the TS, it has NICs, but it really doesn't know whether they are
physical or virtual. The whole point is that the TS just uses the NICs
it has as if they were physical. Hence, it doesn't make sense to talk
about a TS having both kinds of connections. Shouldn't that just be
completely transparent to the TS? Why are you distinguishing vNIC and
pNIC in the context of a TS?

Thomas

---

From: John E Drake <[email-masked]>
Date: Fri, 19 Apr 2013 14:17:09 +0000

Thomas,

This sounds correct.

Irrespectively Yours,

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Thomas Narten
> Sent: Friday, April 19, 2013 7:07 AM
> To: Qin Wu
> Cc: [email-masked]
> Subject: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt
> 
> Let me zero on in this because I don't quite understand this model, and
> I suspect this point is leading to the back-and-forth on the
> terminology thread.  The two terms are also used in draft-wu-nvo3-
> nve2nve-04.tx, which says:
> 
> To me, a Tenant System (TS) doesn't have pNICS and vNICs. It has NICs.
> By definition, a TS is connected to one or more virtual networks (VNs).
> If it has a native connection to the DC network, that is out-of-scope
> for NVO3. Plus, I don't know why it would do that, or what implication
> it would have for NVO3.
> 
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Pat Thaler" <[email-masked]>
Date: Fri, 19 Apr 2013 18:29:55 +0000

In addition to Thomas's point, we should not restrict the number of physical NICs that a tenant system can have. Some tenant systems will have more than one physical NIC.

We may describe some typical tenant systems as part of examining use cases, but NVO3 should define behavior in terms of the network interface, i.e. TSI, behavior and should not restrict tenant system architecture.

Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Friday, April 19, 2013 7:07 AM
To: Qin Wu
Cc: [email-masked]
Subject: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Thomas

---

From: Thomas Narten <[email-masked]>
Date: Fri, 19 Apr 2013 14:48:49 -0400

"Pat Thaler" <[email-masked]> writes:

> In addition to Thomas's point, we should not restrict the number of
> physical NICs that a tenant system can have. Some tenant systems
> will have more than one physical NIC.

Agreed.

> We may describe some typical tenant systems as part of examining use
> cases, but NVO3 should define behavior in terms of the network
> interface, i.e. TSI, behavior and should not restrict tenant system
> architecture.

Another way of looking at it is that the TSI is an attachement
point/interface to the TS. The point where the TSI attaches to the TS
has two sides. On the tenant facing side, it appears to be a NIC. It
looks like a NIC, behaves like a NIC, etc. On the side facing away
from the tenant (e.g., the hypervisor in the case of a virtualized
system) we call it a TSI. The TSI side will have attributes that are
specific to NVO3.

Does that make sense?

Thomas

---

From: "Pat Thaler" <[email-masked]>
Date: Fri, 19 Apr 2013 19:43:57 +0000

Agree, Pat

-----Original Message-----
From: Thomas Narten [mailto:[email-masked]] 
Sent: Friday, April 19, 2013 11:49 AM
To: Pat Thaler
Cc: Qin Wu; [email-masked]
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agreed.

Does that make sense?

Thomas

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 19 Apr 2013 21:15:35 +0000

I completely agree with Thomas.  This had me scratching my head too. -
Larry

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 19 Apr 2013 21:19:09 +0000

I agree. The important thing for us (NVO3 WG) is how the TSI is seen from
the network side, but it is useful to articulate common examples of how
the TSI is seen from the TS side.

 - Larry

---

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 19 Apr 2013 16:22:14 -0700

> system) we call it a TSI. The TSI side will have attributes that are

I don't agree that it always appears as a NIC.  It appears as some
sort of protocol interface, but that is not necessarily a NIC to the
tenant system.   For example, in the physical world, a VLAN doesn't
look like a NIC to the host OS.

Anoop

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Sat, 20 Apr 2013 00:06:15 +0000

True. I would be a NIC for an untagged interface, and a NIC+VLAN sub interface for a tagged VLAN. - Larry

From: Anoop Ghanwani <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 19, 2013 4:22 PM
To: Thomas Narten <[email-masked]<mailto:[email-masked]>>
Cc: Pat Thaler <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Qin Wu <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

On Fri, Apr 19, 2013 at 11:48 AM, Thomas Narten <[email-masked]<mailto:[email-masked]>> wrote:

Does that make sense?

Anoop

---

From: Thomas Narten <[email-masked]>
Date: Fri, 19 Apr 2013 20:05:57 -0400

> look like a NIC to the host OS.

In Linux at least a VLAN does look like a NIC (interface) on the
TS. You first configure the interface, then to use a VLAN, you end up
creating a virtual interface (for that VLAN) that connects through the
other interface. To the linux host, each VLAN appears as its own
interface.

See the "vconfig" command for instance on how this works.

But in any case, I think the broader point stands that a TSI is the
hypervisor-facing side, whereas on the TS, you get an interface of
some sort. The exact details of how that interface is presented depend
on the TS (whether linux, microsoft, etc.) itself. But that is the
case whether the interface is physical or virtual.

Thomas

---

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 19 Apr 2013 18:05:02 -0700

Agreed.

Anoop

---

From: Qin Wu <[email-masked]>
Date: Sat, 20 Apr 2013 02:17:34 +0000

Hi, Thomas:
Thank for your reading and commenting on draft-wu-nvo3-nvo3-nve2nve.
The reason to propose to distinct pNIC from vNIC is becos
Some on the list argued vNIC was not necessary to degenerated into
A meaning include pNIC or NIC. 

Following your discussion, I realized what you emphasized here is
Each TSI or NIC/vNIC plays two side roles, one role is facing tenant,
The other role is facing the side far away from tenant, i.e.,hypervisor side.

So is it possible for pNIC and vNIC are both facing hypervisor side.
I agree tenant does not need to distinguish pNIC from vNIC, however
Why Tenant system in the hypervisor side can not disntinguish pNIC from vNIC.

The definition of tenant system in the NVO3Framework documentsaid:
"
       Tenant System: A physical or virtual system that can play the role
       of a host, or a forwarding element such as a router, switch,
       firewall, etc. It belongs to a single tenant and connects to one or
       more VNs of that tenant.
"
Doesn't one Tenant system play both the role of virtual system and the role of physical system?
Why tenant system can not distinct pNIC from vNIC.

It make sense to say NIC to include both vNIC and pNIC. But not sure NIC
Is right term, it remind me to revisit your proposal to use Tenant NIC
http://www.ietf.org/mail-archive/web/nvo3/current/msg02236.html
makes a lot of sense.
However it doesn't make sense to me to say One TSI is both corresponding to both a pNIC and a vNIC.
Whether we need to distinct pNIC from vNIC, two type of tenant NICs have 
Already existed.

Please see my reply inline below.

Regards!
-Qin
-----Original Message-----
From: Thomas Narten [mailto:[email-masked]] 
Sent: Friday, April 19, 2013 10:07 PM
To: Qin Wu
Cc: [email-masked]
Subject: vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

NICs. 

[Qin]: According to Tenant system definition, tenant system could be a physical system or virtual system.
That is to say, tenant system could have pNICs or vNICs that it uses to communicate with both virtual and
physical network. Doesn't it?
But I realized in the draft I said 
"a tenant system could have both pNICs and vNICs" which is not consistent with the definition of tenant system.
Maybe we should make clear about this to say
"
A tenant system could have either pNICs or vNICs that it uses to communicate with virtual and physical network.
Each pNIC or each vNIC will be treated as one or multiple Tenant system interfaces. It doesn't matter whether 
NIC is pNIC or vNIC. Note that it is not possible for a tenant system to have both pNIC and vNICs.
" 
For the last sentence, do you believe it is correct statement?

By definition, a TS is connected to one or more virtual networks
(VNs). If it has a native connection to the DC network, that is
out-of-scope for NVO3.

[Qin]: Good point, we could add a statement to say:
"
When a tenant system only has pNICs, it is not scope of NOV3 to
Describe having native connection to the DC network using such kind of tenant system.
"
Plus, I don't know why it would do that, or
what implication it would have for NVO3.

physical or virtual. 

[Qin]:If we have a tenant having pNICs and vNICs at the same time,
I think tenant system should know. Unfortunately  we may not have such
Tenant system.

The whole point is that the TS just uses the NICs
it has as if they were physical. Hence, it doesn't make sense to talk
about a TS having both kinds of connections. 

[Qin]:Agree.

Shouldn't that just be
completely transparent to the TS? 

[Qin]: Disagree.

Why are you distinguishing vNIC and
pNIC in the context of a TS?

[Qin]: My point is we can leave distinguishing pNIC from vNIC beyond scope of this document, since as you said, native connection to DC network is not scope of this document. However for TSI, each TSI is either corresponding to a pNIC or a vNIC.
It doesn't make sense to say one TSI is both a pNIC and a vNIC when both pNIC and vNIC are facing hypervisor side rather than pNIC is facing tenant side 
While vNIC is facing hypervisor side.

Thomas

---

From: Qin Wu <[email-masked]>
Date: Sat, 20 Apr 2013 03:11:03 +0000

Hi, Pat:
I agree we should not restrict the number of physical NICs. I will fix this in the draft.
I am just thinking whether we have a case where one tenant system both havs pNIC and havs vNIC facing the same side ,i.e., hypervisor side.
Besides we have:
a) a tenant system only having pNICs facing hypervisor side.
b) a tenant system only having vNICs facing hypervisor side.
It looks Larry give one example of such case,
Referring to what Larry said in http://www.ietf.org/mail-archive/web/nvo3/current/msg02251.html
"
For example, if the TS is a router, it may use the burned-in MAC and also have a virtual MAC for supporting VRRP.  If the TS is a bridge, it will send/receive frames with the MAC address of all the entities it is bridging traffic for.
"
Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pat Thaler
Sent: Saturday, April 20, 2013 2:30 AM
To: Thomas Narten; Qin Wu
Cc: [email-masked]
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Friday, April 19, 2013 7:07 AM
To: Qin Wu
Cc: [email-masked]
Subject: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Thomas

---

From: Qin Wu <[email-masked]>
Date: Sat, 20 Apr 2013 03:15:45 +0000

My interpretation for two sides of TS, is
>From tenant point of view, a tenant that has tenant system doesn't need to distinguish pNIC from vNIC,
What tenant view is just a set of NICs that belong to the same tenant system.
>From hypervisor point of view or tenant system point of view, tenant system should know whether it is pNIC or vNIC.

Regards!
-Qin
-----Original Message-----
From: Pat Thaler [mailto:[email-masked]] 
Sent: Saturday, April 20, 2013 3:44 AM
To: Thomas Narten
Cc: Qin Wu; [email-masked]
Subject: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agree, Pat

-----Original Message-----
From: Thomas Narten [mailto:[email-masked]] 
Sent: Friday, April 19, 2013 11:49 AM
To: Pat Thaler
Cc: Qin Wu; [email-masked]
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agreed.

Does that make sense?

Thomas

---

From: "Reith, Lothar" <[email-masked]>
Date: Sun, 21 Apr 2013 11:21:02 +0000

Thomas, 

See  below. I do not agree to the wording.

 And I suggest to change the definition of tenant system, which I identified as being perhaps a root cause of confusion.

Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Thomas Narten
Gesendet: Freitag, 19. April 2013 20:49
An: Pat Thaler
Cc: [email-masked]; Qin Wu
Betreff: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agreed.

Lothar: Disagree - Given the current definition of tenant system, one would have to make a case differentiation throughout the document as follows:

Case A: Tenant System is a VM 
- In this case - which may be the most important one to many - above statement is wrong, because then the tenant system has zero physical NICs.

Case B: Tenant System is a bare metal server
- In this case above statement is true

Case C: Tenant System is "according to current definition" a router or firewall...
- in this case we start referring to router ports as NICs or pNICs, which may further increase confusion.

Does that make sense?

Thomas

---

From: Qin Wu <[email-masked]>
Date: Mon, 22 Apr 2013 01:59:13 +0000

Hi, Lothar:
Bare metal server is some kind of hypervisor. As I discussed with Larry on the list before, usually hypervisor hosts multiple VMs. Each VM can be a tenant system. So I think  the case B doesn't stand.

Regarding Case A and Case C, I think tenant system can be either physical system or virtual system, as tenant system definition pointed out.
1.If tenant system is physical system, this could be out of scope of NVO3 since as Thomas mentioned, native connection to DC network is not necessary to be in the scope of NOV3. I agree with this, since if tenant system is physical system(e.g., physical network service appliance, the tenant system doesn't need to be a VM)

2. If tenant system is virtual system, it has two categories:
Category (a) Tenant system plays host role 
Category (b) Tenant system plays forwarding element role (I think it should be virtual forwarding element, if the tenant system is a firewall, it should be virtual firewall)

Case A and Case C, in my understanding fall into these two categories. 

Regards!
-Qin
-----Original Message-----
From: Reith, Lothar [mailto:[email-masked]] 
Sent: Sunday, April 21, 2013 7:21 PM
To: Thomas Narten; Pat Thaler
Cc: [email-masked]; Qin Wu
Subject: AW: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Thomas, 

Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Thomas Narten
Gesendet: Freitag, 19. April 2013 20:49
An: Pat Thaler
Cc: [email-masked]; Qin Wu
Betreff: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agreed.

Does that make sense?

Thomas

---

From: "Bannai, Vinay" <[email-masked]>
Date: Mon, 22 Apr 2013 03:32:44 +0000

Sorry for jumping in late to this discussion.

I agree with Tom's definition.

In addition, I would like to point out a use case which is a hybrid.
We are doing a overlay deployment model for VM's in the data center at
PayPal. 
One of the issues that come up is to have a separation of production
traffic and management traffic at the VM level.
We use the management traffic for pushing patches, release updates and
Openstack control traffic. It is quite possible that the management NIC's
on the VM's needs to be bridged to a physical NIC on the hypervisor which
is used for management purposes of the hypervisor. In this case, the VM's
had two NIC's one of them using overlays on the production NIC and the
other NIC is bridged to the management physical NIC on the hypervisor.

-- 
Vinay Bannai
408-967-7784
Cloud Engineering

---

From: "Reith, Lothar" <[email-masked]>
Date: Mon, 22 Apr 2013 07:36:24 +0000

Hi Qin,

I had read that a bare metal server is being used by people who do want to eliminate the overhead introduced by the hypervisor to the performance of the server. If the server runs only a single application - why introduce the overhead of a hypervisor and suffer from the associated performance degradation?

Therefore I tend to disagree with the statement, that a bare metal server is some kind of hypervisor.

Lothar

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]] 
Gesendet: Montag, 22. April 2013 03:59
An: Reith, Lothar; Thomas Narten; Pat Thaler
Cc: [email-masked]
Betreff: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Hi, Lothar:

Regards!
-Qin
-----Original Message-----
From: Reith, Lothar [mailto:[email-masked]] 
Sent: Sunday, April 21, 2013 7:21 PM
To: Thomas Narten; Pat Thaler
Cc: [email-masked]; Qin Wu
Subject: AW: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Thomas, 

Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Thomas Narten
Gesendet: Freitag, 19. April 2013 20:49
An: Pat Thaler
Cc: [email-masked]; Qin Wu
Betreff: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agreed.

Does that make sense?

Thomas

---

From: Qin Wu <[email-masked]>
Date: Mon, 22 Apr 2013 08:27:15 +0000

I thought you are talking about the bare metal hypervisor, it seems you are talking about a different thing
Which intend to be decoupled from hypervisor and not related to either bare metal hypervisor or hosted hypervisor.

Regards!
-Qin
-----Original Message-----
From: Reith, Lothar [mailto:[email-masked]] 
Sent: Monday, April 22, 2013 3:36 PM
To: Qin Wu; Thomas Narten; Pat Thaler
Cc: [email-masked]
Subject: AW: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Hi Qin,

Lothar

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]] 
Gesendet: Montag, 22. April 2013 03:59
An: Reith, Lothar; Thomas Narten; Pat Thaler
Cc: [email-masked]
Betreff: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Hi, Lothar:

Regards!
-Qin
-----Original Message-----
From: Reith, Lothar [mailto:[email-masked]] 
Sent: Sunday, April 21, 2013 7:21 PM
To: Thomas Narten; Pat Thaler
Cc: [email-masked]; Qin Wu
Subject: AW: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Thomas, 

Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Thomas Narten
Gesendet: Freitag, 19. April 2013 20:49
An: Pat Thaler
Cc: [email-masked]; Qin Wu
Betreff: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agreed.

Does that make sense?

Thomas

---

From: Jon Hudson <[email-masked]>
Date: Tue, 23 Apr 2013 20:39:59 -0700

Actually I have customers that still virtualize an OS/App even when the result is a 1:1:1 relationship. 

Due to direct mapping advancements overhead from running on a hypervisor is very very small.

Where the benefits of running an OS/App pair as a VM are many.

For example

1.) Abstract an older OS like Windows NT that does not have drivers for current hardware.

2.) Ability to pause, clone, snapshot or rollback the VM.

3.) Ability to move the VM live from one hypervisor to another. 

Jon

---

From: "Bannai, Vinay" <[email-masked]>
Date: Wed, 24 Apr 2013 04:09:19 +0000

On the issue of performance hits (specifically in regards to network
bandwidth) while running on top of hypervisor, here are some results that
I got from network heresey blog
http://networkheresy.com/category/network-virtualization/

	Throughput	Recv side cpu	Send side cpu
Linux Bridge:	9.3 Gbps	85%	75%
OVS Bridge:	9.4 Gbps	82%	70%
OVS-STT:	9.5 Gbps	70%	70%
OVS-GRE:	2.3 Gbps	75%	97%

Protocols that can leverage the NIC TCP LSO/RSO and other such features
can achieve near line rate.
I have a series of experiments that I plan to run in the coming weeks and
will have a better idea and can post the results.

-- 
Vinay Bannai
408-967-7784
Cloud Engineering

On 4/22/13 12:36 AM, "Reith, Lothar" <[email-masked]> wrote:

>Hi Qin,
>
>I had read that a bare metal server is being used by people who do want
>to eliminate the overhead introduced by the hypervisor to the performance
>of the server. If the server runs only a single application - why
>introduce the overhead of a hypervisor and suffer from the associated
>performance degradation?
>
>Bare metal server is some kind of hypervisor. As I discussed with Larry
>on the list before, usually hypervisor hosts multiple VMs. Each VM can be
>a tenant system. So I think  the case B doesn't stand.
>
>Regarding Case A and Case C, I think tenant system can be either physical
>system or virtual system, as tenant system definition pointed out.
>1.If tenant system is physical system, this could be out of scope of NVO3
>since as Thomas mentioned, native connection to DC network is not
>necessary to be in the scope of NOV3. I agree with this, since if tenant
>system is physical system(e.g., physical network service appliance, the
>tenant system doesn't need to be a VM)
>
>Category (b) Tenant system plays forwarding element role (I think it
>should be virtual forwarding element, if the tenant system is a firewall,
>it should be virtual firewall)
>
> And I suggest to change the definition of tenant system, which I
>identified as being perhaps a root cause of confusion.
>
>Lothar
>
>Lothar: Disagree - Given the current definition of tenant system, one
>would have to make a case differentiation throughout the document as
>follows:
>
>- In this case - which may be the most important one to many - above
>statement is wrong, because then the tenant system has zero physical NICs.
>

---

From: ramki Krishnan <[email-masked]>
Date: Tue, 23 Apr 2013 23:01:16 -0700

Agree with Jon.

From my interaction with customers, one of the popular use cases for bare metal servers is Analytics applications for e.g. Hadoop; the key reason is that these applications keep the CPU busy all the time and hence there is no benefit to virtualization.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jon Hudson
Sent: Tuesday, April 23, 2013 8:40 PM
To: Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

For example

Jon

On Apr 22, 2013, at 12:36 AM, "Reith, Lothar" <[email-masked]> wrote:

> 1.If tenant system is physical system, this could be out of scope of 
> NVO3 since as Thomas mentioned, native connection to DC network is not 
> necessary to be in the scope of NOV3. I agree with this, since if 
> tenant system is physical system(e.g., physical network service 
> appliance, the tenant system doesn't need to be a VM)
> 
> Category (a) Tenant system plays host role Category (b) Tenant system 
> plays forwarding element role (I think it should be virtual forwarding 
> element, if the tenant system is a firewall, it should be virtual 
> firewall)
> 
>> physical NICs that a tenant system can have. Some tenant systems will 
>> have more than one physical NIC.
> 
> Agreed.
>

---

From: "Reith, Lothar" <[email-masked]>
Date: Wed, 24 Apr 2013 10:48:58 +0000

I have not problem if the framework document explicitly states that bare metal servers without hypervisor are out of scope.

Lothar

-----Ursprüngliche Nachricht-----
Von: ramki Krishnan [mailto:[email-masked]] 
Gesendet: Mittwoch, 24. April 2013 08:01
An: Jon Hudson; Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Betreff: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agree with Jon.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jon Hudson
Sent: Tuesday, April 23, 2013 8:40 PM
To: Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

For example

Jon

---

From: David Allan I <[email-masked]>
Date: Wed, 24 Apr 2013 16:10:09 +0000

The architecture should not care...No difference between a bare metal server, and any other non-NVO3 networking or storage appliance that needs to be included in the overall compute and networking mix...we just have fewer "v"s in the bare metal case...

Cheers
Dave 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Wednesday, April 24, 2013 3:49 AM
To: ramki Krishnan; Jon Hudson
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Lothar

-----Ursprüngliche Nachricht-----
Von: ramki Krishnan [mailto:[email-masked]]
Gesendet: Mittwoch, 24. April 2013 08:01
An: Jon Hudson; Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Betreff: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agree with Jon.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jon Hudson
Sent: Tuesday, April 23, 2013 8:40 PM
To: Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

For example

Jon

---

From: Paul Unbehagen <[email-masked]>
Date: Wed, 24 Apr 2013 20:02:58 +0200

+1, most DC's have a mixture of virtual and bare metal. The document  therefore needs to be flexible. 

--
Paul Unbehagen

Sent from my iPhone

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Apr 2013 03:11:10 +0000

+1

-Qin
-----Original Message-----
From: David Allan I [mailto:[email-masked]] 
Sent: Thursday, April 25, 2013 12:10 AM
To: Reith, Lothar; ramki Krishnan; Jon Hudson
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Cheers
Dave 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Wednesday, April 24, 2013 3:49 AM
To: ramki Krishnan; Jon Hudson
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Lothar

-----Ursprüngliche Nachricht-----
Von: ramki Krishnan [mailto:[email-masked]]
Gesendet: Mittwoch, 24. April 2013 08:01
An: Jon Hudson; Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Betreff: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agree with Jon.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jon Hudson
Sent: Tuesday, April 23, 2013 8:40 PM
To: Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

For example

Jon

---

From: Alan Kavanagh <[email-masked]>
Date: Thu, 25 Apr 2013 03:25:24 +0000

+1 

It is no different than if a given app runs native or virtualised, both these models exist and NVO-3 networking will not differentiate either of them.

Alan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: April-24-13 12:10 PM
To: Reith, Lothar; ramki Krishnan; Jon Hudson
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Cheers
Dave 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Wednesday, April 24, 2013 3:49 AM
To: ramki Krishnan; Jon Hudson
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Lothar

-----Ursprüngliche Nachricht-----
Von: ramki Krishnan [mailto:[email-masked]]
Gesendet: Mittwoch, 24. April 2013 08:01
An: Jon Hudson; Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Betreff: RE: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

Agree with Jon.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jon Hudson
Sent: Tuesday, April 23, 2013 8:40 PM
To: Reith, Lothar
Cc: Thomas Narten; Pat Thaler; [email-masked]; Qin Wu
Subject: Re: [nvo3] vNICs and pNics in draft-wu-nvo3-nve2nve-04.txt

For example

Jon