Subject: [nvo3] Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

From: Linda Dunbar <[email-masked]>
Date: Fri, 31 May 2013 21:49:43 +0000

Larry, et al:

In NV03 problem statement draft, "Network Overlay" is used. It is used in a context to indicate that virtualized network is achieved by IP overlay (instead of MPLS overlay, Ethernet Overlay, or TRILL overlay, etc).

In draft-kreeger-nvo3-overlay-cp-03, "Network Virtualization Overlay" is used.

Is there any difference between "Network Virtualization Overlay" and "Network Overlay"? If yes, I suggest to define them properly. If no, let's keep the terminology consistent in NVO3 WG.

NVO3 WG's charter doesn't include tackling control plane issues for all overlay models.
Therefore, it is really out of the scope to have a draft on control plane for all overlay models.

Linda

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Fri, 31 May 2013 23:52:21 +0000

Hi Linda,

See my responses below, marked with LK>.

Thanks, Larry

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 31, 2013 2:49 PM
To: Larry Kreeger <[email-masked]<mailto:[email-masked]>>, Thomas Narten <[email-masked]<mailto:[email-masked]>>, Dinesh Dutt <[email-masked]<mailto:[email-masked]>>, David Black <[email-masked]<mailto:[email-masked]>>, Murari Sridharan <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

Larry, et al:

In NV03 problem statement draft, “Network Overlay” is used. It is used in a context to indicate that virtualized network is achieved by IP overlay (instead of MPLS overlay, Ethernet Overlay, or TRILL overlay, etc).

LK> The problem statement also uses the terms "Network Virtualization" and "Network Overlay" and discusses "Using Network Overlay to provide Virtual Networks".  The document title is "Problem Statement: Overlays for Network Virtualization".

In draft-kreeger-nvo3-overlay-cp-03, “Network Virtualization Overlay” is used.

Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

LK> Network Virtualization can be achieved without using an overlay.   Network Overlays can be used for purposes other than virtualization of the network.  So, a Network Virtualization Overlay describes the more specific use case of using a Network Overlay for creating a Virtual Network.

If yes, I suggest to define them properly. If no, let’s keep the terminology consistent in NVO3 WG.

LK> I don't see a formal definition in the framework document for "Network Overlay" or "Network Virtualization" either (only "Virtual Network").

NVO3 WG’s charter doesn’t include tackling control plane issues for all overlay models.
Therefore, it is really out of the scope to have a draft on control plane for all overlay models.

LK> Well, if you want to discuss terminology, the NVO3 WG charter discusses Data Center VPNs, a term which have not really been using much.  The charter doesn't even have the word "Overlay" in it!  I'm not sure where you are getting the impression that the control plane requirements is trying to address all overlay models based on the term "Network Virtualization Overlay". Do you have some terminology definitions you would like to see added to the Framework?  Once they are there, I will be happy to see them used consistently in all our documents.

Linda