Subject: [nvo3] The packet sequence problem in NVO3

From: Lizhong Jin <[email-masked]>
Date: Sat, 4 May 2013 09:50:48 +0800

Hi all,
Recently, I found the packet sequence problem in openVswitch(with VXLAN),
please refer to the detail
http://openvswitch.org/pipermail/discuss/2012-April/007002.html. Although
this is caused by the specific openvswitch implementation, but such kind of
implementation does gain better performance, while the side effect is the
sequence problem.
Then I suggest to consider the sequence requirement in NVO3-dataplane, and
try to provide some solutions in the later stage.

Regards
Lizhong

---

From: "Black, David" <[email-masked]>
Date: Sun, 5 May 2013 15:42:15 -0400

My initial reaction is that this seems no worse than the typical route-flapping effects of some routing updates - it's certainly worth noting, but I would not require that it be eliminated completely in all solutions.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Friday, May 03, 2013 9:51 PM
To: [email-masked]
Subject: [nvo3] The packet sequence problem in NVO3

Hi all,
Recently, I found the packet sequence problem in openVswitch(with VXLAN), please refer to the detail http://openvswitch.org/pipermail/discuss/2012-April/007002.html. Although this is caused by the specific openvswitch implementation, but such kind of implementation does gain better performance, while the side effect is the sequence problem.
Then I suggest to consider the sequence requirement in NVO3-dataplane, and try to provide some solutions in the later stage.

Regards
Lizhong

---

From: Lizhong Jin <[email-masked]>
Date: Mon, 6 May 2013 10:46:20 +0800

Thanks David.
Since the draft-ietf-nvo3-dataplane-requirements<http://tools.ietf.org/wg/nvo3/draft-ietf-nvo3-dataplane-requirements/>
is
already a WG draft, we need the WG consensus to add this new requirement.
Any solutions deployed with openvswitch should care about the potential
influence of packet out-of-order.

Regards
Lizhong

On Mon, May 6, 2013 at 3:42 AM, Black, David <[email-masked]> wrote:

> My initial reaction is that this seems no worse than the typical
> route-flapping effects of some routing updates - it’s certainly worth
> noting, but I would not require that it be eliminated completely in all
> solutions.****
>
> ** **
>
> Thanks,
> --David
> ----------------------------------------------------****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Lizhong Jin
> *Sent:* Friday, May 03, 2013 9:51 PM
> *To:* [email-masked]
> *Subject:* [nvo3] The packet sequence problem in NVO3****
>
> ** **
>
> Hi all,****
>
> sequence problem.****
> try to provide some solutions in the later stage.****
>
>  ****
>
> Regards****
>
> Lizhong****
>

---

From: ramki Krishnan <[email-masked]>
Date: Sun, 5 May 2013 21:34:56 -0700

As David alluded, this is probably worth noting as an informational guideline - this is perhaps not a data plane requirement.

This problem is not unique to OVS or Overlays. Besides route flapping, out-of-order packet delivery can happen during mac learning in the current switches. There are many possible solutions, each one of these have their tradeoffs.

Thanks,
Ramki

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Sunday, May 05, 2013 7:46 PM
To: Black, David
Cc: [email-masked]
Subject: Re: [nvo3] The packet sequence problem in NVO3

Thanks David.
Since the draft-ietf-nvo3-dataplane-requirements<http://tools.ietf.org/wg/nvo3/draft-ietf-nvo3-dataplane-requirements/> is already a WG draft, we need the WG consensus to add this new requirement.
Any solutions deployed with openvswitch should care about the potential influence of packet out-of-order.

Regards
Lizhong

On Mon, May 6, 2013 at 3:42 AM, Black, David <[email-masked]<mailto:[email-masked]>> wrote:
My initial reaction is that this seems no worse than the typical route-flapping effects of some routing updates - it's certainly worth noting, but I would not require that it be eliminated completely in all solutions.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953<tel:%2B1%20%28508%29%20293-7953>             FAX: +1 (508) 293-7786<tel:%2B1%20%28508%29%20293-7786>
[email-masked]<mailto:[email-masked]>        Mobile: +1 (978) 394-7754<tel:%2B1%20%28978%29%20394-7754>
----------------------------------------------------

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lizhong Jin
Sent: Friday, May 03, 2013 9:51 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [nvo3] The packet sequence problem in NVO3

Hi all,

Regards
Lizhong

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 6 May 2013 14:53:59 +0000

The problem described in the link is some odd behavior during the window of forwarding rule changes. During the window of forwarding rule changes, there are a lot other problems that are more severe than packet sequence.

I don't think it is within the scope NV03 to address behavior when forwarding rules change.

Linda

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Friday, May 03, 2013 8:51 PM
To: [email-masked]
Subject: [nvo3] The packet sequence problem in NVO3

Hi all,

Regards
Lizhong

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Mon, 6 May 2013 16:12:10 +0000

Lizhong,

As already mentioned by others, this is not a hard requirement.

If deemed useful, we can add in the DP reqs that packet re-ordering issues SHOULD be avoided.

Marc

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Monday, May 06, 2013 4:46 AM
To: Black, David
Cc: [email-masked]
Subject: Re: [nvo3] The packet sequence problem in NVO3

Thanks David.

Regards
Lizhong

Thanks,
--David

Hi all,

Regards
Lizhong

---

From: Lizhong Jin <[email-masked]>
Date: Tue, 7 May 2013 00:55:32 +0800

Hi Marc,
I am fine with that. Thanks.

Regards
Lizhong

在 2013-5-7 上午12:12，"LASSERRE, MARC (MARC)" <[email-masked]
>写道：
>> Since the draft-ietf-nvo3-dataplane-requirements is already a WG draft,
we need the WG consensus to add this new requirement.
solutions.
>>> Recently, I found the packet sequence problem in openVswitch(with
VXLAN), please refer to the detail
http://openvswitch.org/pipermail/discuss/2012-April/007002.html. Although
this is caused by the specific openvswitch implementation, but such kind of
implementation does gain better performance, while the side effect is the
sequence problem.
>>>
>>> Then I suggest to consider the sequence requirement in NVO3-dataplane,
and try to provide some solutions in the later stage.