Subject: Re: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

From: P Balaji-B37839 <[email-masked]>
Date: Tue, 2 Jul 2013 09:57:28 +0000

Support.

Few comments:

i)	Section "5.  Security Considerations" discusses about ACL for NVE. IMO, we should also need to have Authentication/Authorization of adding ACLs to NVE to make it more secure. Though this will add little processing during addition of ACLs, But will not have any impact on the runtime traffic while accessing the ACLs for validation. As NVE, will be a single point of hack for potential attacks where one can access multiple VNs of multiple tenants.

ii) Also, if we can accommodate per VN based ACLs which will be quite advantageous for Tenants.

iii) We can also think of Inter - DC overlay network when we may not need any secure gateways for connectivity between NVEs and Intra - DC overlay networks where NVEs can be connected using Secure Gateways of underlying network.

Regards,
Balaji.P

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Friday, June 28, 2013 6:56 AM
To: [email-masked]
Subject: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

This email begins a two week poll to help the chairs judge if there is consensus to adopt draft-kreeger-nvo3-overlay-cp-04 as an NVO3 working group draft.

Please respond to this email on the list with 'support' or 'do not support'.

Please also send any comments on the draft to the NVO3 list.

We are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor, please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.

If you are on the NVO3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

This poll closes on 11 July 2013.

Cheers,
-Benson & Matthew
_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 04 Jul 2013 15:04:10 -0400

Since this is a holiday week for some NVO3 participants, I'm sending 
this reminder about the Call for Adoption of 
draft-kreeger-nvo3-overlay-cp. [1]

Please remember to reply with 'support' or 'do not support' before 
11-July, to help the chairs determine consensus.

Cheers,
-Benson & Matthew

[1] - http://www.ietf.org/mail-archive/web/nvo3/current/msg02487.html

On 2013-06-27 9:25 PM, Benson Schliesser wrote:
> This email begins a two week poll to help the chairs judge if there is 
> consensus to adopt draft-kreeger-nvo3-overlay-cp-04 as an NVO3 working 
> group draft.
>
> We are also polling for knowledge of any IPR that applies to this 
> draft, to ensure that IPR has been disclosed in compliance with IETF 
> IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
> If you are listed as a document author or contributor, please respond 
> to this email whether or not you are aware of any relevant IPR. The 
> draft will not be adopted until a response has been received from each 
> author and contributor.
>
> If you are on the NVO3 WG email list but are not listed as an author 
> or contributor, then please explicitly respond only if you are aware 
> of any IPR that has not yet been disclosed in conformance with IETF 
> rules.
>

---

From: Eric Gray <[email-masked]>
Date: Sat, 6 Jul 2013 12:39:35 +0000

Support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Thursday, July 04, 2013 3:04 PM
To: [email-masked]
Subject: Re: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

Since this is a holiday week for some NVO3 participants, I'm sending this reminder about the Call for Adoption of draft-kreeger-nvo3-overlay-cp. [1]

Please remember to reply with 'support' or 'do not support' before 11-July, to help the chairs determine consensus.

Cheers,
-Benson & Matthew

---

From: Oded Wertheim <[email-masked]>
Date: Sat, 6 Jul 2013 15:07:58 +0000

ש
From: Eric Gray [mailto:[email-masked]]
Sent: Saturday, July 06, 2013 03:39 PM Jerusalem Standard Time
To: Benson Schliesser <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

Support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Thursday, July 04, 2013 3:04 PM
To: [email-masked]
Subject: Re: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

Cheers,
-Benson & Matthew

---

From: Jon Mitchell <[email-masked]>
Date: Sat, 6 Jul 2013 20:33:46 -0700

Support.

-Jon

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Mon, 8 Jul 2013 12:13:12 +0000

Support.

> Since this is a holiday week for some NVO3 participants, I'm 
> sending this reminder about the Call for Adoption of 
> Please remember to reply with 'support' or 'do not support' 
> before 11-July, to help the chairs determine consensus.
> 
> Cheers,
> -Benson & Matthew
>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 8 Jul 2013 14:56:54 +0000

Support, 

Linda

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Mon, 8 Jul 2013 15:00:22 +0000

Support.

-----Original Message-----
From: Benson Schliesser <[email-masked]>
Date: Thursday, June 27, 2013 9:25 PM
To: "[email-masked]" <[email-masked]>
Subject: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

>We are also polling for knowledge of any IPR that applies to this draft,
>to ensure that IPR has been disclosed in compliance with IETF IPR rules
>(see RFCs 3979, 4879, 3669 and 5378 for more details).
>
>If you are listed as a document author or contributor, please respond to
>this email whether or not you are aware of any relevant IPR. The draft
>will not be adopted until a response has been received from each author
>and contributor.
>
>If you are on the NVO3 WG email list but are not listed as an author or
>contributor, then please explicitly respond only if you are aware of any
>IPR that has not yet been disclosed in conformance with IETF rules.
>

---

From: Lucy yong <[email-masked]>
Date: Mon, 8 Jul 2013 15:14:47 +0000

Support!

> Sent: Thursday, July 04, 2013 2:04 PM
> To: [email-masked]

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Mon, 8 Jul 2013 21:32:01 +0000

Support.
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Thursday, June 27, 2013 6:26 PM
To: [email-masked]
Subject: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

Cheers,
-Benson & Matthew

---

From: "Pat Thaler" <[email-masked]>
Date: Wed, 10 Jul 2013 02:49:54 +0000

Support with some comments:

A potential requirement for the overlay cp which is hinted at but should be more explicitly discussed is supporting a pre-connect step for VN connect and VNIC installation. A pre-connect allows the NVE-to-IMA control protocol to operate gathering the information needed for operation before the VNIC and VN connection are installed. This is important for smooth migration where one wants the new location prepared to quickly act when the VM arrives.  (This could be the pre-arrival handshake mentioned in 4.4, but it is important enough that it should be discussed in VN and VNIC association sections.)

Should the control protocol provide a way for the NVE to reject an association request? E.g. if it fetches the profile and can't support the requirements of the VNIC/VN connection?

The document mentions 802.1Q VLAN tags but isn't specific about which tags - there are multiple types of 802.1Q VLAN tags. In 802.1Qbg Edge Virtual Bridging, we specify the S-VLAN (Service VLAN) tag for a similar purpose. Doing so would allow for VN where the tenant uses the C-VLAN space in the VN. This document should also be specific and state that the S-VLAN tag is used. Or if there is a reason to sometimes use the C-VLAN tag and not allow tenants to use that VLAN space, it should allow for either to be used and the control protocols will need to ensure that all the systems communicating use the same tag type. 

Regards,
Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Thursday, July 04, 2013 12:04 PM
To: [email-masked]
Subject: Re: [nvo3] Poll for WG Adoption of draft-kreeger-nvo3-overlay-cp-04

Cheers,
-Benson & Matthew

---

From: Thomas Narten <[email-masked]>
Date: Mon, 15 Jul 2013 17:52:04 +0200

Support as author.  I am not aware of any IPR that applies to this
draft.

Thomas

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 08:30:26 +0000

Support.

-Thomas

> This poll closes on 11 July 2013.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Dinesh Dutt <[email-masked]>
Date: Tue, 16 Jul 2013 22:41:35 -0700

I support the adoption of the document. I'm an author of the document
and I know of no IPR associated with this,

Dinesh

---

From: Zu Qiang <[email-masked]>
Date: Wed, 17 Jul 2013 14:31:17 +0000

Support with clarification comments:
The VN Name-to-VN ID mapping: is there a reason it has to be part of the control protocol? The protocol may need an index for the VN context, either the name or the ID as far as it is unique. It does not have to be two index, right? 
In section 4, there is a statement that " NVEs are expected to be implemented within both hypervisors (or Network Service Appliances) and within access switches. " In the framework draft which the NVE is defined as  "An NVE could be implemented as part of a virtual switch within a hypervisor, a physical switch or router, a Network Service Appliance, or be split  across multiple devices."

Have a nice day
Zu Qiang

>Sent: Thursday, June 27, 2013 9:26 PM
>To: [email-masked]
>This email begins a two week poll to help the chairs judge if there is consensus
>to adopt draft-kreeger-nvo3-overlay-cp-04 as an NVO3 working group draft.
>
>We are also polling for knowledge of any IPR that applies to this draft, to
>ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs
>3979, 4879, 3669 and 5378 for more details).
>
>If you are listed as a document author or contributor, please respond to this
>email whether or not you are aware of any relevant IPR. The draft will not be
>adopted until a response has been received from each author and contributor.
>
>contributor, then please explicitly respond only if you are aware of any IPR
>that has not yet been disclosed in conformance with IETF rules.
>

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 18 Jul 2013 21:11:00 -0400

Just a quick update: The poll for adoption of 
draft-kreeger-nvo3-overlay-cp-04 as a WG item concluded about 1 week 
ago. There appears to be significant WG support for adopting this draft. 
However, the WG has not yet received authors' statements regarding IPR 
from all co-authors of the draft. We are pursuing this matter directly 
with the authors and will make a determination after it is resolved.

Sincerely,
-Benson & Matthew

On 2013-07-04 3:04 PM, Benson Schliesser wrote:
>> This email begins a two week poll to help the chairs judge if there 
>> is consensus to adopt draft-kreeger-nvo3-overlay-cp-04 as an NVO3 
>> working group draft.
>>
>> draft will not be adopted until a response has been received from 
>> each author and contributor.
>>