Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

From: Xuxiaohu <[email-masked]>
Date: Tue, 23 Jul 2013 01:51:06 +0000

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表
> Luyuan Fang (lufang)
> 发送时间: 2013年7月23日 0:19
> 收件人: UTTARO, JAMES; Yakov Rekhter; [email-masked]
> 抄送: L3VPN
> 主题: Re: The possibility of using global MPLS labels as VNIs ... for l3vpn
> 
> As I remember, the global VPN-ID was discussed/debated in L3VPN WG around
> 2003-2006, the global VPN-ID was proposed in the vr draft. The general
> consensus of the WG was that the L3VPN solution would be more flexible and
> scalable without the global VPN-ID, as the way RFC4364/2547 handling it.
> 
> I don't believe this has changed since then. In fact, the extensive large
> scale global deployments of 4364 L3VPNs over the past 15 years provide
> good living testimony of it.

I fully agree that we should make the most of the existing and proven technologies if possible. The reason that I started this discussion is to make sure whether the Virtual Network Context Identification contained in the data packet is REALLY required to be globally unique in some cases.

Best regards,
Xiaohu 

> Luyuan
> 
> -----Original Message-----
> From: <UTTARO>, JAMES <[email-masked]>
> Date: Friday, July 19, 2013 12:49 PM
> To: Yakov Rekhter <[email-masked]>, "[email-masked]"
> <[email-masked]>
> Cc: L3VPN <[email-masked]>
> Subject: RE: The possibility of using global MPLS labels as VNIs ... for
> l3vpn
> 
> >Comments In-Line..
> >
> >Jim Uttaro
> >
> >-----Original Message-----
> >From: [email-masked] [mailto:[email-masked]] On Behalf Of
> >Yakov Rekhter
> >Sent: Friday, July 19, 2013 9:23 AM
> >To: [email-masked]
> >Cc: L3VPN
> >Subject: Re: The possibility of using global MPLS labels as VNIs ... for
> >l3vpn
> >
> >Thomas,
> >
> >> 2013-07-18, Xuxiaohu:
> >> >
> >> > Till now, it seem that the only remaining technical reason for some
> >> > people to prefer VXLAN/NVGRE encapsulation format to
> >> > MAC-in-MPLS-in-IP encapsulation format for network virtualization
> >> > overlay is the former has global VNIs while the latter doesn't have.
> >> > If this reason is true, why can't we consider the possibility of
> >> > using global MPLS labels to achieve the same goal?
> >>
> >> IMHO, examining *why* someone would want a "global VNI" should be the
> >> start of the discussion, rather than possible solutions.
> >>
> >> I could possibly see at least one reason *not* to try to have a
> >> dedicated identifier in the dataplane common for all flows of "a VPN".
> >> It is not related to the encapsulation, but to the fact that RFC4364
> >> has, in fact, no strict notion of "a VPN", but only of how connectivity
> >> is established betweens set of VRFs.
> >
> >Moreover, connectivity between set of VRFs is not "cast in concrete".
> >To the contrary it could change, as extranets are formed/dissolved,
> >and the process of forming/dissolving extranets could be fairly
> >dynamic.
> >[Jim U>] This happens today..
> >
> >Yakov.
> >
> >>
> >> -Thomas
> >>
> >>
> >>______________________________________________________________
> ___________
> >>_____
> >___________________________________________
> >>
> >> Ce message et ses pieces jointes peuvent contenir des informations
> >>confidentie
> >lles ou privilegiees et ne doivent donc
> >> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> >>recu ce
> > message par erreur, veuillez le signaler
> >> a l'expediteur et le detruire ainsi que les pieces jointes. Les
> >>messages elect
> >roniques etant susceptibles d'alteration,
> >> Orange decline toute responsabilite si ce message a ete altere, deforme
> >>ou fal
> >sifie. Merci.
> >>
> >> This message and its attachments may contain confidential or privileged
> >>inform
> >ation that may be protected by law;
> >> they should not be distributed, used or copied without authorisation.
> >If you have received this email in error, please notify the sender and
> >delete th
> >is message and its attachments.
> >> As emails may be altered, Orange is not liable for messages that have
> >>been mod
> >ified, changed or falsified.
> >> Thank you.
> >>
> >>
> >

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 23 Jul 2013 09:39:42 +0300

Kireeti

On Jul 23, 2013, at 4:51, Xuxiaohu <[email-masked]> wrote:

> The reason that I started this discussion is to make sure whether the Virtual Network Context Identification contained in the data packet is REALLY required to be globally unique in some cases.

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 23 Jul 2013 09:46:19 +0300

Hi Xuxiaohu,

Sorry for the previous empty email. 

> The reason that I started this discussion is to make sure whether the Virtual Network Context Identification contained in the data packet is REALLY required to be globally unique in some cases.

No. There's nothing useful that I know that one can do with global IDs in the data plane that one cannot do with local IDs, and local IDs are easier to allocate and manage. So, I'd be going the other way and advocate locally significant VNIDs for VXLAN and NVGRE, not global IDs for VPNs. (And I do)

Kireeti

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 23 Jul 2013 07:05:35 +0000

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Kireeti
> Kompella
> 发送时间: 2013年7月23日 14:46
> 收件人: Xuxiaohu
> 抄送: [email-masked]; L3VPN; Yakov Rekhter; [email-masked];
> UTTARO, JAMES
> > The reason that I started this discussion is to make sure whether the Virtual
> Network Context Identification contained in the data packet is REALLY required
> to be globally unique in some cases.
> 
> No. There's nothing useful that I know that one can do with global IDs in the
> data plane that one cannot do with local IDs, and local IDs are easier to
> allocate and manage. So, I'd be going the other way and advocate locally
> significant VNIDs for VXLAN and NVGRE, not global IDs for VPNs. (And I do)

Hi Kireeti,

I've ever heard that the major technical reason for some operators to prefer VXLAN or NVGRE to MAC-in-MPLS-in-IP as the encapsulation scheme is that the former provides global VNIDs in the data packets. Therefore, I want to know the concrete use cases where the global VNID is required. Now since you advocate locally significant VNIDs for VXLAN and NVGRE, would you please share your reason why not directly use the MAC-in-MPLS-in-IP format where the VNID (i.e., VPN label) is already locally significant?

Best regards,
Xiaohu

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 23 Jul 2013 11:20:51 +0000

+1

Regards,
Jeff

On Jul 23, 2013, at 7:46 AM, "Kireeti Kompella" <[email-masked]> wrote:

> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: Aldrin Isaac <[email-masked]>
Date: Tue, 23 Jul 2013 08:59:57 -0400

+1.

Network operators lose flexibility with Global VNIDs. Virtual topology will
be fine tuned on top of VNIDs by squeezing a square peg (ACLs) into a round
hole (where it's otherwise not needed).  I think local context IDs will
make a come back once we regain our sanity.  :).

On Tuesday, July 23, 2013, Kireeti Kompella wrote:

> On Jul 23, 2013, at 4:51, Xuxiaohu <[email-masked] <javascript:;>>
> wrote:
>
> > The reason that I started this discussion is to make sure whether the
> Virtual Network Context Identification contained in the data packet is
> REALLY required to be globally unique in some cases.
>
> No. There's nothing useful that I know that one can do with global IDs in
> the data plane that one cannot do with local IDs, and local IDs are easier
> to allocate and manage. So, I'd be going the other way and advocate locally
> [email-masked] <javascript:;>

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Tue, 23 Jul 2013 14:31:57 +0000

Xiaohu,

Thanks. I think we are in agreement.
One small subtlety to point out, "existing" is not the reason, "proven"
(to scale), yes. It is "right":-), not because it is there.

>whether the Virtual Network Context Identification contained in the data
>packet is REALLY required to be globally unique in some cases.
Not I know of. 

Thanks,
Luyuan

-----Original Message-----
From: Xuxiaohu <[email-masked]>
Date: Monday, July 22, 2013 9:51 PM
To: Luyuan Fang <[email-masked]>, "UTTARO, JAMES" <[email-masked]>,
Yakov Rekhter <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc: L3VPN <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: re: The possibility of using global MPLS labels as VNIs ... for
l3vpn

>I fully agree that we should make the most of the existing and proven
>technologies if possible. The reason that I started this discussion is to
>make sure whether the Virtual Network Context Identification contained in
>the data packet is REALLY required to be globally unique in some cases.
>
>Best regards,
>Xiaohu 
>
>> Luyuan
>>

---

From: Lucy yong <[email-masked]>
Date: Tue, 23 Jul 2013 15:14:31 +0000

For distributed based architecture, the local context ID has a lot of benefits. For centralized (or SDN) architecture, will the global context ID have advance?  Another way to ask this is: is distributed architecture better than centralized architecture for VPN or virtual network overlay?

Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Aldrin Isaac
Sent: Tuesday, July 23, 2013 8:00 AM
To: Kireeti Kompella
Cc: Luyuan Fang (lufang); L3VPN; Yakov Rekhter; [email-masked]; Xuxiaohu; [email-masked]; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

+1.

Network operators lose flexibility with Global VNIDs. Virtual topology will be fine tuned on top of VNIDs by squeezing a square peg (ACLs) into a round hole (where it's otherwise not needed).  I think local context IDs will make a come back once we regain our sanity.  :).

Kireeti
_______________________________________________
nvo3 mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Tue, 23 Jul 2013 15:21:34 +0000

Lucy,

As I see, using SDN approach or distributed control plane, and using global or local ID are two orthogonal questions.

> is distributed architecture better than centralized architecture for VPN or virtual network overlay?
No necessarily.

Luyuan
From: Lucy yong <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 23, 2013 11:14 AM
To: Aldrin Isaac <[email-masked]<mailto:[email-masked]>>, Kireeti Kompella <[email-masked]<mailto:[email-masked]>>
Cc: Luyuan Fang <[email-masked]<mailto:[email-masked]>>, L3VPN <[email-masked]<mailto:[email-masked]>>, Yakov Rekhter <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Xuxiaohu <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "UTTARO, JAMES" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Lucy

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Aldrin Isaac
Sent: Tuesday, July 23, 2013 8:00 AM
To: Kireeti Kompella
Cc: Luyuan Fang (lufang); L3VPN; Yakov Rekhter; [email-masked]<mailto:[email-masked]>; Xuxiaohu; [email-masked]<mailto:[email-masked]>; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

+1.

Kireeti

---

From: Lucy yong <[email-masked]>
Date: Tue, 23 Jul 2013 15:58:45 +0000

As I see, using SDN approach or distributed control plane, and using global or local ID are two orthogonal questions.
[Lucy] then, the question to be asked is which usage makes sense in the SDN approach,  global ID or local ID? IMHO: they are related.

Lucy

No necessarily.

Luyuan

Lucy

+1.

Kireeti

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Tue, 23 Jul 2013 16:06:05 +0000

You choose the ID type: global or local.
You choose the control paradigm, SDN, dynamic control plane, or hybrid.

The two decisions are independent.

My personal preferences: SDN with local ID.

Luyuan

From: Lucy yong <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 23, 2013 11:58 AM
To: Luyuan Fang <[email-masked]<mailto:[email-masked]>>, Aldrin Isaac <[email-masked]<mailto:[email-masked]>>, Kireeti Kompella <[email-masked]<mailto:[email-masked]>>
Cc: L3VPN <[email-masked]<mailto:[email-masked]>>, Yakov Rekhter <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Xuxiaohu <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "UTTARO, JAMES" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Lucy

No necessarily.

Luyuan

Lucy

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Aldrin Isaac
Sent: Tuesday, July 23, 2013 8:00 AM
To: Kireeti Kompella
Cc: Luyuan Fang (lufang); L3VPN; Yakov Rekhter; [email-masked]<mailto:[email-masked]>; Xuxiaohu; [email-masked]<mailto:[email-masked]>; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

+1.

Kireeti

---

From: Lucy yong <[email-masked]>
Date: Tue, 23 Jul 2013 16:28:19 +0000

In distributed control plane approach, we have strong consensus that local ID is the way to go.

Like to hear more the people opinions about: in SDN approach, will global ID and local ID are equally good (just mater choice) or one is better than other?

Lucy

From: Luyuan Fang (lufang) [mailto:[email-masked]]
Sent: Tuesday, July 23, 2013 11:06 AM
To: Lucy yong; Aldrin Isaac; Kireeti Kompella
Cc: L3VPN; Yakov Rekhter; [email-masked]; Xuxiaohu; [email-masked]; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Luyuan

Lucy

No necessarily.

Luyuan

Lucy

+1.

Kireeti

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 23 Jul 2013 19:45:53 +0300

> Like to hear more the people opinions about: in SDN approach, will global ID and local ID are equally good (just mater choice) or one is better than other?

The SDN (centralized) approach makes allocation of global IDs easier. However, Xiaohu asked a data plane question. Local IDs are much easier for the data plane.

BTW, I am not in favor of centralizing everything. 

Kireeti

---

From: Jakob Heitz <[email-masked]>
Date: Tue, 23 Jul 2013 17:10:13 +0000

Does a pure SDN network need MPLS labels?
A control plane that contains MPLS protocols is distributed
even if there are elements of SDN in it.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Tuesday, July 23, 2013 9:28 AM
To: Luyuan Fang (lufang); Aldrin Isaac; Kireeti Kompella
Cc: L3VPN; Yakov Rekhter; [email-masked]; [email-masked]; UTTARO, JAMES
Subject: RE: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Lucy

From: Luyuan Fang (lufang) [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Tuesday, July 23, 2013 11:06 AM
To: Lucy yong; Aldrin Isaac; Kireeti Kompella
Cc: L3VPN; Yakov Rekhter; [email-masked]<mailto:[email-masked]>; Xuxiaohu; [email-masked]<mailto:[email-masked]>; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Luyuan

Lucy

No necessarily.

Luyuan

Lucy

+1.

Kireeti

---

From: Richard Li <[email-masked]>
Date: Wed, 24 Jul 2013 00:12:19 +0000

We may be able to get some wisdom from VLAN where both local and global ids are used.

The global vlan id is used to build a whole "subnet" across different and multi-hop Ethernet segments. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kireeti Kompella
Sent: Wednesday, July 24, 2013 12:46 AM
To: Lucy yong
Cc: [email-masked]; L3VPN; Yakov Rekhter; [email-masked]; Aldrin Isaac; UTTARO, JAMES
Subject: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn

Kireeti

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 24 Jul 2013 01:50:32 +0000

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Richard
> Li
> 发送时间: 2013年7月24日 8:12
> 收件人: Kireeti Kompella; Lucy yong
> 抄送: L3VPN; Yakov Rekhter; [email-masked]; Aldrin Isaac;
> [email-masked]; UTTARO, JAMES
> 主题: Re: [nvo3] The possibility of using global MPLS labels as VNIs ... for l3vpn
> 

Whether a global VN ID in the data packet is required may depend on whether the transit nodes need to know the global VN ID, IMHO. For VLAN, the transit nodes need to know the global VN ID (i.e., VLAN ID) for packet forwarding. For TRILL, the transit RB nodes need to know the global VN ID (i.e., VLAN ID or FGL) for VLAN or FGL pruning. For NVo3, I haven't seen any use case yet and therefore I want to make sure whether there is any use case that I had missed.

Best regards,
Xiaohu

> Kireeti Kompella
> > Like to hear more the people opinions about: in SDN approach, will global ID
> and local ID are equally good (just mater choice) or one is better than other?
> 
> The SDN (centralized) approach makes allocation of global IDs easier. However,
> Xiaohu asked a data plane question. Local IDs are much easier for the data
> plane.
>