Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

From: Lizhong Jin <[email-masked]>
Date: Tue, 17 Sep 2013 23:26:33 +0800

Hi,
It seems this draft provides a template for analysis without any
conclusion. Or did I missed somthing important?
I would support if the draft could provide further insightful technology
viewpoint. Or is it intentional for the WG to adopt first, and then
generate the technology view?

Thanks
Lizhong

> ---------- Forwarded message ----------
> From: "Bocci, Matthew (Matthew)" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc:
> Date: Fri, 6 Sep 2013 13:57:05 +0000
> Subject: [nvo3] Poll for adoption and IPR check:
> draft-gbclt-nvo3-gap-analysis-00.txt
>  This email begins a two week poll to help the chairs judge if there is
> consensus  to adopt draft-gbclt-nvo3-gap-analysis-00.txt as an NVO3 working
> group draft.
>
> Please respond to this email on the list with 'support' or 'do not
> support'.
>
> Please also send any comments on the draft to the NVO3 list.
>
> Please consider whether this draft takes the right basic approach to a gap
> analysis, and is a good basis for the work going forward (and potential
> future rechartering). It does not have to be perfect at this stage.
>
> Coincidentally, we are also polling for knowledge of any IPR that applies
> to this draft, to ensure that IPR has been disclosed in compliance with
> IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
> If you are listed as a document author or contributor please respond to
> this email whether or not you are aware of any relevant IPR. The draft will
> not be adopted until a response has been received from each author and
> contributor.
>
> If you are on the NVO3 WG email list but are not listed as an author or
> contributor, then please explicitly respond only if you are aware of any
> IPR that has not yet been disclosed in conformance with IETF rules.
>
> This poll closes on Friday 20th September.
>
> Regards
>
> Matthew and Benson
>
>

---

From: Lucy yong <[email-masked]>
Date: Tue, 17 Sep 2013 15:36:52 +0000

This is what I see as well. I like to hear the answer for the question.

Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Tuesday, September 17, 2013 10:27 AM
To: Matthew Bocci
Cc: [email-masked]
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Hi,
It seems this draft provides a template for analysis without any conclusion. Or did I missed somthing important?
I would support if the draft could provide further insightful technology viewpoint. Or is it intentional for the WG to adopt first, and then generate the technology view?

Thanks
Lizhong

---------- Forwarded message ----------
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Fri, 6 Sep 2013 13:57:05 +0000
Subject: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt
This email begins a two week poll to help the chairs judge if there is consensus  to adopt draft-gbclt-nvo3-gap-analysis-00.txt as an NVO3 working group draft.

Please respond to this email on the list with 'support' or 'do not support'.

Please consider whether this draft takes the right basic approach to a gap analysis, and is a good basis for the work going forward (and potential future rechartering). It does not have to be perfect at this stage.

Coincidentally, we are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as a document author or contributor please respond to this email whether or not you are aware of any relevant IPR. The draft will not be adopted until a response has been received from each author and contributor.

If you are on the NVO3 WG email list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Regards

Matthew and Benson

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Tue, 17 Sep 2013 15:53:12 +0000

Lucy, Lizhong,

The point of adopting the draft is to provide a base document that the WG can develop further. One would expect that development to include some conclusions on the technology direction going forward. At this stage, a draft does not have to be complete or have concrete conclusions to be adopted. If the draft is adopted, then  the editors must reflect the consensus of the WG In the draft including conclusions on the technology choices.

Regards

Matthew

On 17/09/2013 16:36, "Lucy yong" <[email-masked]<mailto:[email-masked]>> wrote:

Lucy

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Tuesday, September 17, 2013 10:27 AM
To: Matthew Bocci
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Hi,

Thanks
Lizhong

---------- Forwarded message ----------
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Fri, 6 Sep 2013 13:57:05 +0000
Subject: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Regards

Matthew and Benson

---

From: Lucy yong <[email-masked]>
Date: Tue, 17 Sep 2013 16:43:13 +0000

Matthew,

If the draft was more completed in the template development, it would lift people comfort level on the draft more.

I support this way for documenting gap analysis.

Thanks,
Lucy

From: Bocci, Matthew (Matthew) [mailto:[email-masked]]
Sent: Tuesday, September 17, 2013 10:53 AM
To: Lucy yong; Lizhong Jin
Cc: [email-masked]
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Lucy, Lizhong,

Regards

Matthew

Lucy

Hi,

Thanks
Lizhong

---------- Forwarded message ----------
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Fri, 6 Sep 2013 13:57:05 +0000
Subject: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Regards

Matthew and Benson

---

From: "Pat Thaler" <[email-masked]>
Date: Tue, 17 Sep 2013 23:04:03 +0000

Matthew,

I support this way of documenting gap analysis, but in some cases, the top of the charts aren't filled out with useful candidates.

NVGRE and VXLAN are primarily NVE to NVE protocols. They don't define a VN to NVE control plane and I can think of at least one candidate for the VN to NVE control plane that would work for both NVGRE and VXLAN. Possibly that is true for some of other data plane candidate protocols. For the charts in 5.2, I think at least NVGRE and VXLAN shouldn't be there. A couple of us are working on a draft that will explore the use of IEEE 802.1 VDP as a VN to NVE control plane that could pair with NVGRE and VXLAN (and any other protocol that needs similar information transferred between the hypervisor and the NVE.

I think that the same is true for 5.1 but I don't know what the candidates should be.

Regards,
Pat

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Tuesday, September 17, 2013 9:43 AM
To: Bocci, Matthew (Matthew); Lizhong Jin
Cc: [email-masked]
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Matthew,

Thanks,
Lucy

Lucy, Lizhong,

Regards

Matthew

Lucy

Hi,

Thanks
Lizhong

---------- Forwarded message ----------
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Fri, 6 Sep 2013 13:57:05 +0000
Subject: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Regards

Matthew and Benson

---

From: Thomas Narten <[email-masked]>
Date: Wed, 18 Sep 2013 07:37:16 -0400

> generate the technology view?

The purpose of adopting a document as a WG document is to:

1) Show that WG intends to produce a specific document (and hopefully
that there is an understanding of what the document is intended to
do).

2) Make it clear that for a particular topic or charter deliverable,
the WG has picked one document as a starting point to focus its
efforts on, rather than encouraging competing drafts (which then would
need to be merged or something).

3) Focus attention/WG effort on that one document, rather than
encouraging (or facilitating) the spreading (and dilution) of activity
across multiple (possibly overlapping) efforts intended to result in
more or less the same thing (in the end), i.e., a WG document.

Having everyone focus on one document is generally a quicker path
towards getting a final document then encouraging lots of activity on
different documents that then later have to somehow be merged.

It is not the case that the contents of the document need to be fully
baked prior to WG adoption. Once a WG document, a document will need
additional work, and any content updates are firmly under the control
of the WG. Thus, updating the content, adding things, removing things,
etc. are all clearly expected to still happen once a document is
adopted by the WG. Arguments that major changes won't/don't/can't
happen once the WG adopts a document are just flat out bogus.

In some sense, delaying adoption of a document until its contents have
been updated is sending a signal of "lack of confidence" in the
authors ability/willingness to do the WG's bidding. If that is the
real issue with any document, having a frank coversation with the
chairs would be in order.

Given that the document at issue (gap analysis) was produced via a
design team (put together by the chairs) and the lack of competing
documents that anyone is arguing would be a better starting point for
what is clearly a charter deliverable, I don't quite understand why
there would be hesitation with WG adoption in this case.

Thomas

---

From: Eric Gray <[email-masked]>
Date: Wed, 18 Sep 2013 13:41:36 +0000

Pat,

                Thanks for the comment/input.

                Your view is completely compatible with the way I've interpreted comments we've
seen (from Xiaohu and Linda) about how the candidate technologies for control plane are
not necessarily the same as for the dataplane.  Hence we (as a WG) need to look at exactly
what level of independence is appropriate for this work.

                One substantial improvement your comment adds is to provide additional examples
of where a non-overlap exists.  Thanks very much for this input.

                As your input illustrates, there is not a complete independence.  Some control plane
alternatives are likely to be more appropriate for some data-plane alternatives.  In at least a
few cases, control-plane and data-plane choices may be inseparable.

                As Thomas Narten said in response to a question about adoption criteria, candidate
drafts will often (if not usually/always) require additional work from the WG.

                This is true of this draft more than many, for a number of reasons:

1) this draft is the final product of the current charter - accentuating the fact that it is entirely
     a working group product.
2) this draft depends on a number of other drafts that are not necessarily sufficiently mature
     at this point to allow for this draft to be anything more than a work in progress.
3) this draft is intended to document an analysis of a variety of potential alternative solutions
     against requirements established by the WG, hence -
     A) a big part of the effort I expect to be needed in progressing this draft is in managing the
           contention within the working group (thus progress will necessarily consist of a number
           of baby steps [I anticipate needing to produce more than 10 drafts before we get to WG
           last call - which means we need to get moving on it]), and
     B) the vast majority of the actual analysis needs to come from the WG - as input similar to
          that which you have provided.

                Again, thanks for your input!

--
Eric

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pat Thaler
Sent: Tuesday, September 17, 2013 7:04 PM
To: Lucy yong; Bocci, Matthew (Matthew); Lizhong Jin
Cc: [email-masked]
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Matthew,

Regards,
Pat

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Lucy yong

Matthew,

Thanks,
Lucy

Lucy, Lizhong,

Regards

Matthew

Lucy

Hi,

Thanks
Lizhong

---------- Forwarded message ----------
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Fri, 6 Sep 2013 13:57:05 +0000
Subject: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Regards

Matthew and Benson

---

From: Lizhong Jin <[email-masked]>
Date: Thu, 19 Sep 2013 00:30:26 +0800

Hi Matthew,
Thank you for the explanation. Then I am OK with the adoption since this is
WG adoption, not WG last call.

One comments to the draft, one of the motivation for NVO3 is to solve the
scaling problem as described in the charter. Then the scaling factor for
each solution should be considered.

Regards
Lizhong

On Tue, Sep 17, 2013 at 11:53 PM, Bocci, Matthew (Matthew) <
[email-masked]> wrote:

>  Lucy, Lizhong,
>
>  The point of adopting the draft is to provide a base document that the
> WG can develop further. One would expect that development to include some
> conclusions on the technology direction going forward. At this stage, a
> draft does not have to be complete or have concrete conclusions to be
> adopted. If the draft is adopted, then  the editors must reflect the
> consensus of the WG In the draft including conclusions on the technology
> choices.
>
>  Regards
>
>  Matthew
>
>
>
>   On 17/09/2013 16:36, "Lucy yong" <[email-masked]> wrote:
>
> ****
> ** **
> Lucy****
> ** **
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Lizhong Jin
> *Sent:* Tuesday, September 17, 2013 10:27 AM
> *To:* Matthew Bocci
> *Cc:* [email-masked]
> *Subject:* Re: [nvo3] Poll for adoption and IPR check:
> draft-gbclt-nvo3-gap-analysis-00.txt****
>
> ** **
>
> Hi,****
>
> conclusion. Or did I missed somthing important?****
>
> generate the technology view?****
>
>  ****
>
> Thanks****
>
> Lizhong****
>
>  ****
>
>  ****
>
> draft-gbclt-nvo3-gap-analysis-00.txt****
>
> group draft.****
> ** **
> support'.****
> ** **
> Please also send any comments on the draft to the NVO3 list.****
>
> ** **
>
> future rechartering). It does not have to be perfect at this stage.****
>
> ** **
>
> IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).****
>
> ** **
>
> contributor.****
> ** **
> IPR that has not yet been disclosed in conformance with IETF rules.****
>
> ** **
>
> This poll closes on Friday 20th September.****
>
> ** **
>
> Regards****
>
> ** **
>
> Matthew and Benson****
>
> ** **
>
>

---

From: Eric Gray <[email-masked]>
Date: Wed, 18 Sep 2013 19:55:16 +0000

Lizhong,

                Where scalability is a requirement, each candidate solution will be compared
against the specific requirement(s).  While it is not the intent to directly compare any
solution with any other, comparing multiple solutions against a requirement will make
it fairly easy for a reader to perform the direct comparison.

                Note that a complete analysis would include proposals that would be expected
to improve scalability of those candidate solutions that as options to be considered in
deciding next steps.

                Also note that the comparison should not be "pass/fail" as much as possible, but
should instead indicate expected scalability associated with (potential) implementations
of each approach.

                As a caveat, however, it is important to realize that the scalability of any specific
solution will depend to some extent at least on how it is implemented.  Hence it may be
exceptionally hard to determine precise scalability numbers for some specific solutions.

                Mostly this will require reasonable discussion in the working group.

--
Eric

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Wednesday, September 18, 2013 12:30 PM
To: Bocci, Matthew (Matthew)
Cc: [email-masked]; Lucy yong
Subject: Re: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Hi Matthew,
Thank you for the explanation. Then I am OK with the adoption since this is WG adoption, not WG last call.

One comments to the draft, one of the motivation for NVO3 is to solve the scaling problem as described in the charter. Then the scaling factor for each solution should be considered.

Regards
Lizhong

On Tue, Sep 17, 2013 at 11:53 PM, Bocci, Matthew (Matthew) <[email-masked]<mailto:[email-masked]>> wrote:
Lucy, Lizhong,

Regards

Matthew

Lucy

Hi,

Thanks
Lizhong

---------- Forwarded message ----------
From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Fri, 6 Sep 2013 13:57:05 +0000
Subject: [nvo3] Poll for adoption and IPR check: draft-gbclt-nvo3-gap-analysis-00.txt

Regards

Matthew and Benson