Subject: [nvo3] I-D Action: draft-ietf-nvo3-framework-04.txt

From: [email-masked]
Date: Tue, 12 Nov 2013 09:12:37 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Network Virtualization Overlays Working Group of the IETF.

	Title           : Framework for DC Network Virtualization
	Author(s)       : Marc Lasserre
                          Florin Balus
                          Thomas Morin
                          Nabil Bitar
                          Yakov Rekhter
	Filename        : draft-ietf-nvo3-framework-04.txt
	Pages           : 25
	Date            : 2013-11-12

Abstract:
       This document provides a framework for Network Virtualization over
       L3 (NVO3) and it defines a reference model along with logical
       components required to design a solution.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nvo3-framework

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-nvo3-framework-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-nvo3-framework-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Lucy yong <[email-masked]>
Date: Wed, 13 Nov 2013 17:07:18 +0000

Marc,

Text:
NVO3 Network: An overlay network that provides an Layer2 (L2) or 
       Layer3 (L3) service to Tenant Systems over an L3 underlay network 
       using the architecture and protocols as defined by the NVO3 Working 
       Group.

This is a clear definition.  

However, in section 2.1, the text and draw are a bit fuzzy.

       Figure 2 depicts a DC reference model for network virtualization 
       using L3 (IP/MPLS) overlays where NVEs provide a logical 
       interconnect between Tenant Systems that belong to a specific VN. 

Comment: why use L3 (IP/MPLS) overlays in the general reference model?

             +--------+                                    +--------+ 
             | Tenant +--+                            +----| Tenant | 
             | System |  |                           (')   | System | 
             +--------+  |    .................     (   )  +--------+ 
                         |  +---+           +---+    (_)     
                         +--|NVE|---+   +---|NVE|-----+ 
                            +---+   |   |   +---+ 
                            / .    +-----+      . 
                           /  . +--| NVA |      . 
                          /   . |  +-----+      . 
                         |    . |               .  
                         |    . |  L3 Overlay +--+--++--------+ 
             +--------+  |    . |   Network   | NVE || Tenant | 
             | Tenant +--+    . |             |     || System | 
             | System |       .  \ +---+      +--+--++--------+ 
             +--------+       .....|NVE|.........    
                                   +---+ 
                                     |       
                                     | 
                           ===================== 
                             |               | 
                         +--------+      +--------+ 
                         | Tenant |      | Tenant | 
                         | System |      | System | 
                         +--------+      +--------+ 
     
          Figure 2 : Generic reference model for DC network virtualization 
                         over a Layer3 (IP) infrastructure 

IMO: Figure title and the above text are not consistent. 

Suggested text:

       Figure 2 depicts a DC reference model for network virtualization 
       overlay where NVEs provide a logical interconnect between Tenant 
       Systems that belong to a specific VN.

replace "L3 Overlay Network" in the figure with "Overlay Network", and explain that the overlay network boundary is at NVEs. (i.e. shown as the dotted box). The line between NVE-NVA represents the interface between each NVE and an NVA. BTW, there is a missing line between one NVE and NVA in the draw.

Thanks,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, November 12, 2013 11:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: [nvo3] I-D Action: draft-ietf-nvo3-framework-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Wed, 13 Nov 2013 17:33:09 +0000

Thanks Lucy for your suggestions.

I'll make these changes as part of the IESG review process.

Marc 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Lucy yong
> Sent: Wednesday, November 13, 2013 6:07 PM
> To: LASSERRE, MARC (MARC)
> Cc: [email-masked]
> Subject: [nvo3] comments RE: I-D Action: 
> draft-ietf-nvo3-framework-04.txt
> 
> Marc,
> 
> Text:
> replace "L3 Overlay Network" in the figure with "Overlay 
> Network", and explain that the overlay network boundary is at 
> NVEs. (i.e. shown as the dotted box). The line between 
> NVE-NVA represents the interface between each NVE and an NVA. 
> BTW, there is a missing line between one NVE and NVA in the draw.
> 
> 
> Thanks,
> Lucy
> 
>   
> 
> Please note that it may take a couple of minutes from the 
> time of submission until the htmlized version and diff are 
> available at tools.ietf.org.
>