Subject: [nvo3] http://www.ietf.org/proceedings/92/slides/slides-92-nvo3-3.pdf (draft-ietf-nvo3-hpvr2nve-cp-req-o2)

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Wed, 25 Mar 2015 18:39:02 +0000

Hi,

For IEEE extension for VDP  we believe there's need of other extension than what's mentioned in summary of the presentation

Other useful Extension request

  1.  For IP address extension along with ability to specify multiple IP addresses for the same MAC (secondary address). Same thing for IPv6 address.
  2.  In scenario if we have blade switch in middle LLDP fails due to single hop and this scenario should be supported from standardization.
  3.  Security is already addressed but instead of just .1x or IP sec can we just have authorization for the server also.
  4.  In case of Vanilla Vlan VDP where trigger has Vlan than adding Mobility Domain name will be useful to localize the vlan on the port or allow local switching between different vlans.

Summary From Slides

  1.  Specific unicast destination MAC other than nearest bridge group
  2.  Authentication: TLV for integrity checkl
     *   Direction connection: using existing mechanism liks .1x
     *   Indirect connection: IP sec?
  3.  IP address binding: Add new filter info format type
  4.  Clearer migration indicator: put bits into new filter info format
  5.  State machine to be clarified assoc->pre-assoc behavior properly

Thanks,
Deepak

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Wed, 25 Mar 2015 22:41:04 +0000

Hi Deepak,

For request 1, I think this is covered by Req-10 in draft-ietf-nvo3-hpvr2nve-cp-req-02, which says "The protocol MUST allow an End Device initiating a request to add, remove or update address(es) associated with a TSI instance on the external NVE. Addresses can be expressed in different formats, for example, MAC, IP or pair of IP and MAC. " The key here being the word "address(es)". The table in section 5 indicates that partial extensions are needed in VDP for this.

For request 2, I'm not clear what LLDP has to do with VDP, can you connect the dots for me?

For request 3, this should be covered by Req-11 "The protocol MUST allow the External NVE to authenticate the End Device connected." and the table in section 5 indicates that it is not currently supported by VDP (so it would require extension). I am also not sure what the IP sec mentions on slide are referring to since VDP does not use IP.

For request 4, I need some more clarification.  First, what do you mean by "Vanilla Vlan VDP"?  Second, what do yo mean by "trigger has Vlan".  Third, I don't know what you mean by "Mobility Domain name".  When you say "useful to localize the vlan on the port", which port are you referring to?  The assumption is that the VLANs being used between the End Device (e.g hypervisor) and the NVE are always local only to the connectivity (either a direct link, or bridge(s) connecting them).  When you say "allow local switching between different vlans" are you referring to the NVE acting as a local switch between two directly connected End Devices?  If so, I have always assumed that was the case (maybe we can me it clearer), but I don't know what that has to do with a Mobility Domain.

Thanks, Larry

From: "Deepak Kumar (dekumar)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 25, 2015 1:39 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] http://www.ietf.org/proceedings/92/slides/slides-92-nvo3-3.pdf (draft-ietf-nvo3-hpvr2nve-cp-req-o2)

Hi,

Summary From Slides

Thanks,
Deepak