Subject: [nvo3] requirements for any overlay encapsualtions chosen

From: "Elzur, Uri" <[email-masked]>
Date: Fri, 13 Mar 2015 16:01:32 +0000

in the first few presentations of the virtual FtF  we heard of some guidelines and some implementation ideas

I was wondering what are the group's guidelines as to what minimal content needed to be carried in the header. Clearly there is a range between ultimate flexibility and full rigidity. HW vs. SW implementations (i.e. efficiency, ability to run at wire speed, middle box support, longevity of equipment in the field etc etc. ) are somewhere along that continuum as well as interoperability. Before we dive into the specifics of adopting one option or multiple options or an option per use case it may be good to set some guidelines

Thx

Uri ("Oo-Ree")
C: 949-378-7568

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Benson Schliesser
Sent: Thursday, March 12, 2015 5:06 PM
To: [email-masked]
Subject: Re: [nvo3] reminder about Virtual Interim Meeting tomorrow 2015-03-13

FYI, the agenda was just updated to include links to the latest revisions of the Encap DT and GUE drafts.
-Benson

> Benson Schliesser <mailto:[email-masked]> March 12, 2015 at 
> 7:44 PM Dear NVO3 Contributors -
>
> Just a reminder: tomorrow, 2015-03-13, at 11:00EDT we will hold a 
> virtual interim meeting of the NVO3 WG via WebEx.
>
> Links to all of the details can be found at 
> http://wiki.tools.ietf.org/wg/nvo3/trac/wiki/WikiStart.
>
> Cheers,
> -Benson, Matthew, & Sam
>

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Tom Herbert <[email-masked]>
Date: Fri, 13 Mar 2015 10:30:33 -0700

> I was wondering what are the group's guidelines as to what minimal content needed to be carried in the header. Clearly there is a range between ultimate flexibility and full rigidity. HW vs. SW imp…

In our deployment, the bare minimum requirements for things needed in
an NVO3 encapsulation header were:

1) A virtual network identifier
2) A mechanism to secure the virtual network identifier and outer
addresses against spoofing or corruption
3) A next protocol field that can at least indicate IPv4, IPv6, and Ethernet

There are many other requirements around performance, more features,
stronger security, and extensibility-- but these three were
fundamental to deploying a public multi-tenant solution at scale.

Tom

---

From: Lucy yong <[email-masked]>
Date: Fri, 13 Mar 2015 17:43:17 +0000

Supporting OAM packets is a key for NVO too.

Lucy

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Friday, March 13, 2015 12:31 PM
To: Elzur, Uri
Cc: Benson Schliesser; [email-masked]
Subject: Re: [nvo3] requirements for any overlay encapsualtions chosen

On Fri, Mar 13, 2015 at 9:01 AM, Elzur, Uri <[email-masked]> wrote:
> I was wondering what are the group's guidelines as to what minimal 
> content needed to be carried in the header. Clearly there is a range 
> between ultimate flexibility and full rigidity. HW vs. SW 
> implementations (i.e. efficiency, ability to run at wire speed, middle 
> box support, longevity of equipment in the field etc etc. ) are 
> somewhere along that continuum as well as interoperability. Before we 
> dive into the specifics of adopting one option or multiple options or 
> an option per use case it may be good to set some guidelines
>

In our deployment, the bare minimum requirements for things needed in an NVO3 encapsulation header were:

1) A virtual network identifier
2) A mechanism to secure the virtual network identifier and outer addresses against spoofing or corruption
3) A next protocol field that can at least indicate IPv4, IPv6, and Ethernet

There are many other requirements around performance, more features, stronger security, and extensibility-- but these three were fundamental to deploying a public multi-tenant solution at scale.

Tom

---

From: Haoweiguo <[email-masked]>
Date: Wed, 18 Mar 2015 10:25:15 +0000

Agree the following three requirements are base and fundamental data plane requirements. OAM is an important extension, both passive and active OAM are required. 
Passive OAM has more accuracy in traffic loss,latency and jitter measurements, it needs some specific Flag in NVO3 header for identification.

weiguo

________________________________________
From: Lucy yong [[email-masked]]
Sent: Saturday, March 14, 2015 1:43
To: Tom Herbert; Elzur, Uri
Cc: Benson Schliesser; [email-masked]
Subject: Re: [nvo3] requirements for any overlay encapsualtions chosen

Lucy

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Friday, March 13, 2015 12:31 PM
To: Elzur, Uri
Cc: Benson Schliesser; [email-masked]
Subject: Re: [nvo3] requirements for any overlay encapsualtions chosen

Tom