Subject: [nvo3] FW: New Version Notification for draft-dunbar-nvo3-nva-mapping-distribution-01.txt

From: Linda Dunbar <[email-masked]>
Date: Tue, 3 Mar 2015 22:34:22 +0000

We revised the  draft-dunbar-nvo3-nva-mapping-distribution-00 based on the input from the mailing list discussion and the interim meeting. 

A new subTLV (Enabled-VN TLV) under the IS-IS Router Capability TLV [RFC4971] is specified here for NVE to indicate all its interested VNs in the IS-IS LSP message.

3 different types of subTLV are specified:

   +-+-+-+-+-+-+-+-+
   |INT-VN-TYPE-1  |                  (1 byte)
   +-+-+-+-+-+-+-+-+
   |   Length      |                  (1 byte)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | RESV  |  Start VN ID          |  (4 bytes)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | VNID bit-map....
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+  
Figure 2. Enabled-VN TLV using bit map

   +-+-+-+-+-+-+-+-+
   | INT-VN-TYPE-2 |                  (1 byte)
   +-+-+-+-+-+-+-+-+
   |   Length      |                  (1 byte)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | RESV  |  Start VN ID          |  (4 bytes)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | RESV  |  End VN ID            |  (4 byptes)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+  
Figure 3. Enabled-VN TLV using Range

   +-+-+-+-+-+-+-+-+
   | INT-VN-TYPE-3 |                  (1 byte)
   +-+-+-+-+-+-+-+-+
   |   Length      |                  (1 byte)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | RESV  |        VN ID          |  (4 bytes)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | RESV  |        VN ID          |  (4 bytes)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | RESV  |        VN ID          |  (4 bytes)
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |     .   .   .
   +-+-+-+-+-+-+-+-+-+-+-+-+
Figure 4. Enabled-VN TLV using list

Your comments and suggestions are greatly appreciated. 

Linda Dunbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, March 03, 2015 3:35 PM
To: Linda Dunbar; Linda Dunbar; Donald E. Eastlake 3rd; Donald Eastlake
Subject: New Version Notification for draft-dunbar-nvo3-nva-mapping-distribution-01.txt

A new version of I-D, draft-dunbar-nvo3-nva-mapping-distribution-01.txt
has been successfully submitted by Linda Dunbar and posted to the IETF repository.

Name:		draft-dunbar-nvo3-nva-mapping-distribution
Revision:	01
Title:		NVA Address Mapping Distribution (NAMD) Protocol
Document date:	2015-03-03
Group:		Individual Submission
Pages:		24
URL:            http://www.ietf.org/internet-drafts/draft-dunbar-nvo3-nva-mapping-distribution-01.txt
Status:         https://datatracker.ietf.org/doc/draft-dunbar-nvo3-nva-mapping-distribution/
Htmlized:       http://tools.ietf.org/html/draft-dunbar-nvo3-nva-mapping-distribution-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-dunbar-nvo3-nva-mapping-distribution-01

Abstract:
   This draft describes the protocol for NVA to promptly and
   incrementally distribute the inner (TS) to outer (NVE) mapping
   and VN Context to relevant NVEs in a timely manner.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 11 Mar 2015 05:47:06 +0000

Hi Linda,

Thanks for bringing this out.

Does the WG group need to apply more and more TLVs under IS-IS? I suggest we first request IANA to allocate the IS-IS Application Identifier (tbd1) under the Generic Information TLV (#251) [RFC6823] for NVO3. Then we can further request more NVO3 APPsub-TLVs under this identifier (tbd1).

Thanks,
Mingui

>From: nvo3 [mailto:[email-masked]] On Behalf Of Linda Dunbar
>Sent: Wednesday, March 04, 2015 6:34 AM
>To: [email-masked]
>Subject: [nvo3] FW: New Version Notification for
>draft-dunbar-nvo3-nva-mapping-distribution-01.txt
>
>We revised the  draft-dunbar-nvo3-nva-mapping-distribution-00 based on the
>input from the mailing list discussion and the interim meeting.
>
>A new subTLV (Enabled-VN TLV) under the IS-IS Router Capability TLV [RFC4971]
>is specified here for NVE to indicate all its interested VNs in the IS-IS LSP
>message.
>
>
>Subject: New Version Notification for
>draft-dunbar-nvo3-nva-mapping-distribution-01.txt
>
>
>URL:
>http://www.ietf.org/internet-drafts/draft-dunbar-nvo3-nva-mapping-distributio
>n-01.txt
>Status:
>https://datatracker.ietf.org/doc/draft-dunbar-nvo3-nva-mapping-distribution/
>Htmlized:
>http://tools.ietf.org/html/draft-dunbar-nvo3-nva-mapping-distribution-01
>Diff:
>http://www.ietf.org/rfcdiff?url2=draft-dunbar-nvo3-nva-mapping-distribution-01
>
>Abstract:
>Please note that it may take a couple of minutes from the time of submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>The IETF Secretariat
>
>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3