Subject: Re: [nvo3] Source UDP port : draft-ietf-nvo3-vxlan-gpe-00

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Mon, 21 Sep 2015 23:47:54 +0000

Hi Sandeep,

The recommendation to limit the source UDP ports in VXLAN (RFC 6335) was made to try to avoid problems with firewalls that might be present between two VTEPs, or other side-effects of using a well known (assigned) UDP port.  The downside of this recommendation is a reduction in the amount of flow entropy that can be carried in the source UDP port.  It was felt that this recommendation may cause more harm than good because in practice (certainly in a controlled DC environment) it is not necessary.

 - Larry

From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of "Sandeep Kumar (Sandeep) Relan" <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 21, 2015 at 4:27 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] Source UDP port : draft-ietf-nvo3-vxlan-gpe-00

Hello,

Issue :  Missing details on Source UDP port number range, in accordance with RFC 6335.

Reference:  draft-ietf-nvo3-vxlan-gpe-00 ( VXLAN - GPE)

RFC 7348 (VXLAN) states the following:

Section 5:

>>... When calculating the UDP source port number in this manner,

 It is RECOMMENDED that the value be in the dynamic/private port

 range 49152-65535 [RFC6335<https://tools.ietf.org/html/rfc6335>].

draft-ietf-nvo3-vxlan-gpe-00 does not state anything on this particular aspect in section 4.
Source UDP Port:

>> "no details have been provided about the port range compliance with [RFC6335<https://tools.ietf.org/html/rfc6335>]"

Appreciate if this information can be explicitly mentioned in the next revision of this draft.

Thanks & regards
Sandeep Relan

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Mon, 21 Sep 2015 23:50:44 +0000

From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of Larry Kreeger <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 21, 2015 at 4:47 PM
To: "Sandeep Kumar (Sandeep) Relan" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Source UDP port : draft-ietf-nvo3-vxlan-gpe-00

Hi Sandeep,

The recommendation to limit the source UDP ports in VXLAN (RFC 6335)

>> sorry, this should have said RFC 7348!

was made to try to avoid problems with firewalls that might be present between two VTEPs, or other side-effects of using a well known (assigned) UDP port.  The downside of this recommendation is a reduction in the amount of flow entropy that can be carried in the source UDP port.  It was felt that this recommendation may cause more harm than good because in practice (certainly in a controlled DC environment) it is not necessary.

 - Larry

Hello,

Thanks & regards
Sandeep Relan