Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts

From: Lizhong Jin <[email-masked]>
Date: Fri, 15 Jul 2016 10:15:34 +0800

It has been more than 4 years since the start of NVO3, and since we have
adopted 3 dataplane drafts, option #1 seems the only way we could go now.

Lizhong

> ---------- Forwarded message ----------
> From: Jesse Gross <[email-masked]>
> To: Lucy yong <[email-masked]>, Anoop Ghanwani <
> [email-masked]>, Tom Herbert <[email-masked]>
> Cc: "Bocci, Matthew (Nokia - GB)" <[email-masked]>, NVO3 <
> [email-masked]>
> Date: Thu, 14 Jul 2016 20:26:32 +0000
> Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts
>
> I agree as well. We’ve had this question outstanding for the past couple
> years and haven’t had much luck on picking/merging. Given the timing, I
> think it’s effectively impossible to do so now. It seems like #1 is the
> pragmatic choice.
>
>
>
> On 7/14/16, 1:00 PM, "nvo3 on behalf of Lucy yong" <[email-masked]
> on behalf of [email-masked]> wrote:
>
>
>
> *Agree with Anoop’s analogy.*
>
>
>
> *Lucy*
>
>
>
> *From:* nvo3 [mailto:[email-masked]] *On Behalf Of *Anoop Ghanwani
> *Sent:* Thursday, July 14, 2016 12:46 PM
> *To:* Tom Herbert
> *Cc:* Bocci, Matthew (Nokia - GB); NVO3
> *Subject:* Re: [nvo3] Mail regarding NVO3 data plane drafts
>
>
>
> #2 is going to be nearly impossible (or it would have happened earlier,
> and if it were possible, why would we even bother publishing the other
> two?), so that makes it an easy choice.
>
>
>
> Anoop
>
>
>
> On Thu, Jul 14, 2016 at 10:01 AM, Tom Herbert <[email-masked]> wrote:
>
> On Thu, Jul 14, 2016 at 9:21 AM, Bocci, Matthew (Nokia - GB)
> <[email-masked]> wrote:
> > WG,
> >
> > The NVO3 working group has adopted three data plane encapsulations:
> > -          VXLAN-GPE,
> > -          Geneve,
> > -          GUE (although the draft is moving to the Intarea WG, we
> anticipate that NVO3 will still reference this).
> >
> > We have discussed this situation with Alia and we feel that there is
> little benefit to the community in publishing all three as standards track
> RFCs.
> >
> > We would note that the discussion on the drafts has been relatively
> light since their adoption. There has not been serious discussion about
> their relative pros/cons (if any), or about the actual usefulness of their
> extensibility or differentiators.
> >
> > This leaves two options:
> >
> > 1) Publish all of them as informational or experimental, potentially
> moving one of them to standards track in the future based on
> implementation/deployment.
> > 2) Pick one now based on technical and/or implementation/deployment
> criteria.
> >
>
> I would like to propose a third option. Create a design team in nvo3
> to come up with the goal of proposing one data plane protocol that
> consolidates the best features of the three. Outside of extensibility
> there is fundamentally little difference amongst these, and the
> different models of extensibility (flag-fields, TLVs, NSH) could be
> fit into one protocol.  Also, the encapsulation design considerations
> (draft-ietf-rtgwg-dt-encap-01) provides a good reference for creating
> such an encapsulation protocol.
>
> Thanks,
> Tom
>
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>
>
>
>
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 14 Jul 2016 19:30:53 -0700

And industry deployed VXLAN cannot interoperate at the control-plane.

Dino

> On Jul 14, 2016, at 7:15 PM, Lizhong Jin <[email-masked]> wrote:
> 
> It has been more than 4 years since the start of NVO3, and since we have adopted 3 dataplane drafts, option #1 seems the only way we could go now.
> 
> Lizhong
> 
>  
> To: Lucy yong <[email-masked]>, Anoop Ghanwani <[email-masked]>, Tom Herbert <[email-masked]>
> Cc: "Bocci, Matthew (Nokia - GB)" <[email-masked]>, NVO3 <[email-masked]>
> I agree as well. We’ve had this question outstanding for the past couple years and haven’t had much luck on picking/merging. Given the timing, I think it’s effectively impossible to do so now. It seems like #1 is the pragmatic choice.
> 
>  
> 
> On 7/14/16, 1:00 PM, "nvo3 on behalf of Lucy yong" <[email-masked] on behalf of [email-masked]> wrote:
> 
>  
> 
> Agree with Anoop’s analogy.
> 
>  
> 
> Lucy
> 
>  
> 
> From: nvo3 [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
> Sent: Thursday, July 14, 2016 12:46 PM
> To: Tom Herbert
> Cc: Bocci, Matthew (Nokia - GB); NVO3
> #2 is going to be nearly impossible (or it would have happened earlier, and if it were possible, why would we even bother publishing the other two?), so that makes it an easy choice.
> 
>  
> 
> Anoop
> 
>  
> 
> > -          GUE (although the draft is moving to the Intarea WG, we anticipate that NVO3 will still reference this).
> >
> > We have discussed this situation with Alia and we feel that there is little benefit to the community in publishing all three as standards track RFCs.
> >
> > We would note that the discussion on the drafts has been relatively light since their adoption. There has not been serious discussion about their relative pros/cons (if any), or about the actual usefulness of their extensibility or differentiators.
> >
> > This leaves two options:
> >
> > 1) Publish all of them as informational or experimental, potentially moving one of them to standards track in the future based on implementation/deployment.
> > 2) Pick one now based on technical and/or implementation/deployment criteria.
> >
>

---

From: Jon Hudson <[email-masked]>
Date: Thu, 14 Jul 2016 19:48:48 -0700

From Us to You Mr User 
Love the IETF

> On Jul 14, 2016, at 7:30 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Azhar Sayeed <[email-masked]>
Date: Thu, 14 Jul 2016 23:20:46 -0400

+1 for VXLAN - enough work in performance enhancements being done 

Azhar

> On Jul 14, 2016, at 10:30 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 15 Jul 2016 03:33:48 +0000

Unfortunately, the lack of a protocol type field within the VXLAN header limits its extensibility greatly.

Best regards,
Xiaohu

> -----Original Message-----
> From: nvo3 [mailto:[email-masked]] On Behalf Of Azhar Sayeed
> Sent: Friday, July 15, 2016 11:21 AM
> To: Dino Farinacci
> Cc: Anoop Ghanwani; Tom Herbert; [email-masked]; Lucy yong; Lizhong Jin; Bocci,
> Matthew (Nokia - GB); Jesse Gross
> >> To: Lucy yong <[email-masked]>, Anoop Ghanwani
> >> <[email-masked]>, Tom Herbert <[email-masked]>
> >> Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts I agree as
> >> well. We’ve had this question outstanding for the past couple years and
> haven’t had much luck on picking/merging. Given the timing, I think it’s
> effectively impossible to do so now. It seems like #1 is the pragmatic choice.
> >>
> >>
> >>
> >> On 7/14/16, 1:00 PM, "nvo3 on behalf of Lucy yong"
> <[email-masked] on behalf of [email-masked]> wrote:
> >>
> >>
> >>
> >> #2 is going to be nearly impossible (or it would have happened earlier, and if
> it were possible, why would we even bother publishing the other two?), so that
> makes it an easy choice.
> >>
> >>
> >>
> >> Anoop
> >>
> >>
> >>
> >>> We have discussed this situation with Alia and we feel that there is little
> benefit to the community in publishing all three as standards track RFCs.
> >>>
> >>> We would note that the discussion on the drafts has been relatively light
> since their adoption. There has not been serious discussion about their relative
> pros/cons (if any), or about the actual usefulness of their extensibility or
> differentiators.
> >>>
> >>> This leaves two options:
> >>>
> >>> 1) Publish all of them as informational or experimental, potentially moving
> one of them to standards track in the future based on