Subject: [nvo3] Mail regarding NVO3 data plane drafts

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Thu, 14 Jul 2016 16:21:06 +0000

WG,
 
The NVO3 working group has adopted three data plane encapsulations:
-          VXLAN-GPE,
-          Geneve,
-          GUE (although the draft is moving to the Intarea WG, we anticipate that NVO3 will still reference this).

We have discussed this situation with Alia and we feel that there is little benefit to the community in publishing all three as standards track RFCs. 

We would note that the discussion on the drafts has been relatively light since their adoption. There has not been serious discussion about their relative pros/cons (if any), or about the actual usefulness of their extensibility or differentiators.

This leaves two options:

1) Publish all of them as informational or experimental, potentially moving one of them to standards track in the future based on implementation/deployment.
2) Pick one now based on technical and/or implementation/deployment criteria.

We would therefore like to gain a sense of what the WG would like to do with these drafts.

Please post your comments to the list. We also have a slot to on the NVO3 agenda in Berlin where we would like to continue this discussion.

Best regards,

Matthew and Sam

---

From: Tom Herbert <[email-masked]>
Date: Thu, 14 Jul 2016 10:01:27 -0700

> 2) Pick one now based on technical and/or implementation/deployment criteria.

I would like to propose a third option. Create a design team in nvo3
to come up with the goal of proposing one data plane protocol that
consolidates the best features of the three. Outside of extensibility
there is fundamentally little difference amongst these, and the
different models of extensibility (flag-fields, TLVs, NSH) could be
fit into one protocol.  Also, the encapsulation design considerations
(draft-ietf-rtgwg-dt-encap-01) provides a good reference for creating
such an encapsulation protocol.

Thanks,
Tom

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 14 Jul 2016 10:45:47 -0700

#2 is going to be nearly impossible (or it would have happened earlier, and
if it were possible, why would we even bother publishing the other two?),
so that makes it an easy choice.

Anoop

On Thu, Jul 14, 2016 at 10:01 AM, Tom Herbert <[email-masked]> wrote:

> > -          GUE (although the draft is moving to the Intarea WG, we
> anticipate that NVO3 will still reference this).
> >
> > We have discussed this situation with Alia and we feel that there is
> little benefit to the community in publishing all three as standards track
> RFCs.
> >
> > We would note that the discussion on the drafts has been relatively
> light since their adoption. There has not been serious discussion about
> their relative pros/cons (if any), or about the actual usefulness of their
> extensibility or differentiators.
> >
> > This leaves two options:
> >
> > 1) Publish all of them as informational or experimental, potentially
> moving one of them to standards track in the future based on
> implementation/deployment.
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>

---

From: Lucy yong <[email-masked]>
Date: Thu, 14 Jul 2016 20:00:12 +0000

Agree with Anoop’s analogy.

Lucy

From: nvo3 [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Thursday, July 14, 2016 12:46 PM
To: Tom Herbert
Cc: Bocci, Matthew (Nokia - GB); NVO3
Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts

#2 is going to be nearly impossible (or it would have happened earlier, and if it were possible, why would we even bother publishing the other two?), so that makes it an easy choice.

Anoop

On Thu, Jul 14, 2016 at 10:01 AM, Tom Herbert <[email-masked]<mailto:[email-masked]>> wrote:
On Thu, Jul 14, 2016 at 9:21 AM, Bocci, Matthew (Nokia - GB)

Thanks,
Tom

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Jesse Gross <[email-masked]>
Date: Thu, 14 Jul 2016 20:26:32 +0000

I agree as well. We’ve had this question outstanding for the past couple years and haven’t had much luck on picking/merging. Given the timing, I think it’s effectively impossible to do so now. It seems like #1 is the pragmatic choice.

On 7/14/16, 1:00 PM, "nvo3 on behalf of Lucy yong" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Lucy

Anoop

Thanks,
Tom

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 14 Jul 2016 14:52:25 -0700

My vote is to publish VXLAN ala port 4789. Note its not on the list but the most deployed in real product. That would be practical. 

Dino

P.S. And this is probably the 4th time I have stated this. And as time goes on, VXLAN is even more deployed.

> On Jul 14, 2016, at 1:26 PM, Jesse Gross <[email-masked]> wrote:
> 
> On 7/14/16, 1:00 PM, "nvo3 on behalf of Lucy yong" <[email-masked] on behalf of [email-masked]> wrote:
>

---

From: Dinesh Dutt <[email-masked]>
Date: Thu, 14 Jul 2016 18:15:18 -0700

What Dino said,

Dinesh

---

From: Fabio Maino <[email-masked]>
Date: Fri, 15 Jul 2016 06:45:33 +0200

I support option #1.

Fabio

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Wed, 20 Jul 2016 19:05:35 +0000

I support option 1, thanks.

-Darrel
> On Jul 14, 2016, at 9:21 AM, Bocci, Matthew (Nokia - GB) <[email-masked]> wrote:
> 
> WG,
>

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Wed, 20 Jul 2016 19:59:01 +0000

Dear Chairs,

Option 1 seems the most pragmatic and to yield the desired success.

Thanks
Paul

> On Jul 14, 2016, at 12:21 PM, Bocci, Matthew (Nokia - GB) <[email-masked]> wrote:
> 
> WG,
>

---

From: "Garcia Del Rio, Diego (Nokia - US)" <[email-masked]>
Date: Thu, 21 Jul 2016 14:20:33 +0000

Given the context, I think indeed option 1 seems to be the only viable alternative. It seemed close to impossible to get consensus for a single implementation during the long time the drafts were being discussed, so trying to vote for one now will probably not lead anywhere, IMO.

DIEGO GARCÍA DEL RIO
Nuagenetworks from NOKIA
PRODUCT MANAGER
755 Ravendale Drive
Mountain View CA 94043
Mobile: +1 (415) 439-9420
OnNet: 2852-2726
[email-masked]

-----Original Message-----
From: nvo3 [mailto:[email-masked]] On Behalf Of Paul Quinn (paulq)
Sent: Wednesday, 20 July 2016 12:59
To: Bocci, Matthew (Nokia - GB) <[email-masked]>
Cc: NVO3 <[email-masked]>
Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts

Dear Chairs,

Thanks
Paul

---

From: Alia Atlas <[email-masked]>
Date: Thu, 21 Jul 2016 11:06:12 -0400

Hi Diego,

Please do read RFC 7282.  We don't vote in the IETF for a reason.
While the work has been stalled, what matters is technical objections - not
a beauty
contest.

Regards,
Alia

On Thu, Jul 21, 2016 at 10:20 AM, Garcia Del Rio, Diego (Nokia - US) <
[email-masked]> wrote:

> Given the context, I think indeed option 1 seems to be the only viable
> alternative. It seemed close to impossible to get consensus for a single
> implementation during the long time the drafts were being discussed, so
> trying to vote for one now will probably not lead anywhere, IMO.
>
>
>
>
> DIEGO GARCÍA DEL RIO
> Nuagenetworks from NOKIA
> PRODUCT MANAGER
> 755 Ravendale Drive
> Mountain View CA 94043
> > Please post your comments to the list. We also have a slot to on the
> NVO3 agenda in Berlin where we would like to continue this discussion.
> >
> > Best regards,
> >
> >
> > Matthew and Sam
> >
> >