Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Mon, 4 Jul 2016 08:38:35 +0000

Hi Xiaohu,

Even though the reference is to campus deployment, there could be a generic requirement of routing (l3-gateway),
which may eventually require IP/MAC bindings to be published. Is there any plan to include that in the draft.

>>>>(only a single protocol to be deployed that's IS-IS)
Does it refers to single protocol in overlay and underlay ? I think its highly subjective to the exact requirements.

Thanks
Saumya.

On 7/4/16, 12:36 PM, "nvo3 on behalf of Xuxiaohu" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Due to the success of the NVo3 data encapsulations technology in data center networks, more and more enterprises are considering the adoption of this technology in their campus networks so as to replace the old spanning tree protocols.  Although BGP or Software Defined Network (SDN) controller could still be used as the control plane protocol in campus networks, both of them seem a bit heavyweight, especially for small and even medium sized campus networks.

This draft proposes to use IS-IS as a lightweight control plane protocol for NVo3 overlay networks. In this way, the network provisioning is dramatically simplified (only a single protocol to be deployed that's IS-IS), which is much significant to campus network operators. BTW, it leverages the MAC-Reachability (MAC-RI) TLV as defined in RFC6165 to realize on-demand control-plane based MAC learning on a per-VN basis, most importantly, without any dependence on the multicast capability of the underlay networks.

Any comments are welcome.

Best regards,
Xiaohu

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Friday, July 01, 2016 3:17 PM
To: Himanshu Shah; Himanshu C. Shah; Xuxiaohu; Fan Yongbing; Yongbing Fan
Subject: New Version Notification for draft-xu-nvo3-isis-cp-02.txt
A new version of I-D, draft-xu-nvo3-isis-cp-02.txt has been successfully
submitted by Xiaohu Xu and posted to the IETF repository.
Name: draft-xu-nvo3-isis-cp
Revision: 02
Title: NVo3 Control Plane Protocol Using IS-IS
Document date: 2016-07-01
Group: Individual Submission
Pages: 8
URL:
https://www.ietf.org/internet-drafts/draft-xu-nvo3-isis-cp-02.txt
Status:         https://datatracker.ietf.org/doc/draft-xu-nvo3-isis-cp/
Htmlized:       https://tools.ietf.org/html/draft-xu-nvo3-isis-cp-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-xu-nvo3-isis-cp-02
Abstract:
    This document describes the use of IS-IS as a light-weight control
    plane protocol for Network Virtualization over L3 (NVo3) overlay
    networks.  This light-weight control plane protocol is intended for
    small and even medium sized enterprise campus networks where the NVo3
    technology is to be used.
Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.
The IETF Secretariat

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 5 Jul 2016 08:11:49 +0000

Hi Saumya,

From: nvo3 [mailto:[email-masked]] On Behalf Of Saumya Dikshit (sadikshi)
Sent: Monday, July 04, 2016 4:39 PM
To: Xuxiaohu; [email-masked]; [email-masked]
Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xiaohu,

The current version only considers Layer2 overlay. Layer3 overlay may be considered in future versions.

IS-IS has been widely used  in campus networks for many years. Layer2 overlay control plane could be realized through a tiny extension to IS-IS (i.e., the VN membership auto-discovery based upon a single sub-TLV). Note that the control-plane based MAC learning is optional rather than mandatory.

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Tue, 5 Jul 2016 09:29:24 +0000

Hi Xiaohu,
Please see inline.

From: Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 5, 2016 at 1:41 PM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Saumya,

From: nvo3 [mailto:[email-masked]] On Behalf Of Saumya Dikshit (sadikshi)
Sent: Monday, July 04, 2016 4:39 PM
To: Xuxiaohu; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xiaohu,

The current version only considers Layer2 overlay. Layer3 overlay may be considered in future versions.
<Saumya> And that may require, a new TLV definition, as the existing one "MAC-Reachability (MAC-RI) TLV” may not suffice.
Just thinking aloud if that can be considered as a complete solution provided by any NVO3 construct/encapsulation.

IS-IS has been widely used  in campus networks for many years. Layer2 overlay control plane could be realized through a tiny extension to IS-IS (i.e., the VN membership auto-discovery based upon a single sub-TLV). Note that the control-plane based MAC learning is optional rather than mandatory.
<Saumya> As I understand, the distribution of Overlay information (VN-memebership), will be tightly coupled with the underlay network tied up to same instance of ISIS and
can end up populating non-NVO3 devices in the ISIS network.

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Friday, July 01, 2016 3:17 PM
To: Himanshu Shah; Himanshu C. Shah; Xuxiaohu; Fan Yongbing; Yongbing Fan
Subject: New Version Notification for draft-xu-nvo3-isis-cp-02.txt
Name:draft-xu-nvo3-isis-cp
Revision:02
Title:NVo3 Control Plane Protocol Using IS-IS
Document date:2016-07-01
Group:Individual Submission
Pages:8

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 5 Jul 2016 09:49:13 +0000

Hi Saumya,

Thanks for your further comments. Please see my response inline.

From: Saumya Dikshit (sadikshi) [mailto:[email-masked]]
Sent: Tuesday, July 05, 2016 5:29 PM
To: Xuxiaohu; [email-masked]; [email-masked]
Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

The current version only considers Layer2 overlay. Layer3 overlay may be considered in future versions.
<Saumya> And that may require, a new TLV definition, as the existing one "MAC-Reachability (MAC-RI) TLV" may not suffice.
Just thinking aloud if that can be considered as a complete solution provided by any NVO3 construct/encapsulation.

[Xiaohu] No need for a new TLV definition. The existing Extended IP Reachability TLVs can be reused for layer3 overlay routing exchange purpose.

[Xiaohu] Your observation is correct that VN-membership info would be received by non-NVE devices. However, according to the ISIS specification, IS-IS routers would ignore unknown TLVs in the LSP and pass them on to other neighbors unchanged. Therefore, non-NVE routers don't need processing the VN membership info TLVs at all. Therefore, from the incremental deployment perspective, only those NVE devices need to be upgraded.

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: "Reith, Lothar" <[email-masked]>
Date: Tue, 5 Jul 2016 10:15:16 +0000

Hi Xixiaohu,
. Therefore, non-NVE routers don't need processing the VN membership info TLVs at all. Therefore, from the incremental deployment perspective, only those NVE devices need to be upgraded.

-       What about network address aggregation a la "supernetting" on non-NVE routers - is there no effect? And if not, what are the scalability boundaries given that MAC addresses cannot be aggregated.

Lothar

Von: nvo3 [mailto:[email-masked]] Im Auftrag von Xuxiaohu
Gesendet: Dienstag, 5. Juli 2016 11:49
An: Saumya Dikshit (sadikshi) <[email-masked]>; [email-masked]; [email-masked]
Betreff: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Tue, 5 Jul 2016 14:39:53 +0000

Hi Xiaohu,

Thanks for the response. Please see inline.

From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 5, 2016 at 3:19 PM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

[Xiaohu] No need for a new TLV definition. The existing Extended IP Reachability TLVs can be reused for layer3 overlay routing exchange purpose.
<Saumya>In case no new definitions are required, then l3-gateway can also be accommodated.

<Saumya> If you go by the encapsulations discussed in nvo3, is there an extension sought to map vni to lets say draft-ietf-nvo3-gue-03.

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 6 Jul 2016 01:42:09 +0000

Hi Lothar,

MAC reachability info is invisible to non-NVE routers. More specially, MAC reachability info of a given VN would only be visible to NVEs of that VN. Furthermore, the control-plane based MAC learning is optional rather than mandatory and therefore the MAC table scaling concern could be eliminated greatly.

Best regards,
Xiaohu

From: Reith, Lothar [mailto:[email-masked]]
Sent: Tuesday, July 05, 2016 6:15 PM
To: Xuxiaohu; Saumya Dikshit (sadikshi); [email-masked]; [email-masked]
Subject: AW: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xixiaohu,

Lothar

Von: nvo3 [mailto:[email-masked]] Im Auftrag von Xuxiaohu
Gesendet: Dienstag, 5. Juli 2016 11:49
An: Saumya Dikshit (sadikshi) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 6 Jul 2016 01:54:07 +0000

Hi Saumya,

Did you mean how to advertise tunnel types by NVEs? If so, please refer to https://tools.ietf.org/html/draft-xu-isis-encapsulation-cap.

Best regards,
Xiaohu

From: Saumya Dikshit (sadikshi) [mailto:[email-masked]]
Sent: Tuesday, July 05, 2016 10:40 PM
To: Xuxiaohu; [email-masked]; [email-masked]
Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xiaohu,

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Mon, 18 Jul 2016 12:18:04 +0000

Hi Xiaohu,
Apology for replying back late and thanks for pointing out the document.
I suggest a new section to carry  " MAC-Reachability (MAC-RI) TLV”  and "Extended IP Reachability TLVs “
along with the VNI information. Wherein VNI will map to routing-VRFs.
This is in context to your earlier comments.

Can you give your views  as it will make it up to the mark as BGP-EVPN for both l2 and l3-gateway.

Thanks
Saumya.

From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 6, 2016 at 3:54 AM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Saumya,

Best regards,
Xiaohu

Hi Xiaohu,

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 18 Jul 2016 13:21:38 +0000

Hi Saumya,

Thanks for your suggestion. Once the simple Layer2 overlay approach gains wide support, we can then consider to extend the draft to cover the Layer3 overlay case. As mentioned earlier, BGP-EVPN is more suitable for large campus network while the IS-IS based light-weight CP is more suitable for small and even medium sized campus networks.

Best regards,

Xiaohu

________________________________
发件人: Saumya Dikshit (sadikshi) [[email-masked]]
发送时间: 2016年7月18日 20:18
收件人: Xuxiaohu; [email-masked]; [email-masked]
主题: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xiaohu,

Thanks
Saumya.

Hi Saumya,

Best regards,
Xiaohu

Hi Xiaohu,

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Mon, 18 Jul 2016 13:48:24 +0000

Hi Xiaohu,

Thanks for your response, though I know you are the best judge for your publication,
 but still can’t think of any reason how MAC-IP support will adversely effect the adoption rather otherwise.

Regards,
Saumya.

From: Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 18, 2016 at 3:21 PM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Saumya,

Best regards,

Xiaohu

________________________________
发件人: Saumya Dikshit (sadikshi) [[email-masked]<mailto:[email-masked]>]
发送时间: 2016年7月18日 20:18
收件人: Xuxiaohu; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [nvo3] Simplify the deployment of NVo3 data encapsulations in enterprise campus networks?//FW: New Version Notification for draft-xu-nvo3-isis-cp-02.txt

Hi Xiaohu,

Thanks
Saumya.

Hi Saumya,

Best regards,
Xiaohu

Hi Xiaohu,

Hi Saumya,

Hi Xiaohu,
Please see inline.

Hi Saumya,

Hi Xiaohu,

Best regards,
Xiaohu

Thanks
Saumya.

Hi all,

Best regards,
Xiaohu