Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts

From: "Manish Kumar (manishkr)" <[email-masked]>
Date: Thu, 14 Jul 2016 16:53:50 +0000

Hi Matthew,

I agree this is an important aspect that’s just lingering around. Although not being adopted and not a part of the WG, if there is a discussion on pros-cons/merits-demerits, I believe GRE(+UDP) deserves a discussion as well. For that matter, it may be worth having a broader discussion!

Thanks,
Manish

On 14/07/16 9:51 pm, "nvo3 on behalf of Bocci, Matthew (Nokia - GB)" <[email-masked] on behalf of [email-masked]> wrote:

>WG,
> 
>The NVO3 working group has adopted three data plane encapsulations:
>-          VXLAN-GPE,
>-          Geneve,
>-          GUE (although the draft is moving to the Intarea WG, we anticipate that NVO3 will still reference this).
>
>We have discussed this situation with Alia and we feel that there is little benefit to the community in publishing all three as standards track RFCs. 
>
>We would note that the discussion on the drafts has been relatively light since their adoption. There has not been serious discussion about their relative pros/cons (if any), or about the actual usefulness of their extensibility or differentiators.
>
>This leaves two options:
>
>1) Publish all of them as informational or experimental, potentially moving one of them to standards track in the future based on implementation/deployment.
>2) Pick one now based on technical and/or implementation/deployment criteria.
>
>We would therefore like to gain a sense of what the WG would like to do with these drafts.
>
>Please post your comments to the list. We also have a slot to on the NVO3 agenda in Berlin where we would like to continue this discussion.
>
>Best regards,
> 
>
>Matthew and Sam
>
>
>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Black, David" <[email-masked]>
Date: Thu, 14 Jul 2016 18:41:50 +0000

> I believe GRE(+UDP) deserves a discussion as well.

FYI - over in TSVWG, this GRE/UDP draft is standards track and has completed WG Last Call:
	https://datatracker.ietf.org/doc/draft-ietf-tsvwg-gre-in-udp-encap/

Thanks, --David

> -----Original Message-----
> From: nvo3 [mailto:[email-masked]] On Behalf Of Manish Kumar
> (manishkr)
> Sent: Thursday, July 14, 2016 12:54 PM
> To: Bocci, Matthew (Nokia - GB); NVO3
> Subject: Re: [nvo3] Mail regarding NVO3 data plane drafts
> 
> Hi Matthew,
> 
> I agree this is an important aspect that’s just lingering around. Although not being
> adopted and not a part of the WG, if there is a discussion on pros-cons/merits-
> demerits, I believe GRE(+UDP) deserves a discussion as well. For that matter, it
> may be worth having a broader discussion!
> 
> Thanks,
> Manish
> 
> 
> 
> 
> 
> On 14/07/16 9:51 pm, "nvo3 on behalf of Bocci, Matthew (Nokia - GB)" <nvo3-
> [email-masked] on behalf of [email-masked]> wrote:
> 
> >WG,
> >
> >We have discussed this situation with Alia and we feel that there is little benefit
> to the community in publishing all three as standards track RFCs.
> >
> >We would note that the discussion on the drafts has been relatively light since
> their adoption. There has not been serious discussion about their relative
> pros/cons (if any), or about the actual usefulness of their extensibility or
> differentiators.
> >
> >This leaves two options:
> >
> >1) Publish all of them as informational or experimental, potentially moving one
> of them to standards track in the future based on implementation/deployment.
> >Please post your comments to the list. We also have a slot to on the NVO3
> agenda in Berlin where we would like to continue this discussion.
> >
> >Best regards,
> >
> >
> >Matthew and Sam
> >
> >

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 15 Jul 2016 02:03:18 +0000

IETF has published two informational RFCs dedicated for NVo3 data plane encapsulation, one is RFC7348 (i.e., VXLAN) and the other is RFC7637 (i.e., NVGRE). Both of them have been implemented and deployed. Of course, each has its own flaw. The former has no protocol type field (https://www.ietf.org/mail-archive/web/nvo3/current/msg01520.html) and the latter' ECMP capability is not good enough.  

If the NVo3 WG still wants to publish some RFCs on NVo3 data plane encapsulation, it seems reasonable to build on the above two approaches and fix their flaws accordingly. VXLAN-GPE is designed to fix the flaw of VXLAN although whether or not to use a different port number than VXLAN's port number is still controversial. Personally, I prefer to the approach as defined in (https://tools.ietf.org/html/draft-yong-l3vpn-nvgre-vxlan-encap-03#page-3) since it seem much simpler than the current approach as defined in (https://tools.ietf.org/html/draft-quinn-vxlan-gpe-03#page-8). GRE-in-UDP is a very good choice to fix the flow of NVGRE. 

Best regards,
Xiaohu

> From: nvo3 [mailto:[email-masked]] On Behalf Of Black, David
> Sent: Friday, July 15, 2016 2:42 AM
> To: Manish Kumar (manishkr); NVO3

> > I agree this is an important aspect that’s just lingering around.
> > Although not being adopted and not a part of the WG, if there is a
> > discussion on pros-cons/merits- demerits, I believe GRE(+UDP) deserves
> > a discussion as well. For that matter, it may be worth having a broader
> discussion!
> >
> > Thanks,
> > Manish
> >
> >
> >
> >
> >
> > On 14/07/16 9:51 pm, "nvo3 on behalf of Bocci, Matthew (Nokia - GB)"
> > <nvo3- [email-masked] on behalf of [email-masked]> wrote:
> >
> > >WG,
> > >
> > >-          GUE (although the draft is moving to the Intarea WG, we
> anticipate that
> > NVO3 will still reference this).
> > >
> > their adoption. There has not been serious discussion about their
> > relative pros/cons (if any), or about the actual usefulness of their
> > extensibility or differentiators.
> > >
> > >This leaves two options:
> > >
> > >We would therefore like to gain a sense of what the WG would like to
> > >do with
> > these drafts.
> > >

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 20 Jul 2016 07:20:20 -0700

> IETF has published two informational RFCs dedicated for NVo3 data plane encapsulation, one is RFC7348 (i.e., VXLAN) and the other is RFC7637 (i.e., NVGRE). Both of them have been implemented and de…

Xiaohu,

A minor nit is that it was the Independent Stream Editor at the RFC Editor who published these documents, not the IETF.
In most cases that doesn't make a difference.

Regards,
    Erik