Subject: [nvo3] What needs to be done about OAM?

From: [email-masked] (Dale R. Worley)
Date: Thu, 05 Apr 2018 21:58:47 -0400

My apologies, but I'm new here.  There has been various discussion about
OAM packets, but what I've seen has been fairly vague -- the O bit in
Geneve and a proposal for an OAM encapsulation that was not detailed
about what application-level information the encapsulation would carry.

Is there solid information about what OAM is to achieve and what is
necessary to achieve it?  Or is that a discussion that we really need to
have?

I can see various different ways of opening up the subject.  One is to
show clearly useful implementations, and from that, start to abstract
the functions that they perform.  Conversely, we can show functions for
which there is a need, and start to work out implementations.

Dale

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Tue, 10 Apr 2018 12:22:42 +0000

Dale

There was a draft on OAM requirements in the working group a few years ago, but this somewhat fell by the wayside. 

https://www.ietf.org/archive/id/draft-ashwood-nvo3-operational-requirement-03.txt

It may be a good time for an interested participant to pick this up again.

Matthew

On 06/04/2018, 02:58, "nvo3 on behalf of Dale R. Worley" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Dale
    
    _______________________________________________
    nvo3 mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/nvo3

---

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 10 Apr 2018 14:29:44 -0700

This is a more recent version:
https://tools.ietf.org/html/draft-ashwood-nvo3-oam-requirements-04

See also these drafts:
https://tools.ietf.org/html/draft-tissa-nvo3-oam-fm-04
https://tools.ietf.org/html/draft-singh-nvo3-vxlan-router-alert-02
https://tools.ietf.org/html/draft-nordmark-nvo3-transcending-traceroute-03

IIRC, there was an NVO3 OAM design team that was formed and we met
virtually at least a couple of times and then the effort died off.

Then there was another effort around OAM for overlays in the RTGWG.
https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-02

And finally, BFD over VXLAN:
https://tools.ietf.org/html/draft-ietf-bfd-vxlan-00

I haven't been following stuff closely, so I may have missed some related
work.

Thanks,
Anoop

On Tue, Apr 10, 2018 at 5:22 AM, Bocci, Matthew (Nokia - GB) <
[email-masked]> wrote:

> Dale
>
> There was a draft on OAM requirements in the working group a few years
> ago, but this somewhat fell by the wayside.
>
> On 06/04/2018, 02:58, "nvo3 on behalf of Dale R. Worley" <
> [email-masked] on behalf of [email-masked]> wrote:
>

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 10 Apr 2018 23:45:16 +0200

Hi Anoop,
thank you for the most detailed list of the references to OAM work related
to NVO3 WG. I may add just couple more drafts that came out of OOAM design
team:

   - requirements
   <https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-02>;
   - gap analysis
   <https://tools.ietf.org/html/draft-ooamdt-rtgwg-oam-gap-analysis-02>;
   - OOAM heade
   <https://datatracker.ietf.org/doc/draft-ooamdt-rtgwg-ooam-header/>r;
   - on-demand Echo Request/Reply
   <https://tools.ietf.org/html/draft-ooamdt-rtgwg-demand-cc-cv-03>.

The NVO3 OAM design team, at some point in time, joined in work with OOAM
DT and input, expertise helped us significantly.

Regards,
Greg

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 26 Apr 2018 09:13:48 +0000

Hi Anoop, Greg,
I would suggest to add also draft-fmm-nvo3-pm-alt-mark-01<https://tools.ietf.org/html/draft-fmm-nvo3-pm-alt-mark-01> to the list of the NVO3 OAM related drafts.

Thanks,

Giuseppe

Da: nvo3 [mailto:[email-masked]] Per conto di Greg Mirsky
Inviato: martedì 10 aprile 2018 23:45
A: Anoop Ghanwani
Cc: Bocci, Matthew (Nokia - GB); Dale R. Worley; [email-masked]
Oggetto: Re: [nvo3] What needs to be done about OAM?

Hi Anoop,
thank you for the most detailed list of the references to OAM work related to NVO3 WG. I may add just couple more drafts that came out of OOAM design team:

  *   requirements <https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-02> ;
  *   gap analysis<https://tools.ietf.org/html/draft-ooamdt-rtgwg-oam-gap-analysis-02>;
  *   OOAM heade<https://datatracker.ietf.org/doc/draft-ooamdt-rtgwg-ooam-header/>r;
  *   on-demand Echo Request/Reply<https://tools.ietf.org/html/draft-ooamdt-rtgwg-demand-cc-cv-03>.
The NVO3 OAM design team, at some point in time, joined in work with OOAM DT and input, expertise helped us significantly.

Regards,
Greg

On Tue, Apr 10, 2018 at 11:29 PM, Anoop Ghanwani <[email-masked]<mailto:[email-masked]>> wrote:
This is a more recent version:
https://tools.ietf.org/html/draft-ashwood-nvo3-oam-requirements-04

See also these drafts:

IIRC, there was an NVO3 OAM design team that was formed and we met virtually at least a couple of times and then the effort died off.

Then there was another effort around OAM for overlays in the RTGWG.
https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-02<https://tools.ietf..org/html/draft-ooamdt-rtgwg-ooam-requirement-02>

I haven't been following stuff closely, so I may have missed some related work.

Thanks,
Anoop

On Tue, Apr 10, 2018 at 5:22 AM, Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
Dale

Matthew

On 06/04/2018, 02:58, "nvo3 on behalf of Dale R. Worley" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

    Dale

    _______________________________________________
    nvo3 mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/nvo3

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.