Subject: Re: [nvo3] eVXLAN carrying Group information

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 2 Mar 2021 08:56:40 +0000

Hi Gyan,

Many thanks for your information!

I found the Group Policy ID explained as below,

   o  Group Policy ID: 16-bit identifier that indicates the Group Policy
      ID being encapsulated by this GBP shim header.  The Default GBP ID
      value is special and indicates that the GBP option was not set.
      Packet filters SHOULD be able to match on the Default GBP ID value
      as a way to match packets that do not have the GBP option set.
      The default Default GBP ID is 0, but MAY be configured to be a
      value other than 0.  The allocation of Group Policy ID values is
      outside the scope of this document.

It seems that we could add this in the gap analysis draft,
https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/

Best regards,
Shuping

From: Gyan Mishra [mailto:[email-masked]]
Sent: Monday, March 1, 2021 2:50 PM
To: Pengshuping (Peng Shuping) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [nvo3] eVXLAN carrying Group information

Shuping

I am not sure if you are referring to VXLAN-GPE vxlan Generic protocol extension which has changes in the vxlan header to support multi protocol encapsulation, OAM and BUM.

https://tools.ietf.org/html/draft-ietf-nvo3-vxlan-gpe-10

   The capabilities of the VXLAN-GPE protocol can be extended by

   defining next protocol "shim" headers that are used to implement new

   data plane functions.  For example, Group-Based Policy (GBP) or In-

   situ Operations, Administration, and Maintenance (IOAM) metadata

   functionalities can be added as specified in

   [I-D.lemon-vxlan-lisp-gpe-gbp<https://tools.ietf.org/html/draft-ietf-nvo3-vxlan-gpe-10#ref-I-D.lemon-vxlan-lisp-gpe-gbp>] and

   [I-D.brockners-ippm-ioam-vxlan-gpe<https://tools.ietf.org/html/draft-ietf-nvo3-vxlan-gpe-10#ref-I-D.brockners-ippm-ioam-vxlan-gpe>].

Kind Regards

Gyan

On Sun, Feb 28, 2021 at 10:21 PM Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Anybody knows about using eVXLAN to carry the Group information? What is the scenario? How the group is identified?

Thank you very much!

Best regards,
Shuping

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3
--

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 2 Mar 2021 09:29:13 -0500

That’s great news that this can be a viable marking option for APN
signaling.

Kind Regards

Gyan

On Tue, Mar 2, 2021 at 3:56 AM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> *From:* Gyan Mishra [mailto:[email-masked]]
> *Sent:* Monday, March 1, 2021 2:50 PM
> *To:* Pengshuping (Peng Shuping) <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [nvo3] eVXLAN carrying Group information
>
>
>
>
>
> Shuping
>
>
>
> I am not sure if you are referring to VXLAN-GPE vxlan Generic protocol
> extension which has changes in the vxlan header to support multi protocol
> encapsulation, OAM and BUM.
>
>
>
>    [I-D.lemon-vxlan-lisp-gpe-gbp <https://tools.ietf.org/html/draft-ietf-nvo3-vxlan-gpe-10#ref-I-D.lemon-vxlan-lisp-gpe-gbp>] and
>
>    [I-D.brockners-ippm-ioam-vxlan-gpe <https://tools.ietf.org/html/draft-ietf-nvo3-vxlan-gpe-10#ref-I-D.brockners-ippm-ioam-vxlan-gpe>].
>
>
>
>
>
> Kind Regards
>
>
>
> Gyan
>
>
>
> On Sun, Feb 28, 2021 at 10:21 PM Pengshuping (Peng Shuping) <
> [email-masked]> wrote:
>
> Dear all,
>
>
>
> Anybody knows about using eVXLAN to carry the Group information? What is
> the scenario? How the group is identified?
>
>
>
> Thank you very much!
>
>
>
> Best regards,
>
> Shuping
>
>
>
> [email-masked]
>  <http://www.verizon.com/>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
>
>
> *M 301 502-1347 13101 Columbia Pike
> <https://www.google.com/maps/search/13101+Columbia+Pike?entry=gmail&source=g>
> *Silver Spring, MD
>
>
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 2 Mar 2021 06:37:23 -0800

Hi Shuping,
thank you for your detailed update. Do you think that the Group Policy ID
is the Group Policy as described in OpneStack's Group-based Policy
<https://gbp.readthedocs.io/en/latest/usage.html#:~:text=What%20is%20Group%2DBased%20Policy,is%20independent%20of%20underlying%20infrastructure.>
and Group Policy? If it might, I' will note that SFC's NSH MD Type=2 TLV
draft <https://tools.ietf.org/html/draft-ietf-sfc-nsh-tlv-04> proposes a
TLV to carry Source and Destination Policy identifiers.

Regards,
Greg

On Tue, Mar 2, 2021 at 12:57 AM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> *M 301 502-1347 13101 Columbia Pike  *Silver Spring, MD
>
>

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Thu, 4 Mar 2021 02:23:56 +0000

Hi Gyan,

It could be taken as a existing solution to be included in the gap analysis part, but different from APN.

Best regards,
Shuping

Sent: Tuesday, March 2, 2021 10:29 PM

That’s great news that this can be a viable marking option for APN signaling.

Kind Regards

Gyan

On Tue, Mar 2, 2021 at 3:56 AM Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Gyan,

Best regards,
Shuping

From: Gyan Mishra [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, March 1, 2021 2:50 PM
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] eVXLAN carrying Group information

Shuping

Kind Regards

Gyan

Thank you very much!

Best regards,
Shuping

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://www.google.com/maps/search/13101+Columbia+Pike?entry=gmail&source=g>
Silver Spring, MD

--

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 3 Mar 2021 22:16:14 -0500

Understood.  Agreed.

Thanks

Gyan

On Wed, Mar 3, 2021 at 9:24 PM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> *Sent:* Tuesday, March 2, 2021 10:29 PM
-- 

*Gyan Mishra*