Subject: [nwcrg] Network Coding Charter and Working Group kickoff

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Tue, 11 Dec 2012 01:15:15 +0000

Dear Network Coding WG members,

Brian and I have posted a draft for the NWC Working Group Charter at

http://wiki.tools.ietf.org/group/irtf/trac/wiki/nwcrg

This site is now the official home for our NWC IRTF proposed group.

We invite everybody to read the Charter and provide feedback on this 
mailing list. Our plan is to converge to a text that has general 
consensus. We will have a final discussion and approval during our 
planned meeting at the next IETF in Orlando, FL March 10-15, see 
http://www.ietf.org

We also invite you to express your interests and describe the topics in 
this charter you would like to contribute.

Also, please invite others you know that may be interested to join this 
mailing list by visiting
https://www.irtf.org/mailman/listinfo/nwcrg
or by sending us an email.

Best Regards,

Brian Adamson, Victor Firoiu

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 18 Dec 2012 09:52:57 +0000

Hi,

> http://wiki.tools.ietf.org/group/irtf/trac/wiki/nwcrg

thanks for posting this initial draft! I gave the page a quick read, and  a bit surprised that the section on "NWC Practical Application and Standardization Path" is so much longer and more detailed than the section on "NWC Research". I'd have expected the opposite, i.e., the main focus being on sharing, discussing and developing NWC research?

Lars

---

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Tue, 18 Dec 2012 15:18:00 +0000

Lars,

Thank you for your feedback. Indeed, we will expand on the research part. I would like to invite input from academics and researchers that are part of this group. I think that our focus should be the applied research side, with a view to the results and implications from the theoretical works. 

Victor

-----Original Message-----
From: Eggert, Lars [mailto:[email-masked]] 
Sent: Tuesday, December 18, 2012 4:53 AM
To: Firoiu, Victor (US SSA)
Cc: [email-masked]
Subject: Re: [nwcrg] Network Coding Charter and Working Group kickoff

Hi,

Lars

---

From: Brian Adamson <[email-masked]>
Date: Tue, 18 Dec 2012 10:53:08 -0500

Hi Lars,

I also think a number of the topics we had put under the "Practical Application and Standardization Path" actually have associated research issues that need to be addressed (and the discussion there was intended to convey that).   I think the past decade of research in Network Coding has focused on more of the theoretical benefits of network coding ... More recently, as it has become feasible to apply it, there has been some initial work in different forms to use network coding in the context of a large scale and/or distributed network system. A number of the "Practical Application" areas we identified are really topics that need to be addressed with further work to bring Network Coding into a mainstream system like the Internet, thus they are applied research areas.  

It had slipped by me that the organization of our writeup ends up with very lean "NWC Research" section.   I think there is a good bit of the discussion in the "Practical Application" that could be moved up and identified as research areas.  

Also one area that Victor, Kevin Fall and I had discussed was the fact that for network coding, there is not necessarily a one-to-one correspondence between packet flow and information flow and that is one of the key paradigm shifts that impacts different aspects of network design and operation.  This triggers several of the topics we describe in that "Practical Application" section.  As Victor mentions below, there is definitely applied research activity that could be marshaled to allow Network Coding to be a part of future Internet systems.

Let me know what you think.

Brian Adamson
[email-masked]

On Dec 18, 2012, at 10:18 AM, Firoiu, Victor (US SSA) wrote:

> _______________________________________________
> nwcrg mailing list
> [email-masked]