Subject: [nwcrg] Congestion control in other areas

From: Michael Welzl <[email-masked]>
Date: Tue, 5 Mar 2013 11:05:43 +0100

Dear NWCRG'ers,

Some time ago, I sent the email below to the IRSG; it led to a plan to do this at the Berlin IETF meeting.
I just reminded IRSG members of this, so they could run the idea by their groups at the upcoming meeting.

I think NWCRG would also be a good candidate for this - I have seen multiple proposals for improving TCP with network coding, and suspect that some achieve a "benefit" by actually hiding losses from TCP's congestion control... getting an overview on what approaches exist and how they interact with congestion control would be really good, and definitely of mutual NWCRG-ICCRG interest I think.

Cheers,
Michael

>>> On Nov 8, 2012, at 8:15 AM, Michael Welzl <[email-masked]>
>>> wrote:
>>> 
>>>> Hi all,
>>>> 
>>>> Here's an idea that I got at yesterday's dinner:
>>>> 
>>>> The focus of my group (Internet Congestion Control Research Group, ICCRG) is usually limited to, well, normal congestion on the normal Internet. TCP stuff. However, some of you folks deal with vastly different scenarios which require special forms of congestion control: ICN, constrained devices (I'm cc'ing Carsten as a potential future IRSG member), DTN, multicast... hm, I'd hope that there's some multicast-awareness among ICCRG members, but maybe no more? Could be interesting to hear news about multicast cc, if there is any?
>>>> 
>>>> Anyway, my thought was: wouldn't it be an interesting to organize a small session within the next ICCRG meeting in Orlando about congestion control in all these special contexts? I'm thinking of short presentations by IRSG members (or other experts on the particular topic), one each, in the style:
>>>> 
>>>> - what are the constraints of my environment?
>>>> - what style of proposals do we have?
>>>> ... and, in conclusion, you could say if you're just presenting this "as is", as an educational exercise for ICCRG, or if you're asking for feedback from the community. I'd imagine that this could lead to some interesting discussions, and maybe also attract some congestion controllers to take a closer look at your respective fields.
>>>> 
>>>> Thoughts?
>>>> 
>>>> Cheers,
>>>> Michael
>>>> 
>>>> PS: in case we agree that this should happen, I'd welcome proposals for a cool title for that session  :-)   "Congestion control that you never thought of" or "Congestion control in special environments" is just too boring...
>>>> 
>>> 
>> 
>

---

From: Brian Adamson <[email-masked]>
Date: Tue, 5 Mar 2013 17:12:43 -0500

I think congestion control (and flow control) is going to be an interesting area to examine with respect to network coding in general.  I have also looked at some of the loss tolerant TCP work that uses some packet erasure coding to "hide" loss from TCP to improve performance in environments like wireless.   We have done some of our experimental "wireless ready" congestion control work with our NORM protocol (which includes packet erasure coding capability and happens to work for unicast as well as multicast for which it was designed).  One example of this is a an ECN (explicit congestion notification) mechanism that mostly ignores packet loss and depends upon ECN marking by intermediate systems as congestion indication.  We also have an experimental loss-tolerant NORM congestion control mode that does not require intermediate system actions, but instead uses some heuristics to attempt to discern packet loss due to channel errors from packet loss due to congestion.  This is a key point here is that using erasure coding alone to mask packet loss does not necessarily help differentiate whether the loss is due to congestion or channel errors. There are some approaches which look at loss and delay conjointly to attempt to determine the case.  I think ECN provides one of clearest indicators, but of course is not widely deployed in networks, but if start thinking in terms of different deployments that include network coding in the intermediate systems, then ...

 With respect to congestion control for network coding in general, there are some interesting challenges here since you start to decouple the flow of information from the flow of packets … so new questions arise in terms of resource fairness or whatever measure of fairness or other metrics that you wish to use for congestion control.

One of the motivations for this NWCRG was the fact that use network coding and packet erasure coding is starting to "pop up" in different places within the IRTF / IETF and other forums and it may be useful to have a forum loaded with insight in this area to help determine where/how (or not) network coding fits in.

cheers,

Brian

On Mar 5, 2013, at 5:05 AM, Michael Welzl <[email-masked]> wrote:

> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Michael Welzl <[email-masked]>
Date: Wed, 6 Mar 2013 08:02:05 +0100

Well - this all sounds interesting & relevant to cc. - my question is, would you (or anyone from nwcrg) be willing to give an overview of the nc-cc relationship in existing work in iccrg in berlin?

Sent from my iPhone

---

From: Muriel Medard <[email-masked]>
Date: Wed, 6 Mar 2013 10:28:24 +0000

Dear all,

I am not familiar with the work in iccrg, but would be happy to chat about the possible relation with CTCP. I cc Doug Leith, who has is woking on this and who I believe is the best placed to comment intelligently on this topic.

Best,

Muriel.

---

From: Michael Welzl <[email-masked]>
Date: Wed, 6 Mar 2013 11:30:19 +0100

Thanks, sounds good! Doug, I haven't seen you at an ICCRG meeting for a while, given that we're talking about the IETF in Europe wouldn't that be a welcome chance to participate again, and present something about how network coding and congestion control relate?

---

From: Douglas Leith <[email-masked]>
Date: Wed, 06 Mar 2013 11:49:23 +0000

If it would be useful I'd certainly be happy to give an overview of congestion control in ctcp as part of opening up a wider discussion on congestion control for coded transport.  

Doug

---

From: Michael Welzl <[email-masked]>
Date: Wed, 6 Mar 2013 14:16:36 +0100

( + my co-chair whom I forgot to include in all these emails)

Great! That'd be very welcome. This is the first item to ever be put on the agenda of an ICCRG meeting   :-)

See you in Berlin!
Michael

---

From: Emmanuel Lochin <[email-masked]>
Date: Wed, 06 Mar 2013 15:04:50 +0100

> I think NWCRG would also be a good candidate for this - I have seen multiple proposals for improving TCP with network coding, and suspect that some achieve a "benefit" by actually hiding losses fro…

Hi Michael

Just for recall, during the IAB / IRTF Workshop on Congestion Control 
for Interactive Real-Time Communication last July in Vancouver, there 
were some proposals concerning such technique for multimedia transport 
protocol and in particular : 
http://www.tschofenig.priv.at/cc-workshop/irtf_iab-ccirtcpaper30.pdf

Emmanuel

-- 
Emmanuel Lochin
Professeur ISAE - OSSI
Institut Supérieur de l'Aéronautique et de l'Espace (ISAE)
Issu du rapprochement SUPAERO et ENSICA
10 avenue Edouard Belin - BP 54032 - 31055 Toulouse cedex 4
Tel : 05 61 33 91 85 - Fax : 05 61 33 91 88
Web : http://personnel.isae.fr/emmanuel-lochin/
---
"This email and any attachments are confidential. They may contain legally privileged information or copyright material. You should not read, copy, use or disclose them without authorisation. If you are not an intended recipient, please contact us at once by return email and then delete both messages. We do not accept liability in connection with computer virus, data corruption, delay, interruption, unauthorised access or unauthorised amendment. This notice should not be removed"

---

From: Michael Welzl <[email-masked]>
Date: Wed, 6 Mar 2013 21:09:53 +0100

yeah… and also welcome in iccrg @ berlin, if we make CTCP and this one short, one short presentation each could give a nice "how does coding relate to congestion control" slot. i'm thinking of 10 + 10 minutes presentations + 10 minutes discussion, something like that.

On Mar 6, 2013, at 3:04 PM, Emmanuel Lochin <[email-masked]> wrote:

> Just for recall, during the IAB / IRTF Workshop on Congestion Control for Interactive Real-Time Communication last July in Vancouver, there were some proposals concerning such technique for multimedia transport protocol and in particular : http://www.tschofenig.priv.at/cc-workshop/irtf_iab-ccirtcpaper30.pdf
> 
> Emmanuel
> 
> 
>> 
>> Cheers,
>> Michael
>> 
>>