Subject: [nwcrg] Case studies of network coding.

From: Muriel Medard <[email-masked]>
Date: Tue, 30 Jul 2013 20:10:05 +0000

Dear Victor and all,

thank you for great pre-meeting on Monday! As Victor requested, here are some implementations and algorithms, and their basic characteristics, with some references. The algorithms all refer to discussion topics we had. I am sorry that I shall not be able to attend the Wednesday meeting.

Best,

Muriel.

Kernel - level network coded TCP
RLNC
shim layer between TCP and IP
both end-to-end and with intermediate re-encoding
Jay Kumar Sundararajan, Devavrat Shah, Muriel Médard, Szymon Jakubczak, Michael Mitzenmacher, João Barros,
Network Coding Meets TCP: Theory and Implementation.   Proceedings of the IEEE 99 (3): 490-512 (2011)
Minij Kim, Muriel Médard, João Barros
Modeling network coded TCP throughput: a simple
model and its validation
Valuetools, 131-140 (2010)

CTCP - coded TCP 
RLNC
both end-to-end and with intermediate re-encoding
in application layer, but implements TCP 
can do channel bonding as a single flow 
We introduce CTCP, a reliable transport protocol using network
coding. CTCP is designed to incorporate TCP features
such as congestion control, reliability, and fairness while significantly
improving on TCP’s performance in lossy, interferencelimited
and/or dynamic networks. A key advantage of adopting
a transport layer over a link layer approach is that it provides
backward compatibility with wireless equipment installed
throughout existing networks. We present a portable
userspace implementation of CTCP and extensively evaluate
its performance in both testbed and production wireless
networks.
Leo Urbina
Applying Network Coding to TCP
MIT M.Eng. Thesis 2012
Minji Kim, Jason Cloud, Ali ParandehGheibi, Leonardo Urbina, Kerim Fouli, Douglas Leith, Muriel Médard
Network Coded TCP (CTCP)  arXiv: 1212.2291v2
MinJi Kim Thierry Klein Emina Soljanin João Barros Muriel Médard
Modeling Network Coded TCP: Analysis of Throughput and Energy Cost
http://arxiv.org/abs/1208.3212 2012 CoRR abs/1208.3212 db/journals/corr/corr1208.html#abs-1208-3212
To be presented MONAMI 2013

RLNC in a chip for low-power sensors
use of RLNC by itself outperforms PHY-layer FEC for low target PER
RLNC and PHY-level convolutional codes work separately in coding and decoding, but co-designing the right level of redundancy provides advantages
G. Angelopoulos, Paidimarri, A., Chandrakasan, A. P., and Médard, M., “Experimental Study of the Interplay of Channel and Network Coding in Low Power Sensor Applications”, ICC WCS 2013

Other work on coordinating network coding and PHY-layer coding, without the use of joint coding, but rather by controlling rate alone
M. Xiao, Médard, M., and Aulin, T., “Cross-Layer Design of Rateless Random Codes for Delay Optimization”, IEEE Transactions on Communications, vol. 59, no. 12, December 2011, pp. 3311 - 3322

RLNC at the ENode B
replacing MAC ARQ and HARQ by RLNC on IP packets
we design and implement a network-coding-enhanced network architecture
for next generation wireless networks. The architecture applies intra-session random linear
network coding as a packet erasure code below the IP layer. Using WiMAX as a case
study, a series of point-to-point single-interface experiments are conducted to compare the
performance of the architecture to that of HARQ and ARQ mechanisms. The performance
measures are packet loss percentage, throughput and le transfer delay. The experiments use
the Global Environment for Network Innovations (GENI) WiMAX platforms. UDP trac is
considered; Iperf and UDP based File Transfer Protocol (UFTP) are used as measurement
Compared to HARQ and ARQ mechanisms, the architecture can offer up to 5.9 times gain in throughput and 5.5 times reduction in end-to-end le transfer
applications. 
delay.
(this is demonstration I shared on Monday)
S. Teerapittayanon, Fouli, K., Médard, M., Montpetit, M.-J., Shi, X., Seskar, I., and Gosain, A., “Network Coding as a WiMAX Link Reliability Mechanism”, MACOM 2012**
S. Teerapittayanon, Fouli, K., Médard, M., Montpetit, M.-J., Shi, X., Seskar, I., and Gosain, A., “Network Coding as a WiMAX Link Reliability Mechanism: An Experimental Demonstration”, MACOM 2012
S. Teerapittayanon
Performance Enhancements in Next Generation
Wireless Networks Using Network Coding:
A Case Study in WiMAX
MIT M.Eng. Thesis, 2012

FPGA implementation of RLNC for partial packet reception with network coding (PPRNC)
PPRNC exploits information contained in partial
packets, similarly to existing Hybrid-ARQ schemes, but with a PHY-agnostic
approach. Minimization of the number of retransmitted packets saves transmission
energy and results in higher total network throughput, making PPRNC an attractive
candidate for energy constrained networks.
Georgios Angelopoulos
Energy-Aware Network Coding Circuit and
System Design
MIT, M.S. Thesis, 2011

We discussed the use of network coding in networks where not all nodes use network coding

We have proposed a simple network layer protocol, study
the mean energy to complete uploads of given packets from the nodes to the BS using a
Markov chain model, and show through numerical examples that when reception energy
is taken into account, the incorporation of network coding offers reductions in energy use.
The amount of achievable gains depends on the number of nodes in the network, the de-
gree of asymmetry in channel conditions experienced by different nodes, and the relative
difference between transmitting and receiving power at the nodes. We also demonstrate the
compatibility of the proposed scheme with the IEEE 802.15.6 WBAN standard by describ-
ing ways of incorporating network coding into systems compliant to the standard.
X. Shi, "Energy Aware Network Coding inWireless Networks", MIT Ph.D. Thesis, 2012
X. Shi, Médard, M. and Lucani,. D., “Whether and Where to Code in the Wireless Relay Channel”, accepted to IEEE Journal of Selected Areas in Communication, Vol. 31, No. 8, August 2013

RLNC used in multi path TCP 
We first
present empirical data to help understand the mobile environment when
three heterogeneous networks are available to the mobile device (i.e., a
WiFi network, WiMax network, and an Iridium satellite network). We
then propose a reliable, multi-path protocol called Multi-Path TCP with
Network Coding (MPTCP/NC) that utilizes each of these networks in
parallel. An analytical model is developed and a mean-field approximation
is derived that gives an estimate of the protocol’s achievable throughput.
Finally, a comparison between MPTCP and MPTCP/NC is presented
using both the empirical data and mean-field approximation.
Multi-Path TCP with Network Coding for Mobile Devices in
Heterogeneous Networks
Jason Cloud, Flávio du Pin Calmon, Weifei Zeng, Giovanni Pau, Linda M. Zeger, and Muriel Médard
Accepted to VTC 2013
(Emanuel - this is the paper to which I referred, I would be happy to send you a preprint)

Coding in storage area networks
RLNC for reduction of blocking probability
RLNC for SVC/multi-resolution coding
There is now an implementation in Amazon of a simple CDN to illustrate the gains
U. Ferner, Médard, M., and Soljanin, E., “Toward Sustainable Networking: Storage Area Networks with Network Coding”, Allerton Conference 2012
U. Ferner, Wang, T., Médard, M., "Network Coded Storage with Multi-resolution codes", to be presented at Asilomar 2013

An implementation of RLNC for anonymous P2P
NCGAB, a decentralized peer-to-peer
overlay network based on network coded gossip that provides a resilient, anonymous
broadcast medium. Unlike most anonymous communication systems, NCGAB requires
no cryptosystem, no infrastructure of trust, and no special nodes to operate.
Ivan Sergeev, "Network Coding for Anonymous Broadcast", MIT M.Eng. Thesis, 2013

RLNC implementation for anonymous broadcast
This is something like anonymous posting for streaming content
Melting Pad, an algebraic coding scheme with properties of
information theoretic security and ecient decodability, designed to protect messages
for wide dissemination and for hosting with diminished liability
Ivan Sergeev, "Network Coding for Anonymous Broadcast", MIT M.Eng. Thesis, 2013

Speeding Multicast by Acknowledgment Reduction Technique (SMART)
This algorithm is an alternative to NORM and uses RLNC
We consider transmission of packets from a single source
to many receivers over a single-hop broadcast erasure channel
with heterogeneous links. We propose a predictive model to
minimize feedback as well as extraneous data transmissions
by the source. In addition, we use the method of types to
provide a lower bound for the expected total transmission time,
and use simulations to show that our protocol operates close
to this lower bound. We show that with SMART, counter to
conventional wisdom, the average user’s QoE improves slightly as
the number of users increases. We demonstrate that SMART’s
algorithmic simplicity enables multicast transmissions that on
average take fewer than 2 feedback rounds to complete. We
show the favorable scalability of our technique with the number
of users, which enables reliable quality of experience. We also
show the robustness of this scheme to uncertainty in the number
of receiving nodes, and packet erasure probability, as well as
to partial loss of the feedback. Furthermore, we show that
SMART performs nearly as well as an omniscient transmitter
that requires no feedback.
A. Rezaeee, du Pin Calmon, F., Zeger, L., and Médard, M.,  “Speeding Multicast by Acknowledgment Reduction Technique (SMART) Enabling Robustness of QoE to the Number of Users”, IEEE Journal of Selected Areas in Communication, vol. 30, no. 7, August 2012, pp. 1270-1280

Use of network coding with multi-packet reception
We design a cross-layer approach to aid in developing
a cooperative solution using multi-packet reception (MPR),
network coding (NC), and medium access (MAC). We construct
a model for the behavior of the IEEE 802.11 MAC protocol
and apply it to key small canonical topology components and
their larger counterparts. The results obtained from this model
match the available experimental results with fidelity. Using this
model, we show that fairness allocation by the 802.11 MAC can
significantly impede performance; hence, we devise a new MAC
that not only substantially improves throughput, but provides
fairness to flows of information rather than to nodes. We show
that cooperation between NC, MPR, and our new MAC achieves
super-additive gains of up to 6.3 times that of routing with
the standard 802.11 MAC. Furthermore, we extend the model
to analyze our MAC’s asymptotic and throughput behaviors
as the number of nodes increases or the MPR capability is
limited to only a single node. Finally, we show that although
network performance is reduced under substantial asymmetry or
limited implementation of MPR to a central node, there are some
important practical cases, even under these conditions, where
MPR, NC, and their combination provide significant gains.
J. Cloud, Zeger, L., and Médard, M., “MAC Centered Cooperation - Synergistic Design of Network Coding, Multi-Packet Reception, and Improved Fairness to Increase Network Throughput”, IEEE Journal of Selected Areas in Communication, vol. 30, no. 2, February 2012, pp. 341 - 349
Cloud, Jason, “Cross-Layer Design with Multi-Packet Reception, MAC, and Network Coding in Multi-Hop Networks”, MIT MS Thesis, 2011 
Arman Rezaee, Network Coding, Multi-Packet Reception, and  Feedback: Design Tools for Wireless Broadcast Networks”,  MIT MS Thesis, 2011 

Using coding to avoid interruptions in video
We use the fact that random linear network coding applied to blocks of video
frames can significantly simplify the packet requests at the network layer and avoid duplicate packet
reception. This allows us to model the receiver’s buffer as a queue with Poisson arrivals and deterministic
departures. We consider the probability of interruption in media playback (buffer underflow) as well as
the number of initially buffered packets (initial waiting time) as the Quality of user Experience (QoE)
metrics. We explicitly characterize the optimal trade-off between these metrics by providing upper
and lower bounds on the minimum initial buffering required to achieve certain level of interruption
probability for different regimes of the system parameters
A. ParandehGheibi, Médard, M., Ozdaglar, A., and Shakkottai, S., “Avoiding Interruptions—A QoE Reliability Function for Streaming Media Applications”, IEEE Journal on Selected Areas in Communications, special issue on “Trading rate for Delay at the Transport and Application Layers”, vol. 29, no. 5, May 2011, pp. 1064-1074
For media streaming in technology and cost heterogeneous environments, we employ random linear network coding to address
the problem of efficient streaming in a technology-heterogeneous
setting and simplify the packet selection strategies and alleviate
issues such as duplicate packet reception. The main focus of
this work is the problem of media streaming from multiple
cost-heterogeneous access networks. We model our system after
HTTP streaming systems, where user must decisions on how
many packets to buffer before playback, and which server to
access during the playback. Our objective is to characterize
analytically the trade-off between access cost and user experience.
A. ParandehGheibi, Médard, M., Ozdaglar, A., and Shakkottai, S., “Access-Network Association Policies for Media Streaming in Heterogeneous Environments”, CDC 2010
The benefits in a WiFi/4G  heterogeneous environment were shown using OPNET in
A. Kulkarni, Heindlmaier, M., Traskov, D., Médard, M., and Montpetit, M.-J., “An Implementation of Network Coding with Association Policies in Heterogeneous Networks”, NC-Pro Workshop 2011

Network coding for improving High-Speed Ethernet performance
Parallel transmission, as  defined in high-speed Ethernet standards, enables to use  less expensive   optoelectronics  and offers   
backwards compatibility with legacy Optical Transport Network (OTN) infrastructure.  However, optimal parallel transmission does not scale to large networks, as it requires computationally expensive multipath routing algorithms in the OTN layer to minimize differential delay, and thus the required buffer size, optimize  traffic splitting ratio, and ensure time-constrained frame synchronization. In this paper, we propose a novel framework for high-speed Ethernet, which we refer to as network coded parallel transmission, capable of effective buffer management and frame synchronization without the need for complex multipath algorithms in the OTN layer.  We show that using network coding can also reduce the delay caused by packet re-ordering at the receiver side, thus requiring a smaller overall buffer size, while improving the network throughput.  We design the framework in full compliance with high-speed Ethernet standards specified in IEEE802.3ba and present solutions for network encoding, data structure of coded parallel transmission, buffer management and decoding at the receiver side.  The proposed network coded parallel transmission framework is simple to implement and represents a potential major breakthrough in the system design of future high-speed Ethernet. 
X. Chen, Jukan, A., and Médard, M., “A Novel Network Coded Parallel Transmission Framework for High-Speed Ethernet”, accepted to Globecom 2013 - Optical Networks and Systems Symposium

Network Coding for improved circuit-based resilience
Currently, 1 + 1
dedicated path protection appears to be the most widely deployed
network resilience mechanism because it offers instantaneous
recovery from network failures. However, 1 + 1 protection
consumes almost twice as much capacity as required, which
imposes a stringent constraint on network resource utilization. In
addition, finding an SRLG-disjoint path is essential for 1+1 protection,
which is nonetheless subject to non-trivial computation
complexity and may fail in some SRLG scenarios.  Generalized Dedicated Protection (GDP),
achieves instantaneous recovery from any SRLG failure
event. Finding a non-bifurcated optimal
solution for GDP is NP-complete but a
novel scheme applying bifurcated flows and Network Coding
(GDP-NC) ensures both optimal resource utilization among
dedicated protection approaches and instantaneous recovery for
single unicast flows which can be split into multiple parts in alloptical
networks. 
P. Babarczi, Tapolcai, J., Ho, P.-H.,  and Médard, M., “Optimal Dedicated Protection Approach to Shared Risk Link Group Failures using Network Coding”, ICC ONS 2012

Joint Source Coding and Network Coding
Using Turbo codes and random coding
G. Maierbacher, Barros, J., and Médard, M., “Practical Source-Network Decoding”,, IEEE International Symposium on Wireless Communication Systems, September 2009

Using network coding inside of switches with multicast in order to emulate speed-up
Intra-flow linear network coding is shown to
achieve a larger rate region than the case without coding.
M. Kim, Sundararajan, J.K, Médard, M., Eryilmaz, A., Koetter, R., “Network Coding in a Multicast Switch”, IEEE Transactions on Information Theory, vol. 57, no. 1, January 2011, pp. 436-460

Sparsity - tunable sparsity with RLNC
this allows tunability to vary within a network
S. Feizi, Lucani, D., and Médard, M., “Tunable Sparse Network Coding”, invited paper, IZS 2012

Network coding for time-division duplex particularly in long-latency networks (such as satellite or underwater networks)
D. Lucani, Médard, M., and Stojanovic, M., “On Coding for Delay - Network Coding for Time Division Duplexing”, IEEE Transactions on Information Theory, vol. 58, no. 4, pp. 2330 - 2348

Scheduling for multicasting in mesh networks
D. Traskov, Heindlmaier, M., Médard, M., and Kötter, R., “Scheduling for Network Coded Multicast”, IEEE/ACM Transactions on Networking, vol. 20, no. 5, pp. 1479 – 1488

On the topic of analog network coding, which is good in high SNR
 I. Maric, Goldsmith, A., and Médard, M., “Multihop Analog Network Coding via Amplify-and-Forward: The High SNR Regime”, IEEE Transactions on Information Theory, vol. 58, no. 2, February 2012, pp. 793 – 803

On the benefit of coding together using RLNC different layers in multi-resolution coding
M. Kim, Lucani, D., Shi, X., Zhao, F. and Médard, M., “Network coding for multi-resolution multicast”, INFOCOM 2010

Use of RLNC in MPEG
mixing layers using RLNC, when done with the right parameters, can be very beneficial
Soussi, Khaled, “Evaluation of a Wireless Video Transmission using Network Coding”, Technical University Munich,Fall 2008

RLNC for coded mirror sites
coding allows for less storage, for the same level of redundancy,than replication
S. Huang, Ramamoorthy, A. Médard, M., “Minimum Cost Mirror Sites Using Network Coding: Replication vs. Coding at the Source Nodes”, IEEE Transactions on Information Theory, vol. 57, no. 2, February 2011, pp. 1080-1091    

Optimization for multicat subgraph construction
network coding turns the problem of multicast from a fractional Steiner tree packing problem to a convex problem
D.S. Lun, Ratnakar, N., Médard, M., Koetter, R., Karger, D.R., Ho, T., Ahmed, E., and Zhao, F., “Minimum-Cost Multicast over Coded Packet Networks,” IEEE Transactions on Information Theory, Vol. 52, Issue 6, pp. 2608-2623, June 2006    
that allows a distributed solution with provable convergence in the dual AND the primal simultaneously
Fang Zhao, Muriel Medard, Asuman Ozdaglar, Desmond S Lun "Convergence study of decentralized min-cost subgraph algorithms for multicast in coded networks", accepted to IT Transactions
also F. Zhao, "Distributed Control of Coded Networks", MIT Ph.D. Thesis, 2010
Since we had discussions about security, I include some applications below, in a separate section

----

Extending watchdog in wireless security to coding
Algebraic Watchdog takes advantage of the broadcast nature of wireless networks to
provide a secure global self-checking network. Algebraic Watchdog allows nodes to
detect malicious behaviors probabilistically, and police their neighbors locally using
overheard messages. Unlike traditional detection protocols which are receiver-based,
this protocol gives the senders an active role in checking the nodes downstream. We
provide a trellis-based inference algorithm and protocol for detection, and analyze its
performance.
M. Kim, Médard, M., and Barros, J., “Algebraic Watchdog: Mitigating Misbehavior in Wireless Network Coding”, IEEE Journal of Selected Areas in Communications, vol. 29, no. 10, December 2011
M. Kim, Médard, M., Barros, J. and Koetter, R., “An Algebraic Watchdog for Wireless Network Coding”, ISIT, July 2009

Lightweight encryption by using RLNC and encrypting only the coding coefficients
The key idea is to limit the encryption operations to
a critical set of network coding coefficients in combination
with multi-resolution video coding
L. Lima, Gheorghiu, S., Barros, J., Médard, M., and Toledo, A. T. “Secure Network Coding for Multi-Resolution Wireless Video Streaming,” IEEE Journal of Selected Areas in Communications, vol. 28, Issue 3, March 2010 , pp. 377-388

Protecting against Byzantine attackers using RLNC and polynomial hashes and/or RLNC and error-correcting codes
S. Jaggi, Langberg M., Katti S., Ho T., Katabi D., Médard, M., and Effros, E.,  “Resilient Network Coding in the Presence of Byzantine Adversaries”, Special Issue on Information-theoretic Security of the IEEE Transactions on Information Theory, Volume 54,  Issue 6,  June 2008, pp. 2596 - 2603
T.  Ho, Leong, B., Koetter, R., Médard, M., and Effros, E., “Byzantine Modification Detection in Multicast Networks with Random Network Coding”, Special Issue on Information-theoretic Security of the IEEE Transactions on Information Theory, Volume 54,  Issue 6,  June 2008, pp. 2798-2803
M. Kim, Lima, L., Zhao, F., Barros, J, Médard, M., Koetter, R., Kalker, T. and Han, K., “On Counteracting Byzantine Attacks in Network Coded Peer-to-Peer Networks”, IEEE Journal on Selected Areas in Communications: Special Issue on Mission-Critical Infrastructure, vol 28, Issue 5, May 2010, pp. 692-702**

Homomorphic encryption with network coding
We need to have a
signature scheme that allows nodes to check the validity of a packet without decoding.
In this work, we propose such a signature scheme for network coding. Our scheme
makes use of the linearity property of the packets in a coded system, and allows
nodes to check the integrity of the packets received easily.
F. Zhao, Kalker, T., Médard, M., and Han, K., “Signatures for Content Distribution with Network Coding,” ISIT (5 pages), July 2007
Going Beyond Pollution Attacks: Forcing Byzantine Clients to Code
Correctly
Authors: Raluca Ada Popa, Alessandro Chiesa, Tural Badirkhanli, Muriel Médard
http://arxiv.org/submit/297371

---

From: LOCHIN Emmanuel <[email-masked]>
Date: Wed, 31 Jul 2013 11:04:25 +0200

Dear all,

Following Muriel's email, you will find below a set of implementations 
and algorithms using the on-the-fly coding concept in various case 
ranging from multipath; handover to DTN; All of these contribs should be 
available on the net, if you experience difficulties to get them feel 
free to ask me.
@Muriel, I will be indeed interested in your VTC paper, thanks :)

We wish to remark that we did not patented any of these mechanisms.

Emmanuel

On-the-fly coding for multipath inside CMT-SCTP:

eCMT-SCTP : Improving Performance of Multipath SCTP with Erasure Coding 
Over Lossy Links,
Golam Sarwar, Pierre-Ugo Tournoux, Roksana Boreli, Emmanuel Lochin,
accepted for publication in IEEE LCN 2013

On-the-fly coding for video over multipath:

Online multipath convolutional coding for real-time transmission,
Tuan Tran-Thai, Emmanuel Lochin, Jérôme Lacan,
In 19th International Packet Video Workshop, 10-11 May 2012, Munich, 
Germany.

On-the-fly coding for vertical TCP handover :

A packet error recovery scheme for vertical handovers mobility 
management protocols
Tournoux, Pierre-Ugo and Lochin, Emmanuel and Petander, Henrik and 
Lacan, Jérôme
In ICST MobiQuitous - 7th International ICST Conference on Mobile and 
Ubiquitous Systems, 06-09 Dec 2010, Sydney, Australia.
-> extension with analytical modeling in :
A packet error recovery scheme for vertical handovers mobility 
management protocols,
Pierre-Ugo Tournoux, Emmanuel Lochin, Henrik Petander, Jérôme Lacan,
In Press ICST Transactions on Ubiquitous Environnements (selected 
papers from Mobiquitous’10)

On-the-fly coding for robust streaming in opportunistic/social DTN 
networks:

Robust streaming in delay tolerant networks
Tournoux, Pierre-Ugo and Lochin, Emmanuel and Leguay, Jérémie and 
Lacan, Jérôme
IEEE International Conference on Communications (IEEE ICC 2010), 23-27 
May 2010, Cape Town, South Africa.

On-the-fly coding for realtime multimedia apps :

Tournoux, Pierre-Ugo and Lochin, Emmanuel and Lacan, Jérôme and 
Bouabdallah, Amine and Roca, Vincent On-the-fly erasure coding for 
real-time video applications
IEEE Transactions on Multimedia, vol. 13 (n° 4). pp. 797-812. ISSN 
1520-9210

On-the-Fly Coding for Real-Time Applications
Tournoux, Pierre-Ugo and Bouabdallah, Amine and Lacan, Jérôme and 
Lochin, Emmanuel
ACM Multimedia 2009 System Track, 19-23 Oct 2009, Beijing, China.

Le 30.07.2013 22:10, Muriel Medard a écrit :
> Dear Victor and all,
>
> thank you for great pre-meeting on Monday! As Victor requested, here
> are some implementations and algorithms, and their basic
> characteristics, with some references. The algorithms all refer to
> discussion topics we had. I am sorry that I shall not be able to
> attend the Wednesday meeting.
>
> Best,
>
> Muriel.
>
>
> Jay Kumar Sundararajan, Devavrat Shah, Muriel Médard, Szymon
> Jakubczak, Michael Mitzenmacher, João Barros,
> http://arxiv.org/abs/1208.3212 2012 CoRR abs/1208.3212
> db/journals/corr/corr1208.html#abs-1208-3212
> RLNC and PHY-level convolutional codes work separately in coding and
> decoding, but co-designing the right level of redundancy provides
> advantages
> G. Angelopoulos, Paidimarri, A., Chandrakasan, A. P., and Médard, M.,
> “Experimental Study of the Interplay of Channel and Network Coding in
> Low Power Sensor Applications”, ICC WCS 2013
>
>
> Other work on coordinating network coding and PHY-layer coding,
> without the use of joint coding, but rather by controlling rate alone
> M. Xiao, Médard, M., and Aulin, T., “Cross-Layer Design of Rateless
> Random Codes for Delay Optimization”, IEEE Transactions on
> Communications, vol. 59, no. 12, December 2011, pp. 3311 - 3322
>
>
> RLNC at the ENode B
> Compared to HARQ and ARQ mechanisms, the architecture can offer up to
> 5.9 times gain in throughput and 5.5 times reduction in end-to-end le
> transfer
> applications.
> delay.
> S. Teerapittayanon, Fouli, K., Médard, M., Montpetit, M.-J., Shi, X.,
> Seskar, I., and Gosain, A., “Network Coding as a WiMAX Link
> Reliability Mechanism”, MACOM 2012**
> S. Teerapittayanon, Fouli, K., Médard, M., Montpetit, M.-J., Shi, X.,
> Seskar, I., and Gosain, A., “Network Coding as a WiMAX Link
> Reliability Mechanism: An Experimental Demonstration”, MACOM 2012
> S. Teerapittayanon
> X. Shi, Médard, M. and Lucani,. D., “Whether and Where to Code in the
> Wireless Relay Channel”, accepted to IEEE Journal of Selected Areas 
> in
> Communication, Vol. 31, No. 8, August 2013
>
> U. Ferner, Médard, M., and Soljanin, E., “Toward Sustainable
> Networking: Storage Area Networks with Network Coding”, Allerton
> Conference 2012
> U. Ferner, Wang, T., Médard, M., "Network Coded Storage with
> Multi-resolution codes", to be presented at Asilomar 2013
>
> A. Rezaeee, du Pin Calmon, F., Zeger, L., and Médard, M.,  “Speeding
> Multicast by Acknowledgment Reduction Technique (SMART) Enabling
> Robustness of QoE to the Number of Users”, IEEE Journal of Selected
> Areas in Communication, vol. 30, no. 7, August 2012, pp. 1270-1280
>
>
> J. Cloud, Zeger, L., and Médard, M., “MAC Centered Cooperation -
> Synergistic Design of Network Coding, Multi-Packet Reception, and
> Improved Fairness to Increase Network Throughput”, IEEE Journal of
> Selected Areas in Communication, vol. 30, no. 2, February 2012, pp.
> 341 - 349
> Cloud, Jason, “Cross-Layer Design with Multi-Packet Reception, MAC,
> and Network Coding in Multi-Hop Networks”, MIT MS Thesis, 2011
> Arman Rezaee, Network Coding, Multi-Packet Reception, and  Feedback:
> Design Tools for Wireless Broadcast Networks”,  MIT MS Thesis, 2011
>
>
> A. ParandehGheibi, Médard, M., Ozdaglar, A., and Shakkottai, S.,
> “Avoiding Interruptions—A QoE Reliability Function for Streaming 
> Media
> Applications”, IEEE Journal on Selected Areas in Communications,
> special issue on “Trading rate for Delay at the Transport and
> Application Layers”, vol. 29, no. 5, May 2011, pp. 1064-1074
> For media streaming in technology and cost heterogeneous
> environments, we employ random linear network coding to address
> A. ParandehGheibi, Médard, M., Ozdaglar, A., and Shakkottai, S.,
> “Access-Network Association Policies for Media Streaming in
> Heterogeneous Environments”, CDC 2010
> A. Kulkarni, Heindlmaier, M., Traskov, D., Médard, M., and Montpetit,
> M.-J., “An Implementation of Network Coding with Association Policies
> in Heterogeneous Networks”, NC-Pro Workshop 2011
>
> Parallel transmission, as  defined in high-speed Ethernet standards,
> enables to use  less expensive   optoelectronics  and offers
> backwards compatibility with legacy Optical Transport Network (OTN)
> infrastructure.  However, optimal parallel transmission does not 
> scale
> to large networks, as it requires computationally expensive multipath
> routing algorithms in the OTN layer to minimize differential delay,
> and thus the required buffer size, optimize  traffic splitting ratio,
> and ensure time-constrained frame synchronization. In this paper, we
> propose a novel framework for high-speed Ethernet, which we refer to
> as network coded parallel transmission, capable of effective buffer
> management and frame synchronization without the need for complex
> multipath algorithms in the OTN layer.  We show that using network
> coding can also reduce the delay caused by packet re-ordering at the
> receiver side, thus requiring a smaller overall buffer size, while
> improving the network throughput.  We design the framework in full
> compliance with high-speed Ethernet standards specified in 
> IEEE802.3ba
> and present solutions for network encoding, data structure of coded
> parallel transmission, buffer management and decoding at the receiver
> side.  The proposed network coded parallel transmission framework is
> simple to implement and represents a potential major breakthrough in
> the system design of future high-speed Ethernet.
> X. Chen, Jukan, A., and Médard, M., “A Novel Network Coded Parallel
> Transmission Framework for High-Speed Ethernet”, accepted to Globecom
> 2013 - Optical Networks and Systems Symposium
>
>
> P. Babarczi, Tapolcai, J., Ho, P.-H.,  and Médard, M., “Optimal
> Dedicated Protection Approach to Shared Risk Link Group Failures 
> using
> Network Coding”, ICC ONS 2012
>
> G. Maierbacher, Barros, J., and Médard, M., “Practical Source-Network
> Decoding”,, IEEE International Symposium on Wireless Communication
> Systems, September 2009
>
> M. Kim, Sundararajan, J.K, Médard, M., Eryilmaz, A., Koetter, R.,
> “Network Coding in a Multicast Switch”, IEEE Transactions on
> Information Theory, vol. 57, no. 1, January 2011, pp. 436-460
>
> Network coding for time-division duplex particularly in long-latency
> networks (such as satellite or underwater networks)
> D. Lucani, Médard, M., and Stojanovic, M., “On Coding for Delay -
> Network Coding for Time Division Duplexing”, IEEE Transactions on
> Information Theory, vol. 58, no. 4, pp. 2330 - 2348
>
> D. Traskov, Heindlmaier, M., Médard, M., and Kötter, R., “Scheduling
> for Network Coded Multicast”, IEEE/ACM Transactions on Networking,
> vol. 20, no. 5, pp. 1479 – 1488
>
>  I. Maric, Goldsmith, A., and Médard, M., “Multihop Analog Network
> Coding via Amplify-and-Forward: The High SNR Regime”, IEEE
> Transactions on Information Theory, vol. 58, no. 2, February 2012, 
> pp.
> 793 – 803
>
> M. Kim, Lucani, D., Shi, X., Zhao, F. and Médard, M., “Network coding
> for multi-resolution multicast”, INFOCOM 2010
>
> Use of RLNC in MPEG
> Soussi, Khaled, “Evaluation of a Wireless Video Transmission using
> Network Coding”, Technical University Munich,Fall 2008
>
> S. Huang, Ramamoorthy, A. Médard, M., “Minimum Cost Mirror Sites
> Using Network Coding: Replication vs. Coding at the Source Nodes”,
> IEEE Transactions on Information Theory, vol. 57, no. 2, February
> 2011, pp. 1080-1091
>
> network coding turns the problem of multicast from a fractional
> Steiner tree packing problem to a convex problem
> D.S. Lun, Ratnakar, N., Médard, M., Koetter, R., Karger, D.R., Ho,
> T., Ahmed, E., and Zhao, F., “Minimum-Cost Multicast over Coded 
> Packet
> Networks,” IEEE Transactions on Information Theory, Vol. 52, Issue 6,
> pp. 2608-2623, June 2006
> Fang Zhao, Muriel Medard, Asuman Ozdaglar, Desmond S Lun "Convergence
> study of decentralized min-cost subgraph algorithms for multicast in
> coded networks", accepted to IT Transactions
> M. Kim, Médard, M., and Barros, J., “Algebraic Watchdog: Mitigating
> Misbehavior in Wireless Network Coding”, IEEE Journal of Selected
> Areas in Communications, vol. 29, no. 10, December 2011
> M. Kim, Médard, M., Barros, J. and Koetter, R., “An Algebraic
> Watchdog for Wireless Network Coding”, ISIT, July 2009
>
>
>
> L. Lima, Gheorghiu, S., Barros, J., Médard, M., and Toledo, A. T.
> “Secure Network Coding for Multi-Resolution Wireless Video 
> Streaming,”
> IEEE Journal of Selected Areas in Communications, vol. 28, Issue 3,
> March 2010 , pp. 377-388
>
>
> Protecting against Byzantine attackers using RLNC and polynomial
> hashes and/or RLNC and error-correcting codes
> S. Jaggi, Langberg M., Katti S., Ho T., Katabi D., Médard, M., and
> Effros, E.,  “Resilient Network Coding in the Presence of Byzantine
> Adversaries”, Special Issue on Information-theoretic Security of the
> IEEE Transactions on Information Theory, Volume 54,  Issue 6,  June
> 2008, pp. 2596 - 2603
> T.  Ho, Leong, B., Koetter, R., Médard, M., and Effros, E.,
> “Byzantine Modification Detection in Multicast Networks with Random
> Network Coding”, Special Issue on Information-theoretic Security of
> the IEEE Transactions on Information Theory, Volume 54,  Issue 6,
> June 2008, pp. 2798-2803
> M. Kim, Lima, L., Zhao, F., Barros, J, Médard, M., Koetter, R.,
> Kalker, T. and Han, K., “On Counteracting Byzantine Attacks in 
> Network
> Coded Peer-to-Peer Networks”, IEEE Journal on Selected Areas in
> Communications: Special Issue on Mission-Critical Infrastructure, vol
> 28, Issue 5, May 2010, pp. 692-702**
>
>
>
> F. Zhao, Kalker, T., Médard, M., and Han, K., “Signatures for Content
> Distribution with Network Coding,” ISIT (5 pages), July 2007
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 31 Jul 2013 11:13:58 +0200

This is a great list that fits nicely into the Table of Content I prepared Monday that I think covers these and more as well as includes some of the topics already in the proposed group web site.

Please comment and contribute!

(I followed the IETF format for drafts.)

Title: Network Coding Taxonomy

IPR disclosure(s)

Introduction
(why we need this, network evolution, bottleneck resources etc.)

Network fundamentals
(beyond the butterfly, Inter and intra flow coding, etc.)

Implementations
- Random Linear Network Coding
- Deterministic Network Coding
- Other
 (allow universities/companies/entities who have other implementations to present them)      

Use cases
(inputs from MIT as presented by Muriel and from other list members)
(this is very important to get the support of the community includes but is not limited to storage (CDN and caching), routing, Information/content centric,channel bundling, multipath, MANET/VANET, multimedia, TV, video on demand, software defined networking, industrial networking and applications, economics etc.)

Topologies
- end to end
- re-encoding/relay
- point to multipoint
- multipoint to multipoint
- peer-to-peer
- other?

Interactions with other protocols
(not sure if this should be there but includes congestion control, routing etc.)

Candidates for interoperability
( generations size, Galois field, topology, type, packet format etc.)

Conclusion
Acknowledgement
References

Marie-José Montpetit
[email-masked]
[email-masked]