Subject: [nwcrg] Fwd: [tcpm] New Version Notification for draft-flach-tcpm-fec-00.txt

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 16 Jul 2013 09:22:16 +0000

Hi,

NWCRG folks, this may be of interest to you. The discussion is happening on the TCPM list.

Draft authors, I wanted to make you aware of a proposed new research group in the IRTF on network coding. They will meet in Berlin.

Lars

Begin forwarded message:

> From: Yuchung Cheng <[email-masked]>
> Subject: [tcpm] Fwd: New Version Notification for draft-flach-tcpm-fec-00.txt
> Date: July 15, 2013 23:49:13 GMT+02:00
> To: "[email-masked] Extensions" <[email-masked]>
> 
> Hi
> 
> We are proposing an outrageous idea to send parity data in TCP
> packet to promote sub 1-RTT loss recovery. This requires a separate
> sequence space which we aren't quite sure how to do this yet without
> upsetting middle-boxes. More data can be found in our new paper
> "Reducing Web Latency: the Virtue of Gentle Aggression" sigcomm 2013
> http://static.googleusercontent.com/external_content/untrusted_dlcp/research.google.com/en/us/pubs/archive/41217.pdf
> 
> Comments are very welcome. Linux patches release are under way.
> 
> 
> ---------- Forwarded message ----------
> From:  <[email-masked]>
> Date: Sun, Jul 14, 2013 at 4:59 PM
> Subject: New Version Notification for draft-flach-tcpm-fec-00.txt
> To: Tobias Flach <[email-masked]>, Nandita Dukkipati
> <[email-masked]>, Yuchung Cheng <[email-masked]>, Barath
> Raghavan <[email-masked]>
> 
> 
> 
> A new version of I-D, draft-flach-tcpm-fec-00.txt
> has been successfully submitted by Tobias Flach and posted to the
> IETF repository.
> 
> Filename:        draft-flach-tcpm-fec
> Revision:        00
> Title:           TCP Instant Recovery: Incorporating Forward Error
> Correction in TCP
> Creation date:   2013-07-15
> Group:           Individual Submission
> Number of pages: 15
> URL:             http://www.ietf.org/internet-drafts/draft-flach-tcpm-fec-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-flach-tcpm-fec
> Htmlized:        http://tools.ietf.org/html/draft-flach-tcpm-fec-00
> 
> 
> Abstract:
>   Ordinary TCP loss recovery takes at least one round-trip time and as
>   such can increase application-perceived latency, especially for short
>   flows such as Web transactions.  TCP Instant Recovery (TCP-IR) is an
>   experimental algorithm that allows a receiving end to recover lost
>   packets without retransmissions, thus potentially saving at least one
>   full round-trip time compared to standard TCP.  TCP-IR achieves this
>   by judiciously injecting encoded data segments within a TCP stream.
>   This document describes the TCP-IR algorithm at the sending and
>   receiving ends, along with the required protocol changes.
> 
> 
> 
> 
> The IETF Secretariat
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Brian Adamson <[email-masked]>
Date: Tue, 16 Jul 2013 08:50:33 -0400

Thanks Lars,  we've already had some dialog with the authors and they may be providing a presentation at the NWCRG meeting.  

Sent from my iPad

On Jul 16, 2013, at 5:22 AM, "Eggert, Lars" <[email-masked]> wrote:

> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg