Subject: [nwcrg] suggested addition to NWCRG charter text, for discussion

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 16 Oct 2013 10:30:33 +0000

Hi,

as a result of the discussions in and after Berlin, and in preparation for the Vancouver meeting, I'd like to propose an addition to the current draft charter. (Which is at http://trac.tools.ietf.org/group/irtf/trac/wiki/nwcrg.) I'd like to discuss this addition with the group.

Here is the suggested addition:

"A lot of intellectual property exists in the general area of coding, and specifically, network coding. Research results that are covered by intellectual property rights can of course be brought to and discussed in the group. However, the IRTF requires participants to disclose the existence of IPR in a timely manner when they bring such contributions to the group; please see http://irtf.org/ipr for details.

One desired outcome of the research group is to transition research results in network coding into widely used Internet protocols and technologies. Experience has shown that this transition is much easier when research results under IPR are available without the need to obtain licenses or pay fees. This is why RFC5743 prefers 'that the most liberal terms possible be made available for specifications published as IRTF Stream documents. Terms that do not require fees or licensing are preferable.  Non-discriminatory terms are strongly preferred over those which discriminate among users.' When publishing its results in RFC form, the NWCRG therefore strives to make recommendations that follow this principle."

One could argue that text like this could be part of any RG charter and is therefore redundant. My motivation for including it in this case is that this area of research has a large volume of IPR as well as participants that are new to the IRTF and IETF, and we want to make it very clear what the correct approach here is.

Thoughts?

Thanks,
Lars

---

From: Vincent Roca <[email-masked]>
Date: Wed, 16 Oct 2013 13:46:32 +0200

Hello everybody,

I'm in favor of having this kind of text somewhere since clarifying the situation is always a plus.
I don't know if the charter is the best place for that, but why not. It could also be visibly mentioned
in the web site (but may be this is not feasible if it's not in the charter itself).

In any case the chairs should also emphasize (i.e. **insist** on the related slide during meeting
introduction as was the case in Berlin) for those of us who participate to the meeting.

BTW here's the IPR disclosures I've noticed following our Berlin meeting:

** Code On Network Coding, LLC's Statement about IPR related to IRTF network coding research group
meeting and discussions in Berlin on 7/29/13-7/31/13 (2)
https://datatracker.ietf.org/ipr/2183/
	I note there's one or more unpublished pending patent application mentioned in addition to the list.
	I hope this IPR disclosure will be updated in a timely manner when the patent application will
	become public.

** Code On Network Coding LLC's Statement about IPR related to IRTF network coding research group
meeting in Orlando on 3/11/13 (2) 
https://datatracker.ietf.org/ipr/2184/
	(in fact an update to the Orlondo IPR disclosure, but I don't know what the difference is)
	Same comment concerning unpublished pending patent application.

** NUI Maynooth's Statement about IPR related to NWCRG/ICCRG coded tcp slides 
https://datatracker.ietf.org/ipr/2158/

I see there's no licensing information in any of these disclosures for the moment.

Cheers,

    Vincent

--
   Vincent Roca, PhD, Inria research institute, France
   http://planete.inrialpes.fr/people/roca

On Oct.16 oct. 2013, 12:30, Eggert, Lars wrote:

> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Brian Adamson <[email-masked]>
Date: Wed, 16 Oct 2013 09:51:36 -0400

I think this statement is very desirable.  In fact, it's pretty frank and to the point and could be applied to charter of many IETF groups as well.  I think the reference here to RFC5743 helps emphasize the importance of this in the context of an IRTF group to help promote sharing of research ideas, implementations, etc.

Brian Adamson
[email-masked]

---

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Wed, 16 Oct 2013 17:50:57 +0000

I agree with Brian and Lars. We need all research to be free to flow and useable in the research community. We can put it as a statement at the end of our draft Charter and update it as needed.

This is also good for all groups. Maybe we can have this statement on the IRTF page and have all groups refer to it.

Victor

From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Adamson
Sent: Wednesday, October 16, 2013 9:52 AM
To: Eggert, Lars
Cc: [email-masked]; [email-masked] Steering Group
Subject: Re: [nwcrg] suggested addition to NWCRG charter text, for discussion

Brian Adamson
[email-masked]<mailto:[email-masked]>

Hi,

Thoughts?

Thanks,
Lars
_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Wed, 16 Oct 2013 23:10:22 +0200

Victor,

It's already in IRTF page:
	http://irtf.org/ipr

Otherwise I'm happy to see this idea gathers momentum.
Cheers,

   Vincent

Le 16 oct. 2013 à 19:50, Firoiu, Victor (US SSA) a écrit :

> as a result of the discussions in and after Berlin, and in preparation for the Vancouver meeting, I'd like to propose an addition to the current draft charter. (Which is athttp://trac.tools.ietf.org/group/irtf/trac/wiki/nwcrg.) I'd like to discuss this addition with the group.
>

---

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Thu, 17 Oct 2013 14:44:14 +0000

Lars and Netcoders,

I propose to add this statement provisionally at the end of our proposed Charter and update it when we have other suggestions. We will have a final discussion in Vancouver when we will discuss and hopefully approve the Charter and the NWC group.

Victor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eggert, Lars
Sent: Wednesday, October 16, 2013 6:31 AM
To: [email-masked]
Cc: [email-masked] Steering Group
Subject: [nwcrg] suggested addition to NWCRG charter text, for discussion

Hi,

Thoughts?

Thanks,
Lars