Subject: Re: [nwcrg] Case studies of network coding.

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Wed, 6 Nov 2013 05:32:35 +0000

Marie-José,

Thank you for your proposed outline for taxonomy and I apologize for the delay. I think it is a good start, given our discussions in Berlin.

We've been thinking about how to best approach the description of this rather complex field. I think it would be good to use the freedom of IRTF and start assembling the terminology without consideration of classification on sections. Once we have a critical mass, we can organize them along the lines in your outline.

I will send next a beginning of such collection and propose to be expanded and revised by contributions from our group.

Thanks again,

Victor

On 07/31/2013 05:13 AM, Marie-Jose Montpetit wrote:
> This is a great list that fits nicely into the Table of Content I prepared Monday that I think covers these and more as well as includes some of the topics already in the proposed group web site.
> Please comment and contribute!
> (I followed the IETF format for drafts.)
> Title: Network Coding Taxonomy
> IPR disclosure(s)
> Introduction
> (why we need this, network evolution, bottleneck resources etc.)
> Network fundamentals
> (beyond the butterfly, Inter and intra flow coding, etc.)
> Implementations
> - Random Linear Network Coding
> - Deterministic Network Coding
> - Other
>  (allow universities/companies/entities who have other implementations to present them)
> Use cases
> (inputs from MIT as presented by Muriel and from other list members)
> (this is very important to get the support of the community includes but is not limited to storage (CDN and caching), routing, Information/content centric,channel bundling, multipath, MANET/VANET, multimedia, TV, video on demand, software defined networking, industrial networking and applications, economics etc.)
> Topologies
> - end to end
> - re-encoding/relay
> - point to multipoint
> - multipoint to multipoint
> - peer-to-peer
> - other?
> Interactions with other protocols
> (not sure if this should be there but includes congestion control, routing etc.)
> Candidates for interoperability
> ( generations size, Galois field, topology, type, packet format etc.)
> Conclusion
> Acknowledgement
> References
>
> Marie-José Montpetit
> [email-masked]
> [email-masked]
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 5 Nov 2013 21:36:08 -0800

Just let me know how I can help. I thought sections would help to organize thoughts as my experience with freeform can lead to inefficiencies.

/mjm
Marie-Jose Montpetit
[email-masked]

On Nov 5, 2013, at 9:32 PM, Firoiu, Victor (US SSA) <[email-masked]> wrote:

> We’ve been thinking about how to best approach the description of this rather complex field. I think it would be good to use the freedom of IRTF and start assembling the terminology without consideration of classification on sections. Once we have a critical mass, we can organize them along the lines in your outline.
>  
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg