Subject: Re: [nwcrg] Draft NWCRG agenda for IETF/IRTF 88 Vancouver meeting

From: <[email-masked]>
Date: Tue, 5 Nov 2013 10:18:44 -0800

Dear Victor and all,

The talks look very interesting, looking forward to them! I would be glad to present on the following if there is still room for a short talk – sorry for the late notice.

Best wishes,
Tracey

Title: Multi-source network error correction with distributed Reed Solomon codes

Abstract: Network error correction coding generalizes classical error correction coding to communication over networks. The special case of single-source multicast has been extensively studied in the network coding literature. However, single-source code constructions, which require all information to be available at a single source node, do not extend straightforwardly to the multi-source case where different information is available at different source nodes. We find the multi-source multicast capacity region for general networks, showing that redundant capacity for error correction can be fully shared across different sources. We show that the problem of reliably downloading information from multiple nodes, each having a subset of the demanded messages, is equivalent to a special case of this problem. For this problem, we design a low-complexity distributed coding scheme in which the vectors of symbols received at the sink correspond to codewords from a single Reed Solomon code.

-----Original Message-----
From: Firoiu, Victor (US SSA) [mailto:[email-masked]] 
Sent: Wednesday, October 23, 2013 8:35 AM
To: [email-masked]
Subject: [nwcrg] Draft NWCRG agenda for IETF/IRTF 88 Vancouver meeting

Dear NetCoders,

Based on your requests, we have put together a draft agenda for the upcoming Vancouver meeting.
It is scheduled for Thursday, November 7 at 1pm-3pm.

Please let us know if you have comments on content, order, etc.

If you are interested to present your experiences or open problems, please send a title, short abstract and estimated time, and we'll try to fit you into our 2hr slot.

Best,

Victor

== Meeting Agenda for NWCRG proposed Network Coding Research Group, Vancouver, November 7, 2013 ==

Agenda bashing

Note well, IPR

Brief (Re)Introduction of Network Coding proposed Research Group - Victor Firoiu (BAE Systems), Brian Adamson (NRL)

Not so random, random linear codes - Vincent Roca (INRIA)

Loss Tolerant TCP - Koushik Kar (Lincoln Labs)

RMT and FecFrame Retrospective -  Brian Adamson (NRL)

Content Coding in an experimental ICN (Information Centric Network) - Mario Gerla (UCLA)

Network Coding Taxonomy - Victor Firoiu (BAE Systems), Brian Adamson (NRL)

Discuss NWCRG Charter and establishing NWC as IRTF Group

---

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Tue, 5 Nov 2013 20:06:27 +0000

Hi Tracey,

We think your talk would be interesting to the group and we can fit it for 15min in our agenda.

All the best,

Victor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, November 05, 2013 1:19 PM
To: Firoiu, Victor (US SSA); [email-masked]
Subject: RE: [nwcrg] Draft NWCRG agenda for IETF/IRTF 88 Vancouver meeting

Dear Victor and all,

Best wishes,
Tracey

-----Original Message-----
From: Firoiu, Victor (US SSA) [mailto:[email-masked]] 
Sent: Wednesday, October 23, 2013 8:35 AM
To: [email-masked]
Subject: [nwcrg] Draft NWCRG agenda for IETF/IRTF 88 Vancouver meeting

Dear NetCoders,

Best,

Victor

Agenda bashing

Note well, IPR

---

From: <[email-masked]>
Date: Tue, 5 Nov 2013 21:31:01 -0800

Thanks very much Victor! I have updated my talk information slightly, adding a few clarifications in response to questions from some who are not as familiar with the topic.

Best wishes,
Tracey

Title: Multi-source network error correction coding

Abstract: Network error correction coding generalizes classical error correction coding to communication over networks. In particular, network error correction codes combining random linear network coding (RLNC) with error correction can provide robustness to link or packet errors, which has been extensively studied for the special case of single-source multicast. However, single-source code constructions, which require all information to be available at a single source node, do not extend straightforwardly to the multi-source case where different information is available at different source nodes. We find the multi-source multicast capacity region for general networks, showing that redundant capacity for error correction can be fully shared across different sources, by constructing novel distributed error correction codes leveraging RLNC in the network. We show that the problem of reliably downloading information from distributed storage nodes, each having a subset of the demanded messages, is equivalent to a special case of this problem. For this problem, we design a low-complexity distributed coding scheme in which the vectors of downloaded symbols correspond to codewords from a single Reed Solomon code.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Firoiu, Victor (US SSA)
Sent: Tuesday, November 05, 2013 12:06 PM
To: [email-masked]
Cc: Firoiu, Victor (US SSA)
Subject: Re: [nwcrg] Draft NWCRG agenda for IETF/IRTF 88 Vancouver meeting

Hi Tracey,

All the best,

Victor