Subject: [nwcrg] NWCRG agenda and presentations for tomorrow's meeting

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Thu, 7 Nov 2013 02:37:08 +0000

Dear NetCoders,

We uploaded an updated Agenda and all your presentations at https://datatracker.ietf.org/meeting/88/materials.html (look for the NWCRG section).

Our meeting will be in the Plaza C room at 1pm. Please arrive early so we can start on time and be able to go through all items we scheduled, including discussing and approving our Charter.

If we find that we need more time for discussion, especially on Taxonomy and Architecture, we have the Constable room reserved until 5:20pm.

See you all tomorrow,

Victor Firoiu and Brian Adamson

---

From: "Firoiu, Victor (US SSA)" <[email-masked]>
Date: Thu, 7 Nov 2013 02:54:59 +0000

We actually have the Constable room for longer time: 15:00-19:30, thanks to Lars.

Victor

From: [email-masked] [mailto:[email-masked]] On Behalf Of Firoiu, Victor (US SSA)
Sent: Wednesday, November 06, 2013 9:37 PM
To: [email-masked]
Subject: [nwcrg] NWCRG agenda and presentations for tomorrow's meeting

Dear NetCoders,

See you all tomorrow,

---

From: Cedric Adjih <[email-masked]>
Date: Thu, 7 Nov 2013 18:00:35 +0100 (CET)

Dear all,

  Here is a few comments on the charter (sorry for the late reaction),
as it will be one main topic of discussion for the NWCRG:

. The charter ( http://trac.tools.ietf.org/group/irtf/trac/wiki/nwcrg ) proposes to 
  - collect information on wiki page, related to NWC architecture
  - creating a document with taxonomy [of terminology, of applications]
and one candidate activity is: 
  - research architectures for network coding protocols.

  I like this approach where the first step is to collect information:
and also wonder if the plan is to recharter the group later
with additional items (sorry for not being so familiar with IETF/IRTF process) ?

  Also maybe it would be nice to already have a strategy about how to collect 
and structure all the information that would be summarised on the wiki
pages and in the taxonomy document ?
I tried to think how, but the huge amount of network coding publications
(for instance, 700+ listed on http://www.networkcoding.info/bibliography.php , 
 5000+ citations of "Network Information Flow" Ahlswede et al. 2000)
is a bit intimidating :). There are several books, and even surveys for
applications of network coding in specific areas (for instance [1-5]).

I guess there are many angles of how to approach network coding:
- why use NC ?
  . improved capacity/throughput, reliability, coupon collector problem, energy-efficiency, 
    FEC, . . .
- where to use NC ? 
  . use cases: MANET, video on demand, reliable TCP, CCN/ICN, DTN, ...
    (as also in the list of Marie-Jose' Montpetit, and the ones from Muriel Medard post)
- how to use NC ? 
  . architectures [for instance end-to-end Tetrys/Coded-TCP, or ICN/CCN, or wireless NC routing, ...] 
  . ... based on building blocks (RLC, AL-FEC, sliding windows, congestion control, subgraph
    selection, NC theory, ...) 
and other angles (and these are already in the charter in the part "NWCRG Interest Areas").

But do you think these could be used to structure the wiki information ?
And practically, how would people contribute ? :)

++ a few surveys

[1] Takahiro MATSUDA, Taku NOGUCHI, Tetsuya TAKINE, "Survey of Network Coding and Its Applications", IEICE TRANSACTIONS on Communications, Vol.E94-B, No.3, pp.698-717.
[2] Iqbal, Muhammad Azhar, Dai, Bin, Huang, Benxiong, Hassan, A. and Yu, S. 2011, "Survey of network coding-aware routing protocols in wireless networks", Journal of network and computer applications, vol. 34, no. 6, pp. 1956-1970.
[3] Alexandros G. Dimakis, Kannan Ramchandran, Yunnan Wu, and Changho Suh, "A Survey on Network Codes for Distributed Storage", Proceedings of the IEEE | Vol. 99, No. 3, March 2011.
[4] Riccardo Bassoli, Hugo Marques, Jonathan Rodriguez, Kenneth W. Shum and Rahim Tafazolli, "Network Coding Theory: A Survey", IEEE Communications Surveys & Tutorial, Issue 99, 
[5] Michele Sanna and Ebroul Izquierdo "A Survey of Linear Network Coding and Network Error Correction Code Constructions and Algorithms", International Journal of Digital Multimedia Broadcasting 2011.

Regards,
-- Cedric

----- Original Message -----
From: "Victor Firoiu (US SSA)" <[email-masked]>
To: [email-masked]
Sent: Thursday, November 7, 2013 3:37:08 AM
Subject: [nwcrg] NWCRG agenda and presentations for tomorrow's meeting

Dear NetCoders, 

See you all tomorrow, 

_______________________________________________
nwcrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 7 Nov 2013 09:04:52 -0800

Thanks Cedric! I think that it would be also useful to list who are the main companies and research groups involved in the different aspects of NC somewhere on the list.

Marie-José Montpetit
[email-masked]
[email-masked]

> On Nov 7, 2013, at 9:00, Cedric Adjih <[email-masked]> wrote:
> 
>  Dear all,
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 7 Nov 2013 17:14:42 +0000

Hi,

> with additional items (sorry for not being so familiar with IETF/IRTF process) ?

unlike in the IETF, where a WG charter is a contract between the WG and the IESG about what work should be done and what cannot be done, a charter for an IRTF RG has a different purpose. It's much more about explaining the research area to potential participants and motivate why they might want to join in, and maybe describe what kinds of contributions the RG would be interested in. But the RG can of course work on and discuss other topics related to their area of interest.

(If an RG went completely off-topic, e.g., if you guys all of a sudden started talking about crypto systems, I might have a word with the chairs however.)

I did discuss with Brian and Victor whether the list of current topics of interest should maybe move from the charter to a wiki, so the charter was less quickly outdated (and shorter). We can discuss this later in the meeting.

Lars