Subject: [nwcrg] Minutes from our London meeting

From: Victor Firoiu <[email-masked]>
Date: Tue, 8 Apr 2014 22:00:34 -0400

Dear NetCoders,

Thanks to Angeles Vazquez-Castro, Vincent Roca and a bit of my notes,
I've uploaded our London meeting minutes at
http://www.ietf.org/proceedings/89/minutes/minutes-89-nwcrg

I do not remember a couple of things from our discussions:
- On Cedric's presentation: Is every transmission innovative, and if
so, how is it possible?
- On Igor's presentation: Dynamic Packet Recovery is done for TCP, UDP, both?
Cedric and Igor, please let us know your answers.

If you find anything else missing, please let me know. We have a few
more days to update the minutes in the proceedings.

Thanks,
Victor

---

From: Cedric Adjih <[email-masked]>
Date: Thu, 10 Apr 2014 09:59:35 +0200 (CEST)

Hello Victor, hello all,

Thank you for compiling the minutes of the NWCRG.

For the question from Bhumip, I understood it more as
"how are transmissions innovative, and how is it possible ?",
and I think the answer was along the lines:

1) they are innovative in the 'network coding' sense 

2) 'almost' all the transmissions are innovative 
  [asymptotically, in the specific scenario/topology presented on the slides], 
  which is strong result because there are several receivers for each 
  transmission, and this is 'almost' optimal.

3) without network coding, it is generally impossible to have the same effect: 
  because when a node A transmits a packet and it is received by another node B, 
  when the node B retransmits the packet, and when it is received by A [and possibly
  other nodes], it is useless/redundant for A.

I did not mention it in my answer, but I can add:
- the proof of the result is in Inria Research Report RR-8490
  (also accepted for upcoming conference Algotel-2014)
- argument "3)" can be found for instance in: section II.A of  
  J. Widmer, C. Fragouli, J-Y. Le Boudec "Low-complexity energy-efﬁcient 
  broadcasting in wireless ad-hoc networks using network coding"
  Workshop on Network Coding, Theory, and Applications. 2005 
  (it is also further developped in Inria RR-7011, unpublished).

regards,
-- Cedric

----- Original Message -----
| From: "Victor Firoiu" <[email-masked]>
| To: [email-masked]
| Sent: Wednesday, April 9, 2014 4:00:34 AM
| Subject: [nwcrg] Minutes from our London meeting
| 
| Dear NetCoders,
| 
| Thanks to Angeles Vazquez-Castro, Vincent Roca and a bit of my notes,
| I've uploaded our London meeting minutes at
| http://www.ietf.org/proceedings/89/minutes/minutes-89-nwcrg
| 
| I do not remember a couple of things from our discussions:
| - On Cedric's presentation: Is every transmission innovative, and if
| so, how is it possible?
| - On Igor's presentation: Dynamic Packet Recovery is done for TCP,
| UDP, both?
| Cedric and Igor, please let us know your answers.
| 
| If you find anything else missing, please let me know. We have a few
| more days to update the minutes in the proceedings.
| 
| Thanks,
| Victor
| 
| _______________________________________________
| nwcrg mailing list
| [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg
|