Subject: Re: [nwcrg] Meeting slot in Hawaii

From: "Morten V. Pedersen" <[email-masked]>
Date: Thu, 9 Oct 2014 10:28:34 +0200

Hi Victor,
Here is my proposed title and abstract:

Title: Fulcrum Network Codes

Abstract: This talk introduces Fulcrum network codes, a network coding 
framework that achieves three seemingly conflicting objectives: a) to 
reduce the overhead per coded packet to almost 1 bit per original 
packet; b) to operate the network using only GF(2) operations at 
intermediate nodes if necessary, reducing complexity in the network; c) 
to deliver an end-to-end performance that is close to that of a large 
field size network coding system for high-end receivers while 
simultaneously catering to low-end ones that can only decode in GF(2). 
As a consequence of (b) and (c), Fulcrum codes have a number of 
interesting traits making them interesting for practical implementations 
using network coding.

Do we have any updates on the preliminary IETF agenda (what slot the 
NCWRG will have)?

All the best,
Morten

On 10/06/2014 09:42 PM, Firoiu, Victor (US SSA) wrote:
> Morten, Jonathan, thank you. Please send your proposed title and abstract of your talk.
>
> Thanks,
> Victor
>
> -----Original Message-----
> From: nwcrg [mailto:[email-masked]] On Behalf Of Morten V. Pedersen
> Sent: Monday, October 06, 2014 3:19 PM
> To: [email-masked]
> Subject: Re: [nwcrg] Meeting slot in Hawaii
>
> Hi everybody,
> I would also like to request a slot.
>
> All the best,
> Morten
>
> On 10/03/2014 01:58 PM, Jonathan DETCHART wrote:
>> Dear all,
>>
>> I would like to have a slot to present the Tetrys team updates. Draft
>> to follow.
>> Thanks.
>>
>> Jonathan DETCHART
>> On 03/10/2014 13:48, Brian Adamson wrote:
>>> I requested one.  The preliminary agenda will be announced next week.
>>>
>>> - Brian
>>>
>>>
>>> On Oct 3, 2014, at 5:24 AM, Marie-Jose Montpetit
>>> <[email-masked]> wrote:
>>>
>>>> Do we have a meeting slot in Hawaii?
>>>>
>>>> I think there could be a draft-draft on the architecture and
>>>> potentially other presentations/drafts Thanks
>>>>
>>>>
>>>> /mjm
>>>> _______________________________________________
>>>> nwcrg mailing list
>>>> [email-masked]
>>>> https://www.irtf.org/mailman/listinfo/nwcrg
>>> _______________________________________________
>>> nwcrg mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/nwcrg
>> _______________________________________________
>> nwcrg mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/nwcrg
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 9 Oct 2014 09:19:00 +0000

I think as we are starting to get more and more interesting network codes it would be interesting to have an informational RFC that compares the different solutions from an implementation and use case point of view as was done in FECFrame. And of course compare the NC solutions to the FECFrame since it seems a lot of applications are similar (video streaming amongst others).

/mjm 

Marie-José Montpetit
[email-masked]
[email-masked]

> On Oct 9, 2014, at 04:28, Morten V. Pedersen <[email-masked]> wrote:
> 
> Hi Victor,
> Abstract: This talk introduces Fulcrum network codes, a network coding framework that achieves three seemingly conflicting objectives: a) to reduce the overhead per coded packet to almost 1 bit per original packet; b) to operate the network using only GF(2) operations at intermediate nodes if necessary, reducing complexity in the network; c) to deliver an end-to-end performance that is close to that of a large field size network coding system for high-end receivers while simultaneously catering to low-end ones that can only decode in GF(2). As a consequence of (b) and (c), Fulcrum codes have a number of interesting traits making them interesting for practical implementations using network coding.
> 
> Do we have any updates on the preliminary IETF agenda (what slot the NCWRG will have)?
> 
> All the best,
> Morten
>