Subject: [nwcrg] Agenda for Dallas

From: Victor Firoiu <[email-masked]>
Date: Thu, 19 Feb 2015 10:56:13 -0500

Dear NetCoders,

We are putting together our agenda for our meeting in Dallas. We would like
to request your inputs into topics of discussion and presentations. So far
we have received a request for presentation from Marie-Jose.  Here is a
draft list of topics for now:

1. Marie-Jose Monpetit: Dynamic Network Coding. May also talk about:
policy-based
NC, coded transport for many-to-many video streaming, and IPR aorund NC.

2. Network Coding Architecture - updates and group discussion.

Last, we got a request from IETF if we can reduce our meeting time.
Currently, we have a request for 2.5 hours.  I think we can reduce it to 2
hours, and if we need to have more discussion, I think we can get a room
there.

All the best,

Victor

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 19 Feb 2015 16:50:02 +0000

I think Dynamic NC, policy and transport are 1 slot. The IPR is another one. I am good for a shorter meeting. Please make sure we do not overlap with TAPS.

Marie-José Montpetit
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

On Feb 19, 2015, at 10:57, Victor Firoiu <[email-masked]<mailto:[email-masked]>> wrote:

Dear NetCoders,

We are putting together our agenda for our meeting in Dallas. We would like to request your inputs into topics of discussion and presentations. So far we have received a request for presentation from Marie-Jose.  Here is a draft list of topics for now:

1. Marie-Jose Monpetit: Dynamic Network Coding. May also talk about: policy-based NC, coded transport for many-to-many video streaming, and IPR aorund NC.

Last, we got a request from IETF if we can reduce our meeting time. Currently, we have a request for 2.5 hours.  I think we can reduce it to 2 hours, and if we need to have more discussion, I think we can get a room there.

All the best,

Victor

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Victor Firoiu <[email-masked]>
Date: Thu, 19 Feb 2015 14:06:57 -0500

Thanks, Marie-Jose, sounds good. We put TAPS as "Conflict to avoid" at
highest priority, so it's likely not going to be an issue. But we cannot
request a guarantee.

Victor

On Thu, Feb 19, 2015 at 11:50 AM, Marie-Jose Montpetit <[email-masked]>
wrote:

>  I think Dynamic NC, policy and transport are 1 slot. The IPR is another
> one. I am good for a shorter meeting. Please make sure we do not overlap
> with TAPS.
>
> Marie-José Montpetit
> [email-masked]
> [email-masked]
>
>

---

From: Cedric Adjih <[email-masked]>
Date: Tue, 24 Feb 2015 10:18:28 +0100 (CET)

Hello Victor, hello all,

If there is time, maybe I could use a slot for tentively one of the subjects:
- some ideas related to sliding encoding window
  http://www.ietf.org/archive/id/draft-amdouni-nwcrg-cisew-00.txt
- and/or one network coding method with multiple sources

By the way:
- there was some discussion about thinking/designing of a common sliding window
last time, is there some work done in this area ?
- how can we make progress in the research group, preparing for this meeting ?

best regards,
-- Cedric

----- Original Message -----
| From: "Victor Firoiu" <[email-masked]>
| To: [email-masked], "Brian Adamson" <[email-masked]>, "victor firoiu" <[email-masked]>
| Sent: Thursday, February 19, 2015 4:56:13 PM
| Subject: [nwcrg] Agenda for Dallas
| 
| 
| 
| 
| 
| 
| 
| Dear NetCoders,
| 
| 
| We are putting together our agenda for our meeting in Dallas. We
| would like to request your inputs into topics of discussion and
| presentations. So far we have received a request for presentation
| from Marie-Jose. Here is a draft list of topics for now:
| 
| 
| 1. Marie-Jose Monpetit: Dynamic Network Coding. May also talk about:
| policy-based NC, coded transport for many-to-many video streaming,
| and IPR aorund NC.
| 
| 
| 2. Network Coding Architecture - updates and group discussion.
| 
| 
| Last, we got a request from IETF if we can reduce our meeting time.
| Currently, we have a request for 2.5 hours. I think we can reduce it
| to 2 hours, and if we need to have more discussion, I think we can
| get a room there.
| 
| 
| All the best,
| 
| 
| Victor
| 
| 
| _______________________________________________
| nwcrg mailing list
| [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg
|

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 24 Feb 2015 12:22:44 +0000

Actually you are raising a valid point. What could be done to make the work progress. 

i would say that concentrating on the details of an encoder like sliding windows windows or ways to find coefficients or other which end up being application and protocol dependent anyway could be one avenue but one that I would like to be replaced by a concerted approach to architecture and framework research that applies to the other work being done in the IETF.

/mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]
@SocialTVMIT

> On Feb 24, 2015, at 4:18 AM, Cedric Adjih <[email-masked]> wrote:
> 
>  Hello Victor, hello all,
> 
> [email-masked]

---

From: "wangjinzhu" <[email-masked]>
Date: Wed, 25 Feb 2015 17:16:38 +0800

Dear Victor and Brian

Would you please give us a slot for introducing the work on combining TCP with network coding.           

The attachment is the material and we have submitted a draft  http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt

Thanks 

Best Regards

Jinzhu

From: nwcrg [mailto:[email-masked]] On Behalf Of Victor Firoiu
Sent: Thursday, February 19, 2015 11:56 PM
To: [email-masked]; Brian Adamson; [email-masked]
Subject: [nwcrg] Agenda for Dallas

Dear NetCoders,

All the best,

Victor

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 25 Feb 2015 10:47:44 +0000

Dear Jinzhu:

do you have implementation results of your scheme? Especially the delays at the receiver side could be an issue for TCP time-outs.

And while the “coding bit” is nice it would be interesting to expand it’s use especially for an operator who controls the nodes and the end-user devices.

/mjm

> On Feb 25, 2015, at 4:16 AM, wangjinzhu <[email-masked]> wrote:
> 
> Dear Victor and Brian
> The attachment is the material and we have submitted a draft  http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt <http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt>
>  
> Thanks 
>  
> Best Regards
> Jinzhu
>  
>  
> From: nwcrg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Victor Firoiu
> To: [email-masked] <mailto:[email-masked]>; Brian Adamson; [email-masked] <mailto:[email-masked]>
> <coded TCP.pptx>_______________________________________________
> nwcrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>

---

From: "wangjinzhu" <[email-masked]>
Date: Wed, 25 Feb 2015 19:54:56 +0800

Dear Marie-Jose Montpetit:

Thanks for your comments. 

We tested the coded TCP as a complete system and the test results are shown in the material. Currently, we do not have the test results of each module, such as coding delay, decoding delay.  We will supplement this tests in our follow-up work. 

In the coded TCP sender side, we use the coding block to segment data and encode packets in each coding block in order to make coding/decoding easier. In the meanwhile, the sender side ensure that if the number of the received coded packets is equal or exceeds to the number of the original packets in a coding block at the receiver side, all original packets in this coding block can be decoded successfully. Therefore, the coded TCP receiver side only counts the number of the received coded packets before replying ack. This would not consume too much time and thus would not cause TCP time-out.  

After ack is replied, the receiver side decode the packets in the coding block. We have an estimated result: the delay of decoding packets in a coding block is 2~5ms (the number of packets in a coding block is 7).  We will verify this result in our follow-up work.

Currently, we use the “coding bit” as an indicator of whether coding tcp is supported. We are interested in expanding its usage. 

Best Regards,

Jinzhu

From: nwcrg [mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: Wednesday, February 25, 2015 6:48 PM
To: wangjinzhu
Cc: [email-masked]; [email-masked]; [email-masked]; 邓灵莉/Lingli Deng; Brian Adamson
Subject: Re: [nwcrg] Agenda for Dallas

Dear Jinzhu:

/mjm

@SocialTVMIT

Dear Victor and Brian

The attachment is the material and we have submitted a draft   <http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt> http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt

Thanks 

Best Regards

Jinzhu

From: nwcrg [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Victor Firoiu
Sent: Thursday, February 19, 2015 11:56 PM
To:  <mailto:[email-masked]> [email-masked]; Brian Adamson;  <mailto:[email-masked]> [email-masked]
Subject: [nwcrg] Agenda for Dallas

Dear NetCoders,

All the best,

Victor

<coded TCP.pptx>_______________________________________________
nwcrg mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.irtf.org/mailman/listinfo/nwcrg> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Frank Fitzek <[email-masked]>
Date: Wed, 25 Feb 2015 10:22:28 +0100

Victor,

Morten Pedersen and myself would like to talk about
- NC for software defined networks (SDN)
- Reliable Synchronous Multicast with NC (and NORM)
- RLNC for Storage and Cloud Solutions

Either in two slots or one slot depending on your time. We may bring a 
demo to show the beauty of RLNC.

All the best

-- 
Frank Fitzek
Professor
Chair of Communication Networks
Institute of Communication Technology
TU Dresden

phone:  +49 351 463 33945
fax:    +49 351 463 37163
mobile: +49 173 548 2947
web:    www.fitzek.net
skype:	fitzek

5G Lab Germany Coordinator 5Glab.de

---

From: Brian Adamson <[email-masked]>
Date: Wed, 25 Feb 2015 09:49:57 -0500

Hi Frank,

These sound like good topics.  With regards to a demo, if you include a short demo/movie in the context of your presentations that may be OK particularly if it demonstrates some compelling results for the network coding for particular use cases.  Having a separate demo (back of the room, etc) is somewhat unwieldy for the IRTF/IETF meetings.  

I look forward to seeing you in Dallas.

best regards,

Brian

> On Feb 25, 2015, at 4:22 AM, Frank Fitzek <[email-masked]> wrote:
> 
> Victor,
> 
> Either in two slots or one slot depending on your time. We may bring a demo to show the beauty of RLNC.
> 
> All the best
> 
> 
> 
> 
> -- 
> Frank Fitzek
> Professor