Subject: [nwcrg] NWC Meeting Agenda V2

From: Victor Firoiu <[email-masked]>
Date: Sat, 21 Mar 2015 11:07:34 -0400

Dear Netcoders,

Here is our agenda updated with all the recent requests. I put all talks at
15min, but I think some may take less, please let us know. Also, Morten and
Frank, please give titles to your talks.

To all authors of presentations: please send us the abstract of your talks
and the slides so that we can upload to the IETF web page.

Thanks,

Victor and Brian

== Agenda V2 for NWCRG Meeting, Dallas, Friday, 27 March 2015 ==
Time: 9-11:30am CST. Room: Royal

15min Dynamic Network Coding, policy-based NC, coded transport for
many-to-many video streaming - Marie-Jose Monpetit
http://www.ietf.org/internet-drafts/draft-montpetit-dynamic-nc-00.txt

15min IPR around Network Coding - Vincent Roca

15min Update on Impact of Virtualization and SDN on Emerging Network Coding
- Bhumip Khasnabish
http://datatracker.ietf.org/doc/draft-khasnabish-nwcrg-impact-of-vir-and-sdn/

15min Some ideas related to sliding encoding window and a network coding
method with multiple sources - Cedric Adjih
http://www.ietf.org/archive/id/draft-amdouni-nwcrg-cisew-00.txt

15min Combining TCP with coding in wireless network - Jinzhu Wang
http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt

25min Morten Pedersen and Frank Fitzek
- NC for software defined networks (SDN)
- Reliable Synchronous Multicast with NC (and NORM)
- RLNC for Storage and Cloud Solutions

15min Updates about our (patent free) on-the-fly network coding protocol
draft - Jonathan Detchart
https://tools.ietf.org/html/draft-detchart-nwcrg-tetrys-01

30min Network Coding Architecture, Building Blocks and Signaling - Group
discussion

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 21 Mar 2015 15:19:26 +0000

What exactly do you want to discuss in the 30 minutes architecture? Is there some new material that needs the group approval - could we start the discussion on the list?

See you in Dallas.
 
Marie-Jose Montpetit, Ph.D.
[email-masked]
@SocialTVMIT

> On Mar 21, 2015, at 11:07 AM, Victor Firoiu <[email-masked]> wrote:
> 
> Dear Netcoders,
> 
> Here is our agenda updated with all the recent requests. I put all talks at 15min, but I think some may take less, please let us know. Also, Morten and Frank, please give titles to your talks.
> 
> To all authors of presentations: please send us the abstract of your talks and the slides so that we can upload to the IETF web page.
> 
> Thanks,
> 
> Victor and Brian
> 
> 
> 15min Dynamic Network Coding, policy-based NC, coded transport for many-to-many video streaming - Marie-Jose Monpetit
> http://www.ietf.org/internet-drafts/draft-montpetit-dynamic-nc-00.txt <http://www.ietf.org/internet-drafts/draft-montpetit-dynamic-nc-00.txt>
> 
> 15min Update on Impact of Virtualization and SDN on Emerging Network Coding - Bhumip Khasnabish
> http://datatracker.ietf.org/doc/draft-khasnabish-nwcrg-impact-of-vir-and-sdn/ <http://datatracker.ietf.org/doc/draft-khasnabish-nwcrg-impact-of-vir-and-sdn/>
> 
> 15min Some ideas related to sliding encoding window and a network coding method with multiple sources - Cedric Adjih
> http://www.ietf.org/archive/id/draft-amdouni-nwcrg-cisew-00.txt <http://www.ietf.org/archive/id/draft-amdouni-nwcrg-cisew-00.txt>
>  
> http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt <http://www.ietf.org/internet-drafts/draft-wang-tsvwg-tcp-coding-00.txt>
>  
> 15min Updates about our (patent free) on-the-fly network coding protocol draft - Jonathan Detchart
> https://tools.ietf.org/html/draft-detchart-nwcrg-tetrys-01 <https://tools.ietf.org/html/draft-detchart-nwcrg-tetrys-01>
> 
> 30min Network Coding Architecture, Building Blocks and Signaling - Group discussion
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Victor Firoiu <[email-masked]>
Date: Sat, 21 Mar 2015 11:31:26 -0400

This is the discussion we have recently started on the list regarding
Building Blocks, signaling and packet fields, and is a continuation of the
discussion on Architecture we had during the last meeting.

Victor

On Sat, Mar 21, 2015 at 11:19 AM, Marie-Jose Montpetit <[email-masked]>
wrote:

> What exactly do you want to discuss in the 30 minutes architecture? Is
> there some new material that needs the group approval - could we start the
> discussion on the list?
>
>
> See you in Dallas.
>
> Here is our agenda updated with all the recent requests. I put all talks
> at 15min, but I think some may take less, please let us know. Also, Morten
> and Frank, please give titles to your talks.
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 21 Mar 2015 15:46:12 +0000

Ok - maybe I can start the ball rolling. 

As you can see from the other presentations there are now a lof of “network coding for X” where X is storage, wireless, SDN, video etc. Some are redefining a transport, others are linked to routing and others are application layer. So the list of building blocks is increasing with the number of use cases.

On top of it there are now more than one working “network code”. And there will likely be more in the future also. And each seems to be targeting slightly different services.

So while I think we can agree on a nomenclature most largely inherited from FECFRAME , I doubt that we can agree on common packet fields across all services unless we are ready to live with huge overheads and of course we don’t. 

As for signaling we may also want also have different ways based on what are the code characteristics. 

Maybe we can look at a minimal header field pointing to the type of code used and letting the rest open? 

I really am trying to make progress and not have open ended discussions.

Have a safe trip.

> On Mar 21, 2015, at 11:31 AM, Victor Firoiu <[email-masked]> wrote:
> 
> This is the discussion we have recently started on the list regarding Building Blocks, signaling and packet fields, and is a continuation of the discussion on Architecture we had during the last meeting. 
> 
> Victor
> 
> On Sat, Mar 21, 2015 at 11:19 AM, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> @SocialTVMIT
> 
>> On Mar 21, 2015, at 11:07 AM, Victor Firoiu <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear Netcoders,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
> 
>