Subject: Re: [nwcrg] NC tutorial

From: "Morten V. Pedersen" <[email-masked]>
Date: Sun, 3 May 2015 21:12:48 -0400

Hi all,
Just to re-spawn this discussion. I think it would be very good with a 
tutorial.

To get the ball rolling I was discussing the topic with Muriel Medárd[*] 
and she kindly offered to give an introduction to some of the theory and 
math behind it all. I could present some of the implementation aspects, 
such as computational complexity and memory consumption of the different 
algorithms and finite fields.

Other possible topics that, in my opinion, could be of interest to the 
IETF/IRTF crowd could be:

- Network coding and {sensor networks, routing, mesh networks, 
peer-to-peer, streaming, delay tolerant networks, congestion control, 
Internet of Things}.

Any other suggestions and volunteers for other potential topics?

Muriel's availability is restricted to Friday the 24th, but I think 
Friday is typically the most open day - so perhaps that is a good 
choice? I don't know if there is a process we need to follow or whether 
we can just decide as a group. So let me summon the elders (aka. the 
chairs) on that one.

- M

On 04/01/2015 03:35 AM, Vincent Roca wrote:
> Great. It should be useful to introduce NC concepts in the light of 
> previous IETF activities in terms of content delivery protocols and 
> AL-FEC schemes,
> plus CC and other aspects if meaningful. There’s a lot to say…
> I did something similar a year ago, 
> https://hal.inria.fr/hal-00948895 , probably too Inria-centric on some 
> parts, but it’s easy to fix.
>
> Cheers,
>
>   Vincent
>
>
>> Le 31 mars 2015 à 16:17, jonathan detchart <[email-masked] 
>> <mailto:[email-masked]>> a écrit :
>>
>> We (the Tetrysians) are interested to participate.
>>
>> Thank you Victor for sharing the existing document with the list.
>> Another document to put on a public repo with the architecture draft.
>>
>> Jonathan
>>> On 31 Mar 2015, at 14:34, Marie-Jose Montpetit <[email-masked] 
>>> <mailto:[email-masked]>> wrote:
>>>
>>> Yes interesting! I think I know that team from EU programs.
>>>
>>> But I think we need more of an IETF-oriented tutorial with yes the 
>>> coding fundamentals but more framework/protocol information and of 
>>> course address the issues of congestion control that were raised in 
>>> the past and in Dallas. Hence my reaching out to our FECFRAME 
>>> colleagues to set the 'tone' and then I suppose for the different 
>>> solution-owners to contribute if they are interested (Morten, 
>>> Cedric, Jonathan...).
>>>
>>> Maybe posting what you had done with Muriel and Joao would get the 
>>> ball rolling?
>>>
>>> Thanks
>>>
>>> Marie-José Montpetit
>>> [email-masked] <mailto:[email-masked]>
>>>
>>> On Mar 30, 2015, at 11:40, Firoiu, Victor (US SSA) 
>>> <[email-masked] <mailto:[email-masked]>> 
>>> wrote:
>>>
>>>> I found this recent survey informative and useful as it is 
>>>> systematic in its summarization. It contains much more than a 
>>>> tutorial, but it is a good source of information.
>>>> “Network Coding Theory: A Survey,” Riccardo Bassoli, Hugo Marques, 
>>>> Jonathan Rodriguez, Kenneth W. Shum and Rahim Tafazolli, 
>>>> Communications Surveys & Tutorials, IEEE  (Volume:15 , Issue: 4 ), 
>>>> February 2013.
>>>> http://home.ie.cuhk.edu.hk/~wkshum/papers/NCsurvey.pdf 
>>>> <http://home.ie.cuhk.edu.hk/%7Ewkshum/papers/NCsurvey.pdf>
>>>> Victor
>>>> *From:*nwcrg [mailto:[email-masked]]*On Behalf Of*Morten V. 
>>>> Pedersen
>>>> *Sent:*Monday, March 30, 2015 11:24 AM
>>>> *To:[email-masked] <mailto:[email-masked]>
>>>> *Subject:*Re: [nwcrg] NC tutorial
>>>>
>>>> I think a tutorial document and session would be a nice 
>>>> contribution. Perhaps a Sunday tutorial session based on the 
>>>> document created?
>>>>
>>>> - M
>>>>
>>>> On 03/30/2015 11:15 AM, Marie-Jose Montpetit wrote:
>>>>
>>>>     I actually seek the advice of the group since I know there is
>>>>     information somewhere. Maybe do a joint tutorial on the Sunday
>>>>     in Prague? With all stakeholders involved? Someone like you or
>>>>     Vincent Roca who have been there before would be perfect to be
>>>>     the main presenters with presentations from subject experts?
>>>>     Marie-Jose Montpetit, Ph.D.
>>>>     [email-masked] <mailto:[email-masked]>
>>>>     @SocialTVMIT
>>>>
>>>>         On Mar 30, 2015, at 11:02 AM, Brian Adamson
>>>>         <[email-masked]
>>>>         <mailto:[email-masked]>> wrote:
>>>>         It’s probably worthwhile to do something like this. Were
>>>>         you thinking a presentation type format?  Or something
>>>>         else? On the former, I provided and “RMT Retrospective”
>>>>         brief at one of the earlier NWCRG meetings that may have
>>>>         some useful content to put in the context you suggest here.
>>>>         - Brian
>>>>
>>>>             On Mar 30, 2015, at 10:51 AM, Marie-Jose Montpetit
>>>>             <[email-masked] <mailto:[email-masked]>> wrote:
>>>>             After Friday I was asked many times for a “tutorial” as
>>>>             a number of participants wanted to know more about NC.
>>>>             It made me look at what is available publicly. And
>>>>             there is very little.
>>>>             I have been using the Christina Fragouli paper of 2006
>>>>             that while giving a good overview and being at the
>>>>             “right level” is now a bit dated:
>>>>             algo.epfl.ch/~christin/primer.ps
>>>>             <http://algo.epfl.ch/%7Echristin/primer.ps>
>>>>             And we wrote a paper on "Network Coding Myths” that can
>>>>             also give background:
>>>>             http://www.rle.mit.edu/ncrc/wp-content/uploads/2014/09/2014_butterflies.pdf
>>>>             There are of course other scientific papers that all
>>>>             have some background but those are usually more
>>>>             fundamental research.
>>>>             And sadly the more recent tutorial materials are only
>>>>             offered in scientific conferences, corporate briefings
>>>>             or professional training.
>>>>             And in any case I think we need to also position NC in
>>>>             the evolution of the IEFT from pilc, RMT and FECFRAME
>>>>             and the creation of TCP “flavors”, congestion control
>>>>             and buffer management as well as routing. Not a small task!
>>>>             Would that be something the group could collaborate to
>>>>             collectively? But of course it’s another distraction
>>>>             from the goals of the research group.
>>>>             Marie-Jose Montpetit, Ph.D.
>>>>             [email-masked] <mailto:[email-masked]>
>>>>             @SocialTVMIT
>>>>             _______________________________________________
>>>>             nwcrg mailing list
>>>>             [email-masked] <mailto:[email-masked]>
>>>>             https://www.irtf.org/mailman/listinfo/nwcrg
>>>>
>>>>
>>>>
>>>>
>>>>     _______________________________________________
>>>>
>>>>     nwcrg mailing list
>>>>
>>>>     [email-masked]  <mailto:[email-masked]>
>>>>
>>>>     https://www.irtf.org/mailman/listinfo/nwcrg
>>>>
>>>> _______________________________________________
>>>> nwcrg mailing list
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.irtf.org/mailman/listinfo/nwcrg
>>> _______________________________________________
>>> nwcrg mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.irtf.org/mailman/listinfo/nwcrg
>>
>> _______________________________________________
>> nwcrg mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg
>
>
>
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Muriel Medard <[email-masked]>
Date: Mon, 4 May 2015 01:59:44 +0000

Dear all,

I would be delighted to give a tutorial with Morten and any other volunteers.

Best, Muriel.

Sent from my Verizon Wireless 4G LTE smartphone

-------- Original message --------
From: "Morten V. Pedersen" <[email-masked]>
Date: 05/03/2015 21:13 (GMT-05:00)
To: [email-masked]
Subject: Re: [nwcrg] NC tutorial

Hi all,
Just to re-spawn this discussion. I think it would be very good with a tutorial.

To get the ball rolling I was discussing the topic with Muriel Medárd[*] and she kindly offered to give an introduction to some of the theory and math behind it all. I could present some of the implementation aspects, such as computational complexity and memory consumption of the different algorithms and finite fields.

Other possible topics that, in my opinion, could be of interest to the IETF/IRTF crowd could be:

- Network coding and {sensor networks, routing, mesh networks, peer-to-peer, streaming, delay tolerant networks, congestion control, Internet of Things}.

Muriel's availability is restricted to Friday the 24th, but I think Friday is typically the most open day - so perhaps that is a good choice? I don't know if there is a process we need to follow or whether we can just decide as a group. So let me summon the elders (aka. the chairs) on that one.

- M

On 04/01/2015 03:35 AM, Vincent Roca wrote:
Great. It should be useful to introduce NC concepts in the light of previous IETF activities in terms of content delivery protocols and AL-FEC schemes,
plus CC and other aspects if meaningful. There’s a lot to say…
I did something similar a year ago, https://hal.inria.fr/hal-00948895 , probably too Inria-centric on some parts, but it’s easy to fix.

Cheers,

  Vincent

Le 31 mars 2015 à 16:17, jonathan detchart <[email-masked]<mailto:[email-masked]>> a écrit :

Jonathan
On 31 Mar 2015, at 14:34, Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:

But I think we need more of an IETF-oriented tutorial with yes the coding fundamentals but more framework/protocol information and of course address the issues of congestion control that were raised in the past and in Dallas. Hence my reaching out to our FECFRAME colleagues to set the 'tone' and then I suppose for the different solution-owners to contribute if they are interested (Morten, Cedric, Jonathan...).

Maybe posting what you had done with Muriel and Joao would get the ball rolling?

Thanks

Marie-José Montpetit
[email-masked]<mailto:[email-masked]>

On Mar 30, 2015, at 11:40, Firoiu, Victor (US SSA) <[email-masked]<mailto:[email-masked]>> wrote:

I found this recent survey informative and useful as it is systematic in its summarization. It contains much more than a tutorial, but it is a good source of information.

“Network Coding Theory: A Survey,” Riccardo Bassoli, Hugo Marques, Jonathan Rodriguez, Kenneth W. Shum and Rahim Tafazolli, Communications Surveys & Tutorials, IEEE  (Volume:15 ,  Issue: 4 ), February 2013.
http://home.ie.cuhk.edu.hk/~wkshum/papers/NCsurvey.pdf<http://home.ie.cuhk.edu.hk/%7Ewkshum/papers/NCsurvey.pdf>

Victor

From: nwcrg [mailto:[email-masked]] On Behalf Of Morten V. Pedersen
Sent: Monday, March 30, 2015 11:24 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [nwcrg] NC tutorial

I think a tutorial document and session would be a nice contribution. Perhaps a Sunday tutorial session based on the document created?

- M

On 03/30/2015 11:15 AM, Marie-Jose Montpetit wrote:
I actually seek the advice of the group since I know there is information somewhere. Maybe do a joint tutorial on the Sunday in Prague? With all stakeholders involved? Someone like you or Vincent Roca who have been there before would be perfect to be the main presenters with presentations from subject experts?

Marie-Jose Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>
@SocialTVMIT

On Mar 30, 2015, at 11:02 AM, Brian Adamson <[email-masked]<mailto:[email-masked]>> wrote:

It’s probably worthwhile to do something like this. Were you thinking a presentation type format?  Or something else? On the former, I provided and “RMT Retrospective” brief at one of the earlier NWCRG meetings that may have some useful content to put in the context you suggest here.

- Brian

On Mar 30, 2015, at 10:51 AM, Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:

After Friday I was asked many times for a “tutorial” as a number of participants wanted to know more about NC.

It made me look at what is available publicly. And there is very little.

I have been using the Christina Fragouli paper of 2006 that while giving a good overview and being at the “right level” is now a bit dated:
algo.epfl.ch/~christin/primer.ps<http://algo.epfl.ch/%7Echristin/primer.ps>
And we wrote a paper on "Network Coding Myths” that can also give background:
http://www.rle.mit.edu/ncrc/wp-content/uploads/2014/09/2014_butterflies.pdf

There are of course other scientific papers that all have some background but those are usually more fundamental research.
And sadly the more recent tutorial materials are only offered in scientific conferences, corporate briefings or professional training.

And in any case I think we need to also position NC in the evolution of the IEFT from pilc, RMT and FECFRAME and the creation of TCP “flavors”, congestion control and buffer management as well as routing. Not a small task!

Would that be something the group could collaborate to collectively? But of course it’s another distraction from the goals of the research group.

Marie-Jose Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>
@SocialTVMIT

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

nwcrg mailing list

[email-masked]<mailto:[email-masked]>

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg
_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: jonathan detchart <[email-masked]>
Date: Mon, 4 May 2015 15:14:09 +0200

Hi Morten,

I will be glad to offer my help.

But, in my opinion, I think that for the IETF we should do a tutorial focused on the Network coding applicability and how it fits into FECFRAME for example, and refer to the theory. 

Furthermore, if the goal is to show the benefit of such a technology, we need to talk about the IPR.
A set of solutions are patented, other not. I think, this is important for everybody.

But of course, we will participate. Let us know what is your schedule for the contributions.

Jonathan DETCHART
> On 04 May 2015, at 03:12, Morten V. Pedersen <[email-masked]> wrote:
> 
> Hi all,
>> I did something similar a year ago, https://hal.inria.fr/hal-00948895 <https://hal.inria.fr/hal-00948895> , probably too Inria-centric on some parts, but it’s easy to fix.
>> 
>> Cheers,
>> 
>>   Vincent
>> 
>> 
>>> Le 31 mars 2015 à 16:17, jonathan detchart <[email-masked] <mailto:[email-masked]>> a écrit :
>>> 
>>>> On 31 Mar 2015, at 14:34, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> On Mar 30, 2015, at 11:40, Firoiu, Victor (US SSA) <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>>> http://home.ie.cuhk.edu.hk/~wkshum/papers/NCsurvey.pdf <http://home.ie.cuhk.edu.hk/%7Ewkshum/papers/NCsurvey.pdf>
>>>>>  
>>>>> Victor
>>>>>  
>>>>> From: nwcrg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Morten V. Pedersen
>>>>> To: [email-masked] <mailto:[email-masked]>
>>>>> On Mar 30, 2015, at 11:02 AM, Brian Adamson <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>  
>>>>> On Mar 30, 2015, at 10:51 AM, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> wrote:
>>>>>  
>>>>> algo.epfl.ch/~christin/primer.ps <http://algo.epfl.ch/%7Echristin/primer.ps>
>>>>> http://www.rle.mit.edu/ncrc/wp-content/uploads/2014/09/2014_butterflies.pdf <http://www.rle.mit.edu/ncrc/wp-content/uploads/2014/09/2014_butterflies.pdf>
>>>>>  
>>>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>>>>  
>>>>>  
>>>>> 
>>>>> 
>>>>> 
>>>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>>>>  
>>>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>> 
>> 
>> 
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>

---

From: Muriel Medard <[email-masked]>
Date: Mon, 4 May 2015 13:17:48 +0000

Dear Jonathan,

Thank you. I think a broader technical  rather than the narrower tutorial would be better at this point. IPR issues are not broad technical tutorial material, in my view.

I look forward to have you participate in the tutorial.

Best,

Muriel.

-------- Original message --------
From: jonathan detchart <[email-masked]>
Date: 05/04/2015 09:14 (GMT-05:00)
To: "Morten V. Pedersen" <[email-masked]>
Cc: [email-masked]
Subject: Re: [nwcrg] NC tutorial

Hi Morten,

Jonathan DETCHART
On 04 May 2015, at 03:12, Morten V. Pedersen <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

- M

Cheers,

  Vincent

Jonathan

Thanks

Marie-José Montpetit

Victor

- M

- Brian

nwcrg mailing list

---

From: jonathan detchart <[email-masked]>
Date: Mon, 4 May 2015 15:45:10 +0200

Muriel,
In my view, this tutorial must be done to foster the use of the Network coding in the industry.
As you know in industry, the evaluation of a technology is not only for it's optimality but also for it's overall applicability.
So IPR aspects AND licencing are important.

But I welcome participating with you !

Jonathan DETCHART
> On 04 May 2015, at 15:17, Muriel Medard <[email-masked]> wrote:
> 
> Dear Jonathan, 
> 
>> On 04 May 2015, at 03:12, Morten V. Pedersen <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi all,

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 04 May 2015 15:54:10 +0200

> IPR issues are not broad
> technical tutorial material, in my view.

No.  But then, a tutorial for the IETF shouldn't feel like  "Here is
some cool technology.  Unfortunately, a large part of it cannot be used.
 We won't tell you which part."   This is counterproductive if the
target audience is the IETF.

If NWCRG wants to get some of this technology used, maybe we can learn
from the ECC disaster.  Elliptic curve crypto wasn't used outside of
niches until the work was done to show that much of it had been
published already at least 20 years ago.  RFC 6090 liberated ECC for use
on the Internet by demonstrating (and documenting) which part of it can
be used.

Something like RFC 6090 needs to be written for NC.  Once you have it,
you really want a tutorial revolving around that technology.

Grüße, Carsten

---

From: Muriel Medard <[email-masked]>
Date: Mon, 4 May 2015 14:05:23 +0000

Dear Jonathan,

Thank you. Let us then stick to the technical tutorial, which I hope will be broadly interesting. Licensing will be outside the scope of it.

Best,

Muriel.

-------- Original message --------
From: jonathan detchart <[email-masked]>
Date: 05/04/2015 09:45 (GMT-05:00)
To: Muriel Medard <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: [nwcrg] NC tutorial

Muriel,

Jonathan DETCHART
On 04 May 2015, at 15:17, Muriel Medard <[email-masked]<mailto:[email-masked]>> wrote:

Dear Jonathan,

Best,

Muriel.

-------- Original message --------
From: jonathan detchart <[email-masked]<mailto:[email-masked]>>
Date: 05/04/2015 09:14 (GMT-05:00)
To: "Morten V. Pedersen" <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nwcrg] NC tutorial

Hi Morten,

Jonathan DETCHART

Hi all,

- M

Cheers,

  Vincent

Jonathan

Thanks

Marie-José Montpetit

Victor

- M

- Brian

nwcrg mailing list

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 4 May 2015 14:54:58 +0000

Would a RLNC draft/RFC be the equivalent of 6090?

Marie-José Montpetit
[email-masked]
[email-masked]

---

From: Victor Firoiu <[email-masked]>
Date: Mon, 4 May 2015 11:12:00 -0400

Thanks, Morten for reviving the discussion on tutorial.

I see two aspects: short term (proposed tutorial presentation), and a
tutorial document.

I think the main question is: who is the audience? I think both the
presentation and the document would help network professionals get an idea
about Network Coding, a summary on how it works, cases where is it useful,
and what it needs to operate. I would keep it at a relatively high level,
and provide pointers for in-depth info, such as other nwcrg IDs or
published papers.

Victor

On Sun, May 3, 2015 at 9:12 PM, Morten V. Pedersen <[email-masked]> wrote:

> Muriel's availability is restricted to Friday the 24th, but I think Friday
> is typically the most open day - so perhaps that is a good choice? I don't
> know if there is a process we need to follow or whether we can just decide
> as a group. So let me summon the elders (aka. the chairs) on that one.
>
> - M
>
>
> previous IETF activities in terms of content delivery protocols and AL-FEC
> schemes,
> I did something similar a year ago, https://hal.inria.fr/hal-00948895 ,
> probably too Inria-centric on some parts, but it’s easy to fix.
>
>  Cheers,
>
>    Vincent
>
>
>     Le 31 mars 2015 à 16:17, jonathan detchart <[email-masked]>
> a écrit :
>
> On 31 Mar 2015, at 14:34, Marie-Jose Montpetit <[email-masked]> wrote:
>
> coding fundamentals but more framework/protocol information and of course
> address the issues of congestion control that were raised in the past and
> in Dallas. Hence my reaching out to our FECFRAME colleagues to set the
> 'tone' and then I suppose for the different solution-owners to contribute
> if they are interested (Morten, Cedric, Jonathan...).
>
> On Mar 30, 2015, at 11:40, Firoiu, Victor (US SSA) <
> [email-masked]> wrote:
>
>   I found this recent survey informative and useful as it is systematic
> in its summarization. It contains much more than a tutorial, but it is a
> good source of information.
>
> Jonathan Rodriguez, Kenneth W. Shum and Rahim Tafazolli, Communications
> Surveys & Tutorials, IEEE  (Volume:15 ,  Issue: 4 ), February 2013.
>  *From:* nwcrg [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Morten V. Pedersen
> *Sent:* Monday, March 30, 2015 11:24 AM
> *To:* [email-masked]
> *Subject:* Re: [nwcrg] NC tutorial
>
>
> I think a tutorial document and session would be a nice contribution.
> Perhaps a Sunday tutorial session based on the document created?
>
> - M
>
> I actually seek the advice of the group since I know there is information
> somewhere. Maybe do a joint tutorial on the Sunday in Prague? With all
> stakeholders involved? Someone like you or Vincent Roca who have been there
> before would be perfect to be the main presenters with presentations from
> subject experts?
>
>
>  On Mar 30, 2015, at 11:02 AM, Brian Adamson <[email-masked]>
> wrote:
>
>  It’s probably worthwhile to do something like this. Were you thinking a
> presentation type format?  Or something else? On the former, I provided and
> “RMT Retrospective” brief at one of the earlier NWCRG meetings that may
> have some useful content to put in the context you suggest here.
>
>  - Brian
>
>
>  On Mar 30, 2015, at 10:51 AM, Marie-Jose Montpetit <[email-masked]>
> wrote:
>
>  After Friday I was asked many times for a “tutorial” as a number of
> participants wanted to know more about NC.
>
>  I have been using the Christina Fragouli paper of 2006 that while giving
> a good overview and being at the “right level” is now a bit dated:
>  There are of course other scientific papers that all have some
> background but those are usually more fundamental research.
>  And sadly the more recent tutorial materials are only offered in
> scientific conferences, corporate briefings or professional training.
>
>  And in any case I think we need to also position NC in the evolution of
> the IEFT from pilc, RMT and FECFRAME and the creation of TCP “flavors”,
> congestion control and buffer management as well as routing. Not a small
> task!
>
>  Would that be something the group could collaborate to collectively? But
> of course it’s another distraction from the goals of the research group.
>
>
> nwcrg mailing [email-masked]://www.irtf.org/mailman/listinfo/nwcrg
>
>
>

---

From: Muriel Medard <[email-masked]>
Date: Mon, 4 May 2015 23:20:39 +0000

Dear Victor,

Thank you. I think the tutorial would be for all types of attendees at IETF. The document could come later, maybe informed by audience questions. There is a book coming out and I have ample class notes from my MIT class and from the tutorial with Frank, Morten and others.

Best,

Muriel.

On May 4, 2015, at 11:12 AM, Victor Firoiu <[email-masked]<mailto:[email-masked]>> wrote:

I see two aspects: short term (proposed tutorial presentation), and a tutorial document.

I think the main question is: who is the audience? I think both the presentation and the document would help network professionals get an idea about Network Coding, a summary on how it works, cases where is it useful, and what it needs to operate. I would keep it at a relatively high level, and provide pointers for in-depth info, such as other nwcrg IDs or published papers.

Victor

On Sun, May 3, 2015 at 9:12 PM, Morten V. Pedersen <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,
Just to re-spawn this discussion. I think it would be very good with a tutorial.

- M

Cheers,

  Vincent

Jonathan

Thanks

Marie-José Montpetit

Victor

- M

- Brian

nwcrg mailing list

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Mon, 4 May 2015 23:07:11 -0400

Hi Jonathan,
While I agree that figuring out how we can accommodated NC in existing 
frameworks such as FECFRAME is important. I don't think it will be 
beneficial to include that into a tutorial at this point.

So perhaps before we discuss the actual content, we should agree on the 
scope i.e. who is the intended audience and what information do we wish 
to convey to them.

In my opinion the tutorial should target the IETF participants who may 
have heard of NC, but who have not yet had a chance to familiarize 
themselves with the topic. Therefore the content should serve as an 
introduction to the concept of network coding, how it works, what are 
the implications of using it in communication networks including 
drawbacks and advantages. So I would focus on the concepts and 
fundamentals rather than on specific solutions.

What do you think?

- M

On 05/04/2015 09:14 AM, jonathan detchart wrote:
> But, in my opinion, I think that for the IETF we should do a tutorial 
> focused on the Network coding applicability and how it fits into 
> FECFRAME for example, and refer to the theory.
>
>> To get the ball rolling I was discussing the topic with Muriel 
>> Medárd[*] and she kindly offered to give an introduction to some of 
>> the theory and math behind it all. I could present some of the 
>> implementation aspects, such as computational complexity and memory 
>> consumption of the different algorithms and finite fields.
>>
>> choice? I don't know if there is a process we need to follow or 
>> whether we can just decide as a group. So let me summon the elders 
>> (aka. the chairs) on that one.
>>
>> - M
>>
>>
>>> https://hal.inria.fr/hal-00948895 , probably too Inria-centric on 
>>> some parts, but it’s easy to fix.
>>>
>>> Cheers,
>>>
>>>   Vincent
>>>
>>>
>>>> Le 31 mars 2015 à 16:17, jonathan detchart 
>>>> <[email-masked] <mailto:[email-masked]>> a 
>>>> écrit :
>>>>
>>>>> course address the issues of congestion control that were raised 
>>>>> in the past and in Dallas. Hence my reaching out to our FECFRAME 
>>>>> <[email-masked] 
>>>>> <mailto:[email-masked]>> wrote:
>>>>>
>>>>>> “Network Coding Theory: A Survey,” Riccardo Bassoli, Hugo 
>>>>>> Marques, Jonathan Rodriguez, Kenneth W. Shum and Rahim Tafazolli, 
>>>>>> Communications Surveys & Tutorials, IEEE (Volume:15 ,  Issue: 4 
>>>>>> ), February 2013.
>>>>>> *From:*nwcrg [mailto:[email-masked]]*On Behalf Of*Morten 
>>>>>> V. Pedersen
>>>>>>     information somewhere. Maybe do a joint tutorial on the
>>>>>>     Sunday in Prague? With all stakeholders involved? Someone
>>>>>>     like you or Vincent Roca who have been there before would be
>>>>>>     perfect to be the main presenters with presentations from
>>>>>>     subject experts?
>>>>>>             After Friday I was asked many times for a “tutorial”
>>>>>>             as a number of participants wanted to know more about
>>>>>>             NC.
>>>>>>             I have been using the Christina Fragouli paper of
>>>>>>             2006 that while giving a good overview and being at
>>>>>>             the “right level” is now a bit dated:
>>>>>>             offered in scientific conferences, corporate
>>>>>>             briefings or professional training.
>>>>>>             And in any case I think we need to also position NC
>>>>>>             in the evolution of the IEFT from pilc, RMT and
>>>>>>             FECFRAME and the creation of TCP “flavors”,
>>>>>>             congestion control and buffer management as well as
>>>>>>             routing. Not a small task!
>>>>>>             Would that be something the group could collaborate
>>>>>>             to collectively? But of course it’s another
>>>>>>             distraction from the goals of the research group.

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 5 May 2015 03:30:52 +0000

I will let Jonathan respond with his own opinion.

But since I am in this time zone let me chime in. Disclaimer: I will not take part in the tutorial nor do I plan to attend so please take this as advice from someone who has probably been way too long at the IETF and who supported the idea of a tutorial.

I think the audience will most likely be of a few types:
- as you say Morten people who have no real grasp of network coding but have 'heard' about it: I know a few of them who nonetheless follow the list or have attended one of the meetings by curiosity (actually reaching out to people off list will be hard)
- IETF people who know about FEC in general and want to hear about NC and how it differs from traditional FEC (Muriel's comments on re-encoding are perfect for that group for example)
- protocol people who know about NC but don't really know how it fits in the overall IETF
- people who know about NC but have to be convinced of it's performance

This is a really wide spectrum :-( I do not know how long you want to dedicate to the tutorial but I think it should have sections to answer to each of these participants:
- a generic intro with the theory
- how NC differs from traditional FEC and architecture examples (Victor can help here too)
- how NC fits the IETF - the FECFRAME2 that you, Vincent and Jonathan are working on (and yes Brian you can help too)
- performance from your work, INRIA and ISAE etc.
- resources, implementations, references

Flame away.

Marie-José Montpetit
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

On May 4, 2015, at 23:07, Morten V. Pedersen <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jonathan,
While I agree that figuring out how we can accommodated NC in existing frameworks such as FECFRAME is important. I don't think it will be beneficial to include that into a tutorial at this point.

So perhaps before we discuss the actual content, we should agree on the scope i.e. who is the intended audience and what information do we wish to convey to them.

In my opinion the tutorial should target the IETF participants who may have heard of NC, but who have not yet had a chance to familiarize themselves with the topic. Therefore the content should serve as an introduction to the concept of network coding, how it works, what are the implications of using it in communication networks including drawbacks and advantages. So I would focus on the concepts and fundamentals rather than on specific solutions.

What do you think?

- M

Jonathan DETCHART

Hi all,

- M

Cheers,

  Vincent

Jonathan

Thanks

Marie-José Montpetit

Victor

- M

- Brian

nwcrg mailing list

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Tue, 5 May 2015 00:26:13 -0400

Hi Victor,
+1 I fully agree.

- M

On 05/04/2015 11:12 AM, Victor Firoiu wrote:
> presentation and the document would help network professionals get an 
> idea about Network Coding, a summary on how it works, cases where is 
> it useful, and what it needs to operate. I would keep it at a 
> relatively high level, and provide pointers for in-depth info, such as 
> other nwcrg IDs or published papers.
>
> Victor
>
>     Medárd[*] and she kindly offered to give an introduction to some
>     of the theory and math behind it all. I could present some of the
>     implementation aspects, such as computational complexity and
>     memory consumption of the different algorithms and finite fields.
>
>     peer-to-peer, streaming, delay tolerant networks, congestion
>     control, Internet of Things}.
>
>     Muriel's availability is restricted to Friday the 24th, but I
>     think Friday is typically the most open day - so perhaps that is a
>     good choice? I don't know if there is a process we need to follow
>     or whether we can just decide as a group. So let me summon the
>     elders (aka. the chairs) on that one.
>
>     - M
>
>
>>     Great. It should be useful to introduce NC concepts in the light
>>     of previous IETF activities in terms of content delivery
>>     protocols and AL-FEC schemes,
>>>>     But I think we need more of an IETF-oriented tutorial with yes
>>>>     the coding fundamentals but more framework/protocol information
>>>>     and of course address the issues of congestion control that
>>>>     were raised in the past and in Dallas. Hence my reaching out to
>>>>     our FECFRAME colleagues to set the 'tone' and then I suppose
>>>>     for the different solution-owners to contribute if they are
>>>>     interested (Morten, Cedric, Jonathan...).
>>>>
>>>>>     Marques, Jonathan Rodriguez, Kenneth W. Shum and Rahim
>>>>>     Tafazolli, Communications Surveys & Tutorials, IEEE (Volume:15
>>>>>     ,  Issue: 4 ), February 2013.
>>>>>     *From:*nwcrg [mailto:[email-masked]]*On Behalf
>>>>>     Of*Morten V. Pedersen
>>>>>         I actually seek the advice of the group since I know there
>>>>>         is information somewhere. Maybe do a joint tutorial on the
>>>>>         like you or Vincent Roca who have been there before would
>>>>>         be perfect to be the main presenters with presentations
>>>>>         from subject experts?
>>>>>             It’s probably worthwhile to do something like this.
>>>>>             Were you thinking a presentation type format? Or
>>>>>             something else? On the former, I provided and “RMT
>>>>>             Retrospective” brief at one of the earlier NWCRG
>>>>>             meetings that may have some useful content to put in
>>>>>             the context you suggest here.
>>>>>             - Brian
>>>>>
>>>>>                 After Friday I was asked many times for a
>>>>>                 “tutorial” as a number of participants wanted to
>>>>>                 know more about NC.
>>>>>                 2006 that while giving a good overview and being
>>>>>                 at the “right level” is now a bit dated:
>>>>>                 There are of course other scientific papers that
>>>>>                 all have some background but those are usually
>>>>>                 more fundamental research.
>>>>>                 And sadly the more recent tutorial materials are
>>>>>                 only offered in scientific conferences, corporate
>>>>>                 And in any case I think we need to also position
>>>>>                 NC in the evolution of the IEFT from pilc, RMT and
>>>>>                 congestion control and buffer management as well
>>>>>                 as routing. Not a small task!
>>>>>                 Would that be something the group could
>>>>>                 collaborate to collectively? But of course it’s
>>>>>                 another distraction from the goals of the research
>>>>>                 group.

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Tue, 5 May 2015 00:29:21 -0400

I think this is very good input - thanks!

- M

On 05/04/2015 11:30 PM, Marie-Jose Montpetit wrote:
> But since I am in this time zone let me chime in. Disclaimer: I will 
> not take part in the tutorial nor do I plan to attend so please take 
> this as advice from someone who has probably been way too long at the 
> IETF and who supported the idea of a tutorial.
>
> - as you say Morten people who have no real grasp of network coding 
> but have 'heard' about it: I know a few of them who nonetheless follow 
> the list or have attended one of the meetings by curiosity (actually 
> reaching out to people off list will be hard)
> - IETF people who know about FEC in general and want to hear about NC 
> and how it differs from traditional FEC (Muriel's comments on 
> re-encoding are perfect for that group for example)
> This is a really wide spectrum :-( I do not know how long you want to 
> dedicate to the tutorial but I think it should have sections to answer 
> to each of these participants:
> - how NC fits the IETF - the FECFRAME2 that you, Vincent and Jonathan 
> are working on (and yes Brian you can help too)
> [email-masked] <mailto:[email-masked]>
>> While I agree that figuring out how we can accommodated NC in 
>> existing frameworks such as FECFRAME is important. I don't think it 
>> will be beneficial to include that into a tutorial at this point.
>>
>> So perhaps before we discuss the actual content, we should agree on 
>> the scope i.e. who is the intended audience and what information do 
>> we wish to convey to them.
>>
>> In my opinion the tutorial should target the IETF participants who 
>> may have heard of NC, but who have not yet had a chance to 
>> familiarize themselves with the topic. Therefore the content should 
>> serve as an introduction to the concept of network coding, how it 
>> works, what are the implications of using it in communication 
>> networks including drawbacks and advantages. So I would focus on the 
>> concepts and fundamentals rather than on specific solutions.
>>
>> What do you think?
>>
>> - M
>>
>>
>>> But, in my opinion, I think that for the IETF we should do a 
>>> tutorial focused on the Network coding applicability and how it fits 
>>> into FECFRAME for example, and refer to the theory.
>>>
>>> Furthermore, if the goal is to show the benefit of such a 
>>> technology, we need to talk about the IPR.
>>>>> of previous IETF activities in terms of content delivery protocols 
>>>>> and AL-FEC schemes,
>>>>>>> and of course address the issues of congestion control that were 
>>>>>>> raised in the past and in Dallas. Hence my reaching out to our 
>>>>>>> FECFRAME colleagues to set the 'tone' and then I suppose for the 
>>>>>>> different solution-owners to contribute if they are interested 
>>>>>>> (Morten, Cedric, Jonathan...).
>>>>>>>
>>>>>>>>             all have some background but those are usually more
>>>>>>>>             fundamental research.

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 5 May 2015 08:39:54 +0000

Hi,

On 2015-5-4, at 14:17, Muriel Medard <[email-masked]<mailto:[email-masked]>> wrote:
Thank you. I think a broader technical  rather than the narrower tutorial would be better at this point. IPR issues are not broad technical tutorial material, in my view.

anything contributed to the research group that has IPR associated with needs to have the existence of that IPR disclosed (using the IETF datatracker). That includes presentations at face-to-face meetings, comments at a microphone, and emails to this list, among other types.

If a tutorial covered topics on which the presenter had personal knowledge of any IPR, that would need to be disclosed.

Lars

PS: The gory details are at https://irtf.org/ipr

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 5 May 2015 08:44:18 +0000

> on the Internet by demonstrating (and documenting) which part of it can

+1

Also, the IETF is working on modern audio and video codecs in a way that attempts to have unencumbered  standards in the end, because the current licensing on existing standards is too limiting for may implementors, to the degree that it prevents innovation in the web media space.

My secret hope for the NWCRG at chartering time was that the group would rally together and attempt to come up with NC schemes that could be freely used, therefore actually getting the technology out there.

(All this is my personal view, without any corporate or IRTF chair hats on.)

Lars

---

From: Vincent Roca <[email-masked]>
Date: Tue, 5 May 2015 11:45:33 +0200

I fully agree and have always worked with that ideal in mind at IETF, now IRTF.

Thanks to the work done so far in NWCRG we have reasons to believe that some of the technics are
likely not to be encumbered with IPR (even if it cannot be proven). On the opposite, we know there
are directions where we need to be very careful if we do care about IPRs. The situation was pretty
similar in the RMT/FECFRAME WGs and didn’t prevent us from going forward. It just made me and
others spend time and energy in clarifying the situation from time to time. That’s the price to pay.

So I’m now rather optimist for NC, even if there are restrictions.

Cheers,

 Vincent

> Le 5 mai 2015 à 10:44, Eggert, Lars <[email-masked]> a écrit :
>

---

From: jonathan detchart <[email-masked]>
Date: Tue, 5 May 2015 11:56:31 +0200

Morten,

We’re agree.
I don’t think we have to focus all the tutorial on existing solutions (Tetrys, RLNC, …) or on the integration with frameworks like FECFRAME.
We could quickly ref' the solutions (and the licences) in the tutorial and how we plan to combine (or adapt) the work of the group with the rest of the IETF/IRTF (maybe it’s out of scope, but could be useful for everybody).

That’s why I suggest we talk about the applicability of NC : use cases but also what is free-to-use and what is not for the IETF participants. 

Jonathan DETCHART

> On 05 May 2015, at 05:07, Morten V. Pedersen <[email-masked]> wrote:
> 
> Hi Jonathan,

---

From: Muriel Medard <[email-masked]>
Date: Tue, 5 May 2015 10:41:12 +0000

Dear all

I suggest going with Morten ' s approach. An analysis of whether solutions currently proposed are emcumbered is outside the scope.

Best,

Muriel.

-------- Original message --------
From: jonathan detchart <[email-masked]>
Date: 05/05/2015 05:56 (GMT-05:00)
To: "Morten V. Pedersen" <[email-masked]>
Cc: [email-masked]
Subject: Re: [nwcrg] NC tutorial

Morten,

We’re agree.

Jonathan DETCHART

On 05 May 2015, at 05:07, Morten V. Pedersen <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jonathan,

What do you think?

- M

Jonathan DETCHART

Hi all,

- M

Cheers,

  Vincent

Jonathan

Thanks

Marie-José Montpetit

Victor

- M

- Brian

nwcrg mailing list