Subject: [nwcrg] NWCRG Agenda

From: Victor Firoiu <[email-masked]>
Date: Sun, 12 Jul 2015 18:29:33 -0400

Dear Netcoders,

Following the discussions and requests on our mailing list, we have the
following talks and discussion topics:

draft-roca-nwcrg-fecframev2-problem-position, Vincent Roca, INRIA

draft-detchart-nwcrg-tetrys-02, Jonathan Detchart, ISAE

"System and layer independent network coding architecture design", Ángeles
Vazquez-Castro, Universitat Autónoma de Barcelona

Tutorial discussion.

Architecture discussion.

---

Morten: You asked for a slot, but did not send a title (maybe I missed it).
Please send your title and a short abstract.

Jontahan:
- Please send a short abstract of your talk (the new things in your draft)
- You asked for a second slot for Emmanuel Lochin. Do you still want it? If
so, please send the title and a shot abstract.

Vincent: Please send a short abstract on your presentation.

Angeles:
- Please send a short abstract of your talk.
- You also mentioned a second slot. If you still want it, please send a
title and short abstract.

All: Please let me know if I missed anything.

Thanks,

Victor

---

From: "LOCHIN Emmanuel" <[email-masked]>
Date: Mon, 13 Jul 2015 08:51:34 +0200

Hi Victor,

We do not need a second slot.
Thanks,

Emmanuel

Le Lundi 13 Juillet 2015 00:29 CEST, Victor Firoiu <[email-masked]> a écrit:
 
Dear Netcoders,
 Following the discussions and requests on our mailing list, we have the following talks and discussion topics:

"System and layer independent network coding architecture design", Ángeles Vazquez-Castro, Universitat Autónoma de Barcelona

Tutorial discussion.

Architecture discussion.

---

Morten: You asked for a slot, but did not send a title (maybe I missed it). Please send your title and a short abstract.

Jontahan:
- Please send a short abstract of your talk (the new things in your draft)
- You asked for a second slot for Emmanuel Lochin. Do you still want it? If so, please send the title and a shot abstract.

Angeles:
- Please send a short abstract of your talk.
- You also mentioned a second slot. If you still want it, please send a title and short abstract.
 All: Please let me know if I missed anything.
 Thanks,
 Victor 

--
  
Emmanuel LOCHIN
Professeur ISAE
ISAE SUPAERO - Institut Supérieur de l'Aéronautique et de l'Espace
10 avenue Edouard Belin - BP 54032 - 31055 TOULOUSE CEDEX 4 FRANCE - http://www.isae-supaero.fr
Tel +33 5 61 33 91 85 - Fax (+33) 5 61 33 83 30
Plan d'accès/Access map -  Page personnelle

---

From: Angeles Vazquez-Castro <[email-masked]>
Date: Mon, 13 Jul 2015 11:57:08 +0200

Dear Victor,

I would appreciate two slots if possible with contents as follows:
----------
Title: "System and layer independent network coding architecture design".
Slot 1 - Proposed architecture design methodology.
Slot 2 - Preliminary validation over DVB-S2/X/RCS2 and LTE-A.
----------
Short Abstract: Even if powerful, the broad applicability of network coding poses a challenge to a unified design approach over different communication networks and systems. We propose a (non-reductionist) design architectural framework where instead of layer/system/network-specific design, underlying systems are abstracted towards service-oriented design. The framework seems compatible with (more general) design frameworks such as software-defined networking, cognitive networking or network virtualization. We illustrate preliminary validations over DVB-S2/X/RCS2 and LTE-A.
----------
Many thanks, 
Ángeles - Universitat Autònoma de Barcelona

On Jul 13, 2015, at 12:29 AM, Victor Firoiu <[email-masked]>
 wrote:

> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Tue, 14 Jul 2015 23:35:01 +0200

Hi all,
Still working to make it, but topic will be:

Survey of sliding window coding schemes and the resulting functional 
building blocks.

Based on a survey of recent published sliding window coding schemes we 
have derived a set of functional building blocks and their interfaces. 
We will present the survey and the resulting building blocks.

- M

On 07/13/2015 12:29 AM, Victor Firoiu wrote:
>
> Dear Netcoders,
>
> Following the discussions and requests on our mailing list, we have 
> the following talks and discussion topics:
>
> "System and layer independent network coding architecture design", 
> Ángeles Vazquez-Castro, Universitat Autónoma de Barcelona
>
> Tutorial discussion.
>
> Architecture discussion.
>
> ---
>
> Morten: You asked for a slot, but did not send a title (maybe I missed 
> it). Please send your title and a short abstract.
>
> Jontahan:
> - You asked for a second slot for Emmanuel Lochin. Do you still want 
> it? If so, please send the title and a shot abstract.
>

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Mon, 20 Jul 2015 10:00:30 +0200

Hi everybody,
We are still working on the survey and I think it would better to 
postpone the presentation to our next meeting.

In the mean time we can start to share the the current text on the 
mailing list. We currently have the following papers in the survey:

Paper: Interfacing network coding with TCP: an implementation
Download: [arXiv](http://arxiv.org/abs/0908.1564)
Authors: Jay Kumar Sundararajan, Szymon Jakubczak, Muriel Medard, 
Michael Mitzenmacher, Joao Barros

Paper: Structured Random Linear Codes (SRLC): Bridging the Gap between 
Block and Convolutional Codes
Download: [arXiv](http://arxiv.org/abs/1408.5663)
Authors: Kazuhisa Matsuzono, Vincent Roca, Hitoshi Asaeda

Paper: Low Delay Random Linear Coding Over a Stream
Download:
Authors: Mohammad Karzand, Douglas J. Leith

Paper: Network Coding Over SATCOM: Lessons Learned
Download: [arXiv](http://arxiv.org/abs/1506.06154)
Authors: Jason Cloud, Muriel Médard

Paper: Layered Constructions for Low-Delay Streaming Codes
Download: [arXiv](http://arxiv.org/abs/1308.3827)
Authors: Ahmed Badr, Pratik Patil, Ashish Khisti, Wai-Tian Tan, John 
Apostolopoulos

If anybody knows any sliding window coding schemes that would be 
relevant to include in the survey please let us know. Note, we did not 
include any of the NWCRG proposed schemes - I think the authors of those 
schemes would be the best to add those schemes to the survey.

- M

On 07/14/2015 11:35 PM, Morten V. Pedersen wrote:
>> Morten: You asked for a slot, but did not send a title (maybe I 
>> missed it). Please send your title and a short abstract.
>>
>> Jontahan:

---

From: Cedric Adjih <[email-masked]>
Date: Mon, 20 Jul 2015 15:16:05 +0200 (CEST)

Hi Morten, hi NetCoders,

  Thank you for starting the effort of initiating a survey
on sliding window schemes!

For (our) NWCRG schemes that were proposed, I would cite:

- SEW (as part of DragonCast), described with different
  levels of details in:

  * C.Adjih, S-Y. Cho, E. Baccelli
  "Broadcast With Network Coding: DRAGONCAST", 
  (expired) individual draft, IETF/IRTF, July 2013,
  https://tools.ietf.org/html/draft-adjih-dragoncast-00

  * S-Y. Cho, C. Adjih, 
  "Wireless Broadcast with Network Coding: DRAGONCAST", 
  Inria Research Report  RR-6569, July 2008
  https://hal.inria.fr/inria-00292867

  * S-Y. Cho's PhD thesis
  https://tel.archives-ouvertes.fr/pastel-00004228/document

  I think the specifity is that it is essentially designed as
distributed recoding with online Gaussian elimination, with the
following property: only the decoding buffer (the matrix and vectors
maintained in reduced row echelon form, RREF) is kept. 
RREF has to be slightly differently, so that a node can still generate 
(recode) packets with low indices matching window constraints.
 
- CISEW
  
  * I. Amdouni, C. Adjih
  "Coding Interval-based Sliding Encoding Window"
  (expired) individual draft, IETF/IRTF, July 2014,
  http://www.ietf.org/internet-drafts/draft-amdouni-nwcrg-cisew-00.txt

  CISEW is a overhaul and redesign of SEW; it refines the signaling
and algorithms of SEW, and makes them more general. I.e. it handles
the case of "losses", where some node(s) in the network cannot
keep up with the decoding of others and the sliding speed.

Of course we would be happy to help further contribute to any definition 
of NC building blocks

cheers,
-- Cedric

----- Original Message -----
| From: "Morten V. Pedersen" <[email-masked]>
| To: [email-masked]
| Sent: Monday, July 20, 2015 10:00:30 AM
| Subject: Re: [nwcrg] NWCRG Agenda
| 
| 
| Hi everybody,
| We are still working on the survey and I think it would better to
| postpone the presentation to our next meeting.
| 
| In the mean time we can start to share the the current text on the
| mailing list. We currently have the following papers in the survey:
| 
| Paper: Interfacing network coding with TCP: an implementation
| Download: [arXiv]( http://arxiv.org/abs/0908.1564 )
| Authors: Jay Kumar Sundararajan, Szymon Jakubczak, Muriel Medard,
| Michael Mitzenmacher, Joao Barros
| 
| Paper: Structured Random Linear Codes (SRLC): Bridging the Gap
| between Block and Convolutional Codes
| Download: [arXiv]( http://arxiv.org/abs/1408.5663 )
| Authors: Kazuhisa Matsuzono, Vincent Roca, Hitoshi Asaeda
| 
| Paper: Low Delay Random Linear Coding Over a Stream
| Download:
| Authors: Mohammad Karzand, Douglas J. Leith
| 
| Paper: Network Coding Over SATCOM: Lessons Learned
| Download: [arXiv]( http://arxiv.org/abs/1506.06154 )
| Authors: Jason Cloud, Muriel Médard
| 
| Paper: Layered Constructions for Low-Delay Streaming Codes
| Download: [arXiv]( http://arxiv.org/abs/1308.3827 )
| Authors: Ahmed Badr, Pratik Patil, Ashish Khisti, Wai-Tian Tan, John
| Apostolopoulos
| 
| If anybody knows any sliding window coding schemes that would be
| relevant to include in the survey please let us know. Note, we did
| not include any of the NWCRG proposed schemes - I think the authors
| of those schemes would be the best to add those schemes to the
| survey.
| 
| - M
| 
| 
| 
| On 07/14/2015 11:35 PM, Morten V. Pedersen wrote:
| 
| 
| Hi all,
| Still working to make it, but topic will be:
| 
| Survey of sliding window coding schemes and the resulting functional
| building blocks.
| 
| Based on a survey of recent published sliding window coding schemes
| we have derived a set of functional building blocks and their
| interfaces. We will present the survey and the resulting building
| blocks.
| 
| - M
| 
| 
| On 07/13/2015 12:29 AM, Victor Firoiu wrote:
| 
| 
| 
| 
| 
| 
| 
| Dear Netcoders,
| 
| Following the discussions and requests on our mailing list, we have
| the following talks and discussion topics:
| 
| draft-roca-nwcrg-fecframev2-problem-position, Vincent Roca, INRIA
| 
| draft-detchart-nwcrg-tetrys-02, Jonathan Detchart, ISAE
| 
| "System and layer independent network coding architecture design",
| Ángeles Vazquez-Castro, Universitat Autónoma de Barcelona
| 
| Tutorial discussion.
| 
| Architecture discussion.
| 
| ---
| 
| Morten: You asked for a slot, but did not send a title (maybe I
| missed it). Please send your title and a short abstract.
| 
| Jontahan:
| - Please send a short abstract of your talk (the new things in your
| draft)
| - You asked for a second slot for Emmanuel Lochin. Do you still want
| it? If so, please send the title and a shot abstract.
| 
| Vincent: Please send a short abstract on your presentation.
| 
| Angeles:
| - Please send a short abstract of your talk.
| - You also mentioned a second slot. If you still want it, please send
| a title and short abstract.
| 
| All: Please let me know if I missed anything.
| 
| 
| Thanks,
| 
| Victor
| 
| 
| 
| 
| _______________________________________________
| nwcrg mailing list [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg
| 
| 
| _______________________________________________
| nwcrg mailing list [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg
| 
| _______________________________________________
| nwcrg mailing list
| [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg
|