Subject: [nwcrg] Tutorial discussion

From: Victor Firoiu <[email-masked]>
Date: Mon, 13 Jul 2015 22:36:16 -0400

Regarding the tutorial, here are some ideas for an outline, that include
some inputs I got from Joao last year.

1. Brief overview of the Network Coding potential, with an example
- show high-level how it works
- show benefits, e.g. resilience, exploiting multi-path
- point out components: coding, reliability protocol

2. Overview of the theoretical basis
- fields, linear coding, the randomness benefit
- Main theorems (max-flow min-cut, multicast capacity)

3. Benefits and costs of NC

4. Practical applications

I think there would be two versions of the tutorial:
- one as a 45-50min presentation, possibly as an IAB talk
- another as a written document, to become a nwcrg draft and later
Informational RFC.

Please comment on what you think each version should include, and on which
topic you would like to contribute.

Victor

---

From: Frank Fitzek <[email-masked]>
Date: Mon, 20 Jul 2015 17:07:09 +0200

comments inline

Am 14.07.2015 um 04:36 schrieb Victor Firoiu:
>
> Regarding the tutorial, here are some ideas for an outline, that 
> include some inputs I got from Joao last year.
>
maybe talk about Delay
> - fields, linear coding, the randomness benefit
recoding
> 4. Practical applications
3 and 4 can be combined.
> Please comment on what you think each version should include, and on 
> which topic you would like to contribute.
>
> Victor
>
>
>
>
>
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg