Subject: [nwcrg] NWCRG energy level

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 18 Mar 2016 15:42:41 +0000

Folks,

there hasn't been an email to the RG list since October 2015, and I can see no visible progression on the work items the RG has discussed previously.

Have we run out of steam here?

Lars

---

From: "Firoiu, Victor (US)" <[email-masked]>
Date: Fri, 18 Mar 2016 16:28:12 +0000

Lars,

I agree that it's been quiet. I've had to step away for a while, but I expect to resume activity on architecture and recent research on the mail list in April. 

Victor

-----Original Message-----
From: nwcrg [mailto:[email-masked]] On Behalf Of Eggert, Lars
Sent: Friday, March 18, 2016 11:43 AM
To: [email-masked]
Subject: [nwcrg] NWCRG energy level

Folks,

Lars

---

From: whyeung <[email-masked]>
Date: Sun, 20 Mar 2016 15:54:39 +0800

Dear Lars, Victor, and all,

I just attended an IEEE 802 meeting in Macau.  I was invited to give a presentation at an 802.11ay session on our latest work on BATS code.  Here is the link for my slides:

https://mentor.ieee.org/802.11/dcn/16/11-16-0317-00-00ay-bats-network-coding-for-wireless-relay-networks.pptx <https://mentor.ieee.org/802.11/dcn/16/11-16-0317-00-00ay-bats-network-coding-for-wireless-relay-networks.pptx>

At the meeting we talked to various people and found that there had been proposals before for including network coding in different 802 standards, but they did not go through.  For one thing, the standards under development are on very tight schedules, and the engineers are very reluctant to make drastic changes on what they are familiar with.  Nevertheless, most people there know about network coding, at least some forms of it.

My feeling is that it will take more time for network coding to get into the standards, but the time will come.  It is only the beginning.

Best regards,
Raymond

> On 19 Mar, 2016, at 12:28 am, Firoiu, Victor (US) <[email-masked]> wrote:
> 
> Lars,
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Mon, 21 Mar 2016 08:55:36 +0100

Hello Raymond, Lars et al.

SDOs do like IETF standards and I've experimented this several times during the past years at ETSI and DVB. With an RFC
specifying BATS codes in a non ambiguous way, half of the work would be done and it could even fit within tight schedules.

An IRTF group is perhaps not the best place to standardize FEC codes (only "Experimental"/"Informational" RFCs are possible)
but in the meantime this is better than nothing.

To answer your comment Lars: even if we remained quit since July, there is still a lot of interest in our side and we've made
progress. Me too I'm eager to have RFCs on a couple of technologies/architectural concepts that could help us go forward.

Cheers,

   Vincent

> Le 20 mars 2016 à 08:54, whyeung <[email-masked]> a écrit :
> 
>> On 19 Mar, 2016, at 12:28 am, Firoiu, Victor (US) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Lars,
>> 
>> From: nwcrg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Eggert, Lars
>> To: [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 21 Mar 2016 08:58:20 +0000

Hi,

thanks for the comments. I don't doubt for a second that there are individuals who are/remain very interested in this research area. But in order for the IRTF to spend organizational cycles on an RG in this area, I'd like to see more activity, and from a larger group of people. So let's see if we can make this happen.

Lars

On 2016-03-21, at 8:55, Vincent Roca <[email-masked]> wrote:
>> Le 20 mars 2016 à 08:54, whyeung <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>

---

From: Muriel Medard <[email-masked]>
Date: Mon, 21 Mar 2016 09:21:01 +0000

Dear all,

there is indeed quite a bit of activity in implementing and commercializing network coding, which is now in products, and has moved out of the research area. The latest demos at the Mobile World Congress are clear evidence. There are also standardization efforts in other areas.

Still, the majority of the people who work in network coding are not active in the RG, as Lars points out.

I think we can either decide to let others manage network coding in standards, as is already happening, or make a concerted effort to make this a vibrant group, by actively recruiting, involving and motivating the people who are working in the area to participate. If we decide on the latter, I would be willing to co-chair, at least during my upcoming sabbatical.

Best,

Muriel.

On Mar 21, 2016, at 4:58 AM, Eggert, Lars <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Lars

On 2016-03-21, at 8:55, Vincent Roca <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,

   Vincent

Le 20 mars 2016 à 08:54, whyeung <[email-masked]<mailto:[email-masked]>> a écrit :

https://mentor.ieee.org/802.11/dcn/16/11-16-0317-00-00ay-bats-network-coding-for-wireless-relay-networks.pptx

Best regards,
Raymond

On 19 Mar, 2016, at 12:28 am, Firoiu, Victor (US) <[email-masked]<mailto:[email-masked]>> wrote:

Lars,

Victor

-----Original Message-----
From: nwcrg [mailto:[email-masked]] On Behalf Of Eggert, Lars
Sent: Friday, March 18, 2016 11:43 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [nwcrg] NWCRG energy level

Folks,

Lars

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

_______________________________________________
nwcrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Cedric Adjih <[email-masked]>
Date: Mon, 21 Mar 2016 10:31:47 +0100 (CET)

Hello Lars, hello all, 

I think the research group made good progress on base documents, 
and had started exploring the design space (top-down), which gave us 
a lot of valuable insight. 
There was some opinion(s) that one could go also bottom-up, starting 
from the implementations. 
Maybe some of the strategy for the RG could be identify from the absolute 
minimum for a basic network coding (maybe starting from FECFRAME, etc. 
as some did), and consider keeping it sufficiently extensible, to be 
able to implement most identified designs. 

best regards, 
-- Cedric 

----- Original Message -----

| From: "Lars Eggert" <[email-masked]>
| To: "Vincent Roca" <[email-masked]>
| Cc: "Victor Firoiu (US)" <[email-masked]>,
| [email-masked], "whyeung" <[email-masked]>
| Sent: Monday, March 21, 2016 9:58:20 AM
| Subject: Re: [nwcrg] NWCRG energy level

| Hi,

| thanks for the comments. I don't doubt for a second that there are
| individuals who are/remain very interested in this research area.
| But in order for the IRTF to spend organizational cycles on an RG in
| this area, I'd like to see more activity, and from a larger group of
| people. So let's see if we can make this happen.

| Lars

| On 2016-03-21, at 8:55, Vincent Roca < [email-masked] > wrote:

| | Hello Raymond, Lars et al.
| 

| | SDOs do like IETF standards and I've experimented this several
| | times
| | during the past years at ETSI and DVB. With an RFC
| 
| | specifying BATS codes in a non ambiguous way, half of the work
| | would
| | be done and it could even fit within tight schedules.
| 

| | An IRTF group is perhaps not the best place to standardize FEC
| | codes
| | (only "Experimental"/"Informational" RFCs are possible)
| 
| | but in the meantime this is better than nothing.
| 

| | To answer your comment Lars: even if we remained quit since July,
| | there is still a lot of interest in our side and we've made
| 
| | progress. Me too I'm eager to have RFCs on a couple of
| | technologies/architectural concepts that could help us go forward.
| 

| | Cheers,
| 

| | Vincent
| 

| | | Le 20 mars 2016 à 08:54, whyeung < [email-masked] > a
| | | écrit
| | | :
| | 
| 

| | | Dear Lars, Victor, and all,
| | 
| 

| | | I just attended an IEEE 802 meeting in Macau. I was invited to
| | | give
| | | a
| | | presentation at an 802.11ay session on our latest work on BATS
| | | code.
| | | Here is the link for my slides:
| | 
| 

| | | https://mentor.ieee.org/802.11/dcn/16/11-16-0317-00-00ay-bats-network-coding-for-wireless-relay-networks.pptx
| | 
| 

| | | At the meeting we talked to various people and found that there
| | | had
| | | been proposals before for including network coding in different
| | | 802
| | | standards, but they did not go through. For one thing, the
| | | standards
| | | under development are on very tight schedules, and the engineers
| | | are
| | | very reluctant to make drastic changes on what they are familiar
| | | with. Nevertheless, most people there know about network coding,
| | | at
| | | least some forms of it.
| | 
| 

| | | My feeling is that it will take more time for network coding to
| | | get
| | | into the standards, but the time will come. It is only the
| | | beginning.
| | 
| 

| | | Best regards,
| | 
| 
| | | Raymond
| | 
| 

| | | | On 19 Mar, 2016, at 12:28 am, Firoiu, Victor (US) <
| | | | [email-masked] > wrote:
| | | 
| | 
| 

| | | | Lars,
| | | 
| | 
| 

| | | | I agree that it's been quiet. I've had to step away for a
| | | | while,
| | | | but
| | | | I expect to resume activity on architecture and recent research
| | | | on
| | | | the mail list in April.
| | | 
| | 
| 

| | | | Victor
| | | 
| | 
| 

| | | | -----Original Message-----
| | | 
| | 
| 
| | | | From: nwcrg [ mailto:[email-masked] ] On Behalf Of
| | | | Eggert,
| | | | Lars
| | | 
| | 
| 
| | | | Sent: Friday, March 18, 2016 11:43 AM
| | | 
| | 
| 
| | | | To: [email-masked]
| | | 
| | 
| 
| | | | Subject: [nwcrg] NWCRG energy level
| | | 
| | 
| 

| | | | Folks,
| | | 
| | 
| 

| | | | there hasn't been an email to the RG list since October 2015,
| | | | and
| | | | I
| | | | can see no visible progression on the work items the RG has
| | | | discussed previously.
| | | 
| | 
| 

| | | | Have we run out of steam here?
| | | 
| | 
| 

| | | | Lars
| | | 
| | 
| 

| | | | _______________________________________________
| | | 
| | 
| 
| | | | nwcrg mailing list
| | | 
| | 
| 
| | | | [email-masked]
| | | 
| | 
| 
| | | | https://www.irtf.org/mailman/listinfo/nwcrg
| | | 
| | 
| 

| | | _______________________________________________
| | 
| 
| | | nwcrg mailing list
| | 
| 
| | | [email-masked]
| | 
| 
| | | https://www.irtf.org/mailman/listinfo/nwcrg
| | 
| 

| _______________________________________________
| nwcrg mailing list
| [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 21 Mar 2016 09:49:24 +0000

Hi,

> a lot of valuable insight.

yes, but most were last updated in 2014 or early 2015. Since then, not so much visible activity, hence my original email.

Lars

> From: "Lars Eggert" <[email-masked]>
> To: "Vincent Roca" <[email-masked]>
> Cc: "Victor Firoiu (US)" <[email-masked]>, [email-masked], "whyeung" <[email-masked]>
> Sent: Monday, March 21, 2016 9:58:20 AM
> Subject: Re: [nwcrg] NWCRG energy level
> 
> Hi,
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 23 Mar 2016 15:55:19 +0000

Hi,

> I think we can either decide to let others manage network coding in standards, as is already happening, or make a concerted effort to make this a vibrant group, by actively recruiting, involving an…

if the goal is to manage the ongoing standardization of network coding, the NWCRG is definitely the wrong vessel, since IRTF research groups by definition cannot publish standards-track documents. Especially if that standardization is not happening in the IETF but elsewhere. (If I may ask: where?)

Thanks,
Lars