Subject: [nwcrg] NC presentation during the NFVRG meeting

From: Vincent Roca <[email-masked]>
Date: Mon, 18 Jul 2016 19:48:52 +0200

Hello everybody,

FYI... There was a presentation by Angeles (who contributed to our Prague meeting last year) to the NFVRG this morning.
Slides are available:
	https://www.ietf.org/proceedings/96/slides/slides-96-nfvrg-10.pdf <https://www.ietf.org/proceedings/96/slides/slides-96-nfvrg-10.pdf>
I'm a little bit provocative, but is the NWCRG group still the preferred place to discuss and contribute to NC?

Cheers,

  Vincent

---

From: Angeles Vazquez-Castro <[email-masked]>
Date: Mon, 18 Jul 2016 20:16:55 +0200

Dear All,

I don't like that my presentation, that happens to be in line with the contents of nfvrg, is used to be provocative or in any other way other than strictly technical and constructive as in the spirit of irtf.

Any technical feedback is more than welcome.

Thank you, Ángeles

On Jul 18, 2016, at 7:48 PM, Vincent Roca <[email-masked]>
 wrote:

> 	https://www.ietf.org/proceedings/96/slides/slides-96-nfvrg-10.pdf
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "Firoiu, Victor (US)" <[email-masked]>
Date: Mon, 18 Jul 2016 18:54:38 +0000

Ángeles,

Thank you for your contribution. Of course we wish to discuss it in NWCRG soon. I think Vincent wanted to encourage all of us to be more active on the list, to which I agree.

Victor

From: nwcrg [mailto:[email-masked]] On Behalf Of Angeles Vazquez-Castro
Sent: Monday, July 18, 2016 2:17 PM
To: Vincent Roca
Cc: [email-masked]
Subject: Re: [nwcrg] NC presentation during the NFVRG meeting

Dear All,

Thank you, Ángeles

On Jul 18, 2016, at 7:48 PM, Vincent Roca <[email-masked]<mailto:[email-masked]>>
 wrote:

Hello everybody,

Cheers,

  Vincent

---

From: Vincent Roca <[email-masked]>
Date: Mon, 18 Jul 2016 21:18:41 +0200

I apologize Angeles, at a minimum I should have sent two messages to decouple the two items. It was very clumsy.

But yes, I'd be more than happy to have a "working" NC working group, with live discussions and exchanges of ideas.
What happened during the past two months is not very stimulating from this point of view as I already mentioned.

Cheers,

  Vincent

---

From: Cedric Adjih <[email-masked]>
Date: Tue, 19 Jul 2016 15:23:52 +0200 (CEST)

Dear Angela, 

I guess everyone was excited of seeing a presentation of Network Coding 
in a new context, NFV, and would loved to have it also in the context of the NWCRG, 
since this was a question had been raised in the RG. 

Bhumip for instance once (last year) asked the question: 
"Can the coding/decoding function be implemented using a Virtual Network Function (NFV)? " 
https://www.ietf.org/proceedings/92/slides/slides-92-nwcrg-1.pdf 

An also Frank (Fitzek) also presented some preliminary work in the group, which I guess 
is related with the work he did with Szabo et al. "Network Coding as a Service" 
https://arxiv.org/pdf/1601.03201.pdf 

So thank you for providing input with this interesting combination of NFV with NC. 

In particular, slide 17 of your presentation I see a "NC functional architecture". 
I am curious if you have instantiated this architecture on, say, one application, 
(e.g. have you an idea/details of how the content of the different boxes and 
or they interact). And also have you think of what would be good other applications 
of the use of NC with NFV ? 

best regards, 
-- Cedric 

----- Original Message -----

| From: "Angeles Vazquez-Castro" <[email-masked]>
| To: "Vincent Roca" <[email-masked]>
| Cc: [email-masked]
| Sent: Monday, July 18, 2016 8:16:55 PM
| Subject: Re: [nwcrg] NC presentation during the NFVRG meeting

| Dear All,

| I don't like that my presentation, that happens to be in line with
| the contents of nfvrg, is used to be provocative or in any other way
| other than strictly technical and constructive as in the spirit of
| irtf.

| Any technical feedback is more than welcome.

| Thank you, Ángeles

| On Jul 18, 2016, at 7:48 PM, Vincent Roca < [email-masked] >
| wrote:

| | Hello everybody,
| 

| | FYI... There was a presentation by Angeles (who contributed to our
| | Prague meeting last year) to the NFVRG this morning.
| 
| | Slides are available:
| 
| | https://www.ietf.org/proceedings/96/slides/slides-96-nfvrg-10.pdf
| 
| | I'm a little bit provocative, but is the NWCRG group still the
| | preferred place to discuss and contribute to NC?
| 

| | Cheers,
| 

| | Vincent _______________________________________________
| 
| | nwcrg mailing list
| 
| | [email-masked]
| 
| | https://www.irtf.org/mailman/listinfo/nwcrg
| 

| _______________________________________________
| nwcrg mailing list
| [email-masked]
| https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "M. A. Vazquez-Castro" <[email-masked]>
Date: Wed, 20 Jul 2016 02:32:57 +0200

Dear Cedric,

many thanks for your nice feedback.

I totally agree with what you say. I contacted Victor and Brian in May to inform them about a contribution from my side on this topic and asking how could it best be handled/coordinated between nwcrg and nfvrg. There was no reply nor action that I am aware of within nwcrg.

As for your question, the origin of the framework were proposals of practical designs (see my presentation in Prague), from which we identified preliminary general functional blocks that were common. The resulting framework was not far from other proposals in the wg. It became quite natural to review the functional blocks to match the NFV framework. Of course there is quite some work to do to fine-tune and describe blocks in detail as well as to identify interactions/analytical models between NC blocks and NFV architectural elements e.g. common to potential applications. Different potential study cases can be defined e.g. based on what network coding can provide depending on the target service intent.

After my presentation at NFVRG I was asked to initiate a draft in the context of NFVRG. It will be done together with the company AnsuR technologies (Norway). We will be happy to have discussions and coordinate and proceed accordingly. 

Best wishes, Ángeles

On Jul 19, 2016, at 3:23 PM, Cedric Adjih <[email-masked]>
 wrote:

> From: "Angeles Vazquez-Castro" <[email-masked]>
> To: "Vincent Roca" <[email-masked]>
> Cc: [email-masked]
> Sent: Monday, July 18, 2016 8:16:55 PM

---

From: Frank Fitzek <[email-masked]>
Date: Mon, 25 Jul 2016 20:18:35 +0200

Dear all,
in the last IRTF meeting mentioned that our NWCRG is low in activity. I 
would share his opinion that we are quite silent on this channel, but 
there where several talks about network coding in other groups suchas 
NFV or MANET. We should advertise this here a bit more, just to not 
loose our seat in IRTF. So maybe we can coordinate for the upcoming 
meetings and see our we can foster the work in this group.
FF

-- 
Frank H.P. Fitzek
Professor
Deutsche Telekom Chair of Communication Networks
Institute of Communication Technology
TU Dresden

mobile: +49 151 160 00003
phone:  +49 351 463 33945
fax:    +49 351 463 37163

web:	cn.ifn.et.tu-dresden.de
web:    www.fitzek.net
skype:	fitzek

5G Lab Germany Coordinator 5Glab.de
CFAED Resilience Path Co-leader
HAEC Architecture Group Co-leader