Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt

From: Vincent Roca <[email-masked]>
Date: Thu, 3 Nov 2016 22:06:28 +0100

Hello everybody,

Here are a few suggestions of work that remains to be done in the taxonomy I-D
	https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/ <https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/>
and that complement comments already in the document.
Those are mostly my views and you can disagree. Everything is open for discussions.

1- change the wording of some definitions to use the IETF vocabulary rather than
   the RLNC/information theory vocabulary. Of course this does not apply to all
   definitions.
   Example: "original or coded payloads" => "source or repair symbols"

2- simplify the structure with fewer top level sections.
   Change the order when needed to start with generic aspects and go
   progressively into the details.

3- re-affect items to sections when needed, in particular after the structure
   simplification of step 2.

4- remove items that are not required.
   Example: "Payload Set" and the associated "Rank", "Full Rank", "Range Space", etc.
   were never defined in RMT/FECFRAME although block FEC codes were heavily used.
   Second example: NACK is not FEC related but protocol related and could be removed.
   In any case it is not specific to block codes.

5- determine if items are missing, either from existing RMT/FECFRAME documents,
   or from the network coding domain.

Something else?

**An additional question: who wants and has time to contribute in the coming weeks?**

Cheers,

  Vincent

---

From: Bilbao Josu <[email-masked]>
Date: Sun, 6 Nov 2016 18:23:40 +0000

Hi Vincent,
I agree with your comments.
Which is your proposal of time-line to gather the contributions? I wonder if we could schedule an on-line meeting/audio among the contributors to the Draft to discuss the document and reach a consensus on the terminology...
Best regards,
Josu

De: Vincent Roca [mailto:[email-masked]]
Enviado el: jueves, 3 de noviembre de 2016 22:06
Para: [email-masked]
Asunto: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt

Hello everybody,

Here are a few suggestions of work that remains to be done in the taxonomy I-D
            https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/
and that complement comments already in the document.
Those are mostly my views and you can disagree. Everything is open for discussions.

Something else?

Cheers,

  Vincent

---

From: Vincent Roca <[email-masked]>
Date: Wed, 9 Nov 2016 11:29:27 +0100

Hello Josu,

Thanks for your feedback.

Concerning the time-line, I'd say the sooner the better but of course it will depend on everybody's availability.
Personally I couldn't devote enough time during the past few weeks so I won't blame anybody.

I'd like to suggest you and interested people to **send suggestions on a possible structure on the list (point 2 below)**
so that we can converge. Other points are important too but may depend on this for some of them.

Concerning the meeting/audio, I remind everybody that we have one scheduled on Wednesday 16th, next week,
during IETF 97. I know few people will participate physically, but remote participation tools are pretty efficient, so do
not hesitate. The agenda is not yet published but our taxonomy I-D will be part of it.

We'll see later on if a dedicated audio could be useful, but for the moment I don't think it's the case. Let's discuss
on the list instead.

Cheers,

  Vincent

> Le 6 nov. 2016 à 19:23, Bilbao Josu <[email-masked]> a écrit :
> 
> Hi Vincent,
> Which is your proposal of time-line to gather the contributions? I wonder if we could schedule an on-line meeting/audio among the contributors to the Draft to discuss the document and reach a consensus on the terminology…
> Best regards,
> Josu
>   <>