Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt

From: Vincent Roca <[email-masked]>
Date: Wed, 1 Feb 2017 17:34:52 +0100

Hello,

Thanks to those who responded. We'll have our short telco next week:
	Tuesday Feb. 7
	4 pm Madrid/Paris time
	10 am Boston time
We'll get in touch with participants directly.

Cheers,

  Vincent and Josu

> Le 27 janv. 2017 à 15:49, Vincent Roca <[email-masked]> a écrit :
> 
> Hi everybody,
> 
> We had a discussion and came to the conclusion that having a short telco (approx. 1 hour) could help make
> progress. Josu prepared a doodle:
> 	http://doodle.com/poll/w9mna5vtgnuku53v <http://doodle.com/poll/w9mna5vtgnuku53v>
> 
> This telco is above all for authors and anybody interested in contributing to the taxonomy I-D, but it
> remains open to anybody. If interested please fill it ASAP, we'll decide next Wednesday morning (EU time)
> which slot is the most appropriate. Depending on how many we are, it will take place with Skype or WebEx.
> 
> Last but not least, in order to be efficient, before the Telco, please provide your proposal if you have one:
> 
>> I'm waiting for your proposals for steps 1 (and possibly 2) above, next week if possible.
>> Of course everybody is kindly invited to participate as this is our WG Item document.
> 
> 
> Cheers,
> 
>   Vincent and Josu.
> 
> 
>> Le 6 janv. 2017 à 09:29, Vincent Roca <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
>> Hello everybody,
>> 
>> As said before, we need to update our taxonomy I-D.
>> Goal is to have a finalised version for next IETF, (i.e., mid March if we consider I-D submission cut-off).
>> https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/ <https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/>
>> 
>> Here are the steps I propose (from a previous discussion, slightly updated):
>> 
>> Step 1: reorganise and simplify the structure with fewer top level sections.
>> 
>> Step 2: 
>>    affect items to the new sections,
>>    remove items that are not required,
>>            (e.g., "Payload Set" and the associated "Rank", "Full Rank", "Range Space", etc.
>>             were never defined in RMT/FECFRAME)
>>    determine if items are missing.
>> 
>> Step 3: check all definitions and update the wording if needed to use the IETF vocabulary
>>    rather than the RLNC/information theory vocabulary (primary target audience is IETF
>>    rather than the NC community)
>> 
>> I'm waiting for your proposals for steps 1 (and possibly 2) above, next week if possible.
>> Of course everybody is kindly invited to participate as this is our WG Item document.
>> 
>> To that purpose, you'll find below the list of current (from -01) sections and associated items.
>> Thanks in advance.
>> 
>> 
>> Regards,
>> 
>>   Vincent
>> 
>> 
>> <taxonomy_id_01_structure.rtf>
>> <taxonomy_id_01_structure.txt>
>> _______________________________________________
>> nwcrg mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg
>

---

From: "Firoiu, Victor (US)" <[email-masked]>
Date: Tue, 7 Feb 2017 23:14:36 +0000

Hi Vincent,

I wanted but was not able to participate in this call. Do you have a summary of the discussion?

Thanks,
Victor

From: nwcrg [mailto:[email-masked]] On Behalf Of Vincent Roca
Sent: Wednesday, February 01, 2017 11:35 AM
To: [email-masked]
Cc: Vincent Roca; Bilbao Josu
Subject: Re: [nwcrg] I-D Action: draft-irtf-nwcrg-network-coding-taxonomy-01.txt

Hello,

Cheers,

  Vincent and Josu

Le 27 janv. 2017 à 15:49, Vincent Roca <[email-masked]<mailto:[email-masked]>> a écrit :

Hi everybody,

We had a discussion and came to the conclusion that having a short telco (approx. 1 hour) could help make
progress. Josu prepared a doodle:
            http://doodle.com/poll/w9mna5vtgnuku53v

Cheers,

  Vincent and Josu.

Le 6 janv. 2017 à 09:29, Vincent Roca <[email-masked]<mailto:[email-masked]>> a écrit :

Hello everybody,

As said before, we need to update our taxonomy I-D.
Goal is to have a finalised version for next IETF, (i.e., mid March if we consider I-D submission cut-off).
https://datatracker.ietf.org/doc/draft-irtf-nwcrg-network-coding-taxonomy/

Step 2:

Regards,

  Vincent

[email-masked]<mailto:[email-masked]>

---

From: Vincent Roca <[email-masked]>
Date: Wed, 8 Feb 2017 09:15:58 +0100

Hello Victor et al,

You'll find in the attachement the current proposal for reorganising our I-D as discussed yesterday.
The idea is to have a simple structure organised as follows:

	- Introduction: clarify scope (limited to losses, consider non trivial codes)

	- Section 2: the various ways of using coding in general for network communications

	- Section 3: coding details
		- 3.1: a high level taxonomy
		- 3.2: the coding details (i.e., what constitutes the code specification)
		- 3.3: the practical aspects (i.e., what is in a FEC scheme once you've removed the code specification)
		- 3.4: code examples

We'll have a new audio in exactly two weeks: Tuesday Feb. 21.
	4 pm Madrid/Paris time
	10 am Boston time

The goal is now to work on the various definitions.
I'll soon send some homework to those who expressed their interest (including you, Victor).
If anybody else is interested, just tell me and I'll send you more details.

Cheers,

  Vincent

---

From: "paresh.saxena" <[email-masked]>
Date: Fri, 10 Feb 2017 13:45:53 +0530

Dear Vincent,

We would also like to contribute and participate for the next telco - 
Tuesday, Feb 21. Could you please include us in the list and send us 
more details ?

- M. A. Vazquez-Castro, UAB, Barcelona, Spain.
- Ozgu Alay, Simula Research Laboratory, Oslo, Norway.
- Paresh Saxena, AnsuR Technologies, Oslo, Norway.
- Thomas Treibholz, Simula Research Laboratory, Oslo, Norway.

Best Regards,
Paresh Saxena,
Senior Research Engineer, AnsuR Technologies,
Oslo, Norway.

>> FROM: Vincent Roca <[email-masked]>
>> 
>> SUBJECT: RE: [NWCRG] I-D ACTION:
>> DRAFT-IRTF-NWCRG-NETWORK-CODING-TAXONOMY-01.TXT
>> 
>> DATE: 8 February 2017 at 09:15:58 GMT+1
>> 
>> TO: "Firoiu, Victor (US)" <[email-masked]>,
>> "[email-masked]" <[email-masked]>
>> 
>> 
>> Hello Victor et al,
>> 
>> We'll have a new audio in exactly two weeks: TUESDAY FEB. 21.
>> 4 pm Madrid/Paris time
>> 10 am Boston time
>>

---

From: Vincent Roca <[email-masked]>
Date: Fri, 10 Feb 2017 09:39:17 +0100

Hello Paresh et al,

Thanks for your interest. 
I'm sending you the instructions.
Cheers,

  Vincent

> 
> Dear Vincent,
> 
> We would also like to contribute and participate for the next telco - Tuesday, Feb 21. Could you please include us in the list and send us more details ?
>

---

From: [email-masked]
Date: Fri, 10 Feb 2017 09:43:41 +0100

Hi Vincent,

I would like to contribute, remotely. Will be looking forward to the
details.

Best,
Samah.

On Fri, Feb 10, 2017 at 9:39 AM, Vincent Roca <[email-masked]> wrote:

> Tuesday, Feb 21. Could you please include us in the list and send us more
> details ?
> >
> [email-masked]

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Fri, 10 Feb 2017 15:31:59 +0100

Hi Vincent,
If needed I would also be happy to contribute.

- M

On 02/10/2017 09:43 AM, [email-masked] wrote:
> On Fri, Feb 10, 2017 at 9:39 AM, Vincent Roca <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hello Paresh et al,
>
>     > We would also like to contribute and participate for the next
>     telco - Tuesday, Feb 21. Could you please include us in the list
>     and send us more details ?
>     >
>     >>> FROM: Vincent Roca <[email-masked]
>     <mailto:[email-masked]>>
>     >>> TO: "Firoiu, Victor (US)" <[email-masked]
>     <mailto:[email-masked]>>,
>     >>> "[email-masked] <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]>>
>     >>> Hello Victor et al,
>     >>> You'll find in the attachement the current proposal for
>     reorganising
>     >>> our I-D as discussed yesterday.
>     >>> - Section 2: the various ways of using coding in general for
>     network
>     >>> communications
>     <https://www.irtf.org/mailman/listinfo/nwcrg>
>
>
>
>

---

From: Vincent Roca <[email-masked]>
Date: Mon, 13 Feb 2017 16:27:59 +0100

Hello everybody,

New instructions...

Since a lot of people (16, myself included) declared being interested to work on our NC taxonomy document,
we need a better organisation. Therefore I've created a Google Drive version that I propose to use.
I have invited each of you, using your usual email.
If ever you didn't receive this invitation, or prefer to use a different email, just tell me...

I also propose to continue discussions on this general mailing list (long lists of TO or CC are error prone).

To summarise:

1- What to do?

Have a look at the following doodle to see where you can contribute (idea is to have a few people reviewing each section).
http://doodle.com/poll/fd9z6a3qz56sh6p8 <http://doodle.com/poll/fd9z6a3qz56sh6p8>

You can register yourself in the Doodle (better).
Choose one or more (sub)section(s).
Your job is to update the description of each item in that (sub)section (ideally, do your best otherwise) before next audio.
Do not replace the old text, but add a comment prefixed with your initials (e.g., [VR])
You can also suggest new items, affect them to another (sub)section, rename them or remove them, propose new (sub)section name, etc. Do not hesitate but do that in a non destructive way.

2- Audio:

As said before we'll have a new audio on Tuesday Feb. 21, using WebEx (see link below from Josu who kindly
provides the facility):
	4 pm Madrid/Paris time
	10 am Boston time
Goal is to discuss definitions for which we disagree. Therefore do your proposals ahead of time in order to be efficient during the audio.

3- Hard deadline:

2017-03-13 (Monday): Internet Draft submission cut-off (for all drafts, including -00) by UTC 23:59.
And I'll need some time to prepare the XML version from this online document...

Thanks,

 Vincent

--------------------
Dear all,
Please find below the details for the next telco in 2 weeks.
Join WebEx meeting <https://ik4.webex.com/ik4-en/j.php?MTID=m8a76fdaec019042537b1f05e731d5d07>
Meeting password:       nwcrg  
 
Best regards,
Josu

---

From: Vincent Roca <[email-masked]>
Date: Tue, 21 Feb 2017 14:33:03 +0100

Hello,

Just a reminder... We'll have a (short) audio very soon today (see connection Instructions below).

The Google Drive document is progressing well. A goal of the audio is to get your feedback on a
few questions (in red) listed in this document.

Thanks,

  Vincent

---

From: Vincent Roca <[email-masked]>
Date: Wed, 22 Feb 2017 08:27:58 +0100

Hello everybody,

Yesterday's audio gathered 8 people, myself included, and we made a lot of progress.

This is the last mile... We decided to have a final audio in two weeks, a few days before
the deadline (2017/03/13). Everybody is welcome to participate, both in the audio and
(above all) Google Drive document where you can comment and/or suggest definitions.
(ask me if you don't have access to this document)

Here is a Doodle to select the best date for next audio:
		http://doodle.com/poll/82a4aivnyyxgp626 <http://doodle.com/poll/82a4aivnyyxgp626>
You have two days, until Friday morning (GMT time). Thanks.

Cheers,

  Vincent

---

From: [email-masked]
Date: Thu, 23 Feb 2017 03:23:18 +0100

Hello,

Can you share the link to the latest taxonomy discussed. Thank you,

Best,
Samah

On Wed, Feb 22, 2017 at 8:27 AM, Vincent Roca <[email-masked]> wrote:

> http://doodle.com/poll/82a4aivnyyxgp626

---

From: Vincent Roca <[email-masked]>
Date: Thu, 23 Feb 2017 08:35:14 +0100

Hello Samah,

The latest taxonomy document remains in the Google Drive. You can edit it.
It is split into two parts:

	- the first 8 pages is the new version on which I'd like to have your feedbacks/inputs

	- the remaining pages (highlighted in yellow) is the previous version, here in case
	  one would like to go back to comments already made.

Sorry if it wasn't clear.

Cheers,

  Vincent

> Le 23 févr. 2017 à 03:23, [email-masked] a écrit :
> 
> Hello,
> 
> On Wed, Feb 22, 2017 at 8:27 AM, Vincent Roca <[email-masked] <mailto:[email-masked]>> wrote:
> Hello everybody,
> 
> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
> 
>

---

From: Vincent Roca <[email-masked]>
Date: Fri, 24 Feb 2017 08:16:13 +0100

Hello,

I suggest to hold our final Taxonomy audio on Wednesday March 8th, same time
(4pm Paris time, 10am Boston time).

Webex connection information will follow (once again thanks to Josu).

Cheers,

  Vincent