Subject: Re: [nwcrg] Structuring NWCRG activities: a few ideas...

From: Vincent Roca <[email-masked]>
Date: Fri, 5 May 2017 15:01:50 +0200

Hello Morten,

> One thing that would be interesting to do, for each use-case (in my opinion) - would be to also describe what is the problem/feature that Network Coding enables in each case.

Yes.

> I think the low-latency applications are very interesting, not only point-to-point, but also point-to-multipoint.

Sure, both p2p and p2m. This second use-case is what motivated our work on FECFRAME-extended at TSVWG
(my slides from IETF98: https://www.ietf.org/proceedings/98/slides/slides-98-tsvwg-sessb-63-fecframe-drafts-00.pdf <https://www.ietf.org/proceedings/98/slides/slides-98-tsvwg-sessb-63-fecframe-drafts-00.pdf>).

> I imagine the ICN/CCN will from a transport perspective be related to peer-to-peer type communication? In which case I also agree good use-case.

Exactly (see other emails and references provided by others).

> The others I'm not sure I understand enough about to comment.

I’ll send more details.

> On coding side, I think both items sounds very interesting.
> Low-complexity, low-memory (for embedded devices), parallelized algorithms also are topics what would be interesting to me.

Good point. I see our RG as an opportunity to discuss advanced coding technics, with potential applications to IETF, and this
topic could be important in the near future. Let’s go on.

Thanks,

  Vincent

---

From: Rolf Sperber <[email-masked]>
Date: Tue, 09 May 2017 12:31:27 +0200

Dear all,

I can think of the following use cases for NC:
* High density sensor networks
> * localization of containers, this would be a use case proposed by German Rail
> * Sensors emitting data in LHC applications, CERN
* For parallel computing applications:
> * starting multiple metaheuristic processes on multiple clusters, a friend of
> mine from Iran is working on that
> * Genome sequencing applications
* Peer to peer applications like coded databases
* I will have a close look into Open Telekom Cloud provided by Deutsche
Telekom
Best regards

Rolf

Rolf Sperber
Birkenstrasse 5
76676 Graben-Neudorf
GERMANY
[email-masked]
Phone: +49 7255 9000987
Mobile: +49 151 21262119
skype: rolf.rs01

Von:  nwcrg <[email-masked]> on behalf of Vincent Roca
<[email-masked]>
Datum:  Freitag, 21. April 2017 um 09:36
An:  <[email-masked]>
Betreff:  [nwcrg] Structuring NWCRG activities: a few ideas...

Hello everybody,

Here are a few topics related to « coding for efficient network
communications » on which we could work within the
NWCRG.

Use-cases where end-to-end coding or network coding can be beneficial:

- NC for satellite communications
- NC for ICN/CCN
- NC for NFV
- Virtual/Augmented Reality: can NC help and how?
- Robust, low latency tunnels: this could be the basis of a generic protocol
- something else?

On the Coding side:

- applying sliding window codes for low latency, robust communications
- sliding window codes: several of them have been presented in the past few
years during NWCRG meetings
(or elsewhere). It¹s time to go further with specifications, comparisons,
work on advanced features, etc.
- something else?

A « nice to have »:

- open source sliding window codecs, not encumbered with complex licensing
conditions or (hopefully) IPR
- open source NC solution, here also not encumbered with complex licensing
conditions or (hopefully) IPR
- work on a generic API for sliding window codes

Transversal questions for most of the above topics:

- Q: what are the research topics we¹d like to address? There are in
particular many important and tough questions
on relationships with congestion control and fairness with other flows.
- Q: can we derive a generic architecture from existing NC deployments?

Our group can produce Internet-drafts (and informational or experimental
RFCs). This is a good manner to have
concrete activities that can be discussed within the group and that authors
can valorize. I encourage you all to think
about it.
But inputs can also take other forms: research articles published elsewhere
(or not) provided as input for discussions,
presentations during next IETF99 meeting (Prague, Czech Republic).

Part of the above work is of research type, the rest is more applied. Even
if we are a research group, this second
aspect can both fuel research activities and potentially future IETF work.
Therefore it will not considered as out of
scope.

Finally, please consider the above topic as inputs for discussions. Good
ideas are always welcome, nothing is fixed.

Cheers,

  Vincent
_______________________________________________ nwcrg mailing list
[email-masked] https://www.irtf.org/mailman/listinfo/nwcrg