Subject: Re: [nwcrg] nwcrg Digest, Vol 43, Issue 2

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 9 May 2017 08:55:26 -0400

I think those are all good ideas :-)  Reminds me that we should update is the patents list and the availability of software for research and even product development so we can bring these to life!

mjm

> On May 9, 2017, at 6:31 AM, [email-masked] wrote:
> 
> Send nwcrg mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.irtf.org/mailman/listinfo/nwcrg
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of nwcrg digest..."
> Today's Topics:
> 
>   1. Re: Structuring NWCRG activities: a few ideas... (Rolf Sperber)
> 
> From: Rolf Sperber <[email-masked]>
> Subject: Re: [nwcrg] Structuring NWCRG activities: a few ideas...
> Date: May 9, 2017 at 6:31:27 AM EDT
> To: Vincent Roca <[email-masked]>, <[email-masked]>
> 
> 
> Dear all,
> 
> I can think of the following use cases for NC:
> High density sensor networks
> localization of containers, this would be a use case proposed by German Rail
> Sensors emitting data in LHC applications, CERN
> For parallel computing applications:
> starting multiple metaheuristic processes on multiple clusters, a friend of mine from Iran is working on that
> Genome sequencing applications
> Peer to peer applications like coded databases
> I will have a close look into Open Telekom Cloud provided by Deutsche Telekom
> Best regards
> 
> Rolf
> 
> 
> <8316D768-2B72-45DB-821D-73E99B32398B[1].jpg>
> 
> Rolf Sperber
> Birkenstrasse 5
> 76676 Graben-Neudorf
> GERMANY
> [email-masked]
> Phone: +49 7255 9000987
> Mobile: +49 151 21262119
> skype: rolf.rs01
> 
> Von: nwcrg <[email-masked] <mailto:[email-masked]>> on behalf of Vincent Roca <[email-masked] <mailto:[email-masked]>>
> Datum: Freitag, 21. April 2017 um 09:36
> An: <[email-masked] <mailto:[email-masked]>>
> Betreff: [nwcrg] Structuring NWCRG activities: a few ideas...
> 
> Hello everybody,
> 
> Here are a few topics related to « coding for efficient network communications » on which we could work within the
> NWCRG.
> 
> Use-cases where end-to-end coding or network coding can be beneficial:
> 
> 	- NC for satellite communications
> 	- NC for ICN/CCN
> 	- NC for NFV
> 	- Virtual/Augmented Reality: can NC help and how?
> 	- Robust, low latency tunnels: this could be the basis of a generic protocol
> 	- something else?
> 
> On the Coding side:
> 
> 	- applying sliding window codes for low latency, robust communications
> 	- sliding window codes: several of them have been presented in the past few years during NWCRG meetings
> 		(or elsewhere). It’s time to go further with specifications, comparisons, work on advanced features, etc.
> 	- something else?
> 
> A « nice to have »:
> 
> 	- open source sliding window codecs, not encumbered with complex licensing conditions or (hopefully) IPR
> 	- open source NC solution, here also not encumbered with complex licensing conditions or (hopefully) IPR
> 	- work on a generic API for sliding window codes
> 
> Transversal questions for most of the above topics:
> 
> - Q: what are the research topics we’d like to address? There are in particular many important and tough questions
> 	on relationships with congestion control and fairness with other flows.
> - Q: can we derive a generic architecture from existing NC deployments?
> 
> 
> Our group can produce Internet-drafts (and informational or experimental RFCs). This is a good manner to have
> concrete activities that can be discussed within the group and that authors can valorize. I encourage you all to think
> about it.
> But inputs can also take other forms: research articles published elsewhere (or not) provided as input for discussions,
> presentations during next IETF99 meeting (Prague, Czech Republic).
> 
> Part of the above work is of research type, the rest is more applied. Even if we are a research group, this second
> aspect can both fuel research activities and potentially future IETF work. Therefore it will not considered as out of
> scope.
> 
> Finally, please consider the above topic as inputs for discussions. Good ideas are always welcome, nothing is fixed.
> 
> Cheers,
> 
>   Vincent
> _______________________________________________ nwcrg mailing list [email-masked] <mailto:[email-masked]> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg><8316D768-2B72-45DB-821D-73E99B32398B[1].jpg>
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Tue, 9 May 2017 17:40:05 +0200

Hello Marie-José, Rolf and all,

It seems that we are not short of suggestions for applying network coding. That’s good.
The following question is: do we have deployment experience? Is there any description of such deployments?
Or is it a brand new idea/use-case?

Concerning the patent list, it could be useful but not in my priority list (@all: MJM and myself did the exercice
a few years ago and presented the results here: https://www.ietf.org/proceedings/92/slides/slides-92-nwcrg-3.pdf <https://www.ietf.org/proceedings/92/slides/slides-92-nwcrg-3.pdf> )

The list of available softwares is probably more important, I agree.

Thanks,

  Vincent

> Le 9 mai 2017 à 14:55, Marie-Jose Montpetit <[email-masked]> a écrit :
> 
>> On May 9, 2017, at 6:31 AM, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 	[email-masked] <mailto:[email-masked]>
>>

---

From: Rolf Sperber <[email-masked]>
Date: Tue, 09 May 2017 19:21:00 +0200

Dear Marie-Jose, dear Vincent, all,

there are experiments in the 5G lab of Deutsche Telekom. This lab is run by
Prof Fitzek and his staff. I will contact them tomorrow and hope to come
back with a few network diagrams. There is a software available for peer to
peer NC, i.e. database to client, it is supposed to be public and I will try
to get hold of it tomorrow. If there are no objections by either DT or the
5G chair I will distribute it to the list.

Best wishes so far

Rolf

Rolf Sperber
Birkenstrasse 5
76676 Graben-Neudorf
GERMANY

Von:  nwcrg <[email-masked]> on behalf of Vincent Roca
<[email-masked]>
Datum:  Dienstag, 9. Mai 2017 um 17:40
An:  "[email-masked]" <[email-masked]>
Cc:  <[email-masked]>
Betreff:  Re: [nwcrg] nwcrg Digest, Vol 43, Issue 2

It seems that we are not short of suggestions for applying network coding.
That¹s good.
The following question is: do we have deployment experience? Is there any
description of such deployments?
Or is it a brand new idea/use-case?

Concerning the patent list, it could be useful but not in my priority list
(@all: MJM and myself did the exercice
a few years ago and presented the results here:
https://www.ietf.org/proceedings/92/slides/slides-92-nwcrg-3.pdf )

Thanks,

  Vincent

> I think those are all good ideas :-)  Reminds me that we should update is the
> patents list and the availability of software for research and even product
> development so we can bring these to life!
> 
> mjm
> 
> 
>> * High density sensor networks
>>> * localization of containers, this would be a use case proposed by German
>>> Rail
>>> * Sensors emitting data in LHC applications, CERN
>> * For parallel computing applications:
>>> * starting multiple metaheuristic processes on multiple clusters, a friend
>>> of mine from Iran is working on that
>>> * Genome sequencing applications
>> * Peer to peer applications like coded databases
>> * I will have a close look into Open Telekom Cloud provided by Deutsche
>> Telekom
>> Best regards
>> 
>> Rolf
>> 
>> 
>> Von:  nwcrg <[email-masked]> on behalf of Vincent Roca
>> <[email-masked]>
>> An:  <[email-masked]>
>> Here are a few topics related to « coding for efficient network
>> communications » on which we could work within the
>> NWCRG.
>> 
>> (or elsewhere). It¹s time to go further with specifications, comparisons,
>> work on advanced features, etc.
>> - something else?
>> 
>> A « nice to have »:
>> 
>> - Q: what are the research topics we¹d like to address? There are in
>> particular many important and tough questions
>> concrete activities that can be discussed within the group and that authors
>> can valorize. I encourage you all to think
>> about it.
>> But inputs can also take other forms: research articles published elsewhere
>> (or not) provided as input for discussions,
>> aspect can both fuel research activities and potentially future IETF work.
>> Therefore it will not considered as out of
>> scope.
>> 
>> Finally, please consider the above topic as inputs for discussions. Good
>> ideas are always welcome, nothing is fixed.
>> 
>> Cheers,
>> 
>>   Vincent
>> _______________________________________________ nwcrg mailing list
>> [email-masked]://www.irtf.org/mailman/listinfo/nwcrg

_______________________________________________ nwcrg mailing list
[email-masked] https://www.irtf.org/mailman/listinfo/nwcrg