Subject: [nwcrg] LHC data collection

From: Rolf Sperber <[email-masked]>
Date: Tue, 16 May 2017 16:22:10 +0200

Dear all,

I just had a discussion with a colleague from Huawei (in cc) about the data
collection and evaluation problem they have in the CERN LHC. Thomas sent me
a presentation (attached), the problem for CERN is the high number of
sensors and the extreme volume of data being generated. These data have to
be evaluated and prior to evaluation they have to be transported. Magnetic
fields do not allow copper connections and limited availability of space and
energy prohibit the use of fibre. Use of wireless technology might be
subject to frame loss. Thomas and I would like to go ahead planning an NC
architecture; I heard that Vincent is a member of the CERN Open Lab and this
might be a good chance to get more detailed on one of the use cases. In
parallel I am working on the use cases I proposed last week.

Best regards

Rolf

Rolf Sperber
Birkenstrasse 5
76676 Graben-Neudorf
GERMANY
[email-masked]
Phone: +49 7255 9000987
Mobile: +49 151 21262119
skype: rolf.rs01

---

From: Raymond Yeung <[email-masked]>
Date: Wed, 17 May 2017 14:32:23 +0800

Dear Rolf and Thomas,

This appears to fall into the domain of NC.  Just a specific question: Are the sensors connected to the data collection center in one hop or multiple hops?

A few years ago my collaborator Shenghao Yang and I developed an advanced NC scheme called BATS code.  I gave a talk online at an NWCRG meeting a few years ago on this.  One can think of it as an efficient and rateless implementation of RLNC.  In a multi-hop situation, for simplicity assume that the packet (frame) loss rate on each hop is the same.  By applying BATS code, the end-to-end packet loss rate after many hops (several tens or even 1000 hops) can be maintained close to that of 1 hop.  At the same time, the delay is minimal.

For the past few years, we have spent a lot of effort refining the implementation of the code.  Some details can be found in the attached pdf file and also here:

http://www.inc.cuhk.edu.hk/research/bats <http://www.inc.cuhk.edu.hk/research/bats>

At this link there is a demo for video transmission on the improvement obtained by using BATS code over fountain code for only 2 hops.  If there are more than 2 hops, the improvement would be much bigger.

Best regards,
Raymond

> On May 16, 2017, at 10:22 PM, Rolf Sperber <[email-masked]> wrote:
> 
> Dear all,
> 
> I just had a discussion with a colleague from Huawei (in cc) about the data collection and evaluation problem they have in the CERN LHC. Thomas sent me a presentation (attached), the problem for CERN is the high number of sensors and the extreme volume of data being generated. These data have to be evaluated and prior to evaluation they have to be transported. Magnetic fields do not allow copper connections and limited availability of space and energy prohibit the use of fibre. Use of wireless technology might be subject to frame loss. Thomas and I would like to go ahead planning an NC architecture; I heard that Vincent is a member of the CERN Open Lab and this might be a good chance to get more detailed on one of the use cases. In parallel I am working on the use cases I proposed last week.
> 
> Best regards
> 
> Rolf
> 
> 
> <8316D768-2B72-45DB-821D-73E99B32398B[5].jpg>
> 
> Rolf Sperber
> Birkenstrasse 5
> 76676 Graben-Neudorf
> GERMANY
> <8316D768-2B72-45DB-821D-73E99B32398B[5].jpg><openlab-ws-03-17-realtime-connectivity.pptx>_______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Vincent Roca <[email-masked]>
Date: Wed, 17 May 2017 22:44:10 +0200

Hello Rolf, Thomas, et al.

Thanks Rolf and Thomas for the presentation. It’s clear that very high speed real-time data movement is challenging.
It is pretty in line with a report published recently (co-authored by several IETF/IRTF participants):
	https://science.energy.gov/~/media/ascr/pdf/programdocuments/docs/2017/DOE_Network_2025.pdf

Coding and/or network coding can be part of the solution, for communication aspects and/or storage aspects. At least this is
something to investigate. There can also be relationships with the generic robust low latency tunnelling topic.
There are a few aspects to clarify between what you’re saying (optical fibres and copper links out of scope) and what is in
the slides, but that’s detail.

Yes, let’s go ahead with this topic.

Cheers,

  Vincent

NB: I’m not member of the CERN OpenLab (probably another Vincent) but this is not an issue.
NB2: I’m not sure sending big files as email attachements to the list is much appreciated.

> Le 16 mai 2017 à 16:22, Rolf Sperber <[email-masked]> a écrit :
> 
> Dear all,
>

---

From: Vincent Roca <[email-masked]>
Date: Wed, 17 May 2017 22:55:08 +0200

Dear Raymond,

I remember well your presentation during the London IETF meeting, and I’m happy to see that you and your colleagues moved forward
and now have running software and operational experience. This is highly useful and important, and in line with what we’re looking for.
I’ll come back to you and a few others to discuss how to move forward on this topic and see how to collectively benefit from your and
others experience. Thanks for the pointers.

Cheers,

  Vincent

> Le 17 mai 2017 à 08:32, Raymond Yeung <[email-masked]> a écrit :
> 
> Dear Rolf and Thomas,
> 
> <BATS_Action.pdf>
>> On May 16, 2017, at 10:22 PM, Rolf Sperber <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear all,
>> 
>> [email-masked] <mailto:[email-masked]>
>> Phone: +49 7255 9000987
>> Mobile: +49 151 21262119
>> skype: rolf.rs01
>> [email-masked] <mailto:[email-masked]>
> _______________________________________________
> nwcrg mailing list
> [email-masked]

---

From: Raymond Yeung <[email-masked]>
Date: Thu, 18 May 2017 10:20:17 +0800

Dear Vincent, Thomas and Rolf,

In addition to low latency, another nice feature of BATS is that only a very small buffer is needed at the intermediate nodes.

I would like to introduce to you Shanghao Yang, the main inventor of BATS code, whose email is as cc.  He is now on the faculty of The Chinese University of Hong Kong (Shenzhen).  We would be very happy to see how we can contribute to this project.

Best regards, 
Raymond

> On May 18, 2017, at 4:55 AM, Vincent Roca <[email-masked]> wrote:
> 
> Dear Raymond,
> 
>> Le 17 mai 2017 à 08:32, Raymond Yeung <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
>> Dear Rolf and Thomas,
>> 
>>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>>