Subject: [nwcrg] Interim Meeting - Final Logistics

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 18 Sep 2017 12:20:48 -0400

Hello everyone and thanks for the interest in Tuesday’s nwcrg 9/19 meeting!

This is the latest and hopefully last logistics email.

Before we start we would like to acknowledge the following people in making the meeting possible:
	- Deborah Widener
	- Josu Bilbao
	- Ian Swett
	- Brandon Williams
	- Shirley Shi	

LOGISTICS

For in-person attendants:

The meeting is at the MIT Media Laboratory at 75 Amherst St, Cambridge, MA 02139 in the room E15-359 https://whereis.mit.edu/ <https://whereis.mit.edu/>
We have the room all day except from 12-1:30pm
There will be coffee, water and home made goodies in the morning
Iam Swett from Google is trying to organize lunch at Google Cambridge about 100m from the Media Lab (to be confirmed at the meeting tomorrow)
There will be water and green ice tea in the afternoon
We can all go for beer, some food and post meeting discussions at Meadhall (https://themeadhall.com/ <https://themeadhall.com/>) after the meeting; there is a reservation under Marie-José Montpetit (sadly everyone has to pay for their own expenses)

If you are coming from outside Boston you can ask for the MIT rate at the Marriott and Kendall Square hotels. There are also other lower cost hotels in Cambridge/Somerville and Boston that are close to MIT.
And AirBnb is always a solution as they now have business travel options.

For remote participants:

The meeting will be on Webex:
https://ik4.webex.com/ik4-en/j.php?MTID=mccce6c7d8333b19afbbe7fa2995e011e <https://ik4.webex.com/ik4-en/j.php?MTID=mccce6c7d8333b19afbbe7fa2995e011e>
Meeting number: 845 848 855
Meeting password: Pp5PH9EY

For people who cannot attend:

We intend in taking minutes of the salient discussions and to record the (audio) webex for later viewing. The recording will be uploaded to the group wiki: https://trac.ietf.org/trac/irtf/wiki/nwcrg <https://trac.ietf.org/trac/irtf/wiki/nwcrg>

INTERIM MEETING

Call for presentations and drafts:

While we have some presentations planned we welcome others as they related to the agenda below. Also for the people who presented in the past and those are presenting tomorrow we encourage for the work to be included in drafts that will show the progress to the whole IRTF community.

Agenda:

1. Working group status and update of the Charter
	
	- discussions on a RG charter update proposal (see attached document)
	- the proposal was submitted last week and no comments we received; please send comments if possible before the meeting!

2. Special Presentation: Network Coding with Satellite Protocols - DLR
	- to accommodate the DLR team and the time zone differences

3. Research fundamentals and applied research on Coding

	3.1. Research challenges
		- Discussions on what could/should be in

	3.2. Improved or new codes, encoding/decoding optimisations

	3.3. Performance evaluation of network codes: how to?
		- sharing our know-how on the topic
		- can we use the new sliding codes to start a common set of procedures?
		- can some of the industrial partners share their experience?

	3.4. Generic API
		- how generic should it be?

	3.5. Specifying new FEC Schemes
		- writing an I-D is no longer that complex: take example on the RLC I-D
		- there is still no I-D on the MIT/Caltech RLNC. Should we consider one? The goal is to have one draft per coding scheme (as per what is happening in cyber research for crypto solutions)

4.  Network Coding Use Cases Research
	A non exhaustive list follows. Will there be presenters for these?
	In particular define Research Challenges associated to each use-case.

	4.1. NC and satellite
		- In addition to the DLR presentation as apllicable

	4.2. NC and ICN/CCN

	4.3. Long Delay Networks/DTN

	4.4. CDN/Storage

	4.5. QUIC and sliding window codes

	4.6. NC and robust communications for the enterprise and in industrial environments

	4.7. NC and Congestion Control

5. Presentation of on going projects related to our RG
	- if you’re involved in a research project and want to present it…

6. Discussions

	6.1. Leveraging the group to create new projects
		- example: an open-source, free, reference implementation of sliding window codes under NWCRG umbrella

	6.2. How to tryout NC in a project?
		- need to get more people to tryout NC
		- many licenses exist with different clauses/prices/constraints and business relationships (academia vs. industry). Can we make it simpler for the group members?

7. How do we work better together?

	7.1. Use of the wiki for meeting audio recordings, minutes, references etc. (under review and being updated)
		https://trac.ietf.org/trac/irtf/wiki/nwcrg <https://trac.ietf.org/trac/irtf/wiki/nwcrg>

	7.2. Use of Google Docs to foster joint document development to meet the proposed milestones

	7.2. Interim meetings/post IRTF meetings
		- one interim meeting per year? 

	7.3. Other? Suggestions?

8. IETF’100 meeting preparation (Singapore)
	- who plans to participate, with what contribution(s)?

End

---

From: Muriel Medard <[email-masked]>
Date: Tue, 19 Sep 2017 02:13:40 +0000

Dear all,

Thank you for this document and the effort you are putting into the group. It is great to see the commitment you and Vince have to network coding.

I would like to attend the whole day but I am afraid that teaching duties (I am teaching our EECS introductory undergrad algorithms this term) will only allow me to join in the second part of the day. Shirley from my team will be attending the whole session.

Everyone knows our point of view on the IP related topics, given the foundational university inventions. We do not need to re-re-re discuss it. Instead, I am please that you are running this at MIT, one of the universities where were RLNC was invented. I would strongly encourage you and the working group to focus on the technology and its developments. We should all be aligned in pushing this exceptional technology and potentially co-developing it with industrial players. We are noticing that the market is now ready and momentum is positive.

See you on Tuesday.

Best,

Muriel.

Muriel Medard
Cecil H. Green
Professor of EECS
Head, Network Coding and Reliable Networking Group
Gilbreth Lecturer. National Academy of Engineering
[email-masked]<mailto:[email-masked]>

On Sep 18, 2017, at 12:20 PM, Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:

LOGISTICS

The meeting is at the MIT Media Laboratory at 75 Amherst St, Cambridge, MA 02139 in the room E15-359 https://whereis.mit.edu/
We have the room all day except from 12-1:30pm
There will be coffee, water and home made goodies in the morning
Iam Swett from Google is trying to organize lunch at Google Cambridge about 100m from the Media Lab (to be confirmed at the meeting tomorrow)
There will be water and green ice tea in the afternoon
We can all go for beer, some food and post meeting discussions at Meadhall (https://themeadhall.com/) after the meeting; there is a reservation under Marie-José Montpetit (sadly everyone has to pay for their own expenses)

For remote participants:

The meeting will be on Webex:
https://ik4.webex.com/ik4-en/j.php?MTID=mccce6c7d8333b19afbbe7fa2995e011e
Meeting number: 845 848 855
Meeting password: Pp5PH9EY

We intend in taking minutes of the salient discussions and to record the (audio) webex for later viewing. The recording will be uploaded to the group wiki: https://trac.ietf.org/trac/irtf/wiki/nwcrg

INTERIM MEETING

Agenda:

3.1. Research challenges

3.4. Generic API

4.1. NC and satellite

4.2. NC and ICN/CCN

4.4. CDN/Storage

6. Discussions

7.1. Use of the wiki for meeting audio recordings, minutes, references etc. (under review and being updated)
https://trac.ietf.org/trac/irtf/wiki/nwcrg

7.3. Other? Suggestions?

End

<nwcrg_charter_update.rtf>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 19 Sep 2017 03:23:25 -0400

Thank you Muriel and welcome to the meeting! Yes having the meeting at Media Lab is very nice :)

We do not intend to spend too much time on IPR as yes we are aware of the history. But as you know the IPR aspects (not only MIT’s) may impact the deployment of the technology. 

We are aligned with you in pushing the coding technologies forward as yes the market is ready hence the proposal for common APIs. We must remember though that we are a research group hence all our RFC will be informational. But yes they could lead to IETF proposal. I think where we may diverge is in considering more than one coding technology.

One question to you and your team is if you could come up with RLNC and/or CTCP draft(s) to inform the list members and their partners of the basics of RLNC hence helping promoting the tech?

See you in E15!

mjm

> On Sep 18, 2017, at 10:13 PM, Muriel Medard <[email-masked]> wrote:
> 
> Dear all,
> 
> [email-masked] <mailto:[email-masked]>
> 
> 
>> On Sep 18, 2017, at 12:20 PM, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>> wrote:
>>