Subject: [nwcrg] nwcrg charter update proposal

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 14 Sep 2017 10:28:15 -0400

Hello list!

Please find enclosed a proposed revised version of our charter. This update was made necessary to address the developments in the field since 2013 as well as to identify new reserch directions to tacle novel challenges in networking performances. The review of this charter is the first item of our agenda for Tuesday.

We welcome any comment on the list ahead of the meeting.

And of course we re-invite everyone to come in-person (MIT E15-359) or participate via webex in next Tuesday interim meeting to finalize this charter and plan the future of the group.

Vincent and Marie-José

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Thu, 14 Sep 2017 18:01:53 +0200

Could you expand on the motivation for this and outline the changes?

- M

On 09/14/2017 04:28 PM, Marie-Jose Montpetit wrote:
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 14 Sep 2017 12:12:55 -0400

We did a lot of changes! Look at the current charter and you will see,

The motivation is simple: after 4 years the network coding world has changed and expanded.

In 2013 there were very little codes/codecs available or implemented. Now there is RLNC (still lacking a draft BTW), the proposal from Cedric Adjih, Tetrys and now the sliding window codes from Inria and maybe others. There also has been a lot of research and improvements on codecs and librairies that were not there at the beginning (you were important in that). New use cases have also emerged and applications have multiplied beyond wireless or p2p - including QUIC as was presented last time. Other IPR developments including the fact that Raptors are at the end of their patent also change the landscape.

So there was a real need to re-align the group to get new members, new projects and new challenges. It does not negate the wonderful work that was done in the past. It just wants to include more recent developments.

I value your participation and hope you will continue be an active member of the community.

mjm
> On Sep 14, 2017, at 12:01 PM, Morten V. Pedersen <[email-masked]> wrote:
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>

---

From: Cedric Adjih <[email-masked]>
Date: Tue, 19 Sep 2017 11:43:57 +0200 (CEST)

Hello all, 

Here are a few quick comments on the charter: 
- Globally, I like its current content very much; especially the added focus of the group (reflected in the title of the charter) on general coding issues. 
- Also explicitly citing sliding windows as a topic, is great as it covers a large number of applications of NC (but not all: e.g. distributed storage, ...). 

I notice the division in: Coding Research/ Applications / APIs / Open-source software; 
This matches a bottom-up approach from uses cases and applications, so it is a path to fast progress in the group. 
Now one question is the focus on APIs rather than protocols/building blocks and packets formats (as might be more common in IETF/IRTF, e.g. for interoperability). 

best regards, 
-- Cedric 

----- Mail original -----

De: "Marie-Jose Montpetit" <[email-masked]> 
À: "Morten V. Pedersen" <[email-masked]> 
Cc: [email-masked] 
Envoyé: Jeudi 14 Septembre 2017 18:12:55 
Objet: Re: [nwcrg] nwcrg charter update proposal 

mjm 

<blockquote>

On Sep 14, 2017, at 12:01 PM, Morten V. Pedersen < [email-masked] > wrote: 

- M 

<blockquote>

Hello list!

Vincent and Marie-José 

_______________________________________________
nwcrg mailing list [email-masked] https://www.irtf.org/mailman/listinfo/nwcrg 

</blockquote>

</blockquote>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 19 Sep 2017 05:49:18 -0400

Thanks Cedric. 

I think in APIs we also include formats and of course a main aspect of the research is protocols and building blocks. Maybe we should be more explicit in the description.

We can discuss this later today!

mjm

> On Sep 19, 2017, at 5:43 AM, Cedric Adjih <[email-masked]> wrote:
> 
>   Hello all,
> 
> On Sep 14, 2017, at 12:01 PM, Morten V. Pedersen <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: Vincent Roca <[email-masked]>
Date: Thu, 28 Sep 2017 17:01:15 +0200

Dear all,

Please find attached to this email an updated version of our RG charter.
This version tries to take into account feedbacks received from the list and during our interim meeting.
Comments are of course welcome.

Cheers,

  Marie-José and Vincent