Subject: [nwcrg] Fwd: NWCRG September 2017 Interim Meeting Agenda

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 8 Sep 2017 09:59:51 -0400

Resend. The 1st one may not have gotten there.

> Begin forwarded message:
> 
> From: Marie-Jose Montpetit <[email-masked]>
> Subject: NWCRG September 2017 Interim Meeting Agenda
> Date: September 8, 2017 at 9:18:33 AM EDT
> To: [email-masked]
> Cc: Vincent Roca <[email-masked]>, Joe Lipowski <[email-masked]>, Margaret Craig <[email-masked]>, Jesus Jimenez <[email-masked]>, David Coombs <[email-masked]>, Marie-Jose Montpetit <[email-masked]>
> 
> Please find below a draft agenda. We expect declared participants to contribute to these items or suggest new items.
> 
> Tell us (Marie-José and Vincent) what you are planning to present/talk about as well as timing constraints (if any), we’ll try to accommodate them. We understand that our European and Asian contributors will have issues with the US-EDT 9-5 schedule and US participants may need to catch planes or trains. 
> 
> BTW the venue is still pending but we are working hard on it. 
> 
> 
> NWCRG September 2017 Interim Meeting Agenda
> (version 1)
> 
> 
> 1. Working group status and update of the Charter
> 	- discussions on a RG charter update proposal
> 
> 2. Research fundamentals and applied research on Coding
> 	2.1. improved and new codes and associated techniques… Anything?
> 		- NB: writing an I-D to present it is no longer that complex if we take example on the RLC I-D
> 		- There is still no I-D on the MIT/Caltech RLNC should we consider one?
> 
> 	2.2. encoding/decoding optimisation
> 		- an idea: can we design GPU-friendly codes?
> 		- good practices
> 		- something else?
> 
> 	2.3. performance evaluation of network codes: how to?
> 		- can we use the new sliding codes to start a common set of procedures?
> 		- can some of the industrial partners share their experience?
> 		- sharing our know-how on the topic…
> 
> 	2.4. generic API
> 		- again use the sliding window codes to define the first set?
> 		- it’s feasible and several examples exist (public or not), could we standardise something 
> 		  to ease open-source code development (see project proposal below)
> 
> 3. Network Coding Use Cases Research (examples below - will there be presenters for these?)
> 
> 	3.1. NC and ICN/CCN
> 
> 	3.2. NC and satellite
> 
> 	3.3. Long Delay Networks/DTN,
> 
> 	3.4. CDN/Storage
> 
> 	3.5. QUIC and sliding window codes
> 
> 	3.6. NC and robust communications for the enterprise
> 
> 	3.7 Other?
> 
> 4. Presentation of on going projects related to our RG
> 	- if you’re involved in a research project and want to present it...
> 
> 5. Discussions
> 	5.1. leveraging the group to create new projects
> 		- example: an open-source, free, reference implementation of sliding window
> 		  codes under NWCRG umbrella ti be used to further protocol developement
> 
> 	5.2. how to tryout NC in an project?
> 		- need to get more people to tryout NC
> 		- many licenses exist with different clauses/prices/constraints and business relationships (academia vs. industry) - can we make it simple for the group?
> 
> 6. IETF’100 meeting preparation (Singapore)
> 	- who plans to participate, with what contribution?
> 
> End

---

From: Xiaomeng Shi <[email-masked]>
Date: Fri, 8 Sep 2017 15:53:21 +0000

Dear Marie-Jose and Vincent,

Thank you for your hard work in organizing the interim meeting! 

For the venue, CodeOn has conference spaces at the Cambridge Innovation Center (CIC) in Kendall Square, and we’d be delighted to host the meeting for the day.  I’ve also spoken with Muriel.  If there are many participants and space is an issue, she would be happy to host it at MIT as well.

Please let me know your decisions on this and if there is anything we can do to help set things up.

Thanks!
Shirley

> On Sep 8, 2017, at 9:59 AM, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 8 Sep 2017 13:25:10 -0400

Thank you (and CodeOn) for the nice offer. I will have confirmation early next week. But for our out of town participants it will be in Cambridge.

> On Sep 8, 2017, at 11:53 AM, Xiaomeng Shi <[email-masked]> wrote:
>