Subject: Re: [nwcrg] nwcrg charter update proposal

From: "Morten V. Pedersen" <[email-masked]>
Date: Fri, 6 Oct 2017 10:26:43 +0200

Dear all,

A high-level comment:

In "Scope and objectives".
We say "packet erasure coding and protocols to mitigate losses at". I 
think strictly focusing on coding for erasures/packet loss it to narrow. 
There are many other interesting applications where the code is not only 
used to deal with packet loss, but also to e.g. reduce state needed in 
the network. A good example of this is data collection algorithms in 
e.g. IoT networks, where coding can minimize the state information 
needed for the routing of information.

It (packet loss) is more or less the focus throughout the rest of the 
document as well - I'm not sure whether we would want to loosen that?

All the best,
Morten

On 09/28/2017 05:01 PM, Vincent Roca wrote:
> Dear all,
>
> Please find attached to this email an updated version of our RG charter.
> This version tries to take into account feedbacks received from the list and during our interim meeting.
> Comments are of course welcome.
>
> Cheers,
>
>    Marie-José and Vincent
>
>
>
>
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 6 Oct 2017 06:59:12 -0400

Good point. We did focus the document on losses but we are aware of the other applications such as ICN where it’s not losses but also reduced state and cache hits. Actually in the proposed milestones there will be a draft on ICN. We do not have any IoT for now but it could be added.

We can add  few words.

Thanks

mjm
> On Oct 6, 2017, at 4:26 AM, Morten V. Pedersen <[email-masked]> wrote:
> 
> Dear all,
> 
> A high-level comment:
> We say "packet erasure coding and protocols to mitigate losses at". I think strictly focusing on coding for erasures/packet loss it to narrow. There are many other interesting applications where the code is not only used to deal with packet loss, but also to e.g. reduce state needed in the network. A good example of this is data collection algorithms in e.g. IoT networks, where coding can minimize the state information needed for the routing of information. 
> It (packet loss) is more or less the focus throughout the rest of the document as well - I'm not sure whether we would want to loosen that?
> 
> All the best,
> Morten
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>

---

From: Vincent Roca <[email-masked]>
Date: Wed, 11 Oct 2017 14:35:47 +0200

Morten et al.,

Thank you for your feedback.
Here is attached an updated version of the charter taking into account your comment.
Cheers,

  Marie-José and Vincent