Subject: [nwcrg] Fwd: New Version Notification for draft-heide-nwcrg-rlnc-00.txt

From: Xiaomeng Shi <[email-masked]>
Date: Fri, 9 Feb 2018 23:27:23 +0000

Dear all,

We submitted a new I-D for RLNC-Based Symbol Representation, and hope to present for discussion at the London meeting.  Any comments, feedbacks, and inputs on the draft would be greatly welcomed and appreciated.

Kind regards,

Shirley Shi
Code On

> 
> -------- Forwarded Message --------
> Subject:	New Version Notification for draft-heide-nwcrg-rlnc-00.txt
> Date:	Wed, 07 Feb 2018 05:30:21 -0800
> From:	[email-masked] <mailto:[email-masked]>
> To:	Vince Chook <[email-masked]> <mailto:[email-masked]>, Vince Chook <[email-masked]> <mailto:[email-masked]>, Janus Heide <[email-masked]> <mailto:[email-masked]>, Shirley Shi <[email-masked]> <mailto:[email-masked]>, Muriel Medard<[email-masked]> <mailto:[email-masked]>
> 
> A new version of I-D, draft-heide-nwcrg-rlnc-00.txt
> has been successfully submitted by Shirley Shi and posted to the
> IETF repository.
> 
> Name:		draft-heide-nwcrg-rlnc
> Revision:	00
> Title:		Random Linear Network Coding (RLNC)-Based Symbol Representation
> Document date:	2018-02-06
> Group:		Individual Submission
> Pages:		20
> URL:            https://www.ietf.org/internet-drafts/draft-heide-nwcrg-rlnc-00.txt <https://www.ietf.org/internet-drafts/draft-heide-nwcrg-rlnc-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-heide-nwcrg-rlnc/ <https://datatracker.ietf.org/doc/draft-heide-nwcrg-rlnc/>
> Htmlized:       https://tools.ietf.org/html/draft-heide-nwcrg-rlnc-00 <https://tools.ietf.org/html/draft-heide-nwcrg-rlnc-00>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-heide-nwcrg-rlnc-00 <https://datatracker.ietf.org/doc/html/draft-heide-nwcrg-rlnc-00>
> 
> 
> Abstract:
>    This document describes the use of Random Linear Network Coding
>    (RLNC) schemes for erasure correction in data transfer, with an
>    emphasis on RLNC encoded symbol representations in data packets.
>    Both block and sliding window RLNC code implementations are
>    described.  By providing erasure correction using randomly generated
>    repair symbols, such RLNC-based schemes offer advantages in
>    accommodating varying frame sizes and dynamically changing
>    connections, reducing the need for feedback, and lowering the amount
>    of state information needed at the sender and receiver.
> 
> 
>                                                                                   
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: [email-masked]
Date: Sun, 11 Feb 2018 08:57:01 +0800

Dear Xiaomemg, all,

I have the following notes/suggestions:

1. to refer to network coding as a "compute and forward" consistent with
mentioning and after "store and forward" in the text, etc etc;

2. to connect the symbol representation of nework codes between the two
coding layers, when itself used to source or channel code; in turn, we may
try,

3. to add the symbol represenation for adaptive RLNC which is a hybrid mix
of: reduced, different code rates>1, or rateless codes=1.

4. a geometric representation of symbols pre and post RLNC coding might be
interesting to add.

Best,
Samah.

On Saturday, February 10, 2018, Xiaomeng Shi <[email-masked]> wrote:

> Dear all,
>
> We submitted a new I-D for RLNC-Based Symbol Representation, and hope to
> present for discussion at the London meeting.  Any comments, feedbacks, and
> inputs on the draft would be greatly welcomed and appreciated.
>
>
> Kind regards,
>
> Shirley Shi
> Code On
>
>
>
> From: [email-masked]
> To: Vince Chook <[email-masked]> <[email-masked]>,
> Vince Chook <[email-masked]> <[email-masked]>, Janus
> Heide <[email-masked]> <[email-masked]>, Shirley Shi
> <[email-masked]> <[email-masked]>, Muriel Medard <muriel.medard@
> codeontechnologies.com> <[email-masked]>
>
> URL:            https://www.ietf.org/internet-drafts/draft-heide-nwcrg-rlnc-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-heide-nwcrg-rlnc/
> Htmlized:       https://tools.ietf.org/html/draft-heide-nwcrg-rlnc-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-heide-nwcrg-rlnc-00
>
>
> Abstract: