Subject: [nwcrg] This afternoon’s meeting

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 22 Mar 2018 08:43:51 +0000

Hi everyone! We are meeting this afternoon at 1:30pm London time. There will be remote participation via Meetecho which also allows to record and allow questions etc. 

Hope to see a lot of you personally and virtually.

Vincent and Marie-José

Marie-José Montpetit
[email-masked]
[email-masked]

---

From: Kerim Fouli <[email-masked]>
Date: Thu, 22 Mar 2018 18:02:51 -0400

Dear all,

Thanks to the participants for today's presentations, and thanks to 
Marie-José, Vincent and all organizers for setting up the meeting. As a 
follow-up to Muriel's comments, I have attached some of the articles she 
referred to, listed below by topic.

1. Satellite Communications: Practical implementations of network coding 
over SATCOM demonstrating various benefits.

  * U. Speidel, Cocker, ‘E., Vingelmann, P., Heide, J., and Médard, M.,
    “Can Network Coding Bridge the Digital Divide in the Pacific?”,
    Netcod 2015
  * U. Speidel, L. Qian, ’E. Cocker, P. Vingelmann, J. Heide, M. Médard,
    “Can Network Coding Mitigate TCP-induced Queue Oscillation on
    Narrowband Satellite Links?, International Conference on Wireless
    and Satellite Systems, 301–314, Springer International Publishing,
    July 2015
  * J. Cloud, and Médard, M. “Network Coding over SATCOM - Lessons
    Learned”, WiSATS 2015
  * U. Speidel, Cocker, ‘E., Médard, M., Heide, J., and Vingelmann, P.,
    “Topologies for the Provision of Network-Coded Services via Shared
    Satellite Channels”, SPACOMM 2017 (Winner Best Paper Award) [Paper
    and Presentation]
  * J. Cloud, Leith, D, and Médard, M. “Network Coded TCP (TCP)
    Performance over Satellite Networks”, SPACOMM 2014
  * Ulrich Speidel , "Improving the utilisation of shared Internet
    satellite connections: A testbed for TCP/NC and PEPs for satellite
    connections and whole‐of-island proofs," Final project report to
    Internet NZ, Jan. 2017.
  * M. Médard, “Applications of random linear network coding (RLNC) to
    satellite communications”, tutorial, 7th Advanced Satellite
    Multimedia Systems Conference (ASMS) and 13th Signal Processing for
    Space Communications Workshop (SPSC)

2. Hardware implementations: Implementations in FPGA and ASIC for 
various applications. This is joint work with Prof. Anantha 
Chandrakasan, Dean of Engineering at MIT.

  * G. Angelopoulos, Médard, M., and Chandrakasan, A. P., “Energy-Aware
    Hardware Implementation of Network Coding”, NC-Pro Workshop 2011.
  * G. Angelopoulos, Médard, M. and Chandrakasan, A., “PRAC: Exploiting
    Partial Packets without Cross-layer or Feedback Information”, IEEE
    ICC Wireless Communications Symposium 2014
  * G. Angelopoulos, Paidimarri, A., Chandrakasan, A. P., and Médard,
    M., “Experimental Study of the Interplay of Channel and Network
    Coding in Low Power Sensor Applications”, ICC WCS 2013 (winner of a
    Best Paper Award)
  * G. Angelopoulos, Médard, M., and Chandrakasan, A., “Harnessing
    Partial Packets in Wireless Networks: Throughput and Energy
    Benefits”, IEEE Transactions on Wireless Communications, Vol. 16,
    No. 2, pp. 694 -704, Nov. 2016
  * G. Angelopoulos, Paidimarri, A., Chandrakasan, A., and Médard, M.,
    “A Random Linear Network Coding Accelerator in a 2.4GHz Transmitter
    for IoT Applications”, IEEE Transactions on Circuits and Systems,
    Vol. 16, No. 2, Feb. 2017, pp. 694-704

3. Network Coding and Congestion Control: Here's an example of an 
implementation that combines both.

  * M. Kim, Cloud, J., ParandehGheibi, A., Urbina, L., Fouli, K., Leith,
    D., and Médard, M., “Congestion Control for Coded Transport
    Layers”,  IEEE ICC Communication QoS, Reliability and Modeling
    Symposium 2014

4. Regarding convolutional codes. Note that the original RLNC paper, 
listed and attached, includes convolutional codes.

  * T. Ho, Médard, M., Koetter, R., Karger, D.R., Effros, M., Shi, J.,
    and Leong, B., “A Random Linear Network Coding Approach to
    Multicast,” IEEE Transactions on Information Theory, Vol. 52, Issue
    10, pp. 4413-4430, October 2006. ** (Winner of the 2009 of the IEEE
    Communication Society and Information Theory Society joint Paper Award)
  * W. Guo, Shi, X., Cai., N, and Médard, M., “Localized Dimension
    Growth: A Convolutional Random Network Coding Approach to Managing
    Memory and Decoding Delay”,  IEEE Transactions on Communications,
    vol. 61, no. 9, September 2013, pp. 3894-3905
  * Elona Erez, Michelle Effros, and Tracey Ho, "Network Codes with
    Deadlines," Forty-Sixth Annual Allerton Conference, Allerton,
    Illinois, USA September 23-26, 2008
  * Elona Erez and Meir Feder, "Efficient Network Code Design for Cyclic
    Networks", IEEE TRANSACTIONS ON INFORMATION THEORY, VOL. 56, NO. 8,
    AUGUST 2010.

5. Network Coding as a solution for lower layer errors: our latest white 
paper (listed) illustrates the concept through analysis.

  * D. Adams, Du, J., Médard, M., and Yu, C., “Delay Constrained
    Throughput-Reliability Tradeoff in Network-Coded Wireless Systems”,
    Globecom Communications Theory Symposium 2014 (finalist for Best
    Paper Award)
  * "RLNC as a Network-Layer Code, A study of RLNC as a complement to
    physical-layer coding." Code On White Paper - 2018.

I hope that these articles are an interesting read for everyone on the 
list.

Note that the attached ZIP file has the PDFs already classified in 
directories. Please don't hesitate to contact me if there was any 
trouble downloading or unzipping.

Best,

Kerim

-- 
*Kerim Fouli*

*cid:[email-masked]* 
<http://www.codeontechnologies.com/>

Code On Network Coding LLC (“Code On”), a limited liability company 
based in Cambridge, MA. Information transmitted in or attached to this 
e-mail is intended only for the person or entity to which it is 
addressed, and may contain confidential and/or privileged material. If 
this email has been sent to you by mistake and you are not the intended 
recipient, please telephone or email the sender immediately and delete 
it from your system; do not read, copy or disclose its contents to 
anyone. No responsibility is accepted by Code On for any loss or damage 
arising in any way from the receipt or use of this e-mail or its 
attachments. Please note that all e-mail messages are subject to 
interception for lawful business purposes.

<https://www.linkedin.com/company/code-on-technologies>cid:[email-masked] 
<https://twitter.com/codeontech?lang=en-gb>

On 3/22/18 4:43 AM, Marie-Jose Montpetit wrote:
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Kerim Fouli <[email-masked]>
Date: Thu, 22 Mar 2018 18:12:30 -0400

Dear all,

He's a link to the ZIP file, in case the file size is an issue:
https://www.dropbox.com/s/og0u79cu33mk4wg/RLNC_Documents_For_IETF_101.zip

Best,

+K

On 3/22/18 6:02 PM, Kerim Fouli wrote:
> Marie-José, Vincent and all organizers for setting up the meeting. As 
> a follow-up to Muriel's comments, I have attached some of the articles 
> she referred to, listed below by topic.
>
> 1. Satellite Communications: Practical implementations of network 
> coding over SATCOM demonstrating various benefits.
>
>   * U. Speidel, Cocker, ‘E., Vingelmann, P., Heide, J., and Médard,
>     M., “Can Network Coding Bridge the Digital Divide in the
>     Pacific?”, Netcod 2015
>   * U. Speidel, L. Qian, ’E. Cocker, P. Vingelmann, J. Heide, M.
>     Médard, “Can Network Coding Mitigate TCP-induced Queue Oscillation
>     on Narrowband Satellite Links?, International Conference on
>     Wireless and Satellite Systems, 301–314, Springer International
>     Publishing, July 2015
>   * U. Speidel, Cocker, ‘E., Médard, M., Heide, J., and Vingelmann,
>     P., “Topologies for the Provision of Network-Coded Services via
>     Shared Satellite Channels”, SPACOMM 2017 (Winner Best Paper Award)
>     [Paper and Presentation]
>     Multimedia Systems Conference (ASMS) and 13th Signal Processing
>     for Space Communications Workshop (SPSC)
>
>
>   * G. Angelopoulos, Médard, M., and Chandrakasan, A. P.,
>     “Energy-Aware Hardware Implementation of Network Coding”, NC-Pro
>     Workshop 2011.
>   * G. Angelopoulos, Médard, M. and Chandrakasan, A., “PRAC:
>     Exploiting Partial Packets without Cross-layer or Feedback
>     Information”, IEEE ICC Wireless Communications Symposium 2014
>     Coding in Low Power Sensor Applications”, ICC WCS 2013 (winner of
>     a Best Paper Award)
>     “A Random Linear Network Coding Accelerator in a 2.4GHz
>     Transmitter for IoT Applications”, IEEE Transactions on Circuits
>     and Systems, Vol. 16, No. 2, Feb. 2017, pp. 694-704
>
>
>   * M. Kim, Cloud, J., ParandehGheibi, A., Urbina, L., Fouli, K.,
>     Leith, D., and Médard, M., “Congestion Control for Coded Transport
>     Multicast,” IEEE Transactions on Information Theory, Vol. 52,
>     Issue 10, pp. 4413-4430, October 2006. ** (Winner of the 2009 of
>     the IEEE Communication Society and Information Theory Society
>     joint Paper Award)
>   * Elona Erez and Meir Feder, "Efficient Network Code Design for
>     Cyclic Networks", IEEE TRANSACTIONS ON INFORMATION THEORY, VOL.
>     56, NO. 8, AUGUST 2010.
>
>
> 5. Network Coding as a solution for lower layer errors: our latest 
> white paper (listed) illustrates the concept through analysis.
>
>     Throughput-Reliability Tradeoff in Network-Coded Wireless
>     Systems”, Globecom Communications Theory Symposium 2014 (finalist
>     for Best Paper Award)
> this email has been sent to you by mistake and you are not the 
> intended recipient, please telephone or email the sender immediately 
> and delete it from your system; do not read, copy or disclose its 
> contents to anyone. No responsibility is accepted by Code On for any 
> loss or damage arising in any way from the receipt or use of this 
> e-mail or its attachments. Please note that all e-mail messages are 
> subject to interception for lawful business purposes.
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 23 Mar 2018 00:36:15 +0000

Thanks at lot!

I intend to load all of these on the wiki as background material for the list.

mjm
> On Mar 22, 2018, at 10:02 PM, Kerim Fouli <[email-masked]> wrote:
> 
> Dear all,
>  
> Thanks to the participants for today's presentations, and thanks to Marie-José, Vincent and all organizers for setting up the meeting. As a follow-up to Muriel's comments, I have attached some of the articles she referred to, listed below by topic. 
>  
> 1. Satellite Communications: Practical implementations of network coding over SATCOM demonstrating various benefits.
> U. Speidel, Cocker, ‘E., Vingelmann, P., Heide, J., and Médard, M., “Can Network Coding Bridge the Digital Divide in the Pacific?”, Netcod 2015
> U. Speidel, L. Qian, ’E. Cocker, P. Vingelmann, J. Heide, M. Médard, “Can Network Coding Mitigate TCP-induced Queue Oscillation on Narrowband Satellite Links?, International Conference on Wireless and Satellite Systems, 301–314, Springer International Publishing, July 2015
> J. Cloud, and Médard, M. “Network Coding over SATCOM - Lessons Learned”, WiSATS 2015
> U. Speidel, Cocker, ‘E., Médard, M., Heide, J., and Vingelmann, P., “Topologies for the Provision of Network-Coded Services via Shared Satellite Channels”, SPACOMM 2017 (Winner Best Paper Award) [Paper and Presentation]
> J. Cloud, Leith, D, and Médard, M. “Network Coded TCP (TCP) Performance over Satellite Networks”, SPACOMM 2014  
> Ulrich Speidel , "Improving the utilisation of shared Internet satellite connections: A testbed for TCP/NC and PEPs for satellite connections and whole‐of-island proofs," Final project report to Internet NZ, Jan. 2017.
> M. Médard, “Applications of random linear network coding (RLNC) to satellite communications”, tutorial, 7th Advanced Satellite Multimedia Systems Conference (ASMS) and 13th Signal Processing for Space Communications Workshop (SPSC)
>  
> 2. Hardware implementations: Implementations in FPGA and ASIC for various applications. This is joint work with Prof. Anantha Chandrakasan, Dean of Engineering at MIT.
> G. Angelopoulos, Médard, M., and Chandrakasan, A. P., “Energy-Aware Hardware Implementation of Network Coding”, NC-Pro Workshop 2011.   
> G. Angelopoulos, Médard, M. and Chandrakasan, A., “PRAC: Exploiting Partial Packets without Cross-layer or Feedback Information”, IEEE ICC Wireless Communications Symposium 2014 
> G. Angelopoulos, Paidimarri, A., Chandrakasan, A. P., and Médard, M., “Experimental Study of the Interplay of Channel and Network Coding in Low Power Sensor Applications”, ICC WCS 2013 (winner of a Best Paper Award)
> G. Angelopoulos, Médard, M., and Chandrakasan, A., “Harnessing Partial Packets in Wireless Networks: Throughput and Energy Benefits”, IEEE Transactions on Wireless Communications, Vol. 16, No. 2, pp. 694 -704, Nov. 2016
> G. Angelopoulos, Paidimarri, A., Chandrakasan, A., and Médard, M., “A Random Linear Network Coding Accelerator in a 2.4GHz Transmitter for IoT Applications”, IEEE Transactions on Circuits and Systems, Vol. 16, No. 2, Feb. 2017, pp. 694-704
>  
> 3. Network Coding and Congestion Control: Here's an example of an implementation that combines both.
> M. Kim, Cloud, J., ParandehGheibi, A., Urbina, L., Fouli, K., Leith, D., and Médard, M., “Congestion Control for Coded Transport Layers”,  IEEE ICC Communication QoS, Reliability and Modeling Symposium 2014 
>  
> 4. Regarding convolutional codes. Note that the original RLNC paper, listed and attached, includes convolutional codes.
> T. Ho, Médard, M., Koetter, R., Karger, D.R., Effros, M., Shi, J., and Leong, B., “A Random Linear Network Coding Approach to Multicast,” IEEE Transactions on Information Theory, Vol. 52, Issue 10, pp. 4413-4430, October 2006. ** (Winner of the 2009 of the IEEE Communication Society and Information Theory Society joint Paper Award)
> W. Guo, Shi, X., Cai., N, and Médard, M., “Localized Dimension Growth: A Convolutional Random Network Coding Approach to Managing Memory and Decoding Delay”,  IEEE Transactions on Communications, vol. 61, no. 9, September 2013, pp. 3894-3905 
> Elona Erez, Michelle Effros, and Tracey Ho, "Network Codes with Deadlines," Forty-Sixth Annual Allerton Conference, Allerton, Illinois, USA September 23-26, 2008
> Elona Erez and Meir Feder, "Efficient Network Code Design for Cyclic Networks", IEEE TRANSACTIONS ON INFORMATION THEORY, VOL. 56, NO. 8, AUGUST 2010.
>  
> 5. Network Coding as a solution for lower layer errors: our latest white paper (listed) illustrates the concept through analysis.
> D. Adams, Du, J., Médard, M., and Yu, C., “Delay Constrained Throughput-Reliability Tradeoff in Network-Coded Wireless Systems”, Globecom Communications Theory Symposium 2014 (finalist for Best Paper Award)
> "RLNC as a Network-Layer Code, A study of RLNC as a complement to physical-layer coding." Code On White Paper - 2018.
>  
> I hope that these articles are an interesting read for everyone on the list. 
>  
> Note that the attached ZIP file has the PDFs already classified in directories. Please don't hesitate to contact me if there was any trouble downloading or unzipping.
>  
> Best,
>  
> Kerim
>  
> 
> -- 
> Kerim Fouli
> 
> <Mail Attachment.png> <http://www.codeontechnologies.com/>
> 
> Code On Network Coding LLC (“Code On”), a limited liability company based in Cambridge, MA. Information transmitted in or attached to this e-mail is intended only for the person or entity to which it is addressed, and may contain confidential and/or privileged material. If this email has been sent to you by mistake and you are not the intended recipient, please telephone or email the sender immediately and delete it from your system; do not read, copy or disclose its contents to anyone. No responsibility is accepted by Code On for any loss or damage arising in any way from the receipt or use of this e-mail or its attachments. Please note that all e-mail messages are subject to interception for lawful business purposes.
> 
> <Mail Attachment.jpeg> <https://www.linkedin.com/company/code-on-technologies><Mail Attachment.jpeg> <https://twitter.com/codeontech?lang=en-gb>
>  
> 
> 
> 
> 
>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
> 
> <RLNC_Documents_For_IETF_101.zip>_______________________________________________
> nwcrg mailing list
> [email-masked]

---

From: "Kerim Fouli" <[email-masked]>
Date: Fri, 23 Mar 2018 01:45:45 -0400

Dear all,

Thanks Marie-José! Here are a few more papers on multicasting and NORM, another topic that came up in the meeting. 

The MIT NC group has an RLNC-based NORM improvement that allows for further ACK explosion reduction wrt to NORM:

*	Rezaee, du Pin Calmon, F., Zeger, L., and Médard, M.,  “Speeding Multicast by Acknowledgment Reduction Technique (SMART) Enabling Robustness of QoE to the Number of Users”, IEEE Journal of Selected Areas in Communication, vol. 30, no. 7, August 2012, pp. 1270-1280 

The delay gains expected for the multicast scenarios that NORM tackles are considerable, as shown in earlier collaborations with Asu Ozdaglar (current head of MIT EECS) and Attila Eryilmaz (faculty at Ohio State):

*	E. Ahmed, Eryilmaz, A., Médard, M., and Ozdaglar, A, “Economic Aspects of Network Coding”, Allerton Conference, October 2006 
*	Eryilmaz, Ozdaglar, A., and Médard, M., “On the Delay and Throughput Gains of Coding in Unreliable Networks”, IEEE Transactions on Information Theory, Volume 54, Issue 12, December 2008, pp:5511- 5524

Best,

+K

From: nwcrg <[email-masked]> On Behalf Of Marie-Jose Montpetit
Sent: Thursday, March 22, 2018 8:36 PM
To: Kerim Fouli <[email-masked]>
Cc: [email-masked]
Subject: Re: [nwcrg] This afternoon’s meeting

Thanks at lot!

mjm

On Mar 22, 2018, at 10:02 PM, Kerim Fouli <[email-masked] <mailto:[email-masked]> > wrote:

Dear all, 

*	U. Speidel, Cocker, ‘E., Vingelmann, P., Heide, J., and Médard, M., “Can Network Coding Bridge the Digital Divide in the Pacific?”, Netcod 2015
*	U. Speidel, L. Qian, ’E. Cocker, P. Vingelmann, J. Heide, M. Médard, “Can Network Coding Mitigate TCP-induced Queue Oscillation on Narrowband Satellite Links?, International Conference on Wireless and Satellite Systems, 301–314, Springer International Publishing, July 2015
*	J. Cloud, and Médard, M. “Network Coding over SATCOM - Lessons Learned”, WiSATS 2015
*	U. Speidel, Cocker, ‘E., Médard, M., Heide, J., and Vingelmann, P., “Topologies for the Provision of Network-Coded Services via Shared Satellite Channels”, SPACOMM 2017 (Winner Best Paper Award) [Paper and Presentation]
*	J. Cloud, Leith, D, and Médard, M. “Network Coded TCP (TCP) Performance over Satellite Networks”, SPACOMM 2014   
*	Ulrich Speidel , "Improving the utilisation of shared Internet satellite connections: A testbed for TCP/NC and PEPs for satellite connections and whole‐of-island proofs," Final project report to Internet NZ, Jan. 2017.
*	M. Médard, “Applications of random linear network coding (RLNC) to satellite communications”, tutorial, 7th Advanced Satellite Multimedia Systems Conference (ASMS) and 13th Signal Processing for Space Communications Workshop (SPSC)

*	G. Angelopoulos, Médard, M., and Chandrakasan, A. P., “Energy-Aware Hardware Implementation of Network Coding”, NC-Pro Workshop 2011.    
*	G. Angelopoulos, Médard, M. and Chandrakasan, A., “PRAC: Exploiting Partial Packets without Cross-layer or Feedback Information”, IEEE ICC Wireless Communications Symposium 2014  
*	G. Angelopoulos, Paidimarri, A., Chandrakasan, A. P., and Médard, M., “Experimental Study of the Interplay of Channel and Network Coding in Low Power Sensor Applications”, ICC WCS 2013 (winner of a Best Paper Award)
*	G. Angelopoulos, Médard, M., and Chandrakasan, A., “Harnessing Partial Packets in Wireless Networks: Throughput and Energy Benefits”, IEEE Transactions on Wireless Communications, Vol. 16, No. 2, pp. 694 -704, Nov. 2016
*	G. Angelopoulos, Paidimarri, A., Chandrakasan, A., and Médard, M., “A Random Linear Network Coding Accelerator in a 2.4GHz Transmitter for IoT Applications”, IEEE Transactions on Circuits and Systems, Vol. 16, No. 2, Feb. 2017, pp. 694-704 

*	M. Kim, Cloud, J., ParandehGheibi, A., Urbina, L., Fouli, K., Leith, D., and Médard, M., “Congestion Control for Coded Transport Layers”,  IEEE ICC Communication QoS, Reliability and Modeling Symposium 2014  

*	T. Ho, Médard, M., Koetter, R., Karger, D.R., Effros, M., Shi, J., and Leong, B., “A Random Linear Network Coding Approach to Multicast,” IEEE Transactions on Information Theory, Vol. 52, Issue 10, pp. 4413-4430, October 2006. ** (Winner of the 2009 of the IEEE Communication Society and Information Theory Society joint Paper Award)
*	W. Guo, Shi, X., Cai., N, and Médard, M., “Localized Dimension Growth: A Convolutional Random Network Coding Approach to Managing Memory and Decoding Delay”,  IEEE Transactions on Communications, vol. 61, no. 9, September 2013, pp. 3894-3905  
*	Elona Erez, Michelle Effros, and Tracey Ho, "Network Codes with Deadlines," Forty-Sixth Annual Allerton Conference, Allerton, Illinois, USA September 23-26, 2008
*	Elona Erez and Meir Feder, "Efficient Network Code Design for Cyclic Networks", IEEE TRANSACTIONS ON INFORMATION THEORY, VOL. 56, NO. 8, AUGUST 2010.

*	D. Adams, Du, J., Médard, M., and Yu, C., “Delay Constrained Throughput-Reliability Tradeoff in Network-Coded Wireless Systems”, Globecom Communications Theory Symposium 2014 (finalist for Best Paper Award)
*	"RLNC as a Network-Layer Code, A study of RLNC as a complement to physical-layer coding." Code On White Paper - 2018.

 
Best,
 
Kerim

-- 
Kerim Fouli 

 <http://www.codeontechnologies.com/> <Mail Attachment.png>

 <https://www.linkedin.com/company/code-on-technologies> <Mail Attachment.jpeg> <https://twitter.com/codeontech?lang=en-gb> <Mail Attachment.jpeg>

 
 
Vincent and Marie-José
 
Marie-José Montpetit

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 23 Mar 2018 06:56:20 +0000

Thank you again. 

This reminds me that we are overdue to put a list of related papers on the wiki. It was an action of mine to create a good list of references from the whole community and encourage further research.

Anyone on the list (presenters of yesterday please note!) who has published papers on the topic of coding at the network layer please send it to me (no need to flood the list) I will update the wiki and send a note to the list. I think we need papers that relate to the current documents: Tetrys, ICN , satellite, protocol design etc. I also want to put links to related architecture documents (QUIC for one), background (FECFRAME) and others (there is a NC myth paper that we wrote a few years ago). And if anyone has non-proprietary information on experiments this would also be welcome (Kerim: do you have any papers related to Surat’s thesis?).

So thanks again to Kerim and Muriel for starting the work.

mjm
> On Mar 23, 2018, at 5:45 AM, Kerim Fouli <[email-masked]> wrote:
> 
> Dear all,
>  
> Rezaee, du Pin Calmon, F., Zeger, L., and Médard, M.,  “Speeding Multicast by Acknowledgment Reduction Technique (SMART) Enabling Robustness of QoE to the Number of Users”, IEEE Journal of Selected Areas in Communication, vol. 30, no. 7, August 2012, pp. 1270-1280 
>  
> E. Ahmed, Eryilmaz, A., Médard, M., and Ozdaglar, A, “Economic Aspects of Network Coding”, Allerton Conference, October 2006 
> Eryilmaz, Ozdaglar, A., and Médard, M., “On the Delay and Throughput Gains of Coding in Unreliable Networks”, IEEE Transactions on Information Theory, Volume 54, Issue 12, December 2008, pp:5511- 5524
>  
> Best,
>  
> +K
>  
>  
> From: nwcrg <[email-masked] <mailto:[email-masked]>> On Behalf Of Marie-Jose Montpetit
> To: Kerim Fouli <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
>> On Mar 22, 2018, at 10:02 PM, Kerim Fouli <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> Dear all, 
>>  
> <2006_Allerton_Economic.pdf><2008_TransIT_Delay.pdf><2012_JSAC_SMART.PDF>

---

From: whyeung <[email-masked]>
Date: Sat, 24 Mar 2018 16:02:35 +0800

Dear all,

In the Mar 2014 NWCRG meeting, I gave a presentation (through the Internet) on BATched Sparse (BATS) codes that solve the problem of packet loss accumulation in a multi-hop wireless networks.  Recently we have put together a video demo for transmitting a live video over 10 Raspberry Pi 3’s:

http://iest2.ie.cuhk.edu.hk/~whyeung/BATS.mp4 <http://iest2.ie.cuhk.edu.hk/~whyeung/BATS.mp4>

This video was shown at the Fog World Congress held in Santa Clara in Oct last year.  Here is the homepage of our BATS codes research:

http://www.inc.cuhk.edu.hk/research/bats <http://www.inc.cuhk.edu.hk/research/bats>

If you are interested in knowing more, please feel free to contact me.  Thanks a lot.

Best regards,
Raymond

----------------------------------
Prof. Raymond W. Yeung
Co-Director, Institute of Network Coding
Choh-Ming Li Professor of Information Engineering
The Chinese University of Hong Kong
https://www.ie.cuhk.edu.hk/people/raymond.shtml

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 24 Mar 2018 08:22:36 +0000

Hello:

Thanks for this update; I will put that information on the wiki. 

Would you consider a contribution in Montreal? The idea of an inner and outer code is interesting :)

mjm

> On Mar 24, 2018, at 8:02 AM, whyeung <[email-masked]> wrote:
> 
> Dear all,
> 
> https://www.ie.cuhk.edu.hk/people/raymond.shtml <https://www.ie.cuhk.edu.hk/people/raymond.shtml>
> 
> 
>

---

From: whyeung <[email-masked]>
Date: Sat, 24 Mar 2018 16:56:31 +0800

Hi Marie-Jose,

Thank you for your interest.

For Montreal, I suppose you are talking about this one:

https://datatracker.ietf.org/meeting/102/agenda <https://datatracker.ietf.org/meeting/102/agenda>

Since I will be in the US in the 3rd week of June, I probably won’t be able to make it to the Montreal meeting.  When and where is the next meeting?

Raymond

> On Mar 24, 2018, at 4:22 PM, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> Hello:
> 
>> On Mar 24, 2018, at 8:02 AM, whyeung <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear all,
>>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 24 Mar 2018 09:05:48 +0000

After Montreal we want an interim on Sept. 25th.

You could present remotely at 102.

Marie-José Montpetit
[email-masked]
[email-masked]

> On Mar 24, 2018, at 8:56 AM, whyeung <[email-masked]> wrote:
> 
> Hi Marie-Jose,
> 
> https://datatracker.ietf.org/meeting/102/agenda
> 
>>> http://iest2.ie.cuhk.edu.hk/~whyeung/BATS.mp4
>>> 
>>> http://www.inc.cuhk.edu.hk/research/bats
>>>