Subject: Re: [nwcrg] [tsvwg] I-D Action: draft-ietf-tsvwg-rlc-fec-scheme-03.txt

From: Vincent Roca <[email-masked]>
Date: Mon, 7 May 2018 19:45:44 +0200

Dear all,

Here is a new version of our RLC FEC Scheme I-D. This is a major revision.
This version:

- includes the updates following Gorry's detailed review;

- changes the way the coding coefficients are generated in a non backward
  compatible manner (at this stage, this is not an issue). In fact after initializing
  the PRNG with a seed, we add a first call to rand whose return value is ignored.

  "Indeed, the PRNG sequences produced by two seeds in sequence have a
   high probability of starting with the same value since I1 = A * seed
   (modulo M) which is further scaled to a small range (either {0, ...
   15} or {0, ... 255}).  Producing several times the same first coding
   coefficient could reduce the protection of the first source symbol if
   multiple repair symbols are produced with the same coding window's
   left edge.  The extra call avoids such side effects. »

  This is something we only discovered recently! Fixing this issue like that
  avoids to recommend not to use seeds in sequence in the application which
  I think will be a common way of managing those seeds. No matter what the
  developer chooses, the sequence should be appropriate.

- includes a new version of section 3.1. "Possible Parameter Derivation"
  There is I think a much better structure, that better explains what could be done
  depending on the situtation, what is sender specific or receiver specific, and
  how a receiver can evaluate the maximum encoding window size whereas this
  parameter is never transmitted explicitly.

- includes a brand new section 3.6. "Linear Combination of Source Symbols
  Computation ».
  We realised this was not necessarily clear how to do that. There is also a link to a
  well known reference that further explains how to perform such computation
  efficiently [PBM13].

- and various clarifications here and there.

Cheers,

   Vincent and Belkacem

> Le 7 mai 2018 à 19:28, [email-masked] a écrit :
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Transport Area Working Group WG of the IETF.
> 
>        Title           : Sliding Window Random Linear Code (RLC) Forward Erasure Correction (FEC) Schemes for FECFRAME
>        Authors         : Vincent Roca
>                          Belkacem Teibi
> 	Filename        : draft-ietf-tsvwg-rlc-fec-scheme-03.txt
> 	Pages           : 30
> 	Date            : 2018-05-07
> 
> Abstract:
>   This document describes two fully-specified Forward Erasure
>   Correction (FEC) Schemes for Sliding Window Random Linear Codes
>   (RLC), one for RLC over GF(2) (binary case), a second one for RLC
>   over GF(2^^8), both of them with the possibility of controlling the
>   code density.  They can protect arbitrary media streams along the
>   lines defined by FECFRAME extended to sliding window FEC codes.
>   These sliding window FEC codes rely on an encoding window that slides
>   over the source symbols, generating new repair symbols whenever
>   needed.  Compared to block FEC codes, these sliding window FEC codes
>   offer key advantages with real-time flows in terms of reduced FEC-
>   related latency while often providing improved packet erasure
>   recovery capabilities.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-tsvwg-rlc-fec-scheme-03
> https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-rlc-fec-scheme-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-rlc-fec-scheme-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>

---

From: Vincent Roca <[email-masked]>
Date: Mon, 7 May 2018 20:08:08 +0200

A second message specifically to you, NWCRG specialists.

TSV (the generic Transport Working Group) counts on you, as coding experts, to review this I-D.
It entered WG Last Call 3 weeks ago, meaning it’s the right timing to review it.

This is also important I-D for our RG since it is a concrete example of sliding window FEC Scheme,
even if it is limited to the FECFRAME transport protocol. Part of it will be reusable in the context of
our RG.

Thanks in advance.

Cheers,

  Vincent and Belkacem

> Le 7 mai 2018 à 19:45, Vincent Roca <[email-masked]> a écrit :
> 
> Dear all,
> 
>> Le 7 mai 2018 à 19:28, [email-masked] <mailto:[email-masked]> a écrit :
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/ <https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/>
>>