Subject: Re: [nwcrg] [tsvwg] I-D Action: draft-ietf-tsvwg-fecframe-ext-03.txt

From: Vincent Roca <[email-masked]>
Date: Wed, 25 Jul 2018 12:10:27 +0200

Hello Wes, all,

We have just updated the FECFRAME extension and RLC FEC Scheme for FECFRAME I-Ds as
discussed during IETF 102 meeting. Those updates fix a few typos, slightly improve text, add
an acknowledgment section. We authors do not think it requires a new WGLC.

Cheers,

   Vincent

NB: if one looks at the RLC FEC Scheme diff:
	https://tools.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-rlc-fec-scheme-06.txt <https://tools.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-rlc-fec-scheme-06.txt>
	one may think that Appendix A providing the TinyMT32 C-code has been significantly changed.
	This is not the case, we merely updated a few comments (in particular added references
	for the initial PRNG state parameters’ choice). The rfcdiff tool seems to have lost tracks.

> Le 25 juil. 2018 à 11:50, [email-masked] a écrit :
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Transport Area Working Group WG of the IETF.
> 
>        Title           : Forward Error Correction (FEC) Framework Extension to Sliding Window Codes
>        Authors         : Vincent Roca
>                          Ali Begen
> 	Filename        : draft-ietf-tsvwg-fecframe-ext-03.txt
> 	Pages           : 20
> 	Date            : 2018-07-25
> 
> Abstract:
>   RFC 6363 describes a framework for using Forward Error Correction
>   (FEC) codes to provide protection against packet loss.  The framework
>   supports applying FEC to arbitrary packet flows over unreliable
>   transport and is primarily intended for real-time, or streaming,
>   media.  However FECFRAME as per RFC 6363 is restricted to block FEC
>   codes.  The present document extends FECFRAME to support FEC Codes
>   based on a sliding encoding window, in addition to Block FEC Codes,
>   in a backward compatible way.  During multicast/broadcast real-time
>   content delivery, the use of sliding window codes significantly
>   improves robustness in harsh environments, with less repair traffic
>   and lower FEC-related added latency.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-fecframe-ext/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-tsvwg-fecframe-ext-03
> https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-fecframe-ext-03
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-fecframe-ext-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 25 Jul 2018 10:06:31 -0400

> an acknowledgment section. We authors do not think it requires a new WGLC.

Thanks.  I think everyone who commented during the WGLC has now 
confirmed that they're happy with the changes, so I'll start the 
shepherd write-up.