Subject: [nwcrg] Other topics for Bangkok

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 25 Sep 2018 13:36:03 -0400

Also at the interim today I presented a few ideas about new applications and services that could need NC. We already have touched ICN. NFV and satellite in multiple topologies.

The new “topics” that I see include:
- NC ias part of “in-network” computing and programmable data planes
- AR/VR that require strict timing, low loss and stream synchronization
- AI applications both as generating sensitive information and allowing to profile network performances

While I do not plan a draft before Bangkok I do plan a presentation to see the interest of the community. And of course we can start exchanging on the list.

Thanks

mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Thu, 27 Sep 2018 13:50:59 +0200

Hi Marie-Jose,
Another application which requires strict timing and low-loss is 
emerging on-demand gaming services - we recently blogged about that:
http://steinwurf.com/blog/2018-09-24-low-delay-packet-correction.html

But I think also video conferencing, remote desktop etc. could be 
candidates.

- M

On 09/25/2018 07:36 PM, Marie-Jose Montpetit wrote:
> Also at the interim today I presented a few ideas about new 
> applications and services that could need NC. We already have touched 
> ICN. NFV and satellite in multiple topologies.
>
> While I do not plan a draft before Bangkok I do plan a presentation to 
> see the interest of the community. And of course we can start 
> exchanging on the list.
>
> Thanks
>
> mjm
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> +1-781-526-2661
> @SocialTVMIT
>
>
>
>
>
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 27 Sep 2018 08:02:02 -0400

Yes gaming for me is part of the AR/VR realm but yes I agree.

> On Sep 27, 2018, at 7:50 AM, Morten V. Pedersen <[email-masked]> wrote:
> 
> Hi Marie-Jose,
> Another application which requires strict timing and low-loss is emerging on-demand gaming services - we recently blogged about that:
> http://steinwurf.com/blog/2018-09-24-low-delay-packet-correction.html <http://steinwurf.com/blog/2018-09-24-low-delay-packet-correction.html>
> 
> But I think also video conferencing, remote desktop etc. could be candidates.
> 
> - M
> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/nwcrg <https://www.irtf.org/mailman/listinfo/nwcrg>
>

---

From: Fernando Ramos <[email-masked]>
Date: Thu, 27 Sep 2018 15:38:43 +0100

Dear Marie-Jose, and All,

With respect to “in-network” computing, Muriel and I have been collaborating on the topic. If you are interested, you may want to look at the thesis of a master student we co-advised recently:

Network coding data planes with programmable switches
http://repositorio.ul.pt/handle/10451/30687

This is still very preliminary work, using the P4 language (https://p4.org) to program a NC switch. As follow-up we now have another student who will experiment with the new version of the language (P4_16) and use programmable hardware (a NetFPGA and a Barefoot Tofino switch, specifically) to more clearly understand what is possible to achieve given the hardware constraints. Even more recently (well, just over lunch today at ICNP in Cambridge, UK :-) I had a good chat on the issue with another colleague, Rakesh Kumar from UIIC, who is also interested in this topic.

I’m v. happy to contribute to the discussions around this topic in the future.

Best,

Fernando

> No dia 25/09/2018, às 18:36, Marie-Jose Montpetit <[email-masked]> escreveu:
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 27 Sep 2018 10:42:50 -0400

Great!

Can I add you to our list for the side meeting on in-network computing?  We are proposing the COIN (computing in the network).

mjm

> On Sep 27, 2018, at 10:38 AM, Fernando Ramos <[email-masked]> wrote:
>

---

From: Fernando Ramos <[email-masked]>
Date: Thu, 27 Sep 2018 15:44:02 +0100

Sure - feel free to add me.

Fernando 

> No dia 27/09/2018, às 15:42, Marie-Jose Montpetit <[email-masked]> escreveu:
> 
> Great!
>